SP2 installed - now unable to RDp

Discussion in 'Windows 64bit' started by nbailey, Jan 15, 2008.

  1. nbailey

    nbailey Guest

    Hi there,

    I installed SP2 on a 64bit Windows Server 2003 server. As a result i am
    unable to RDP to the server even though the firewall is set to allow RDP.
    Even if i switch the forewall off i am unable to RDP. The only way i am
    currently getting round this issue is to disable the firewall service (which
    is far from ideal!!!).

    Can anyone help?

    Many thanks in advance
     
    nbailey, Jan 15, 2008
    #1
    1. Advertising

  2. Check the settings on your NIC. SP2 changes some settings that can cause
    issues. Specifically:

    netsh interface tcp set global autotuning=disabled
    netsh interface tcp set global chimney=disabled
    netsh interface tcp set global rss=disabled

    This turns off RSS, TCP Offload and TCPChimney. You can also do this in the
    registry, at:

    hklm:/system/currentcontrolset/services/tcpip/parameters.

    --
    Charlie.
    http://msmvps.com/xperts64
    http://mvp.support.microsoft.com/profile/charlie.russel


    "nbailey" <> wrote in message
    news:...
    > Hi there,
    >
    > I installed SP2 on a 64bit Windows Server 2003 server. As a result i am
    > unable to RDP to the server even though the firewall is set to allow RDP.
    > Even if i switch the forewall off i am unable to RDP. The only way i am
    > currently getting round this issue is to disable the firewall service
    > (which
    > is far from ideal!!!).
    >
    > Can anyone help?
    >
    > Many thanks in advance
     
    Charlie Russel - MVP, Jan 15, 2008
    #2
    1. Advertising

  3. nbailey

    nbailey Guest

    Charlie,

    Many thanks for this, can you tell me what the
    hklm:/system/currentcontrolset/services/tcpip/parameters should be as i.e.
    name, type and data values?

    Many thanks.


    "Charlie Russel - MVP" wrote:

    > Check the settings on your NIC. SP2 changes some settings that can cause
    > issues. Specifically:
    >
    > netsh interface tcp set global autotuning=disabled
    > netsh interface tcp set global chimney=disabled
    > netsh interface tcp set global rss=disabled
    >
    > This turns off RSS, TCP Offload and TCPChimney. You can also do this in the
    > registry, at:
    >
    > hklm:/system/currentcontrolset/services/tcpip/parameters.
    >
    > --
    > Charlie.
    > http://msmvps.com/xperts64
    > http://mvp.support.microsoft.com/profile/charlie.russel
    >
    >
    > "nbailey" <> wrote in message
    > news:...
    > > Hi there,
    > >
    > > I installed SP2 on a 64bit Windows Server 2003 server. As a result i am
    > > unable to RDP to the server even though the firewall is set to allow RDP.
    > > Even if i switch the forewall off i am unable to RDP. The only way i am
    > > currently getting round this issue is to disable the firewall service
    > > (which
    > > is far from ideal!!!).
    > >
    > > Can anyone help?
    > >
    > > Many thanks in advance

    >
     
    nbailey, Jan 15, 2008
    #3
  4. Just run the netsh commands - they'll fix it, or should.

    For the registry settings, there are three "enable" parameters - set them to
    "0" to disable them. They are:
    EnableRSS
    EnableTCPA
    EnableTCPChimney

    But the easy way is to run the netsh commands - they set the registry for
    you. Once you've done this, reboot the server.

    --
    Charlie.
    http://msmvps.com/xperts64
    http://mvp.support.microsoft.com/profile/charlie.russel


    "nbailey" <> wrote in message
    news:...
    > Charlie,
    >
    > Many thanks for this, can you tell me what the
    > hklm:/system/currentcontrolset/services/tcpip/parameters should be as i.e.
    > name, type and data values?
    >
    > Many thanks.
    >
    >
    > "Charlie Russel - MVP" wrote:
    >
    >> Check the settings on your NIC. SP2 changes some settings that can cause
    >> issues. Specifically:
    >>
    >> netsh interface tcp set global autotuning=disabled
    >> netsh interface tcp set global chimney=disabled
    >> netsh interface tcp set global rss=disabled
    >>
    >> This turns off RSS, TCP Offload and TCPChimney. You can also do this in
    >> the
    >> registry, at:
    >>
    >> hklm:/system/currentcontrolset/services/tcpip/parameters.
    >>
    >> --
    >> Charlie.
    >> http://msmvps.com/xperts64
    >> http://mvp.support.microsoft.com/profile/charlie.russel
    >>
    >>
    >> "nbailey" <> wrote in message
    >> news:...
    >> > Hi there,
    >> >
    >> > I installed SP2 on a 64bit Windows Server 2003 server. As a result i am
    >> > unable to RDP to the server even though the firewall is set to allow
    >> > RDP.
    >> > Even if i switch the forewall off i am unable to RDP. The only way i am
    >> > currently getting round this issue is to disable the firewall service
    >> > (which
    >> > is far from ideal!!!).
    >> >
    >> > Can anyone help?
    >> >
    >> > Many thanks in advance

    >>
     
    Charlie Russel - MVP, Jan 16, 2008
    #4
  5. nbailey

    nbailey Guest

    Yep, that did the trick. Many thanks Charlie for your quick response and
    helpfulness.

    "Charlie Russel - MVP" wrote:

    > Just run the netsh commands - they'll fix it, or should.
    >
    > For the registry settings, there are three "enable" parameters - set them to
    > "0" to disable them. They are:
    > EnableRSS
    > EnableTCPA
    > EnableTCPChimney
    >
    > But the easy way is to run the netsh commands - they set the registry for
    > you. Once you've done this, reboot the server.
    >
    > --
    > Charlie.
    > http://msmvps.com/xperts64
    > http://mvp.support.microsoft.com/profile/charlie.russel
    >
    >
    > "nbailey" <> wrote in message
    > news:...
    > > Charlie,
    > >
    > > Many thanks for this, can you tell me what the
    > > hklm:/system/currentcontrolset/services/tcpip/parameters should be as i.e.
    > > name, type and data values?
    > >
    > > Many thanks.
    > >
    > >
    > > "Charlie Russel - MVP" wrote:
    > >
    > >> Check the settings on your NIC. SP2 changes some settings that can cause
    > >> issues. Specifically:
    > >>
    > >> netsh interface tcp set global autotuning=disabled
    > >> netsh interface tcp set global chimney=disabled
    > >> netsh interface tcp set global rss=disabled
    > >>
    > >> This turns off RSS, TCP Offload and TCPChimney. You can also do this in
    > >> the
    > >> registry, at:
    > >>
    > >> hklm:/system/currentcontrolset/services/tcpip/parameters.
    > >>
    > >> --
    > >> Charlie.
    > >> http://msmvps.com/xperts64
    > >> http://mvp.support.microsoft.com/profile/charlie.russel
    > >>
    > >>
    > >> "nbailey" <> wrote in message
    > >> news:...
    > >> > Hi there,
    > >> >
    > >> > I installed SP2 on a 64bit Windows Server 2003 server. As a result i am
    > >> > unable to RDP to the server even though the firewall is set to allow
    > >> > RDP.
    > >> > Even if i switch the forewall off i am unable to RDP. The only way i am
    > >> > currently getting round this issue is to disable the firewall service
    > >> > (which
    > >> > is far from ideal!!!).
    > >> >
    > >> > Can anyone help?
    > >> >
    > >> > Many thanks in advance
    > >>

    >
     
    nbailey, Jan 17, 2008
    #5
  6. Good news. Glad it fixed it.

    --
    Charlie.
    http://msmvps.com/xperts64
    http://mvp.support.microsoft.com/profile/charlie.russel


    "nbailey" <> wrote in message
    news:...
    > Yep, that did the trick. Many thanks Charlie for your quick response and
    > helpfulness.
    >
    > "Charlie Russel - MVP" wrote:
    >
    >> Just run the netsh commands - they'll fix it, or should.
    >>
    >> For the registry settings, there are three "enable" parameters - set them
    >> to
    >> "0" to disable them. They are:
    >> EnableRSS
    >> EnableTCPA
    >> EnableTCPChimney
    >>
    >> But the easy way is to run the netsh commands - they set the registry for
    >> you. Once you've done this, reboot the server.
    >>
    >> --
    >> Charlie.
    >> http://msmvps.com/xperts64
    >> http://mvp.support.microsoft.com/profile/charlie.russel
    >>
    >>
    >> "nbailey" <> wrote in message
    >> news:...
    >> > Charlie,
    >> >
    >> > Many thanks for this, can you tell me what the
    >> > hklm:/system/currentcontrolset/services/tcpip/parameters should be as
    >> > i.e.
    >> > name, type and data values?
    >> >
    >> > Many thanks.
    >> >
    >> >
    >> > "Charlie Russel - MVP" wrote:
    >> >
    >> >> Check the settings on your NIC. SP2 changes some settings that can
    >> >> cause
    >> >> issues. Specifically:
    >> >>
    >> >> netsh interface tcp set global autotuning=disabled
    >> >> netsh interface tcp set global chimney=disabled
    >> >> netsh interface tcp set global rss=disabled
    >> >>
    >> >> This turns off RSS, TCP Offload and TCPChimney. You can also do this
    >> >> in
    >> >> the
    >> >> registry, at:
    >> >>
    >> >> hklm:/system/currentcontrolset/services/tcpip/parameters.
    >> >>
    >> >> --
    >> >> Charlie.
    >> >> http://msmvps.com/xperts64
    >> >> http://mvp.support.microsoft.com/profile/charlie.russel
    >> >>
    >> >>
    >> >> "nbailey" <> wrote in message
    >> >> news:...
    >> >> > Hi there,
    >> >> >
    >> >> > I installed SP2 on a 64bit Windows Server 2003 server. As a result i
    >> >> > am
    >> >> > unable to RDP to the server even though the firewall is set to allow
    >> >> > RDP.
    >> >> > Even if i switch the forewall off i am unable to RDP. The only way i
    >> >> > am
    >> >> > currently getting round this issue is to disable the firewall
    >> >> > service
    >> >> > (which
    >> >> > is far from ideal!!!).
    >> >> >
    >> >> > Can anyone help?
    >> >> >
    >> >> > Many thanks in advance
    >> >>

    >>
     
    Charlie Russel - MVP, Jan 17, 2008
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Paul King

    RDP over Wireless SP2

    Paul King, Jun 13, 2005, in forum: Wireless Networking
    Replies:
    4
    Views:
    2,438
    Sooner Al [MVP]
    Jun 13, 2005
  2. =?Utf-8?B?VGhlYQ==?=

    Garbled Display after SP2 Installed - Please help!!

    =?Utf-8?B?VGhlYQ==?=, Apr 19, 2005, in forum: Microsoft Certification
    Replies:
    3
    Views:
    556
    Jarrette Smith
    May 2, 2005
  3. Brando

    C: Drive takes ages after SP2 installed

    Brando, Sep 20, 2004, in forum: Computer Support
    Replies:
    6
    Views:
    593
    Pennywise
    Sep 24, 2004
  4. Mike

    Help! Installed Windows XP sp2 and IE 7!

    Mike, Jan 24, 2007, in forum: Computer Support
    Replies:
    3
    Views:
    453
    Walter Mautner
    Jan 24, 2007
  5. nbailey

    SP2 - Unable to RDP

    nbailey, Jan 15, 2008, in forum: Windows 64bit
    Replies:
    1
    Views:
    392
    Charlie Russel - MVP
    Jan 15, 2008
Loading...

Share This Page