Sony DSC-P10 Problem

Discussion in 'Digital Photography' started by dan9125@aol.com, Sep 19, 2005.

  1. Guest

    Hi all,
    I have a 2 year old Sony P10 5.0 mege pixel camera and ive been
    getting a dirt or smudge mark in all my shots in the upper right area
    of the picture. Someone told me it might be the sensor inside is dirty
    because the lens is clean. Is it possible to clean the sensor on this
    camera, has anyone tried it before. I didnt want to open up the camera
    and make it worse. Thanks for any input. (I can send you a picture as
    an example if it would help.)

     
    , Sep 19, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. luke

    Sony DSC P10 (or the DSC P5, DSC P9 or DSC P12)

    luke, Dec 24, 2003, in forum: Digital Photography
    Replies:
    2
    Views:
    605
  2. Jim Spen

    LCD Font As Small on a Sony DSC-V1 as a DSC-P10

    Jim Spen, Feb 26, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    482
    Stephen G. Giannoni
    Apr 4, 2004
  3. Stefan Brueggemann

    Sony DSC-P10 oder DSC-P100

    Stefan Brueggemann, Jun 25, 2004, in forum: Digital Photography
    Replies:
    3
    Views:
    1,113
    Anoni Moose
    Jul 2, 2004
  4. Bevluvsrats

    Sony Cybershot DSC P10 problem

    Bevluvsrats, Oct 15, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    541
    Ed Ruf
    Oct 15, 2004
  5. Sony DSC-P10 Problem

    , Feb 16, 2007, in forum: Digital Photography
    Replies:
    1
    Views:
    385
    adminforto
    Feb 17, 2007
Loading...

Share This Page