Some Questions on VLAN Trunking and Layer 3 Routing

Discussion in 'Cisco' started by tman, Sep 19, 2008.

  1. tman

    tman Guest

    Hope this is not to verbose.

    -- What I am trying to do:

    I am trying to configure a Cisco 2948G-L3 and a Cisco 3548 for vlan
    trunking. I am

    currently using the Cisco 2948G-L3 as a router. It is not configured
    with VLANs, it has

    various groups of ports configured in seven different BVIs. Each BVI
    has an ip assigned

    and acts as the default gateway for end stations on its respective
    subnet. This all

    works great and we have used it for years.

    I am now trying to figure out how to configure the Cisco 2948G-L3 to
    terminate a VLAN

    trunk from a Nortel switch that we will be getting soon for some
    wireless phones. We

    will also be using the Nortel wireless network for a few wireless
    workstations and

    laptops. We will have four VLANs on the Nortel switch. Two of them do
    not need to trunk

    to the Cisco 2948G-L3 as they will have ports on the Nortel switch
    assigned to them to

    get to devices.

    I also thought I would create and additional BVI, Bridge-group 111 on
    the Cisco 2948G-L3

    to bridge VLAN1 to the other switch for management.

    We do want to trunk two VLANs so they can be routed to our other
    subnets. To simmulate

    the Nortel switch, I am using the Cisco 3548 to work out the
    configuration.

    What I have done is created the VLANs on the Cisco 3548. Configured
    fa0/1 as a trunk.

    I am using dot1q as the trunk protocol. Configured the trunk to allow
    only VLANs 1,

    100, and 200. Vtp is set to transparent.

    On the Cisco 2948G-L3 I configured fa44 with three
    subinterfaces:fa44.1, fa44.100, and

    fa44.200. They are configure with dot1q and fa44.100 and fa44.200
    have ip addresses

    assigned. I made fa44.1 a member of bridge-group 111.

    BVI111 on the Cisco 2948G-L3 has ip address 192.168.11.1 255.255.255.0
    and VLAN 1 on the

    Cisco 3548 has ip address 192.168.11.2 with a default gateway of
    192.168.11.1.

    -- A Basic Question:

    I am assuming that the subinterfaces fa44.100 and fa44.20 on the Cisco
    2948G-L3 will

    route to the other BVIs. Is this correct?

    -- My Problem So Far:

    My bridging of VLAN1 does not work as I cannot ping the VLAN1 ip
    addresses across the

    trunk. I have not tried the other subnets yet, but if the bridging
    doesn't work the

    others probably aren't either.

    Is there a way to confirm the trunk is working? The interfaces line
    protocols are up.


    Here is the config of my subinterfaces on the Cisco 2948G-L3 where the
    trunk comes in.

    interface FastEthernet44
    no ip address
    no ip directed-broadcast
    !
    interface FastEthernet44.1
    encapsulation dot1Q 1 native
    no ip directed-broadcast
    bridge-group 111
    !
    interface FastEthernet44.100
    encapsulation dot1Q 100
    ip address 192.168.8.1 255.255.255.0
    ip helper-address 192.168.3.4
    no ip directed-broadcast
    !
    interface FastEthernet44.200
    encapsulation dot1Q 200
    ip address 192.168.10.1 255.255.255.0
    ip helper-address 192.168.3.4
    no ip directed-broadcast


    Here is the trunk on the Cisco 3548

    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,100,200,1002-1005
    switchport mode trunk

    Any suggestions will be appreciated.
    tman, Sep 19, 2008
    #1
    1. Advertising

  2. tman

    tman Guest

    On Sep 18, 6:13 pm, tman <> wrote:
    > Hope this is not to verbose.
    >
    > -- What I am trying to do:
    >
    > I am trying to configure a Cisco 2948G-L3 and a Cisco 3548 for vlan
    > trunking.  I am
    >
    > currently using the Cisco 2948G-L3 as a router.  It is not configured
    > with VLANs, it has
    >
    > various groups of ports configured in seven different BVIs.  Each BVI
    > has an ip assigned
    >
    > and acts as the default gateway for end stations on its respective
    > subnet.  This all
    >
    > works great and we have used it for years.
    >
    > I am now trying to figure out how to configure the Cisco 2948G-L3 to
    > terminate a VLAN
    >
    > trunk from a Nortel switch that we will be getting soon for some
    > wireless phones.  We
    >
    > will also be using the Nortel wireless network for a few wireless
    > workstations and
    >
    > laptops. We will have four VLANs on the Nortel switch.  Two of them do
    > not need to trunk
    >
    > to the Cisco 2948G-L3 as they will have ports on the Nortel switch
    > assigned to them to
    >
    > get to devices.
    >
    > I also thought I would create and additional BVI, Bridge-group 111 on
    > the Cisco 2948G-L3
    >
    > to bridge VLAN1 to the other switch for management.
    >
    > We do want to trunk two VLANs so they can be routed to our other
    > subnets.  To simmulate
    >
    > the Nortel switch, I am using the Cisco 3548 to work out the
    > configuration.
    >
    > What I have done is created the VLANs on the Cisco 3548.  Configured
    > fa0/1 as a trunk.
    >
    > I am using dot1q as the trunk protocol.  Configured the trunk to allow
    > only VLANs 1,
    >
    > 100, and 200. Vtp is set to transparent.
    >
    > On the Cisco 2948G-L3 I configured fa44 with three
    > subinterfaces:fa44.1, fa44.100, and
    >
    > fa44.200.  They are configure with dot1q and fa44.100 and fa44.200
    > have ip addresses
    >
    > assigned.  I made fa44.1 a member of bridge-group 111.
    >
    > BVI111 on the Cisco 2948G-L3 has ip address 192.168.11.1 255.255.255.0
    > and VLAN 1 on the
    >
    > Cisco 3548 has ip address 192.168.11.2 with a default gateway of
    > 192.168.11.1.
    >
    > -- A Basic Question:
    >
    > I am assuming that the subinterfaces fa44.100 and fa44.20 on the Cisco
    > 2948G-L3 will
    >
    > route to the other BVIs.  Is this correct?
    >
    > -- My Problem So Far:
    >
    > My bridging of VLAN1 does not work as I cannot ping the VLAN1 ip
    > addresses across the
    >
    > trunk.  I have not tried the other subnets yet, but if the bridging
    > doesn't work the
    >
    > others probably aren't either.
    >
    > Is there a way to confirm the trunk is working?  The interfaces line
    > protocols are up.
    >
    > Here is the config of my subinterfaces on the Cisco 2948G-L3 where the
    > trunk comes in.
    >
    > interface FastEthernet44
    >  no ip address
    >  no ip directed-broadcast
    > !
    > interface FastEthernet44.1
    >  encapsulation dot1Q 1 native
    >  no ip directed-broadcast
    >  bridge-group 111
    > !
    > interface FastEthernet44.100
    >  encapsulation dot1Q 100
    >  ip address 192.168.8.1 255.255.255.0
    >  ip helper-address 192.168.3.4
    >  no ip directed-broadcast
    > !
    > interface FastEthernet44.200
    >  encapsulation dot1Q 200
    >  ip address 192.168.10.1 255.255.255.0
    >  ip helper-address 192.168.3.4
    >  no ip directed-broadcast
    >
    > Here is the trunk on the Cisco 3548
    >
    > interface FastEthernet0/1
    >  switchport trunk encapsulation dot1q
    >  switchport trunk allowed vlan 1,100,200,1002-1005
    >  switchport mode trunk
    >
    > Any suggestions will be appreciated.


    Finally got it working. I had forgotten the route ip command on the
    new BVI, bridgegroup 111.
    tman, Sep 19, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. praveen
    Replies:
    1
    Views:
    3,049
    Bjørn Djupvik
    Oct 22, 2003
  2. WabukiSensei
    Replies:
    4
    Views:
    49,754
    WabukiSensei
    Dec 6, 2006
  3. mnkyb0i

    VLAN Trunking/Routing Problem

    mnkyb0i, Jun 26, 2007, in forum: Cisco
    Replies:
    0
    Views:
    475
    mnkyb0i
    Jun 26, 2007
  4. Mark
    Replies:
    4
    Views:
    426
    Doug McIntyre
    Sep 1, 2008
  5. Bob Simon

    VLAN Trunking and Routing Qs

    Bob Simon, Nov 18, 2008, in forum: Cisco
    Replies:
    5
    Views:
    1,446
    Stephen
    Nov 20, 2008
Loading...

Share This Page