Soho 97 Dial Backup fails

Discussion in 'Cisco' started by Richard Weatherley, Jul 8, 2003.

  1. Hi

    I can't get dial backup working on a Soho 97.
    The modem on the AUX port never dials.
    Debugging reveals the error:

    Di1 DDR: Cannot place call, no dialer string set

    Relevant parts of config (sanitized):

    modemcap entry aopen:MSC=&F1S0=0
    chat-script dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT nnnnnn \T"
    TIMEOUT 60 CONNECT \c
    !
    interface ATM0
    no ip address
    backup interface async1
    backup delay 10 10
    no ip mroute-cache
    atm vc-per-vp 64
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    dsl operating-mode auto
    !
    interface Dialer1
    ip address negotiated
    no ip directed-broadcast
    ip access-group 110 in
    ip inspect from_internal out
    no cdp enable
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname xxx
    ppp chap password 7 zzz
    ppp pap sent-username xxx password 7 yyy
    hold-queue 224 in
    !
    interface Async1
    no ip address
    encapsulation ppp
    dialer in-band
    dialer pool-member 2
    async default routing
    async mode dedicated
    !
    interface Dialer2
    ip address negotiated
    encapsulation ppp
    no ip directed-broadcast
    ip access-group 110 in
    ip inspect from_internal out
    no cdp enable
    no ip route-cache
    no ip mroute-cache
    dialer pool 2
    dialer-group 1
    dialer idle-timeout 300
    dialer remote-name pacific
    dialer string nnnnnnnn modem-script dialout
    ppp authentication chap pap
    ppp chap hostname xxx
    ppp chap password 7 zzz
    ppp pap sent-username xxx password 7 yyy
    ppp ipcp dns request
    ppp ipcp mask request
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1 150
    dialer-list 1 protocol ip permit
    !
    line aux 0
    script dialer dialout
    modem callout
    modem autoconfigure type aopen
    transport input all
    stopbits 1
    speed 57600
    flowcontrol hardware

    Debugging settings:

    debug atm events
    debug ip routing
    debug dialer
    debug modem
    debug chat line 1
    debug ppp negotiation

    Debugging output when DSL line unplugged
    (to test dial backup):

    00:55:48: %LINK-5-CHANGED: Interface Async1, changed state to standby mode
    00:55:51: DSL: Defect: LOS LOF LCDf LOM: retraining
    00:55:51: DSL: Received response: 0x41
    00:55:51: Resetting ATM0
    00:55:53: %LINK-3-UPDOWN: Interface ATM0, changed state to down
    00:55:53: DSL: SM: [DMTDSL_SHOWTIME -> DMTDSL_RE_OPEN]
    00:55:53: DSL: Send ADSL_CLOSE command.
    00:55:53: DSL: Sent command 0x4
    00:55:54: DSL: Received response: 0x25
    00:55:54: DSL: Connection closed
    00:55:54: DSL: SM: [DMTDSL_RE_OPEN -> DMTDSL_DO_OPEN]
    00:55:54: DSL: Send ADSL_OPEN command.
    00:55:54: DSL: Using subfunction 0x15
    00:55:54: DSL: Using subfunction 0x15
    00:55:54: LOCAL:Max noise margin for power cutoff 31
    00:55:54: DSL: Sent command 0x3
    00:55:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed
    state to down
    00:55:54: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    00:55:54: Vi3 IPCP: Remove link info for cef entry 203.9.190.190
    00:55:54: Vi3 CDPCP: State is Closed
    00:55:54: Vi3 IPCP: State is Closed
    00:55:54: Vi3 PPP: Phase is ESTABLISHING, renegotiate LCP
    00:55:54: Vi3 PPP: No remote authentication for call-out
    00:55:54: Vi3 LCP: O CONFREQ [Closed] id 12 len 10
    00:55:54: Vi3 LCP: MagicNumber 0x0D5B454E (0x05060D5B454E)
    00:55:54: %DIALER-6-UNBIND: Interface Vi3 unbound from profile Di1
    00:55:54: RT: Pruning routes for Dialer1 (3)
    00:55:54: RT: delete route to 203.9.190.190 via 0.0.0.0, Dialer1
    00:55:54: RT: no routes to 203.9.190.190, flushing
    00:55:54: RT: NET-RED 203.9.190.190/32
    00:55:54: RT: NET-RED queued, Queue size 1
    00:55:54: RT: delete network route to 203.9.190.0
    00:55:54: RT: NET-RED 203.9.190.0/24
    00:55:54: RT: NET-RED queued, Queue size 2
    00:55:54: Vi3 LCP: State is Closed
    00:55:54: Vi3 PPP: Phase is DOWN
    00:55:54: RT: delete route to 203.100.236.210 via 0.0.0.0, Dialer1
    00:55:54: RT: no routes to 203.100.236.210, flushing
    00:55:54: RT: NET-RED 203.100.236.210/32
    00:55:54: RT: NET-RED queued, Queue size 1
    00:55:54: RT: delete network route to 203.100.236.0
    00:55:54: RT: NET-RED 203.100.236.0/24
    00:55:54: RT: NET-RED queued, Queue size 2
    00:55:54: RT: delete route to 0.0.0.0 via 0.0.0.0, Dialer1
    00:55:54: RT: no routes to 0.0.0.0, flushing
    00:55:54: RT: NET-RED 0.0.0.0/0
    00:55:54: RT: NET-RED queued, Queue size 1
    00:55:54: RT: NET-RED 0.0.0.0/0
    00:55:54: RT: NET-RED queued, Queue size 2
    00:55:54: Di1 IPCP: Remove route to 203.9.190.190
    00:55:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    Virtual-Access3, changed state to down
    00:55:55: RT: add 0.0.0.0/0 via 0.0.0.0, static metric [150/0]
    00:55:55: RT: NET-RED 0.0.0.0/0
    00:55:55: RT: NET-RED queued, Queue size 1
    00:55:55: RT: default path is now 0.0.0.0 via 0.0.0.0
    00:55:55: RT: new default network 0.0.0.0
    00:55:55: RT: NET-RED 0.0.0.0/0
    00:55:55: RT: NET-RED queued, Queue size 2
    00:55:56: Di1 DDR: Cannot place call, no dialer string set

    Any help gratefully received.

    Richard
    Richard Weatherley, Jul 8, 2003
    #1
    1. Advertising

  2. ~ Hi
    ~
    ~ I can't get dial backup working on a Soho 97.
    ~ The modem on the AUX port never dials.
    ~ Debugging reveals the error:
    ~
    ~ Di1 DDR: Cannot place call, no dialer string set
    ^^^

    You're trying to dial out via Dialer1, not Dialer2.
    Adjust your backup scheme so that you try to call via
    Dialer2.

    "backup interface async1" is no good - async1 is not
    a dialer interface (and besides, it won't cover the
    case where the ATM0 physical interface stays up but the
    IP path to the aggregation router goes down.)

    I'd recommend using dialer watch on the host route to
    the peer's (aggregation router's) address.

    Aaron

    ---

    ~ Relevant parts of config (sanitized):
    ~
    ~ modemcap entry aopen:MSC=&F1S0=0
    ~ chat-script dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT nnnnnn \T"
    ~ TIMEOUT 60 CONNECT \c
    ~ !
    ~ interface ATM0
    ~ no ip address
    ~ backup interface async1
    ~ backup delay 10 10
    ~ no ip mroute-cache
    ~ atm vc-per-vp 64
    ~ no atm ilmi-keepalive
    ~ pvc 8/35
    ~ encapsulation aal5mux ppp dialer
    ~ dialer pool-member 1
    ~ dsl operating-mode auto
    ~ !
    ~ interface Dialer1
    ~ ip address negotiated
    ~ no ip directed-broadcast
    ~ ip access-group 110 in
    ~ ip inspect from_internal out
    ~ no cdp enable
    ~ encapsulation ppp
    ~ dialer pool 1
    ~ dialer-group 1
    ~ ppp authentication chap pap callin
    ~ ppp chap hostname xxx
    ~ ppp chap password 7 zzz
    ~ ppp pap sent-username xxx password 7 yyy
    ~ hold-queue 224 in
    ~ !
    ~ interface Async1
    ~ no ip address
    ~ encapsulation ppp
    ~ dialer in-band
    ~ dialer pool-member 2
    ~ async default routing
    ~ async mode dedicated
    ~ !
    ~ interface Dialer2
    ~ ip address negotiated
    ~ encapsulation ppp
    ~ no ip directed-broadcast
    ~ ip access-group 110 in
    ~ ip inspect from_internal out
    ~ no cdp enable
    ~ no ip route-cache
    ~ no ip mroute-cache
    ~ dialer pool 2
    ~ dialer-group 1
    ~ dialer idle-timeout 300
    ~ dialer remote-name pacific
    ~ dialer string nnnnnnnn modem-script dialout
    ~ ppp authentication chap pap
    ~ ppp chap hostname xxx
    ~ ppp chap password 7 zzz
    ~ ppp pap sent-username xxx password 7 yyy
    ~ ppp ipcp dns request
    ~ ppp ipcp mask request
    ~ !
    ~ ip classless
    ~ ip route 0.0.0.0 0.0.0.0 Dialer1 150
    ~ dialer-list 1 protocol ip permit
    ~ !
    ~ line aux 0
    ~ script dialer dialout
    ~ modem callout
    ~ modem autoconfigure type aopen
    ~ transport input all
    ~ stopbits 1
    ~ speed 57600
    ~ flowcontrol hardware
    ~
    ~ Debugging settings:
    ~
    ~ debug atm events
    ~ debug ip routing
    ~ debug dialer
    ~ debug modem
    ~ debug chat line 1
    ~ debug ppp negotiation
    ~
    ~ Debugging output when DSL line unplugged
    ~ (to test dial backup):
    ~
    ~ 00:55:48: %LINK-5-CHANGED: Interface Async1, changed state to standby mode
    ~ 00:55:51: DSL: Defect: LOS LOF LCDf LOM: retraining
    ~ 00:55:51: DSL: Received response: 0x41
    ~ 00:55:51: Resetting ATM0
    ~ 00:55:53: %LINK-3-UPDOWN: Interface ATM0, changed state to down
    ~ 00:55:53: DSL: SM: [DMTDSL_SHOWTIME -> DMTDSL_RE_OPEN]
    ~ 00:55:53: DSL: Send ADSL_CLOSE command.
    ~ 00:55:53: DSL: Sent command 0x4
    ~ 00:55:54: DSL: Received response: 0x25
    ~ 00:55:54: DSL: Connection closed
    ~ 00:55:54: DSL: SM: [DMTDSL_RE_OPEN -> DMTDSL_DO_OPEN]
    ~ 00:55:54: DSL: Send ADSL_OPEN command.
    ~ 00:55:54: DSL: Using subfunction 0x15
    ~ 00:55:54: DSL: Using subfunction 0x15
    ~ 00:55:54: LOCAL:Max noise margin for power cutoff 31
    ~ 00:55:54: DSL: Sent command 0x3
    ~ 00:55:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed
    ~ state to down
    ~ 00:55:54: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    ~ 00:55:54: Vi3 IPCP: Remove link info for cef entry 203.9.190.190
    ~ 00:55:54: Vi3 CDPCP: State is Closed
    ~ 00:55:54: Vi3 IPCP: State is Closed
    ~ 00:55:54: Vi3 PPP: Phase is ESTABLISHING, renegotiate LCP
    ~ 00:55:54: Vi3 PPP: No remote authentication for call-out
    ~ 00:55:54: Vi3 LCP: O CONFREQ [Closed] id 12 len 10
    ~ 00:55:54: Vi3 LCP: MagicNumber 0x0D5B454E (0x05060D5B454E)
    ~ 00:55:54: %DIALER-6-UNBIND: Interface Vi3 unbound from profile Di1
    ~ 00:55:54: RT: Pruning routes for Dialer1 (3)
    ~ 00:55:54: RT: delete route to 203.9.190.190 via 0.0.0.0, Dialer1
    ~ 00:55:54: RT: no routes to 203.9.190.190, flushing
    ~ 00:55:54: RT: NET-RED 203.9.190.190/32
    ~ 00:55:54: RT: NET-RED queued, Queue size 1
    ~ 00:55:54: RT: delete network route to 203.9.190.0
    ~ 00:55:54: RT: NET-RED 203.9.190.0/24
    ~ 00:55:54: RT: NET-RED queued, Queue size 2
    ~ 00:55:54: Vi3 LCP: State is Closed
    ~ 00:55:54: Vi3 PPP: Phase is DOWN
    ~ 00:55:54: RT: delete route to 203.100.236.210 via 0.0.0.0, Dialer1
    ~ 00:55:54: RT: no routes to 203.100.236.210, flushing
    ~ 00:55:54: RT: NET-RED 203.100.236.210/32
    ~ 00:55:54: RT: NET-RED queued, Queue size 1
    ~ 00:55:54: RT: delete network route to 203.100.236.0
    ~ 00:55:54: RT: NET-RED 203.100.236.0/24
    ~ 00:55:54: RT: NET-RED queued, Queue size 2
    ~ 00:55:54: RT: delete route to 0.0.0.0 via 0.0.0.0, Dialer1
    ~ 00:55:54: RT: no routes to 0.0.0.0, flushing
    ~ 00:55:54: RT: NET-RED 0.0.0.0/0
    ~ 00:55:54: RT: NET-RED queued, Queue size 1
    ~ 00:55:54: RT: NET-RED 0.0.0.0/0
    ~ 00:55:54: RT: NET-RED queued, Queue size 2
    ~ 00:55:54: Di1 IPCP: Remove route to 203.9.190.190
    ~ 00:55:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    ~ Virtual-Access3, changed state to down
    ~ 00:55:55: RT: add 0.0.0.0/0 via 0.0.0.0, static metric [150/0]
    ~ 00:55:55: RT: NET-RED 0.0.0.0/0
    ~ 00:55:55: RT: NET-RED queued, Queue size 1
    ~ 00:55:55: RT: default path is now 0.0.0.0 via 0.0.0.0
    ~ 00:55:55: RT: new default network 0.0.0.0
    ~ 00:55:55: RT: NET-RED 0.0.0.0/0
    ~ 00:55:55: RT: NET-RED queued, Queue size 2
    ~ 00:55:56: Di1 DDR: Cannot place call, no dialer string set
    ~
    ~ Any help gratefully received.
    ~
    ~ Richard
    Aaron Leonard, Jul 8, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ivana

    dial-in user fails on 3640

    Ivana, Jan 28, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,486
    Ivan Ostres
    Jan 29, 2004
  2. Morten Lundstrøm

    How-to backup Cisco SOHO 77

    Morten Lundstrøm, Apr 4, 2004, in forum: Cisco
    Replies:
    2
    Views:
    676
  3. Eitan Goldin

    play media when a voip dial-peer fails

    Eitan Goldin, Jul 12, 2004, in forum: Cisco
    Replies:
    0
    Views:
    438
    Eitan Goldin
    Jul 12, 2004
  4. Eitan Goldin

    play media when a voip dial-peer fails

    Eitan Goldin, Jul 12, 2004, in forum: Cisco
    Replies:
    0
    Views:
    566
    Eitan Goldin
    Jul 12, 2004
  5. Wao
    Replies:
    12
    Views:
    1,292
Loading...

Share This Page