Soho-77 irb routing w/DHCP but no NAT

Discussion in 'Cisco' started by Greg Young, May 12, 2004.

  1. Greg Young

    Greg Young Guest

    I have a soho-77 that I am using to replace the Speed Stream ADSL
    Modem from the ISP.

    I have a working config for DHCP and NAT but want to loose the NAT
    part and allow the clients on e0 to receive the Public IP addresses
    assigned from the ISP's DHCP server. This is so I can place my PIX
    Firewall behind the 77

    TIA

    Greg

    Current configuration:
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Router
    !
    no logging buffered
    !
    ip subnet-zero
    ip name-server 66.133.170.2
    ip name-server 66.133.128.138
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool CLIENT
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    lease 0 2
    !
    bridge irb
    !
    !
    !
    interface Ethernet0
    ip address 10.10.10.1 255.255
    ip nat inside
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0/35
    encapsulation aal5snap
    !
    dsl operating-mode auto
    bridge-group 1
    hold-queue 224 in
    !
    interface BVI1
    ip address dhcp client-id Ethernet0
    ip nat outside
    !
    ip nat inside source list 102 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 BVI1
    ip http server
    !
    access-list 23 permit 10.10.10.0 0.0.0.255
    access-list 102 permit ip 10.10.10.0 0.0.0.255 any
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    exec-timeout 120 0
    transport input none
    stopbits 1
    line vty 0 4
    access-class 23 in
    exec-timeout 120 0
    login local
    length 0
    !
    scheduler max-task-time 5000
    end
    Greg Young, May 12, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alexandre
    Replies:
    0
    Views:
    8,119
    Alexandre
    Oct 17, 2003
  2. rwilson
    Replies:
    1
    Views:
    719
    Jesper Skriver
    Oct 28, 2003
  3. G-Unit
    Replies:
    0
    Views:
    1,979
    G-Unit
    Jan 16, 2004
  4. Replies:
    1
    Views:
    1,511
  5. dinghy
    Replies:
    0
    Views:
    625
    dinghy
    Nov 15, 2006
Loading...

Share This Page