slow over router

Discussion in 'Cisco' started by dt1649651@yahoo.com, Jul 9, 2007.

  1. Guest

    The router is a 2811 with 4 Port FE Switch. This switch connects local
    LANs together. Recently I notice that copying files between LANs is
    slower than usual and "show process" shows a high cpu utilization:

    CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    minutes: 90%


    Below is the output of "show process" when there is no copying file
    running.

    CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    minutes: 29%


    It was not that slow before. Any advice is greatly appreciated.

    DT
    , Jul 9, 2007
    #1
    1. Advertising

  2. <> ha scritto nel messaggio
    news:...
    > The router is a 2811 with 4 Port FE Switch. This switch connects local
    > LANs together. Recently I notice that copying files between LANs is
    > slower than usual and "show process" shows a high cpu utilization:
    >
    > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    > minutes: 90%
    >
    >
    > Below is the output of "show process" when there is no copying file
    > running.
    >
    > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    > minutes: 29%
    >
    >
    > It was not that slow before. Any advice is greatly appreciated.
    >
    > DT
    >


    Hi,

    I'm in hurry so I've to be quick... it seems that your router is using much
    more CPU that normal (probably due to process switching during transfers or
    other control plane processes) ... I suggest you look in your config and see
    if you have CEF enabled (or at least Fast Switching).

    Regards,
    Gabriele
    Gabriele Beltrame, Jul 9, 2007
    #2
    1. Advertising

  3. Guest

    On Jul 9, 12:39 pm, "Gabriele Beltrame" <> wrote:
    > <> ha scritto nel messaggionews:...
    >
    >
    >
    > > The router is a 2811 with 4 Port FE Switch. This switch connects local
    > > LANs together. Recently I notice that copying files between LANs is
    > > slower than usual and "show process" shows a high cpu utilization:

    >
    > > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    > > minutes: 90%

    >
    > > Below is the output of "show process" when there is no copying file
    > > running.

    >
    > > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    > > minutes: 29%

    >
    > > It was not that slow before. Any advice is greatly appreciated.

    >
    > > DT

    >
    > Hi,
    >
    > I'm in hurry so I've to be quick... it seems that your router is using much
    > more CPU that normal (probably due to process switching during transfers or
    > other control plane processes) ... I suggest you look in your config and see
    > if you have CEF enabled (or at least Fast Switching).
    >


    Thanks Babriele. I checked and there is no CEF or fastswitching set on
    the router.

    Vu
    , Jul 9, 2007
    #3
  4. <> ha scritto nel messaggio
    news:...
    > On Jul 9, 12:39 pm, "Gabriele Beltrame" <> wrote:
    >> <> ha scritto nel
    >> messaggionews:...
    >>
    >>
    >>
    >> > The router is a 2811 with 4 Port FE Switch. This switch connects local
    >> > LANs together. Recently I notice that copying files between LANs is
    >> > slower than usual and "show process" shows a high cpu utilization:

    >>
    >> > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    >> > minutes: 90%

    >>
    >> > Below is the output of "show process" when there is no copying file
    >> > running.

    >>
    >> > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    >> > minutes: 29%

    >>
    >> > It was not that slow before. Any advice is greatly appreciated.

    >>
    >> > DT

    >>
    >> Hi,
    >>
    >> I'm in hurry so I've to be quick... it seems that your router is using
    >> much
    >> more CPU that normal (probably due to process switching during transfers
    >> or
    >> other control plane processes) ... I suggest you look in your config and
    >> see
    >> if you have CEF enabled (or at least Fast Switching).
    >>

    >
    > Thanks Babriele. I checked and there is no CEF or fastswitching set on
    > the router.
    >
    > Vu
    >


    Hi,

    Then enable ip (ip cef in Global Config) (by default it is enabled... maybe
    someone has disabled it for debugging purposes)

    Since it could be disabled also on a per-interface base, make sure it is
    enabled on all interfaces ( ip route-cache cef in Interface config )

    Regards,
    Gabriele
    Gabriele Beltrame, Jul 9, 2007
    #4
  5. Guest

    On Jul 9, 3:26 pm, "Gabriele Beltrame" <> wrote:
    > <> ha scritto nel messaggionews:...
    >
    >
    >
    > > On Jul 9, 12:39 pm, "Gabriele Beltrame" <> wrote:
    > >> <> ha scritto nel
    > >> messaggionews:...

    >
    > >> > The router is a 2811 with 4 Port FE Switch. This switch connects local
    > >> > LANs together. Recently I notice that copying files between LANs is
    > >> > slower than usual and "show process" shows a high cpu utilization:

    >
    > >> > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    > >> > minutes: 90%

    >
    > >> > Below is the output of "show process" when there is no copying file
    > >> > running.

    >
    > >> > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    > >> > minutes: 29%

    >
    > >> > It was not that slow before. Any advice is greatly appreciated.

    >
    > >> > DT

    >
    > >> Hi,

    >
    > >> I'm in hurry so I've to be quick... it seems that your router is using
    > >> much
    > >> more CPU that normal (probably due to process switching during transfers
    > >> or
    > >> other control plane processes) ... I suggest you look in your config and
    > >> see
    > >> if you have CEF enabled (or at least Fast Switching).

    >
    > > Thanks Babriele. I checked and there is no CEF or fastswitching set on
    > > the router.

    >
    > > Vu

    >
    > Hi,
    >
    > Then enable ip (ip cef in Global Config) (by default it is enabled... maybe
    > someone has disabled it for debugging purposes)
    >
    > Since it could be disabled also on a per-interface base, make sure it is
    > enabled on all interfaces ( ip route-cache cef in Interface config )
    >



    This router has a serious problem with IP CEF that it will crash the
    router under high load. Cisco techsupport suggested me to turn off
    CEF.
    I just turned it on to check if the throughput is improved. The
    throughput did improve but it crashed the router after about 10
    seconds :(

    I have to check if there is a newer IOS that fixes this problem.

    Thanks, Gabriele.

    Vu
    , Jul 9, 2007
    #5
  6. <> ha scritto nel messaggio
    news:...
    > On Jul 9, 3:26 pm, "Gabriele Beltrame" <> wrote:
    >> <> ha scritto nel
    >> messaggionews:...
    >>
    >>
    >>
    >> > On Jul 9, 12:39 pm, "Gabriele Beltrame" <> wrote:
    >> >> <> ha scritto nel
    >> >> messaggionews:...

    >>
    >> >> > The router is a 2811 with 4 Port FE Switch. This switch connects
    >> >> > local
    >> >> > LANs together. Recently I notice that copying files between LANs is
    >> >> > slower than usual and "show process" shows a high cpu utilization:

    >>
    >> >> > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    >> >> > minutes: 90%

    >>
    >> >> > Below is the output of "show process" when there is no copying file
    >> >> > running.

    >>
    >> >> > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    >> >> > minutes: 29%

    >>
    >> >> > It was not that slow before. Any advice is greatly appreciated.

    >>
    >> >> > DT

    >>
    >> >> Hi,

    >>
    >> >> I'm in hurry so I've to be quick... it seems that your router is using
    >> >> much
    >> >> more CPU that normal (probably due to process switching during
    >> >> transfers
    >> >> or
    >> >> other control plane processes) ... I suggest you look in your config
    >> >> and
    >> >> see
    >> >> if you have CEF enabled (or at least Fast Switching).

    >>
    >> > Thanks Babriele. I checked and there is no CEF or fastswitching set on
    >> > the router.

    >>
    >> > Vu

    >>
    >> Hi,
    >>
    >> Then enable ip (ip cef in Global Config) (by default it is enabled...
    >> maybe
    >> someone has disabled it for debugging purposes)
    >>
    >> Since it could be disabled also on a per-interface base, make sure it is
    >> enabled on all interfaces ( ip route-cache cef in Interface config )
    >>

    >
    >
    > This router has a serious problem with IP CEF that it will crash the
    > router under high load. Cisco techsupport suggested me to turn off
    > CEF.
    > I just turned it on to check if the throughput is improved. The
    > throughput did improve but it crashed the router after about 10
    > seconds :(
    >
    > I have to check if there is a newer IOS that fixes this problem.
    >
    > Thanks, Gabriele.
    >
    > Vu
    >


    Hi,

    Disable CEF and enable Fast Switching then ( ip route-cache flow )

    The first packet for each flow will be process switched, but the following
    ones will be served within the interrupt.

    Regards,
    Gabriele
    Gabriele Beltrame, Jul 9, 2007
    #6
  7. Guest

    On Jul 9, 4:25 pm, "Gabriele Beltrame" <> wrote:
    > <> ha scritto nel messaggionews:...
    >
    >
    >
    > > On Jul 9, 3:26 pm, "Gabriele Beltrame" <> wrote:
    > >> <> ha scritto nel
    > >> messaggionews:...

    >
    > >> > On Jul 9, 12:39 pm, "Gabriele Beltrame" <> wrote:
    > >> >> <> ha scritto nel
    > >> >> messaggionews:...

    >
    > >> >> > The router is a 2811 with 4 Port FE Switch. This switch connects
    > >> >> > local
    > >> >> > LANs together. Recently I notice that copying files between LANs is
    > >> >> > slower than usual and "show process" shows a high cpu utilization:

    >
    > >> >> > CPU utilization for five seconds: 99%/35%; one minute: 99%; five
    > >> >> > minutes: 90%

    >
    > >> >> > Below is the output of "show process" when there is no copying file
    > >> >> > running.

    >
    > >> >> > CPU utilization for five seconds: 28%/10%; one minute: 24%; five
    > >> >> > minutes: 29%

    >
    > >> >> > It was not that slow before. Any advice is greatly appreciated.

    >
    > >> >> > DT

    >
    > >> >> Hi,

    >
    > >> >> I'm in hurry so I've to be quick... it seems that your router is using
    > >> >> much
    > >> >> more CPU that normal (probably due to process switching during
    > >> >> transfers
    > >> >> or
    > >> >> other control plane processes) ... I suggest you look in your config
    > >> >> and
    > >> >> see
    > >> >> if you have CEF enabled (or at least Fast Switching).

    >
    > >> > Thanks Babriele. I checked and there is no CEF or fastswitching set on
    > >> > the router.

    >
    > >> > Vu

    >
    > >> Hi,

    >
    > >> Then enable ip (ip cef in Global Config) (by default it is enabled...
    > >> maybe
    > >> someone has disabled it for debugging purposes)

    >
    > >> Since it could be disabled also on a per-interface base, make sure it is
    > >> enabled on all interfaces ( ip route-cache cef in Interface config )

    >
    > > This router has a serious problem with IP CEF that it will crash the
    > > router under high load. Cisco techsupport suggested me to turn off
    > > CEF.
    > > I just turned it on to check if the throughput is improved. The
    > > throughput did improve but it crashed the router after about 10
    > > seconds :(

    >
    > > I have to check if there is a newer IOS that fixes this problem.

    >
    > > Thanks, Gabriele.

    >
    > > Vu

    >
    > Hi,
    >
    > Disable CEF and enable Fast Switching then ( ip route-cache flow )
    >
    > The first packet for each flow will be process switched, but the following
    > ones will be served within the interrupt.


    I downloaded the ios 12.4.15T and this one, according to the bug
    database, already fixed this CEF bug ( more exactly since 12.4.5 or
    12.4.4T ). After upgrading the IOS, I can turn CEF on and now the
    throughput is as expected.

    Thanks, Gabriele.

    Vu
    , Jul 10, 2007
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    883
    Theo Markettos
    Feb 14, 2008
  2. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    648
    Expert lino fitter
    Dec 10, 2008
  3. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    5
    Views:
    660
    Expert lino fitter
    Dec 12, 2008
  4. Beauregard T. Shagnasty

    Re: slow slow slow!

    Beauregard T. Shagnasty, Dec 10, 2008, in forum: Computer Support
    Replies:
    2
    Views:
    662
    Shel-hed
    Dec 10, 2008
  5. chuckcar

    Re: slow slow slow!

    chuckcar, Dec 10, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    538
    chuckcar
    Dec 10, 2008
Loading...

Share This Page