slow broadband on cisco router (long)

Discussion in 'Cisco' started by tg, Mar 4, 2009.

  1. tg

    tg Guest

    cisco 2651XM router with wic1-adsl card
    IOS: c2600-ipbase-mz.123-11.T.bin (12Mb)
    broadband = bog standard 8Mb adsl on BT line

    I've discovered to my dismay my cisco router only gives me half the
    broadband speed of a cheap plastic router (Billion 5200G). If I connect
    my PC straight to a Billion 5200G adsl router I am getting about
    3800kbps download at speedtest.net, and a file download from
    microsoft.com came down at about 450Kb/sec.
    However if I swap the Billion for my cisco router I only get about
    2500kbps at speedtest.net and the same file from MS downloads at approx
    290KKB/sec. This is quite a difference and I never expected cisco gear
    to give such poor performance - unless I'm doing something wrong that
    is.
    In testing the cisco I used two different IOS's - a minimal IOS (above)
    and a larger IOS with a bare bones running-config (below), no firewalls
    or anything and still the speed was slow. Next thing I did was change
    the adsl card (I've got two cards) but that made no difference.
    Another thing I tried was I took the adsl card out of the cisco router
    and configured a route through it out into the Billion router, so
    effectively the internet traffic was still going through the cisco
    router and the speed was back up to 3800kbps again, which would indicate
    the problem is with the WIC1-adsl card. So either these cards aren't
    much cop or I haven't configured it correctly.
    I duplicated the above test on a second 2651XM router I have and I got
    the same results.
    Below is a copy of my running-config and a bit extra so if anyone can
    see frailties in it that would cause adsl slowness I'd be grateful for
    some tips.
    Thanks if you can advise and sorry for the long post but I wanted to
    give as much info as possible.


    vpn#show int ATM0/0
    ATM0/0 is up, line protocol is up
    Hardware is DSLSAR (with Alcatel ADSL Module)
    MTU 4470 bytes, sub MTU 4470, BW 448 Kbit/sec, DLY 1140 usec,
    reliability 5/255, txload 1/255, rxload 1/255
    Encapsulation ATM, loopback not set
    Encapsulation(s): AAL5 AAL2, PVC mode
    23 maximum active VCs, 256 VCs per VP, 1 current VCCs
    VC Auto Creation Disabled.
    VC idle disconnect time: 300 seconds
    Last input never, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: Per VC Queueing
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    12 packets input, 343 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    10 packets output, 256 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out



    vpn#show int Dialer0
    Dialer0 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Internet address is xxxxxxxxxxxxx/32
    MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 1 seconds on reset
    Interface is bound to Vi2
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 00:07:38
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    8 packets input, 252 bytes
    8 packets output, 196 bytes
    Bound to:
    Virtual-Access2 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 448 Kbit/sec, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Open: IPCP
    PPPoATM vaccess, cloned from Dialer0
    Vaccess status 0x44
    Bound to ATM0/0 VCD: 1, VPI: 0, VCI: 38, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di0 (Encapsulation PPP)
    Last input 00:00:25, output never, output hang never
    Last clearing of "show interface" counters 00:01:31
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    21 packets input, 517 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    18 packets output, 356 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions




    router running config:
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname vpn
    !
    boot-start-marker
    boot-end-marker
    !
    no logging console
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
    enable password xxxxxxxxxx
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    ip dhcp excluded-address 192.168.1.1 192.168.1.199
    ip dhcp excluded-address 192.168.1.241 192.168.1.255
    !
    ip dhcp pool 192.168.1.0/24
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 212.23.3.100 212.23.6.100
    !
    !
    ip name-server 212.23.3.100
    ip name-server 212.23.6.100
    !
    !
    !
    !
    interface ATM0/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description $ETH-LAN$
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    no mop enabled
    !
    interface Dialer0
    ip address negotiated previous
    no ip redirects
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname zzzzzzzzzzzz
    ppp chap password 0 zzzzzzzzzzz
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
    !
    ip http server
    ip nat inside source list 100 interface Dialer0 overload
    !
    access-list 100 remark internet
    access-list 100 remark SDM_ACL Category=2
    access-list 100 permit ip any any
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password xxxxx
    login
    !
    !
    end
     
    tg, Mar 4, 2009
    #1
    1. Advertising

  2. "tg" <> writes:
    >cisco 2651XM router with wic1-adsl card
    >IOS: c2600-ipbase-mz.123-11.T.bin (12Mb)
    >broadband = bog standard 8Mb adsl on BT line


    >I've discovered to my dismay my cisco router only gives me half the
    >broadband speed of a cheap plastic router (Billion 5200G). If I connect
    >my PC straight to a Billion 5200G adsl router I am getting about
    >3800kbps download at speedtest.net, and a file download from
    >microsoft.com came down at about 450Kb/sec.


    >However if I swap the Billion for my cisco router I only get about
    >2500kbps at speedtest.net and the same file from MS downloads at approx
    >290KKB/sec. This is quite a difference and I never expected cisco gear
    >to give such poor performance - unless I'm doing something wrong that
    >is.


    Hmm, I wonder what kind of limitations the WIC bus may have on the Cisco.
    Usually I've done things with lower 2600's like the 2610 which is
    going to crap out about 3Mbps anyway. But your 2651XM should have
    enough steam for at least 25Mbps.

    I couldn't find a reference on bus speed for the WIC bus, only this in
    a Cisco patent for the HWIC bus..

    ::: The legacy WICs were conceived several years ago, and originally
    ::: targeted PHY devices with a maximum bit rate of a few Mbps.

    Maybe I should pop a WIC-1ADSL in a bigger router and see what I can
    push at work off my test DSLAM. Would be an interesting test. I know
    some of the max packet rates of some of my lab stuff, and know my test
    DSLAM is about as clean a DSL line as I can get.

    There isn't much you can configure on the router for the WIC-1ADSL card.
    I'd start suspecting more of a physical hardware limitation.
    The 2600 series is *not* a very speedy or very big router, even by the
    standards of $60 consumer routers. Afterall, the 2600 series was designed
    in the '90s to push a T1 or maybe two.

    Even an 857/877 should run circles around a 2600, even being it a 2651XM.
     
    Doug McIntyre, Mar 4, 2009
    #2
    1. Advertising

  3. tg

    bod43 Guest

    On 4 Mar, 05:02, Doug McIntyre <> wrote:
    > "tg" <> writes:
    > >cisco 2651XM router with wic1-adsl card
    > >IOS: c2600-ipbase-mz.123-11.T.bin (12Mb)
    > >broadband = bog standard 8Mb adsl on BT line
    > >I've discovered to my dismay my cisco router only gives me half the
    > >broadband speed of a cheap plastic router (Billion 5200G). If I connect
    > >my PC straight to a Billion 5200G adsl router I am getting about
    > >3800kbps download at speedtest.net, and a file download from
    > >microsoft.com came down at about 450Kb/sec.
    > >However if I swap the Billion for my cisco router I only get about
    > >2500kbps at speedtest.net and the same file from MS downloads at approx
    > >290KKB/sec. This is quite a difference and I never expected cisco gear
    > >to give such poor performance - unless I'm doing something wrong that
    > >is.

    >
    > Hmm, I wonder what kind of limitations the WIC bus may have on the Cisco.
    > Usually I've done things with lower 2600's like the 2610 which is
    > going to crap out about 3Mbps anyway. But your 2651XM should have
    > enough steam for at least 25Mbps.
    >
    > I couldn't find a reference on bus speed for the WIC bus, only this in
    > a Cisco patent for the HWIC bus..
    >
    > ::: The legacy WICs were conceived several years ago, and originally
    > ::: targeted PHY devices with a maximum bit rate of a few Mbps.
    >
    > Maybe I should pop a WIC-1ADSL in a bigger router and see what I can
    > push at work off my test DSLAM. Would be an interesting test. I know
    > some of the max packet rates of some of my lab stuff, and know my test
    > DSLAM is about as clean a DSL line as I can get.
    >
    > There isn't much you can configure on the router for the WIC-1ADSL card.
    > I'd start suspecting more of a physical hardware limitation.
    > The 2600 series is *not* a very speedy or very big router, even by the
    > standards of $60 consumer routers. Afterall, the 2600 series was designed
    > in the '90s to push a T1 or maybe two.
    >
    > Even an 857/877 should run circles around a 2600, even being it a 2651XM.


    Interesting ideas.
    http://www.cisco.com/en/US/products/hw/routers/ps274/products_tech_note09186a00800b0858.shtml

    "WIC-2T
    Supports one port at 8 Mbps when used
    in NM-1FE1R2W, NM-1FE2W, NM-2FE2W, or NM-2W,
    or Cisco 2600 chassis WIC slots. All other WIC ports
    on that network module or Cisco 2600 chassis must
    not be used.

    Supports two ports at 4 Mbps each when used in
    NM-1FE1R2W, NM-1FE2W, NM-2FE2W, or NM-2W,
    or Cisco 2600 chassis WIC slots. All other WIC ports
    on that network module or Cisco 2600 chassis must
    not be used."


    There is more so read the original. Note especially
    comment about "other WIC ports must not be used".
    I forget what is in the router in question.

    While limits exist it seems that the WIC 'bus'
    can support 8Mbps in each direction at least.

    I used the OP's test site with an 877 (12.4(15)T
    with latest DSL firmware) and got 6.5Mbps down.

    I would say that it was definately worth a software
    change to the latest. I don't know anout the WIC-1ADSL
    but the 8[57]7 and HWIC-ADSLs have had numerous
    software changes, some listing fixes for performance problems.

    Please post results from the following.

    reboot router - to clear ALL counters - ideally
    carry out speed tests
    when completed gather
    sh int
    sh dsl int
    sh buff
    post results.
     
    bod43, Mar 4, 2009
    #3
  4. tg

    tg Guest

    "Artie Lange" <> wrote in message
    news:gokjgh$in9$...
    > tg wrote:
    >> cisco 2651XM router with wic1-adsl card
    >> IOS: c2600-ipbase-mz.123-11.T.bin (12Mb)
    >> broadband = bog standard 8Mb adsl on BT line
    >>

    >
    > Should not be using T train for IOS versions, bugs could be common.


    ok thanks. What IOS would you recommend? - please note that if I can
    resolve this speed problem with a different IOS I also want to run a
    small ip phone system on the router with outgoing sip trunk.
    >
    > Can we see a show interface FastEthernet0/1


    gladly - this is from a fresh boot of the router.

    vpn#show int f0/1
    FastEthernet0/1 is up, line protocol is up
    Hardware is AmdFE, address is 000c.31ee.67e1 (bia 000c.31ee.67e1)
    Description: $ETH-LAN$
    Internet address is 192.168.1.254/24
    MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:00:05, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    7 packets output, 1299 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
     
    tg, Mar 4, 2009
    #4
  5. tg

    tg Guest

    "Doug McIntyre" <> wrote in message
    news:49ae0b66$0$18868$...
    > "tg" <> writes:


    ok thanks for your feedback Doug and I suppose a more immediate solution
    would be to throw the adsl card back in the drawer and use a consumer
    level one-port router as a gateway to the internet. I have to use a
    cisco router however as I run a small ip phone system on it with
    outgoing sip trunk as well as several PC's.
    If you do the wic-adsl speed tests you spoke of I'd be interested to
    hear what results you get.
     
    tg, Mar 4, 2009
    #5
  6. "tg" <> writes:
    >"Doug McIntyre" <> wrote in message
    >news:49ae0b66$0$18868$...
    >> "tg" <> writes:


    >ok thanks for your feedback Doug and I suppose a more immediate solution
    >would be to throw the adsl card back in the drawer and use a consumer
    >level one-port router as a gateway to the internet. I have to use a
    >cisco router however as I run a small ip phone system on it with
    >outgoing sip trunk as well as several PC's.
    >If you do the wic-adsl speed tests you spoke of I'd be interested to
    >hear what results you get.


    After a bit of other stuff going on, going back to a 3640, I don't
    think its worth $200 to upgrade it to enough Flash to run an IP+ image
    for the card, and the bootrom doesn't support TFTP on a 3640. Sorry,
    but I wasn't going to do an XMODEM download of 28MB of IOS to try it out.

    BUT, going through searches on things, I found something interesting
    that I haven't seen before that could be very relavent to you.

    http://www.dslreports.com/forum/r21036407-HELP-cisoc-3640-nm1fe2w-wic1adsl-speed-problem

    The 2nd post. The clockrate of the ATM controller on his 2620 was set
    to limit it to 2.6Mbps max.

    He could change the clockrate with an
    int atm 0/0 clockrate aal5 5300000

    on his 3640, but the 2620 could do a clockrate of 8000000.

    That sounds completely relavent to your issue.

    I've installed plenty of these cards, but almost always in something
    like a 2610 which is about 3Mbps-4.5Mbps max anyway, and as backup
    solutions, that was good enough.
     
    Doug McIntyre, Mar 12, 2009
    #6
  7. tg

    Dan Lanciani Guest

    In article <49b9813c$0$92355$>, (Doug McIntyre) writes:

    | After a bit of other stuff going on, going back to a 3640, I don't
    | think its worth $200 to upgrade it to enough Flash to run an IP+ image
    | for the card, and the bootrom doesn't support TFTP on a 3640. Sorry,
    | but I wasn't going to do an XMODEM download of 28MB of IOS to try it out.

    The 3640 bootrom will use pretty much any handy IOS image in flash as
    an rxboot loader to boot another IOS by tftp, ftp, or rcp. This is handy
    since the last 12.4 jk9o3s image didn't fit in flash even if you had the
    maximum supported. :) Of course, you have to have enough RAM...

    Dan Lanciani
    ddl@danlan.*com
     
    Dan Lanciani, Mar 13, 2009
    #7
  8. ddl@danlan.*com (Dan Lanciani) writes:
    >In article <49b9813c$0$92355$>, (Doug McIntyre) writes:


    >| After a bit of other stuff going on, going back to a 3640, I don't
    >| think its worth $200 to upgrade it to enough Flash to run an IP+ image
    >| for the card, and the bootrom doesn't support TFTP on a 3640. Sorry,
    >| but I wasn't going to do an XMODEM download of 28MB of IOS to try it out.


    >The 3640 bootrom will use pretty much any handy IOS image in flash as
    >an rxboot loader to boot another IOS by tftp, ftp, or rcp. This is handy
    >since the last 12.4 jk9o3s image didn't fit in flash even if you had the
    >maximum supported. :) Of course, you have to have enough RAM...


    Yeah, probably not enough RAM in these boxes either to attempt that either.

    Its still interested me enough to try to cycle something out of
    production to test with though.
     
    Doug McIntyre, Mar 13, 2009
    #8
  9. tg

    blanken79

    Joined:
    Apr 16, 2010
    Messages:
    8
    Location:
    Greenville,SC
    Doug McIntyre was correct. I just installed a WIC adsl card in my 2621..and it was the clock rate that was limiting my download speeds at 2.6 megs. Changed to the 7 meg clock rate and now getting my full speed of 6 megs.
     
    blanken79, Apr 16, 2010
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sam
    Replies:
    6
    Views:
    5,621
  2. Bill
    Replies:
    2
    Views:
    761
    Nobody
    May 28, 2008
  3. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    698
    Expert lino fitter
    Dec 10, 2008
  4. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    5
    Views:
    702
    Expert lino fitter
    Dec 12, 2008
  5. Beauregard T. Shagnasty

    Re: slow slow slow!

    Beauregard T. Shagnasty, Dec 10, 2008, in forum: Computer Support
    Replies:
    2
    Views:
    711
    Shel-hed
    Dec 10, 2008
Loading...

Share This Page