site to site vpn using cisco pix 501's

Discussion in 'Cisco' started by gsiebrecht, Aug 25, 2006.

  1. gsiebrecht

    gsiebrecht Guest

    I'm having the worst time trying to get a site to site VPN set up
    between two pix 501's any pointers would be super helpful here, I've
    tried so many things and this is my last resort. The tunnel comes up
    but I cannot access any devices on the remote lans.

    here is a config from one of the pix's, unsanitized for utmost clarity.

    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname breda
    domain-name westianet.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.168.1.0 remote_site_lan
    access-list inside_outbound_nat0_acl permit ip 10.246.246.0
    255.255.255.0 remote_site_lan 255.255.255.0
    access-list outside_cryptomap_20 permit ip 10.246.246.0 255.255.255.0
    remote_site_lan 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 65.174.244.23 255.255.255.0
    ip address inside 10.246.246.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location remote_site_lan 255.255.255.0 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 65.174.244.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.246.246.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer 65.174.244.26
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address 65.174.244.26 netmask 255.255.255.255
    no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 10.246.246.2-10.246.246.129 inside
    dhcpd dns 65.174.244.11
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:25109c8532d510c399cab38bfa73424c
    : end
     
    gsiebrecht, Aug 25, 2006
    #1
    1. Advertising

  2. gsiebrecht

    AM Guest

    gsiebrecht wrote:

    > I'm having the worst time trying to get a site to site VPN set up
    > between two pix 501's any pointers would be super helpful here, I've
    > tried so many things and this is my last resort. The tunnel comes up
    > but I cannot access any devices on the remote lans.


    Are the configs the same?

    do you have "sysopt connection permit-ipsec" allowed on both sides?
    do you have the same "nat (inside) 0 access-list inside_outbound_nat0_acl" on both sides 10.246.246.0/24 and
    192.168.1.0/24, namely with the source and destination in the ACL inverted?

    Maybe the traffic is NATted while it must not be.

    To run the test do not use the inside interface of the PIXes but two real PCs on the LANs.

    Alex.
     
    AM, Aug 25, 2006
    #2
    1. Advertising

  3. gsiebrecht

    gsiebrecht Guest

    To run the test do not use the inside interface of the PIXes but two
    real PCs on the LANs.

    thats the ticket right there, I was trying to test it using the console
    port. Using real PC's it works.


    AM wrote:
    > gsiebrecht wrote:
    >
    > > I'm having the worst time trying to get a site to site VPN set up
    > > between two pix 501's any pointers would be super helpful here, I've
    > > tried so many things and this is my last resort. The tunnel comes up
    > > but I cannot access any devices on the remote lans.

    >
    > Are the configs the same?
    >
    > do you have "sysopt connection permit-ipsec" allowed on both sides?
    > do you have the same "nat (inside) 0 access-list inside_outbound_nat0_acl" on both sides 10.246.246.0/24 and
    > 192.168.1.0/24, namely with the source and destination in the ACL inverted?
    >
    > Maybe the traffic is NATted while it must not be.
    >
    > To run the test do not use the inside interface of the PIXes but two real PCs on the LANs.
    >
    > Alex.
     
    gsiebrecht, Aug 25, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Robert
    Replies:
    3
    Views:
    2,268
    Robert
    Dec 14, 2005
  2. Replies:
    1
    Views:
    694
    Walter Roberson
    Nov 14, 2006
  3. Jeff
    Replies:
    5
    Views:
    1,206
  4. Replies:
    1
    Views:
    426
    =?UTF-8?B?TWljaGHFgiBJd2Fzemtv?=
    Feb 22, 2007
  5. Replies:
    0
    Views:
    825
Loading...

Share This Page