Sipgate and ATA186

Discussion in 'UK VOIP' started by Malcolm Loades, Sep 5, 2006.

  1. This works perfectly with the exception of not being able to send DTMF
    tones over the line - dialling is no problem. Therefore I'm unable to
    call most business lines which answer with "For xxxx please press y".
    This also rules out voicemail.

    I've changed the analogue handset to an alternative which makes no
    difference. The ATA186 is running Version: v3.1.0 atasip (Build
    040211A).

    Any ideas, please?
    Malcolm Loades, Sep 5, 2006
    #1
    1. Advertising

  2. Malcolm Loades

    PhilT Guest

    Malcolm Loades wrote:

    > This works perfectly with the exception of not being able to send DTMF
    > tones over the line - dialling is no problem. Therefore I'm unable to
    > call most business lines which answer with "For xxxx please press y".
    > This also rules out voicemail.


    > Any ideas, please?


    are there any options to configure "in band signalling " or similar
    DTMF options on the ATA ?

    Phil
    PhilT, Sep 5, 2006
    #2
    1. Advertising

  3. In message <>, PhilT
    <> writes
    >
    >Malcolm Loades wrote:
    >
    >> This works perfectly with the exception of not being able to send DTMF
    >> tones over the line - dialling is no problem. Therefore I'm unable to
    >> call most business lines which answer with "For xxxx please press y".
    >> This also rules out voicemail.

    >
    >> Any ideas, please?

    >
    >are there any options to configure "in band signalling " or similar
    >DTMF options on the ATA ?


    Not that I can see.

    Sipgate have very detailed instructions for setting up the ATA186 on
    their website including a screen shot of the ATA186 configuration page
    (only accesible by registered users) and mine appears to match theirs.
    I asked Sipgate support for help but they asked the same question as
    you! I assume the ATA186 should work on Sipgate, otherwise why have
    such detailed configuration details for it? Sipgate ignore this
    question :-(

    Does anyone here successfully use an ATA186 and Sipgate? Does anyone
    use an ATA186 successfully with another provider?

    Thanks.
    Malcolm Loades, Sep 5, 2006
    #3
  4. Malcolm Loades

    PhilT Guest

    Malcolm Loades wrote:

    > Does anyone here successfully use an ATA186 and Sipgate? Does anyone
    > use an ATA186 successfully with another provider?
    >


    I have used mine with FWD as well as BT. Its resting at the moment.
    (Assuming we're talking about a Cisco ATA186).

    http://www.geckotechllc.com/pdf/CiscoATA18xguide.pdf may help. There's
    a reference on p94 to an audio settings bitmap :-

    4-5 and 20-21:DtmfMethod 0-Always in band.
    1-By negotiation
    2-Always out of band.
    3-Disabled; no DTMF is sent. This is the default setting.

    Good hunting.

    Phil
    PhilT, Sep 5, 2006
    #4
  5. Malcolm Loades

    Ivor Jones Guest

    "Malcolm Loades" <> wrote in
    message news:+E3lp0KBZW$
    > In message
    > <>,
    > PhilT <> writes
    > >
    > > Malcolm Loades wrote:
    > >
    > > > This works perfectly with the exception of not being
    > > > able to send DTMF tones over the line - dialling is
    > > > no problem. Therefore I'm unable to call most
    > > > business lines which answer with "For xxxx please
    > > > press y". This also rules out voicemail.

    > >
    > > > Any ideas, please?

    > >
    > > are there any options to configure "in band signalling
    > > " or similar DTMF options on the ATA ?

    >
    > Not that I can see.


    There should be an option somewhere, I've not seen a 186 however the 486 I
    had was configurable in this way, I can't remember the details offhand.

    However, as far as Sipgate voicemail goes, if you dial the remote access
    number 020 7043 7777 then you should be able to access it ok, let me know
    if you have problems. Note that this number will ask you for your SIP ID
    and 4-digit PIN.

    Ivor
    Ivor Jones, Sep 5, 2006
    #5
  6. Malcolm Loades

    Tim Guest

    Malcolm Loades wrote:
    > This works perfectly with the exception of not being able to send DTMF
    > tones over the line - dialling is no problem. Therefore I'm unable to
    > call most business lines which answer with "For xxxx please press y".
    > This also rules out voicemail.


    The same problem was reported to me yesterday but with sipgate and an
    ATA1100.

    I try and find out whether they got it working or not.


    Tim
    Tim, Sep 5, 2006
    #6
  7. In message <>, Ivor Jones
    <> writes
    >"Malcolm Loades" <> wrote in
    >message news:+E3lp0KBZW$
    >> In message
    >> <>,
    >> PhilT <> writes
    >> >
    >> > Malcolm Loades wrote:
    >> >
    >> > > This works perfectly with the exception of not being
    >> > > able to send DTMF tones over the line - dialling is
    >> > > no problem. Therefore I'm unable to call most
    >> > > business lines which answer with "For xxxx please
    >> > > press y". This also rules out voicemail.
    >> >
    >> > > Any ideas, please?
    >> >
    >> > are there any options to configure "in band signalling
    >> > " or similar DTMF options on the ATA ?

    >>
    >> Not that I can see.

    >
    >There should be an option somewhere, I've not seen a 186 however the 486 I
    >had was configurable in this way, I can't remember the details offhand.
    >
    >However, as far as Sipgate voicemail goes, if you dial the remote access
    >number 020 7043 7777 then you should be able to access it ok, let me know
    >if you have problems. Note that this number will ask you for your SIP ID
    >and 4-digit PIN.


    Fine if done from a 'regular' phone, but no good using the
    ATA186/Sipgate combination because the tones aren't recognised!

    Malcolm
    Malcolm Loades, Sep 5, 2006
    #7
  8. In message <>, PhilT
    <> writes
    >Malcolm Loades wrote:
    >
    >> Does anyone here successfully use an ATA186 and Sipgate? Does anyone
    >> use an ATA186 successfully with another provider?
    >>

    >
    >I have used mine with FWD as well as BT. Its resting at the moment.
    >(Assuming we're talking about a Cisco ATA186).
    >
    >http://www.geckotechllc.com/pdf/CiscoATA18xguide.pdf may help. There's
    >a reference on p94 to an audio settings bitmap :-


    Unfortunately this guide is for MGCP not SIP.

    Malcolm
    Malcolm Loades, Sep 5, 2006
    #8
  9. Malcolm Loades

    PhilT Guest

    Malcolm Loades wrote:

    > Unfortunately this guide is for MGCP not SIP.


    are you saying the audio bitmap does not exist on the SIP config ?

    Having run both MGCP and SIP there is a lot of common ground on the
    settings, as is clear from the Cisco documentation on the web.

    The Sipgate page shows "0x00150015" as the "AudioMode:" setting.

    The default in the manual is 0x00350035

    With my limited bitmap skills it appears that the Sipgate setting is
    for "by negotiation" so I suggest you try 0x00050005 which is "DTMF
    always in band".

    Phil
    PhilT, Sep 5, 2006
    #9
  10. Malcolm Loades

    Ivor Jones Guest

    "Malcolm Loades" <> wrote in
    message news:9OJFLjM5$d$
    > In message <>, Ivor Jones
    > <> writes


    [snip]

    > > However, as far as Sipgate voicemail goes, if you dial
    > > the remote access number 020 7043 7777 then you should
    > > be able to access it ok, let me know if you have
    > > problems. Note that this number will ask you for your
    > > SIP ID and 4-digit PIN.

    >
    > Fine if done from a 'regular' phone, but no good using the
    > ATA186/Sipgate combination because the tones aren't
    > recognised!


    Ah, I see what you mean. Can you send me a screenshot of the configuration
    page..? Send to g6urp01 at googlemail dot com and I'll have a look and see
    if I can see anything obviously out of place.

    Ivor
    Ivor Jones, Sep 6, 2006
    #10
  11. PhilT wrote:
    > Malcolm Loades wrote:
    >
    >> Unfortunately this guide is for MGCP not SIP.

    >
    > are you saying the audio bitmap does not exist on the SIP config ?
    >
    > Having run both MGCP and SIP there is a lot of common ground on the
    > settings, as is clear from the Cisco documentation on the web.
    >
    > The Sipgate page shows "0x00150015" as the "AudioMode:" setting.
    >
    > The default in the manual is 0x00350035
    >
    > With my limited bitmap skills it appears that the Sipgate setting is
    > for "by negotiation" so I suggest you try 0x00050005 which is "DTMF
    > always in band".
    >

    Of course you will want this to be always outband if you use G.729.
    so presumably 0x00250025.
    Thomas Kenyon, Sep 6, 2006
    #11
  12. Malcolm Loades

    PhilT Guest

    Thomas Kenyon wrote:

    > Of course you will want this to be always outband if you use G.729.
    > so presumably 0x00250025.


    depends whether outband works or not I suppose :)

    Phil
    PhilT, Sep 6, 2006
    #12
  13. Malcolm Loades

    PhilT Guest

    Thomas Kenyon wrote:

    > Of course you will want this to be always outband if you use G.729.
    > so presumably 0x00250025.


    depends whether outband works or not I suppose :)

    Phil
    PhilT, Sep 6, 2006
    #13
  14. Malcolm Loades

    techpro Guest

    Malcolm Loades wrote:
    > This works perfectly with the exception of not being able to send DTMF
    > tones over the line - dialling is no problem. Therefore I'm unable to
    > call most business lines which answer with "For xxxx please press y".
    > This also rules out voicemail.
    >
    > I've changed the analogue handset to an alternative which makes no
    > difference. The ATA186 is running Version: v3.1.0 atasip (Build
    > 040211A).
    >
    > Any ideas, please?


    This sounds exactly the same as the problem I have using the
    SMC7908VoWBRA router. DTMF tones are not recognized so I cannot use the
    Sipgate voicemail by dialling 50000. A few months ago I spent quite a
    lot of time emailing Sipgate tech support without resolving it. I seem
    to recall discovering that there are two varieties of out of band DTMF
    - perhaps my SMC and your device only implements one of them.

    I tried again today as I found out that there is a firmware upgrade for
    my device, but still no luck unfortunately. It's annoying, as it works
    great otherwise.
    techpro, Sep 6, 2006
    #14
  15. PhilT wrote:
    > Thomas Kenyon wrote:
    >
    >> Of course you will want this to be always outband if you use G.729.
    >> so presumably 0x00250025.

    >
    > depends whether outband works or not I suppose :)
    >
    > Phil
    >

    True, but inband isn't supposed to work with that codec. (well, support
    is non-standard).
    Thomas Kenyon, Sep 6, 2006
    #15
  16. In message <>,
    PhilT <> writes
    >
    >Malcolm Loades wrote:
    >
    >> Unfortunately this guide is for MGCP not SIP.

    >
    >are you saying the audio bitmap does not exist on the SIP config ?
    >
    >Having run both MGCP and SIP there is a lot of common ground on the
    >settings, as is clear from the Cisco documentation on the web.
    >
    >The Sipgate page shows "0x00150015" as the "AudioMode:" setting.
    >
    >The default in the manual is 0x00350035
    >
    >With my limited bitmap skills it appears that the Sipgate setting is
    >for "by negotiation" so I suggest you try 0x00050005 which is "DTMF
    >always in band".
    >

    Thanks for the suggestions, and also everyone else who responded. My
    setting was 0x00150015 as per the Sipgate page. I've tried 0 and 2
    ...... still no DTMF detected by the other end.

    More Googling brings up lots of reports similar to mine but no solution
    :-( Unless someone knows better!

    Malcolm
    Malcolm Loades, Sep 8, 2006
    #16
  17. Malcolm Loades

    PhilT Guest

    Malcolm Loades wrote:
    > In message <>,
    > PhilT <> writes
    > >The Sipgate page shows "0x00150015" as the "AudioMode:" setting.
    > >
    > >The default in the manual is 0x00350035
    > >
    > >With my limited bitmap skills it appears that the Sipgate setting is
    > >for "by negotiation" so I suggest you try 0x00050005 which is "DTMF
    > >always in band".
    > >

    > Thanks for the suggestions, and also everyone else who responded. My
    > setting was 0x00150015 as per the Sipgate page. I've tried 0 and 2
    > ..... still no DTMF detected by the other end.
    >


    0x00050005 works fine with sipgate on an ATA186 calling out to a BT
    line, I can hear the tones and they work with Call Minder's IVR menu
    including accepting a PIN and navigating the menu. They don't seem to
    work with Sipgate's voicemail.

    Version: v3.1.0 atasip (Build 040211A)

    Phil
    PhilT, Sep 10, 2006
    #17
  18. In message <>,
    PhilT <> writes
    >
    >Malcolm Loades wrote:
    >> In message <>,
    >> PhilT <> writes
    >> >The Sipgate page shows "0x00150015" as the "AudioMode:" setting.
    >> >
    >> >The default in the manual is 0x00350035
    >> >
    >> >With my limited bitmap skills it appears that the Sipgate setting is
    >> >for "by negotiation" so I suggest you try 0x00050005 which is "DTMF
    >> >always in band".
    >> >

    >> Thanks for the suggestions, and also everyone else who responded. My
    >> setting was 0x00150015 as per the Sipgate page. I've tried 0 and 2
    >> ..... still no DTMF detected by the other end.
    >>

    >
    >0x00050005 works fine with sipgate on an ATA186 calling out to a BT
    >line, I can hear the tones and they work with Call Minder's IVR menu
    >including accepting a PIN and navigating the menu. They don't seem to
    >work with Sipgate's voicemail.
    >
    >Version: v3.1.0 atasip (Build 040211A)
    >

    Superb! Thanks!

    I'd been doing the testing of each setting by calling Sipgate's
    voicemail - no wonder it failed. The setting you suggest does indeed
    work fine otherwise - I can live with that.

    Malcolm
    Malcolm Loades, Sep 11, 2006
    #18
  19. Malcolm Loades

    PhilT Guest

    Malcolm Loades wrote:

    > I'd been doing the testing of each setting by calling Sipgate's
    > voicemail - no wonder it failed.


    I'm afraid I have learned that...

    testing + sipgate = insanity + invalid conclusions

    the variability of the service is too great for robust testing.

    Phil
    PhilT, Sep 11, 2006
    #19
  20. Malcolm Loades

    Ivor Jones Guest

    "PhilT" <> wrote in message
    news:
    > Malcolm Loades wrote:
    >
    > > I'd been doing the testing of each setting by calling
    > > Sipgate's voicemail - no wonder it failed.

    >
    > I'm afraid I have learned that...
    >
    > testing + sipgate = insanity + invalid conclusions
    >
    > the variability of the service is too great for robust
    > testing.


    How so..? It works fine here and has done almost 100% since the server
    upgrades in April.

    Ivor
    Ivor Jones, Sep 12, 2006
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Koby
    Replies:
    0
    Views:
    1,667
  2. Umrilov D

    ATA186+RoundTripDelay

    Umrilov D, Nov 11, 2003, in forum: Cisco
    Replies:
    0
    Views:
    467
    Umrilov D
    Nov 11, 2003
  3. Steve Blair

    ATA186 & domain name

    Steve Blair, Dec 12, 2003, in forum: Cisco
    Replies:
    1
    Views:
    428
    Steve Blair
    Dec 12, 2003
  4. stu
    Replies:
    3
    Views:
    1,913
    next_hop
    May 22, 2004
  5. chikenzass

    ATA186 and VOICEBUSTER setup

    chikenzass, Jun 25, 2005, in forum: UK VOIP
    Replies:
    0
    Views:
    2,492
    chikenzass
    Jun 25, 2005
Loading...

Share This Page