simulate point-to-point with 2620's

Discussion in 'Cisco' started by np, Mar 2, 2004.

  1. np

    np Guest

    Hello,
    I need to configure a point-to-point between two of our offices and I want
    to make sure the configs are correct before I send one of the routers to our
    other office. What type of cable can I use to connect the two routers for
    testing? They have the T1 DSU/CSU cards in them

    Also, how's this config look? Do I need anything else?

    interface Serial0
    description WAN office1
    ip address 192.168.1.x 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable

    interface FastEthernet0
    description LAN office1
    ip address 172.16.x.x 255.255.0.0 .
    speed auto
    no cdp enable

    ip route 0.0.0.0 0.0.0.0 Serial0

    *************************************
    interface Serial0
    description WAN office2
    ip address 192.168.1.x 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable

    interface FastEthernet0
    description LAN office2
    ip address 172.16.x.x 255.255.0.0
    speed auto
    no cdp enable

    ip route 0.0.0.0 0.0.0.0 Serial0



    Thanks!
     
    np, Mar 2, 2004
    #1
    1. Advertising

  2. On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:

    ~ Hello,
    ~ I need to configure a point-to-point between two of our offices and I want
    ~ to make sure the configs are correct before I send one of the routers to our
    ~ other office. What type of cable can I use to connect the two routers for
    ~ testing? They have the T1 DSU/CSU cards in them

    Just make a crossover T1 cable.

    RJ-45 ----- RJ-45
    1 ----- 4
    2 ----- 5
    4 ----- 1
    5 ----- 2

    ~ Also, how's this config look? Do I need anything else?
    ~
    ~ interface Serial0
    ~ description WAN office1
    ~ ip address 192.168.1.x 255.255.255.252
    ~ encapsulation ppp
    ~ service-module t1 timeslots 1-24
    ~ no cdp enable
    ~
    ~ interface FastEthernet0
    ~ description LAN office1
    ~ ip address 172.16.x.x 255.255.0.0 .
    ~ speed auto
    ~ no cdp enable
    ~
    ~ ip route 0.0.0.0 0.0.0.0 Serial0
    ~
    ~ *************************************
    ~ interface Serial0
    ~ description WAN office2
    ~ ip address 192.168.1.x 255.255.255.252
    ~ encapsulation ppp
    ~ service-module t1 timeslots 1-24
    ~ no cdp enable
    ~
    ~ interface FastEthernet0
    ~ description LAN office2
    ~ ip address 172.16.x.x 255.255.0.0
    ~ speed auto
    ~ no cdp enable
    ~
    ~ ip route 0.0.0.0 0.0.0.0 Serial0

    Practically speaking, I wouldn't think that each
    side would have a default route to the other.

    Aaron
     
    Aaron Leonard, Mar 2, 2004
    #2
    1. Advertising

  3. np

    Brian V Guest

    "Aaron Leonard" <> wrote in message
    news:...
    > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    >
    > ~ Hello,
    > ~ I need to configure a point-to-point between two of our offices and I

    want
    > ~ to make sure the configs are correct before I send one of the routers to

    our
    > ~ other office. What type of cable can I use to connect the two routers

    for
    > ~ testing? They have the T1 DSU/CSU cards in them
    >
    > Just make a crossover T1 cable.
    >
    > RJ-45 ----- RJ-45
    > 1 ----- 4
    > 2 ----- 5
    > 4 ----- 1
    > 5 ----- 2
    >
    > ~ Also, how's this config look? Do I need anything else?
    > ~
    > ~ interface Serial0
    > ~ description WAN office1
    > ~ ip address 192.168.1.x 255.255.255.252
    > ~ encapsulation ppp
    > ~ service-module t1 timeslots 1-24
    > ~ no cdp enable
    > ~
    > ~ interface FastEthernet0
    > ~ description LAN office1
    > ~ ip address 172.16.x.x 255.255.0.0 .
    > ~ speed auto
    > ~ no cdp enable
    > ~
    > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > ~
    > ~ *************************************
    > ~ interface Serial0
    > ~ description WAN office2
    > ~ ip address 192.168.1.x 255.255.255.252
    > ~ encapsulation ppp
    > ~ service-module t1 timeslots 1-24
    > ~ no cdp enable
    > ~
    > ~ interface FastEthernet0
    > ~ description LAN office2
    > ~ ip address 172.16.x.x 255.255.0.0
    > ~ speed auto
    > ~ no cdp enable
    > ~
    > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    >
    > Practically speaking, I wouldn't think that each
    > side would have a default route to the other.
    >
    > Aaron


    nor would they have the same subnet on each lan! (unless of course it was
    configured for bridging..which it's not!)
     
    Brian V, Mar 2, 2004
    #3
  4. np

    np Guest

    "Brian V" <> wrote in message
    news:FT51c.101199$Xp.434175@attbi_s54...
    >
    > "Aaron Leonard" <> wrote in message
    > news:...
    > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > >
    > > ~ Hello,
    > > ~ I need to configure a point-to-point between two of our offices and I

    > want
    > > ~ to make sure the configs are correct before I send one of the routers

    to
    > our
    > > ~ other office. What type of cable can I use to connect the two routers

    > for
    > > ~ testing? They have the T1 DSU/CSU cards in them
    > >
    > > Just make a crossover T1 cable.
    > >
    > > RJ-45 ----- RJ-45
    > > 1 ----- 4
    > > 2 ----- 5
    > > 4 ----- 1
    > > 5 ----- 2
    > >
    > > ~ Also, how's this config look? Do I need anything else?
    > > ~
    > > ~ interface Serial0
    > > ~ description WAN office1
    > > ~ ip address 192.168.1.x 255.255.255.252
    > > ~ encapsulation ppp
    > > ~ service-module t1 timeslots 1-24
    > > ~ no cdp enable
    > > ~
    > > ~ interface FastEthernet0
    > > ~ description LAN office1
    > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > ~ speed auto
    > > ~ no cdp enable
    > > ~
    > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > ~
    > > ~ *************************************
    > > ~ interface Serial0
    > > ~ description WAN office2
    > > ~ ip address 192.168.1.x 255.255.255.252
    > > ~ encapsulation ppp
    > > ~ service-module t1 timeslots 1-24
    > > ~ no cdp enable
    > > ~
    > > ~ interface FastEthernet0
    > > ~ description LAN office2
    > > ~ ip address 172.16.x.x 255.255.0.0
    > > ~ speed auto
    > > ~ no cdp enable
    > > ~
    > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > >
    > > Practically speaking, I wouldn't think that each
    > > side would have a default route to the other.
    > >
    > > Aaron

    >
    > nor would they have the same subnet on each lan! (unless of course it was
    > configured for bridging..which it's not!)
    >
    >


    Thanks for the comments,
    Can you explain the subnet net issue more. We use a 172.16.0.0/22 scheme.
    "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses 172.16.8.x -
    172.16.11.x. My goal is to have anything destined for the other office go
    through the point-to-point and all other traffice out a firewall.
     
    np, Mar 2, 2004
    #4
  5. np

    Brian V Guest

    "np" <> wrote in message news:...
    >
    > "Brian V" <> wrote in message
    > news:FT51c.101199$Xp.434175@attbi_s54...
    > >
    > > "Aaron Leonard" <> wrote in message
    > > news:...
    > > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > > >
    > > > ~ Hello,
    > > > ~ I need to configure a point-to-point between two of our offices and

    I
    > > want
    > > > ~ to make sure the configs are correct before I send one of the

    routers
    > to
    > > our
    > > > ~ other office. What type of cable can I use to connect the two

    routers
    > > for
    > > > ~ testing? They have the T1 DSU/CSU cards in them
    > > >
    > > > Just make a crossover T1 cable.
    > > >
    > > > RJ-45 ----- RJ-45
    > > > 1 ----- 4
    > > > 2 ----- 5
    > > > 4 ----- 1
    > > > 5 ----- 2
    > > >
    > > > ~ Also, how's this config look? Do I need anything else?
    > > > ~
    > > > ~ interface Serial0
    > > > ~ description WAN office1
    > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > ~ encapsulation ppp
    > > > ~ service-module t1 timeslots 1-24
    > > > ~ no cdp enable
    > > > ~
    > > > ~ interface FastEthernet0
    > > > ~ description LAN office1
    > > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > > ~ speed auto
    > > > ~ no cdp enable
    > > > ~
    > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > ~
    > > > ~ *************************************
    > > > ~ interface Serial0
    > > > ~ description WAN office2
    > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > ~ encapsulation ppp
    > > > ~ service-module t1 timeslots 1-24
    > > > ~ no cdp enable
    > > > ~
    > > > ~ interface FastEthernet0
    > > > ~ description LAN office2
    > > > ~ ip address 172.16.x.x 255.255.0.0
    > > > ~ speed auto
    > > > ~ no cdp enable
    > > > ~
    > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > >
    > > > Practically speaking, I wouldn't think that each
    > > > side would have a default route to the other.
    > > >
    > > > Aaron

    > >
    > > nor would they have the same subnet on each lan! (unless of course it

    was
    > > configured for bridging..which it's not!)
    > >
    > >

    >
    > Thanks for the comments,
    > Can you explain the subnet net issue more. We use a 172.16.0.0/22 scheme.
    > "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses 172.16.8.x -
    > 172.16.11.x. My goal is to have anything destined for the other office go
    > through the point-to-point and all other traffice out a firewall.
    >
    >


    You have a Class B (/16 bit) mask on both lans...

    The following will work:

    interface Serial0
    description WAN office1
    ip address 192.168.1.1 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable

    interface FastEthernet0
    description LAN office1
    ip address 172.16.0.1 255.255.192.0 .
    speed auto
    no cdp enable
    ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    remote)
    ip route 172.16.8.0 255.255.192.0 192.168.1.2
    *************************************
    interface Serial0
    description WAN office2
    ip address 192.168.1.2 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable
    interface FastEthernet0
    description LAN office2
    ip address 172.16.8.1 255.255.192.0
    speed auto
    no cdp enable
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
     
    Brian V, Mar 2, 2004
    #5
  6. np

    Brian V Guest

    Corrections Below.

    "Brian V" <> wrote in message
    news:db71c.462539$na.1095079@attbi_s04...
    >
    > "np" <> wrote in message

    news:...
    > >
    > > "Brian V" <> wrote in message
    > > news:FT51c.101199$Xp.434175@attbi_s54...
    > > >
    > > > "Aaron Leonard" <> wrote in message
    > > > news:...
    > > > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > > > >
    > > > > ~ Hello,
    > > > > ~ I need to configure a point-to-point between two of our offices

    and
    > I
    > > > want
    > > > > ~ to make sure the configs are correct before I send one of the

    > routers
    > > to
    > > > our
    > > > > ~ other office. What type of cable can I use to connect the two

    > routers
    > > > for
    > > > > ~ testing? They have the T1 DSU/CSU cards in them
    > > > >
    > > > > Just make a crossover T1 cable.
    > > > >
    > > > > RJ-45 ----- RJ-45
    > > > > 1 ----- 4
    > > > > 2 ----- 5
    > > > > 4 ----- 1
    > > > > 5 ----- 2
    > > > >
    > > > > ~ Also, how's this config look? Do I need anything else?
    > > > > ~
    > > > > ~ interface Serial0
    > > > > ~ description WAN office1
    > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > ~ encapsulation ppp
    > > > > ~ service-module t1 timeslots 1-24
    > > > > ~ no cdp enable
    > > > > ~
    > > > > ~ interface FastEthernet0
    > > > > ~ description LAN office1
    > > > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > > > ~ speed auto
    > > > > ~ no cdp enable
    > > > > ~
    > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > ~
    > > > > ~ *************************************
    > > > > ~ interface Serial0
    > > > > ~ description WAN office2
    > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > ~ encapsulation ppp
    > > > > ~ service-module t1 timeslots 1-24
    > > > > ~ no cdp enable
    > > > > ~
    > > > > ~ interface FastEthernet0
    > > > > ~ description LAN office2
    > > > > ~ ip address 172.16.x.x 255.255.0.0
    > > > > ~ speed auto
    > > > > ~ no cdp enable
    > > > > ~
    > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > >
    > > > > Practically speaking, I wouldn't think that each
    > > > > side would have a default route to the other.
    > > > >
    > > > > Aaron
    > > >
    > > > nor would they have the same subnet on each lan! (unless of course it

    > was
    > > > configured for bridging..which it's not!)
    > > >
    > > >

    > >
    > > Thanks for the comments,
    > > Can you explain the subnet net issue more. We use a 172.16.0.0/22

    scheme.
    > > "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses 172.16.8.x -
    > > 172.16.11.x. My goal is to have anything destined for the other office

    go
    > > through the point-to-point and all other traffice out a firewall.
    > >
    > >

    >
    > You have a Class B (/16 bit) mask on both lans...
    >


    Lets try this again! Wasn't thinking when I typed the other mask. This is
    the correct config....

    The following will work:
    interface Serial0
    description WAN office1
    ip address 192.168.1.1 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable

    interface FastEthernet0
    description LAN office1
    ip address 172.16.0.1 255.255.252.0 .
    speed auto
    no cdp enable
    ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    remote)
    ip route 172.16.8.0 255.255.252.0 192.168.1.2
    *************************************
    interface Serial0
    description WAN office2
    ip address 192.168.1.2 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    no cdp enable
    interface FastEthernet0
    description LAN office2
    ip address 172.16.8.1 255.255.252.0
    speed auto
    no cdp enable
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
     
    Brian V, Mar 2, 2004
    #6
  7. np

    np Guest

    "Brian V" <> wrote in message
    news:KU71c.29754$PR3.513146@attbi_s03...
    > Corrections Below.
    >
    > "Brian V" <> wrote in message
    > news:db71c.462539$na.1095079@attbi_s04...
    > >
    > > "np" <> wrote in message

    > news:...
    > > >
    > > > "Brian V" <> wrote in message
    > > > news:FT51c.101199$Xp.434175@attbi_s54...
    > > > >
    > > > > "Aaron Leonard" <> wrote in message
    > > > > news:...
    > > > > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > > > > >
    > > > > > ~ Hello,
    > > > > > ~ I need to configure a point-to-point between two of our offices

    > and
    > > I
    > > > > want
    > > > > > ~ to make sure the configs are correct before I send one of the

    > > routers
    > > > to
    > > > > our
    > > > > > ~ other office. What type of cable can I use to connect the two

    > > routers
    > > > > for
    > > > > > ~ testing? They have the T1 DSU/CSU cards in them
    > > > > >
    > > > > > Just make a crossover T1 cable.
    > > > > >
    > > > > > RJ-45 ----- RJ-45
    > > > > > 1 ----- 4
    > > > > > 2 ----- 5
    > > > > > 4 ----- 1
    > > > > > 5 ----- 2
    > > > > >
    > > > > > ~ Also, how's this config look? Do I need anything else?
    > > > > > ~
    > > > > > ~ interface Serial0
    > > > > > ~ description WAN office1
    > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > ~ encapsulation ppp
    > > > > > ~ service-module t1 timeslots 1-24
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ interface FastEthernet0
    > > > > > ~ description LAN office1
    > > > > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > > > > ~ speed auto
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > > ~
    > > > > > ~ *************************************
    > > > > > ~ interface Serial0
    > > > > > ~ description WAN office2
    > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > ~ encapsulation ppp
    > > > > > ~ service-module t1 timeslots 1-24
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ interface FastEthernet0
    > > > > > ~ description LAN office2
    > > > > > ~ ip address 172.16.x.x 255.255.0.0
    > > > > > ~ speed auto
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > >
    > > > > > Practically speaking, I wouldn't think that each
    > > > > > side would have a default route to the other.
    > > > > >
    > > > > > Aaron
    > > > >
    > > > > nor would they have the same subnet on each lan! (unless of course

    it
    > > was
    > > > > configured for bridging..which it's not!)
    > > > >
    > > > >
    > > >
    > > > Thanks for the comments,
    > > > Can you explain the subnet net issue more. We use a 172.16.0.0/22

    > scheme.
    > > > "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses 172.16.8.x -
    > > > 172.16.11.x. My goal is to have anything destined for the other

    office
    > go
    > > > through the point-to-point and all other traffice out a firewall.
    > > >
    > > >

    > >
    > > You have a Class B (/16 bit) mask on both lans...
    > >

    >
    > Lets try this again! Wasn't thinking when I typed the other mask. This is
    > the correct config....
    >
    > The following will work:
    > interface Serial0
    > description WAN office1
    > ip address 192.168.1.1 255.255.255.252
    > encapsulation ppp
    > service-module t1 timeslots 1-24
    > no cdp enable
    >
    > interface FastEthernet0
    > description LAN office1
    > ip address 172.16.0.1 255.255.252.0 .
    > speed auto
    > no cdp enable
    > ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    > remote)
    > ip route 172.16.8.0 255.255.252.0 192.168.1.2
    > *************************************
    > interface Serial0
    > description WAN office2
    > ip address 192.168.1.2 255.255.255.252
    > encapsulation ppp
    > service-module t1 timeslots 1-24
    > no cdp enable
    > interface FastEthernet0
    > description LAN office2
    > ip address 172.16.8.1 255.255.252.0
    > speed auto
    > no cdp enable
    > ip route 0.0.0.0 0.0.0.0 192.168.1.1
    >
    >

    Brian,
    Thanks for your help
     
    np, Mar 2, 2004
    #7
  8. In article <KU71c.29754$PR3.513146@attbi_s03>, "Brian V" <> wrote:
    >Lets try this again! Wasn't thinking when I typed the other mask. This is
    >the correct config....
    >
    > The following will work:
    >interface Serial0
    >description WAN office1
    >ip address 192.168.1.1 255.255.255.252
    >encapsulation ppp
    >service-module t1 timeslots 1-24
    >no cdp enable
    >
    >interface FastEthernet0
    >description LAN office1
    >ip address 172.16.0.1 255.255.252.0 .
    >speed auto
    >no cdp enable
    >ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    >remote)
    >ip route 172.16.8.0 255.255.252.0 192.168.1.2


    I think this should actually be
    ip route 172.16.8.0 255.255.252.0 192.168.1.1 ( or Serial0 would also work )


    >*************************************
    >interface Serial0
    >description WAN office2
    >ip address 192.168.1.2 255.255.255.252
    >encapsulation ppp
    >service-module t1 timeslots 1-24
    >no cdp enable
    >interface FastEthernet0
    >description LAN office2
    >ip address 172.16.8.1 255.255.252.0
    >speed auto
    >no cdp enable
    >ip route 0.0.0.0 0.0.0.0 192.168.1.1


    and this be
    ip route 0.0.0.0 0.0.0.0 192.168.1.2 ( or Serial0 )


    Gordon Montgomery
    Living Scriptures, Inc
    (anti spam - replace lsi with livingscriptures)
    (801) 627-2000
     
    Gordon Montgomery, Mar 3, 2004
    #8
  9. np

    Brian V Guest

    "Gordon Montgomery" <> wrote in message
    news:...
    > In article <KU71c.29754$PR3.513146@attbi_s03>, "Brian V"

    <> wrote:
    > >Lets try this again! Wasn't thinking when I typed the other mask. This

    is
    > >the correct config....
    > >
    > > The following will work:
    > >interface Serial0
    > >description WAN office1
    > >ip address 192.168.1.1 255.255.255.252
    > >encapsulation ppp
    > >service-module t1 timeslots 1-24
    > >no cdp enable
    > >
    > >interface FastEthernet0
    > >description LAN office1
    > >ip address 172.16.0.1 255.255.252.0 .
    > >speed auto
    > >no cdp enable
    > >ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    > >remote)
    > >ip route 172.16.8.0 255.255.252.0 192.168.1.2

    >
    > I think this should actually be
    > ip route 172.16.8.0 255.255.252.0 192.168.1.1 ( or Serial0 would also

    work )
    >
    >
    > >*************************************
    > >interface Serial0
    > >description WAN office2
    > >ip address 192.168.1.2 255.255.255.252
    > >encapsulation ppp
    > >service-module t1 timeslots 1-24
    > >no cdp enable
    > >interface FastEthernet0
    > >description LAN office2
    > >ip address 172.16.8.1 255.255.252.0
    > >speed auto
    > >no cdp enable
    > >ip route 0.0.0.0 0.0.0.0 192.168.1.1

    >
    > and this be
    > ip route 0.0.0.0 0.0.0.0 192.168.1.2 ( or Serial0 )
    >
    >
    > Gordon Montgomery
    > Living Scriptures, Inc
    > (anti spam - replace lsi with livingscriptures)
    > (801) 627-2000


    Gordon,
    The IP route statement should always point to the next hop address. In your
    example it is pointing to itself. The only time that you should use a
    interface statement is when you are doing IP unnumbered, do not know the
    next hop IP or you are obtaining it via dhcp (there's a few other, but we'll
    keep it to the most common). The drawback to pointing it to an interface is
    that it will continously need to arp for the next hop. Adds latency and is
    unneeded when you know the IP address of the next hop.
    -Brian
     
    Brian V, Mar 3, 2004
    #9
  10. In article <utc1c.30832$PR3.569362@attbi_s03>, "Brian V" <> wrote:
    >
    >Gordon,
    >The IP route statement should always point to the next hop address. In your
    >example it is pointing to itself. The only time that you should use a
    >interface statement is when you are doing IP unnumbered, do not know the
    >next hop IP or you are obtaining it via dhcp (there's a few other, but we'll
    >keep it to the most common). The drawback to pointing it to an interface is
    >that it will continously need to arp for the next hop. Adds latency and is
    >unneeded when you know the IP address of the next hop.
    >-Brian
    >
    >

    I guess I learn something every day if I'm not careful.

    Makes sense. I will try it out here.

    Gordon
     
    Gordon Montgomery, Mar 3, 2004
    #10
  11. np

    np Guest

    "Brian V" <> wrote in message
    news:KU71c.29754$PR3.513146@attbi_s03...
    > Corrections Below.
    >
    > "Brian V" <> wrote in message
    > news:db71c.462539$na.1095079@attbi_s04...
    > >
    > > "np" <> wrote in message

    > news:...
    > > >
    > > > "Brian V" <> wrote in message
    > > > news:FT51c.101199$Xp.434175@attbi_s54...
    > > > >
    > > > > "Aaron Leonard" <> wrote in message
    > > > > news:...
    > > > > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > > > > >
    > > > > > ~ Hello,
    > > > > > ~ I need to configure a point-to-point between two of our offices

    > and
    > > I
    > > > > want
    > > > > > ~ to make sure the configs are correct before I send one of the

    > > routers
    > > > to
    > > > > our
    > > > > > ~ other office. What type of cable can I use to connect the two

    > > routers
    > > > > for
    > > > > > ~ testing? They have the T1 DSU/CSU cards in them
    > > > > >
    > > > > > Just make a crossover T1 cable.
    > > > > >
    > > > > > RJ-45 ----- RJ-45
    > > > > > 1 ----- 4
    > > > > > 2 ----- 5
    > > > > > 4 ----- 1
    > > > > > 5 ----- 2
    > > > > >
    > > > > > ~ Also, how's this config look? Do I need anything else?
    > > > > > ~
    > > > > > ~ interface Serial0
    > > > > > ~ description WAN office1
    > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > ~ encapsulation ppp
    > > > > > ~ service-module t1 timeslots 1-24
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ interface FastEthernet0
    > > > > > ~ description LAN office1
    > > > > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > > > > ~ speed auto
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > > ~
    > > > > > ~ *************************************
    > > > > > ~ interface Serial0
    > > > > > ~ description WAN office2
    > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > ~ encapsulation ppp
    > > > > > ~ service-module t1 timeslots 1-24
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ interface FastEthernet0
    > > > > > ~ description LAN office2
    > > > > > ~ ip address 172.16.x.x 255.255.0.0
    > > > > > ~ speed auto
    > > > > > ~ no cdp enable
    > > > > > ~
    > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > >
    > > > > > Practically speaking, I wouldn't think that each
    > > > > > side would have a default route to the other.
    > > > > >
    > > > > > Aaron
    > > > >
    > > > > nor would they have the same subnet on each lan! (unless of course

    it
    > > was
    > > > > configured for bridging..which it's not!)
    > > > >
    > > > >
    > > >
    > > > Thanks for the comments,
    > > > Can you explain the subnet net issue more. We use a 172.16.0.0/22

    > scheme.
    > > > "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses 172.16.8.x -
    > > > 172.16.11.x. My goal is to have anything destined for the other

    office
    > go
    > > > through the point-to-point and all other traffice out a firewall.
    > > >
    > > >

    > >
    > > You have a Class B (/16 bit) mask on both lans...
    > >

    >
    > Lets try this again! Wasn't thinking when I typed the other mask. This is
    > the correct config....
    >
    > The following will work:
    > interface Serial0
    > description WAN office1
    > ip address 192.168.1.1 255.255.255.252
    > encapsulation ppp
    > service-module t1 timeslots 1-24
    > no cdp enable
    >
    > interface FastEthernet0
    > description LAN office1
    > ip address 172.16.0.1 255.255.252.0 .
    > speed auto
    > no cdp enable
    > ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    > remote)
    > ip route 172.16.8.0 255.255.252.0 192.168.1.2
    > *************************************
    > interface Serial0
    > description WAN office2
    > ip address 192.168.1.2 255.255.255.252
    > encapsulation ppp
    > service-module t1 timeslots 1-24
    > no cdp enable
    > interface FastEthernet0
    > description LAN office2
    > ip address 172.16.8.1 255.255.252.0
    > speed auto
    > no cdp enable
    > ip route 0.0.0.0 0.0.0.0 192.168.1.1
    >
    >


    I've connected a crossover cable to both wic ports and the serial 0/0
    interface will not come up. I've tried no shutdown on both and verfied that
    the cable is a crossover with a fluke tool. Any thoughts?

    Thanks again
     
    np, Mar 3, 2004
    #11
  12. np

    Brian V Guest

    "np" <> wrote in message news:...
    >
    > "Brian V" <> wrote in message
    > news:KU71c.29754$PR3.513146@attbi_s03...
    > > Corrections Below.
    > >
    > > "Brian V" <> wrote in message
    > > news:db71c.462539$na.1095079@attbi_s04...
    > > >
    > > > "np" <> wrote in message

    > > news:...
    > > > >
    > > > > "Brian V" <> wrote in message
    > > > > news:FT51c.101199$Xp.434175@attbi_s54...
    > > > > >
    > > > > > "Aaron Leonard" <> wrote in message
    > > > > > news:...
    > > > > > > On Tue, 2 Mar 2004 12:23:48 -0500, "np" <> wrote:
    > > > > > >
    > > > > > > ~ Hello,
    > > > > > > ~ I need to configure a point-to-point between two of our

    offices
    > > and
    > > > I
    > > > > > want
    > > > > > > ~ to make sure the configs are correct before I send one of the
    > > > routers
    > > > > to
    > > > > > our
    > > > > > > ~ other office. What type of cable can I use to connect the two
    > > > routers
    > > > > > for
    > > > > > > ~ testing? They have the T1 DSU/CSU cards in them
    > > > > > >
    > > > > > > Just make a crossover T1 cable.
    > > > > > >
    > > > > > > RJ-45 ----- RJ-45
    > > > > > > 1 ----- 4
    > > > > > > 2 ----- 5
    > > > > > > 4 ----- 1
    > > > > > > 5 ----- 2
    > > > > > >
    > > > > > > ~ Also, how's this config look? Do I need anything else?
    > > > > > > ~
    > > > > > > ~ interface Serial0
    > > > > > > ~ description WAN office1
    > > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > > ~ encapsulation ppp
    > > > > > > ~ service-module t1 timeslots 1-24
    > > > > > > ~ no cdp enable
    > > > > > > ~
    > > > > > > ~ interface FastEthernet0
    > > > > > > ~ description LAN office1
    > > > > > > ~ ip address 172.16.x.x 255.255.0.0 .
    > > > > > > ~ speed auto
    > > > > > > ~ no cdp enable
    > > > > > > ~
    > > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > > > ~
    > > > > > > ~ *************************************
    > > > > > > ~ interface Serial0
    > > > > > > ~ description WAN office2
    > > > > > > ~ ip address 192.168.1.x 255.255.255.252
    > > > > > > ~ encapsulation ppp
    > > > > > > ~ service-module t1 timeslots 1-24
    > > > > > > ~ no cdp enable
    > > > > > > ~
    > > > > > > ~ interface FastEthernet0
    > > > > > > ~ description LAN office2
    > > > > > > ~ ip address 172.16.x.x 255.255.0.0
    > > > > > > ~ speed auto
    > > > > > > ~ no cdp enable
    > > > > > > ~
    > > > > > > ~ ip route 0.0.0.0 0.0.0.0 Serial0
    > > > > > >
    > > > > > > Practically speaking, I wouldn't think that each
    > > > > > > side would have a default route to the other.
    > > > > > >
    > > > > > > Aaron
    > > > > >
    > > > > > nor would they have the same subnet on each lan! (unless of course

    > it
    > > > was
    > > > > > configured for bridging..which it's not!)
    > > > > >
    > > > > >
    > > > >
    > > > > Thanks for the comments,
    > > > > Can you explain the subnet net issue more. We use a 172.16.0.0/22

    > > scheme.
    > > > > "Office1" uses 172.16.0.x - 172.16.3.x and "Office2" uses

    172.16.8.x -
    > > > > 172.16.11.x. My goal is to have anything destined for the other

    > office
    > > go
    > > > > through the point-to-point and all other traffice out a firewall.
    > > > >
    > > > >
    > > >
    > > > You have a Class B (/16 bit) mask on both lans...
    > > >

    > >
    > > Lets try this again! Wasn't thinking when I typed the other mask. This

    is
    > > the correct config....
    > >
    > > The following will work:
    > > interface Serial0
    > > description WAN office1
    > > ip address 192.168.1.1 255.255.255.252
    > > encapsulation ppp
    > > service-module t1 timeslots 1-24
    > > no cdp enable
    > >
    > > interface FastEthernet0
    > > description LAN office1
    > > ip address 172.16.0.1 255.255.252.0 .
    > > speed auto
    > > no cdp enable
    > > ip route 0.0.0.0 0.0.0.0 X.X.X.X (the x's being your next hop, not the
    > > remote)
    > > ip route 172.16.8.0 255.255.252.0 192.168.1.2
    > > *************************************
    > > interface Serial0
    > > description WAN office2
    > > ip address 192.168.1.2 255.255.255.252
    > > encapsulation ppp
    > > service-module t1 timeslots 1-24
    > > no cdp enable
    > > interface FastEthernet0
    > > description LAN office2
    > > ip address 172.16.8.1 255.255.252.0
    > > speed auto
    > > no cdp enable
    > > ip route 0.0.0.0 0.0.0.0 192.168.1.1
    > >
    > >

    >
    > I've connected a crossover cable to both wic ports and the serial 0/0
    > interface will not come up. I've tried no shutdown on both and verfied

    that
    > the cable is a crossover with a fluke tool. Any thoughts?
    >
    > Thanks again
    >
    >



    You are using a T1 crossover cable right? It is NOT the same as an ethernet
    crossover.

    1>4
    2>5
    4>1
    5>2

    Once you have the right cable you'll need to set the clockrate on one side.
    There is no clocking by using a crossover cable, clocking is typically
    supplied by the telco (provided you pass thru atleast 1 pop). By default all
    serial interfaces look at line for clocking.


    Do this on your "office1" router.
    conf t
    int s0
    clockrate 56000
    exit
    wr mem

    you may also need to "bounce" the interface after doing the above.
    conf t
    int s0
    shut
    <count to 10>
    no shut
    exit

    make sure you remove the clockrate (no clockrate 56000) before trying to
    bring the real circuit up. If you don't you'll see all kinds of errors.

    Good luck,
    -Brian
     
    Brian V, Mar 4, 2004
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    456
    BradReeseCom
    Feb 23, 2005
  2. Spencer Teran

    Cisco ONS 15327 to simulate circuits

    Spencer Teran, Mar 1, 2005, in forum: Cisco
    Replies:
    0
    Views:
    406
    Spencer Teran
    Mar 1, 2005
  3. R Siffredi

    Simulate network/transmission latency

    R Siffredi, Sep 8, 2005, in forum: Cisco
    Replies:
    6
    Views:
    4,566
  4. Stacy E
    Replies:
    2
    Views:
    1,549
  5. Replies:
    3
    Views:
    1,640
Loading...

Share This Page