Simple(?) QoS question

Discussion in 'Cisco' started by spork, Jan 25, 2007.

  1. spork

    spork Guest

    Hello,

    I have a problem that I though would be very easy to solve.

    I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
    have three vlans hanging of of fa0.

    One vlan is for voice traffic and needs absolute priority to the
    internet.
    One vlan is for general office traffic and should have less priority
    than the voice vlan.
    One vlan is for public wireless access and should have the lowest
    priority.

    I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
    work with Frame - the command to apply the policy to the subinterface
    either doesn't exist or I get a line similar to: CBWFQ : Not supported
    on subinterfaces
    Applying to the main interface has no effect.

    This should be pretty easy, what am I missing?
    spork, Jan 25, 2007
    #1
    1. Advertising

  2. spork

    Scooby Guest

    "spork" <> wrote in message
    news:...
    > Hello,
    >
    > I have a problem that I though would be very easy to solve.
    >
    > I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
    > have three vlans hanging of of fa0.
    >
    > One vlan is for voice traffic and needs absolute priority to the
    > internet.
    > One vlan is for general office traffic and should have less priority
    > than the voice vlan.
    > One vlan is for public wireless access and should have the lowest
    > priority.
    >
    > I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
    > work with Frame - the command to apply the policy to the subinterface
    > either doesn't exist or I get a line similar to: CBWFQ : Not supported
    > on subinterfaces
    > Applying to the main interface has no effect.
    >
    > This should be pretty easy, what am I missing?
    >


    Here's an article on VoIP over Frame-Relay that should offer some tips:

    http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuration_example09186a0080094af9.shtml

    Hope that helps,

    Jim
    Scooby, Jan 25, 2007
    #2
    1. Advertising

  3. spork

    vty 0 4 Guest

    define a map-class, apply service policies to map-class, apply
    map-class under "frame-relay interface dlc1 xx"

    From experience, 1721 + CBWFQ = problems

    On 25 Jan 2007 12:22:52 -0800, "spork" <>
    wrote:

    >Hello,
    >
    >I have a problem that I though would be very easy to solve.
    >
    >I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
    >have three vlans hanging of of fa0.
    >
    >One vlan is for voice traffic and needs absolute priority to the
    >internet.
    >One vlan is for general office traffic and should have less priority
    >than the voice vlan.
    >One vlan is for public wireless access and should have the lowest
    >priority.
    >
    >I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
    >work with Frame - the command to apply the policy to the subinterface
    >either doesn't exist or I get a line similar to: CBWFQ : Not supported
    >on subinterfaces
    >Applying to the main interface has no effect.
    >
    >This should be pretty easy, what am I missing?
    vty 0 4, Jan 26, 2007
    #3
  4. spork

    spork Guest

    On Jan 25, 6:02 pm, "Scooby" <> wrote:
    > "spork" <> wrote in message
    >
    > news:...
    >
    > > Hello,

    >
    > > I have a problem that I though would be very easy to solve.

    >
    > > I have a Cisco 1721 that has a frame-relay T1 to the internet, and I
    > > have three vlans hanging of of fa0.

    >
    > > One vlan is for voice traffic and needs absolute priority to the
    > > internet.
    > > One vlan is for general office traffic and should have less priority
    > > than the voice vlan.
    > > One vlan is for public wireless access and should have the lowest
    > > priority.

    >
    > > I've fiddled with CBWFQ, LLQ and a few others. None of them seem to
    > > work with Frame - the command to apply the policy to the subinterface
    > > either doesn't exist or I get a line similar to: CBWFQ : Not supported
    > > on subinterfaces
    > > Applying to the main interface has no effect.

    >
    > > This should be pretty easy, what am I missing?

    >
    > Here's an article on VoIP over Frame-Relay that should offer some tips:
    >
    > http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuratio...


    That's got me stumped. I've got the following to differentiate the 3
    vlans:

    policy-map inet-out
    class studio-out
    priority 400
    class office-out
    bandwidth 800
    class class-default
    fair-queue

    class-map match-all office-out
    match access-group 2
    class-map match-all wireless-out
    match access-group 3
    class-map match-all studio-out
    match access-group 1

    !
    interface Serial0.1 point-to-point
    bandwidth 1490
    ip address x.x.x.233 255.255.255.0
    ip nat outside
    frame-relay interface-dlci 16
    class frame-out
    !
    map-class frame-relay frame-out
    service-policy output inet-out
    !
    access-list 1 permit 216.220.105.24 0.0.0.7
    access-list 2 permit 192.168.0.0 0.0.0.255
    access-list 3 permit 192.168.1.0 0.0.0.255

    Now when I go to the main frame interface and add the "frame-relay
    traffic-shaping", it gives me this:

    evradio(config-if)#frame-relay traffic-shaping
    I/f Serial0.1 DLCI 16 class studio-out requested bandwidth 400 (kbps),
    available only 1 (kbps)
    Traffic shaping not enabled due to invalid policy in map-class frame-
    out

    Where is this 1Kb/s limit coming from? I do have bandwidth statements
    on both the main serial interface and the frame subinterface (1536).

    > Hope that helps,
    >
    > Jim
    spork, Feb 1, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,469
  2. Matt

    Simple QoS

    Matt, Mar 5, 2006, in forum: UK VOIP
    Replies:
    6
    Views:
    2,241
    Richard Smith
    Mar 10, 2006
  3. Replies:
    7
    Views:
    4,184
    Kimba W. Lion
    Jan 26, 2007
  4. dominix
    Replies:
    2
    Views:
    456
    dominix
    Feb 6, 2007
  5. MeekiMoo
    Replies:
    0
    Views:
    630
    MeekiMoo
    Jul 28, 2009
Loading...

Share This Page