Simple multihoming with route-map and NAT

Discussion in 'Cisco' started by bsvorinic@gmail.com, Jun 6, 2006.

  1. Guest

    I'm having tough time trying to set up something that looks like it
    should be rather easy:

    Cisco router with:
    - one FastEthernet port connected to LAN
    - one Ethernet port connected to DSL (PPPoE)
    - one Serial port connected point-to-point

    DSL gets it's IP assigned from ISP (dynamic), Serial port has static
    public IP addresses.

    What I'm trying to achieve is to route outgoing mail (SMTP) thru Serial
    port. All other outgoing traffic should be sent thru DSL, also NAT-ed.

    Can anyone provide some sample configuration or advice? What I tried to
    do looks something like:

    =====================================================
    interface FastEthernet0
    ip address _local_private_address_
    ip nat inside

    interface Serial0.1 point-to-point
    ip address _public_static_address_
    ip nat outside

    interface Ethernet0
    no ip address
    pppoe enable

    interface Dialer0
    ip address negotiated
    ip nat outside

    access-list 102 remark allow NAT from local addresses
    access-list 102 permit ip _local_network_ 0.0.0.255 any

    ip access-list extended alNATtoSerial
    permit tcp _local_network_ 0.0.0.255 any eq smtp

    route-map rmNATtoDSL permit 10
    match ip address 102

    route-map rmNATtoSerial permit 10
    match ip address alNATtoSerial

    ip nat inside source route-map rmNATtoDSL interface Dialer0 overload
    ip nat inside source route-map rmNATtoSerial interface Serial0.1
    overload
    =====================================================

    Thanks in advance,
    Bruno
    , Jun 6, 2006
    #1
    1. Advertising

  2. wrote:

    > I'm having tough time trying to set up something that looks like it
    > should be rather easy:
    >
    > Cisco router with:
    > - one FastEthernet port connected to LAN
    > - one Ethernet port connected to DSL (PPPoE)
    > - one Serial port connected point-to-point

    *
    *
    *
    > route-map rmNATtoDSL permit 10
    > match ip address 102
    >
    > route-map rmNATtoSerial permit 10
    > match ip address alNATtoSerial
    >
    > ip nat inside source route-map rmNATtoDSL interface Dialer0 overload
    > ip nat inside source route-map rmNATtoSerial interface Serial0.1
    > overload
    > =====================================================
    >
    > Thanks in advance,
    > Bruno


    Among other problems, the route maps are only applied when a translation
    which is NOT in the translation table is required (at connection setup). If
    the link then fails, the bad translation for the failed link will continue
    in use until you stop using it and it times out. You get lucky and have the
    translate cleared if the serial line goes down hard, but even if you unplug
    the ethernet, the translations going through it will remain.

    It can also be a challenge detecting when one of your links is down.

    A search on ping based routing will get you most of the past messages where
    this topic has been generally addressed.

    Good luck and have fun!
    --
    Vincent C Jones, Consultant Expert advice and a helping hand
    Networking Unlimited, Inc. for those who want to manage and
    Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    http://www.networkingunlimited.com
    Vincent C Jones, Jun 16, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Christian Lox
    Replies:
    4
    Views:
    1,444
    Klaus Thielking-Riechert
    Jul 4, 2004
  2. Tarek Hamdy
    Replies:
    12
    Views:
    5,461
    Tarek Hamdy
    Oct 7, 2004
  3. AM
    Replies:
    3
    Views:
    599
  4. Replies:
    1
    Views:
    5,138
    Barry Margolin
    Aug 13, 2005
  5. Replies:
    9
    Views:
    4,887
    Scott Perry
    Aug 7, 2008
Loading...

Share This Page