Setup Remote VPN on PIX 501

Discussion in 'Cisco' started by tom.weber@gmail.com, Mar 23, 2006.

  1. Guest

    I'm trying to configure a remote VPN where clients can connect using
    the VPN client and have access to the internal network. I'm new to the
    PIX, and seem to be having some trouble.

    All configuration is done through the PDM.

    I used the Wizard to create the vpn server.

    Internal Network 192.168.1.0/24
    VPN IP Pool 10.10.10.1 - 10.10.10.11

    And for the exemtion I just clicked finish, so they will have access to
    the internal network.

    The client can authenticate with the VPN server, and be assigned an ip
    address, however cannot ping or access any internal clients, nor ping
    the 192.168.1.1 internal interface on the PIX. Where am I going wrong?

    Detailed step by step would be great.

    Thanks!

    Tom
     
    , Mar 23, 2006
    #1
    1. Advertising

  2. In article <>,
    <> wrote:
    >I'm trying to configure a remote VPN where clients can connect using
    >the VPN client and have access to the internal network. I'm new to the
    >PIX, and seem to be having some trouble.


    >All configuration is done through the PDM.


    >I used the Wizard to create the vpn server.


    >Internal Network 192.168.1.0/24
    >VPN IP Pool 10.10.10.1 - 10.10.10.11


    >And for the exemtion I just clicked finish, so they will have access to
    >the internal network.


    >The client can authenticate with the VPN server, and be assigned an ip
    >address, however cannot ping or access any internal clients, nor ping
    >the 192.168.1.1 internal interface on the PIX. Where am I going wrong?


    The text version of your configuration (with passwords scrubbed)
    would help.

    I am not going to try to guess what the PDM might or might not have
    done on your behalf -- too many different screens and you would
    have to describe each configuration step and each drop-box selection
    and so on for me to be able to replicate what you ended up with.
    The text configuration is *much* easier to answer questions about.

    My -guess- is that the PDM didn't happen to turn on
    sysopt connection permit-ipsec
    but I don't have enough information to be sure.

    >The client can authenticate with the VPN server, and be assigned an ip
    >address, however cannot ping or access any internal clients, nor ping
    >the 192.168.1.1 internal interface on the PIX. Where am I going wrong?


    For your purposes you should assume that the VPN clients will
    never be able to ping the PIX inside interface IP. [If you *really*
    needed them to be able to do that, it would be possible to configure,
    but it's a relatively advanced configuration and seldom worth the
    bother.]
     
    Walter Roberson, Mar 23, 2006
    #2
    1. Advertising

  3. Guest

    Building configuration...
    : Saved
    :
    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password EDITED encrypted
    passwd EDITED encrypted
    hostname pix
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 10.10.10.0 VPN
    object-group service RemoteDesktop tcp
    port-object range 3389 3389
    access-list inside_access_in remark Allow all outbound UDP port 53 for
    DNS
    access-list inside_access_in permit udp any any eq domain
    access-list inside_access_in remark Allow ping to any external IP
    access-list inside_access_in permit icmp any any
    access-list inside_access_in remark Allow all outbound TCP connections
    access-list inside_access_in permit tcp any any
    access-list outside_access_in remark Allow external DNS via UDP
    access-list outside_access_in permit udp any eq domain any
    access-list outside_access_in remark Allow ping from outside to inside
    access-list outside_access_in permit icmp any any
    access-list outside_access_in remark Remote Desktop to any internal IP
    access-list outside_access_in permit tcp any any object-group
    RemoteDesktop
    access-list inside_outbound_nat0_acl permit ip any 192.168.1.48
    255.255.255.240
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.48
    255.255.255.240
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool donkpool 192.168.1.50-192.168.1.60
    pdm location 12.151.16.35 255.255.255.255 outside
    pdm location 192.168.1.2 255.255.255.255 inside
    pdm location 255.255.255.255 255.255.255.255 inside
    pdm location 66.69.153.207 255.255.255.255 outside
    pdm location VPN 255.255.255.224 inside
    pdm location 192.168.1.64 255.255.255.224 outside
    pdm location VPN 255.255.255.240 outside
    pdm location 12.151.16.35 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask
    255.255.255.255 0 0
    access-group outside_access_in in interface outside
    access-group inside_access_in in interface inside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 12.151.16.35 255.255.255.255 outside
    http 66.69.153.207 255.255.255.255 outside
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address
    outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup donk address-pool donkpool
    vpngroup donk idle-time 1800
    vpngroup donk password ********
    telnet 12.151.16.35 255.255.255.255 outside
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 66.69.153.207 255.255.255.255 outside
    ssh 12.151.16.35 255.255.255.255 outside
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.20-192.168.1.49 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    username rogers password EDITED encrypted privilege 15
    terminal width 80
    Cryptochecksum:EDITED
    : end
    [OK]



    I've also tried to ping internal machines, no go.
    Client side I get this error:

    7 12:59:44.999 03/23/06 Sev=Warning/2 CVPND/0xE3400013
    AddRoute failed to add a route: code 87
    Destination 143.62.255.255
    Netmask 255.255.255.255
    Gateway 192.168.1.50
    Interface 192.168.1.50

    8 12:59:44.999 03/23/06 Sev=Warning/2 CM/0xA3100024
    Unable to add route. Network: 8f3effff, Netmask: ffffffff, Interface:
    c0a80132, Gateway: c0a80132.

    (trying to vpn from a 143.62 ip)
     
    , Mar 23, 2006
    #3
  4. In article <>,
    <> wrote:
    >PIX Version 6.3(4)


    >ip address inside 192.168.1.1 255.255.255.0


    >ip local pool donkpool 192.168.1.50-192.168.1.60


    >vpngroup donk address-pool donkpool


    In order for the return traffic to reach the VPN clients from
    your inside hosts, your vpngroup IP pool needs to be in a different
    subnet than your inside address. For example you could use

    ip local pool donkpool 192.168.2.50-192.168.2.60 mask 255.255.255.0

    as long as you made the appropriate adjustments to other
    parts of the configuration.


    >dhcpd address 192.168.1.20-192.168.1.49 inside


    Just for clarity: what I said about ip local pool does NOT apply
    to the dhcpd addresses. Hosts that are "inside" the PIX need to
    have addresses that are "inside" the PIX, but hosts that are "outside"
    the PIX (e.g., the VPN clients) need to have addresses that
    are "outside" the PIX.
     
    Walter Roberson, Mar 23, 2006
    #4
  5. Guest

    I've tried with another IP Pool for the vpn clients
    (10.10.10.1-10.10.10.11) with the same problem. The exact same error on
    the client (tried from multiple machines, even toggling modes)
     
    , Mar 23, 2006
    #5
  6. In article <>,
    <> wrote:
    >I've tried with another IP Pool for the vpn clients


    Please quote context. There's only one regular poster in these groups
    who uses googlegroups as a regular email reader; the rest of us do not
    have the context "right there" to look at.

    >(10.10.10.1-10.10.10.11) with the same problem. The exact same error on
    >the client (tried from multiple machines, even toggling modes)


    I'd like to see the editted configuration.
     
    Walter Roberson, Mar 24, 2006
    #6
  7. Guest

    This is my current config, which is still receiving the route error:

    "PIX# sh ru
    : Saved
    :
    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password EDITED encrypted
    passwd EDITED encrypted
    hostname PIX
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    object-group service RemoteDesktop tcp
    port-object range 3389 3389
    access-list outside_access_in remark Remote Desktop to internal server
    access-list outside_access_in permit tcp any interface outside
    object-group RemoteDesktop
    access-list outside_access_in remark Allow inbound ping replies
    access-list outside_access_in permit icmp any any echo-reply
    access-list inside_outbound_nat0_acl permit ip 10.5.10.0 255.255.255.0
    10.197.202.48 255.255.255.240
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 10.5.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool donkpool 10.197.202.50-10.197.202.60
    pdm location 12.151.16.35 255.255.255.255 outside
    pdm location 10.5.10.20 255.255.255.255 inside
    pdm location 10.5.10.20 255.255.255.255 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (outside,inside) tcp interface 3389 10.5.10.20 3389 netmask
    255.255.255.255 0 0
    access-group outside_access_in in interface outside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 12.151.16.35 255.255.255.255 outside
    http 10.5.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup donk address-pool donkpool
    vpngroup donk idle-time 1800
    vpngroup donk password ********
    telnet timeout 5
    ssh 12.151.16.35 255.255.255.255 outside
    ssh timeout 5
    console timeout 0
    dhcpd address 10.5.10.20-10.5.10.40 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:EDITED
    : end
    "
     
    , Mar 24, 2006
    #7
  8. Guest

    > There's only one regular poster in these groups
    > who uses googlegroups as a regular email reader; the rest of us do not
    > have the context "right there" to look at.


    Walter,

    Are you refering to me here?

    I do consider myself a regular contributor however
    I have no idea if that may be the viewpoint of someone else?

    I use Google groups for all my Usenet access
    and I do try to contribute as much
    as I can. From my Google View I suspect that it is difficult to
    appreciate the tools used by other users of this group and
    I am concerned that I do not meet their requirements.

    I have recently been making an effort to appropriately
    'quote' past messages even though I have to do it entirely
    manually and from my 'Google' view it appears
    superfluous.

    Anyway, please let me know if I am causing difficulties
    and inform me of possible improvements to my
    posting style. My goal is to communicate as effectively
    as I can.

    More contentiously:-
    Why don't you use Google Groups too?!!!!!!:)
    Seems a perfect plan to me:)))))))))

    BTW Google Groups is not a 'a regular email reader'.

    Thanks,

    Me.
     
    , Mar 27, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tim Fortea
    Replies:
    2
    Views:
    1,026
  2. nbaxley

    Setup PIX 501 VPN

    nbaxley, Nov 24, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,419
    John Smith
    Nov 24, 2004
  3. Andre
    Replies:
    7
    Views:
    733
    Andre
    Feb 20, 2005
  4. Marko Uusitalo
    Replies:
    1
    Views:
    1,517
    Frank Durham
    Apr 11, 2005
  5. Replies:
    1
    Views:
    657
    Walter Roberson
    Nov 14, 2006
Loading...

Share This Page