Settings for Freepbx / Trixbox ??

Discussion in 'UK VOIP' started by Brian A, Feb 2, 2007.

  1. Brian A

    Brian A Guest

    FreePBX / Trixbox
    I am starting off by trying to get voip.co.uk working, then I want to
    go onto voiptalk.
    I am using a softphone (x-lite) as my test extension as I currently
    only have one ATA and that is in service.
    I have suceeded in getting outgoing calls to work. However I am having
    no luck at all with incoming calls.
    I Googled and found some settings but still no luck.

    I have set the' Inbound Route' to accept any DID and the 'Core' to
    route directly to my extension (softphone).

    The trunk has INCOMING settings:-

    User Context 123456

    Under 'User Details' :-

    authuser=123456
    canreinvite=no
    context=from-pstn
    fromdomain=proxy.voip.co.uk
    fromuser=123456
    host=proxy.voip.co.uk
    insecure=very
    secret==xxxxxxxx
    type=peer
    username=123456

    Where 123456 represents my userID and xxxxxxxx my password.

    Register String
    123456:/123456

    ( I have also tried @proxy.voip.co.uk as suggested on one of
    voip.co.uk technical pages.)

    Any ideas about what I am doing wrong or need to add?

    Further, do I need to do anything in regard to my dynamic IP?

    Remove 'no_spam_' from email address.
     
    Brian A, Feb 2, 2007
    #1
    1. Advertising

  2. Brian A

    Jono Guest

    Brian A explained :
    > FreePBX / Trixbox
    > I am starting off by trying to get voip.co.uk working, then I want to
    > go onto voiptalk.
    > I am using a softphone (x-lite) as my test extension as I currently
    > only have one ATA and that is in service.
    > I have suceeded in getting outgoing calls to work. However I am having
    > no luck at all with incoming calls.
    > I Googled and found some settings but still no luck.
    >
    > I have set the' Inbound Route' to accept any DID and the 'Core' to
    > route directly to my extension (softphone).
    >
    > The trunk has INCOMING settings:-
    >
    > User Context 123456
    >
    > Under 'User Details' :-
    >
    > authuser=123456
    > canreinvite=no
    > context=from-pstn
    > fromdomain=proxy.voip.co.uk
    > fromuser=123456
    > host=proxy.voip.co.uk
    > insecure=very
    > secret==xxxxxxxx
    > type=peer
    > username=123456
    >
    > Where 123456 represents my userID and xxxxxxxx my password.
    >
    > Register String
    > 123456:/123456
    >
    > ( I have also tried @proxy.voip.co.uk as suggested on one of
    > voip.co.uk technical pages.)
    >
    > Any ideas about what I am doing wrong or need to add?
    >
    > Further, do I need to do anything in regard to my dynamic IP?
    >
    > Remove 'no_spam_' from email address.


    This is my *Outgoing* config:

    authuser=123456
    canreinvite=no
    context=from-pstn
    fromdomain=proxy.voip.co.uk
    fromuser=123456
    host=proxy.voip.co.uk
    insecure=very
    secret=abcd1efg
    type=peer
    username=123456

    Note: *Inbound* section of trunk is *BLANK*, as is the User Context
    box.

    Register string:
    123456:/123456

    Then, in FreePBX, you need to create an inbound route or DID, where
    123456 is the DID, not your PSTN number.

    Also, do you have this voip.co.uk account registering on another
    device, or at Voxalot? If so, I would log in to voip.co.uk's control
    panel & create a 2nd SIP account for your Trixbox. Then point this new
    SIP account to the same incoming target - your PSTN number.

    For some problems, editing sip.conf can help:

    Near the bottom, but above any #includes, add -
    callerid = Unknown
    externip = your.dyndns.domain; or WAN IP
    localnet=192.168.1.0/255.255.255.0; where 192.168.1 is 1st 3 octets of
    your network
    nat=yes
     
    Jono, Feb 3, 2007
    #2
    1. Advertising

  3. Brian A

    Brian A Guest

    On Sat, 03 Feb 2007 08:51:27 GMT, Jono <>
    wrote:

    >Brian A explained :
    >> FreePBX / Trixbox
    >> I am starting off by trying to get voip.co.uk working, then I want to
    >> go onto voiptalk.
    >> I am using a softphone (x-lite) as my test extension as I currently
    >> only have one ATA and that is in service.
    >> I have suceeded in getting outgoing calls to work. However I am having
    >> no luck at all with incoming calls.
    >> I Googled and found some settings but still no luck.
    >>
    >> I have set the' Inbound Route' to accept any DID and the 'Core' to
    >> route directly to my extension (softphone).
    >>
    >> The trunk has INCOMING settings:-
    >>
    >> User Context 123456
    >>
    >> Under 'User Details' :-
    >>
    >> authuser=123456
    >> canreinvite=no
    >> context=from-pstn
    >> fromdomain=proxy.voip.co.uk
    >> fromuser=123456
    >> host=proxy.voip.co.uk
    >> insecure=very
    >> secret==xxxxxxxx
    >> type=peer
    >> username=123456
    >>
    >> Where 123456 represents my userID and xxxxxxxx my password.
    >>
    >> Register String
    >> 123456:/123456
    >>
    >> ( I have also tried @proxy.voip.co.uk as suggested on one of
    >> voip.co.uk technical pages.)
    >>
    >> Any ideas about what I am doing wrong or need to add?
    >>
    >> Further, do I need to do anything in regard to my dynamic IP?
    >>
    >> Remove 'no_spam_' from email address.

    >
    >This is my *Outgoing* config:
    >
    >authuser=123456
    >canreinvite=no
    >context=from-pstn
    >fromdomain=proxy.voip.co.uk
    >fromuser=123456
    >host=proxy.voip.co.uk
    >insecure=very
    >secret=abcd1efg
    >type=peer
    >username=123456
    >
    >Note: *Inbound* section of trunk is *BLANK*, as is the User Context
    >box.
    >
    >Register string:
    >123456:/123456
    >
    >Then, in FreePBX, you need to create an inbound route or DID, where
    >123456 is the DID, not your PSTN number.
    >
    >Also, do you have this voip.co.uk account registering on another
    >device, or at Voxalot? If so, I would log in to voip.co.uk's control
    >panel & create a 2nd SIP account for your Trixbox. Then point this new
    >SIP account to the same incoming target - your PSTN number.
    >
    >For some problems, editing sip.conf can help:
    >
    >Near the bottom, but above any #includes, add -
    >callerid = Unknown
    >externip = your.dyndns.domain; or WAN IP
    >localnet=192.168.1.0/255.255.255.0; where 192.168.1 is 1st 3 octets of
    >your network
    >nat=yes

    Thanks, Jono, for all that - I thought you might come up with some
    answers. I'll give all that a try. :)


    Remove 'no_spam_' from email address.
     
    Brian A, Feb 3, 2007
    #3
  4. Brian A

    Brian A Guest


    >>This is my *Outgoing* config:
    >>
    >>authuser=123456
    >>canreinvite=no
    >>context=from-pstn
    >>fromdomain=proxy.voip.co.uk
    >>fromuser=123456
    >>host=proxy.voip.co.uk
    >>insecure=very
    >>secret=abcd1efg
    >>type=peer
    >>username=123456
    >>
    >>Note: *Inbound* section of trunk is *BLANK*, as is the User Context
    >>box.
    >>
    >>Register string:
    >>123456:/123456
    >>
    >>Then, in FreePBX, you need to create an inbound route or DID, where
    >>123456 is the DID, not your PSTN number.
    >>
    >>Also, do you have this voip.co.uk account registering on another
    >>device, or at Voxalot? If so, I would log in to voip.co.uk's control
    >>panel & create a 2nd SIP account for your Trixbox. Then point this new
    >>SIP account to the same incoming target - your PSTN number.
    >>
    >>For some problems, editing sip.conf can help:
    >>
    >>Near the bottom, but above any #includes, add -
    >>callerid = Unknown
    >>externip = your.dyndns.domain; or WAN IP
    >>localnet=192.168.1.0/255.255.255.0; where 192.168.1 is 1st 3 octets of
    >>your network
    >>nat=yes

    I have now set up a gateway from my ATA just in case there was a
    problem with the softphone.
    I can now do incoming calls. I thought the outgoing was working
    successfully but it isn't :-(
    It is a strange fault.

    The same fault exists whether I dial out via voip.co.uk or via
    sipbroker.
    I can connect to some SIP numbers such as the sipphone conference
    number etc. but with other providers, I get one of 2 responses.
    1. The call is answered but I only get 0.5 seconds of audio then the
    audio cuts off but the call remains established.
    2. I get a message to say the lines are busy. This so if I try calling
    the clock on voiptalk via sipbroker. - it applies to others too.

    If I call via voip.co.uk, to an 0800 number, I connect but get
    condition 1.

    I have used exactly the same settings as you gave for the outgoing
    trunk settings. I have also set up a dynamic IP account with dyndns
    and entered the details in my router, and the sip.conf file as you
    suggested.

    Any more ideas?
    Remove 'no_spam_' from email address.
     
    Brian A, Feb 3, 2007
    #4
  5. Brian A

    Jono Guest

    Brian A brought next idea :

    > I have now set up a gateway from my ATA just in case there was a
    > problem with the softphone.
    > I can now do incoming calls. I thought the outgoing was working
    > successfully but it isn't :-(
    > It is a strange fault.
    >
    > The same fault exists whether I dial out via voip.co.uk or via
    > sipbroker.
    > I can connect to some SIP numbers such as the sipphone conference
    > number etc. but with other providers, I get one of 2 responses.
    > 1. The call is answered but I only get 0.5 seconds of audio then the
    > audio cuts off but the call remains established.
    > 2. I get a message to say the lines are busy. This so if I try calling
    > the clock on voiptalk via sipbroker. - it applies to others too.
    >
    > If I call via voip.co.uk, to an 0800 number, I connect but get
    > condition 1.
    >
    > I have used exactly the same settings as you gave for the outgoing
    > trunk settings. I have also set up a dynamic IP account with dyndns
    > and entered the details in my router, and the sip.conf file as you
    > suggested.
    >
    > Any more ideas?



    Hmm.

    Have you got voip.co.uk working sucessfully on any device?

    Have you set up an outboud route? If so, what have you got set?

    Does a Sipgate trunk give the same condition? - tested with an 0800
    number of course.

    Can you post your entire sip.conf file and sip_additional.conf files -
    beware not to include actual passwords & usernames - I suggest you copy
    & paste to a notepad document before pasting into your newsreader
     
    Jono, Feb 3, 2007
    #5
  6. Brian A

    Brian A Guest

    On Sat, 03 Feb 2007 14:51:55 GMT, Jono <>
    wrote:

    Thanks for your reply. I have worked out what is going wrong.
    I had already got router settings in place, for port forwarding, for
    my ATA. I put the trixbox in DMZ while I was setting it all up. There
    would be conflict I think with using both options. I disabled DMZ,
    changed the port forwards to my trixbox and most outgoing calls are
    now working perfectly. I probably just need to do a bit more tweaking
    of the port forwarding to get it all to work.
    Thanks for your time in replying. The settings you posted, and changes
    to the sip.conf file, were most useful.



    Remove 'no_spam_' from email address.
     
    Brian A, Feb 3, 2007
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. linker3000
    Replies:
    1
    Views:
    823
    paul123
    Jul 25, 2006
  2. Brian A
    Replies:
    3
    Views:
    2,169
    Desk Rabbit
    Feb 2, 2007
  3. Replies:
    8
    Views:
    1,424
  4. Jono

    FreePBX outbound routes

    Jono, Jul 24, 2007, in forum: UK VOIP
    Replies:
    4
    Views:
    5,221
  5. Giuen
    Replies:
    0
    Views:
    1,259
    Giuen
    Sep 12, 2008
Loading...

Share This Page