Setting up QOS on 831 for VoIP

Discussion in 'Cisco' started by craigdt-online@charter.net, Apr 9, 2006.

  1. Guest

    I have a Cisco 831 Router running code version 12.3. I am trying to
    setup QOS for VoIP (using SunRocket). I have set a couple things up,
    but while I'm talking if I do an upload test quality is terrible.
    Downstream is fine even during a test.

    I have Charter as my ISP, and I consistently get 2.9 Mb down/240 Kb up
    using Speakeasy's test.

    Here is my current config:

    Current configuration : 2077 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Thomas
    !
    logging buffered 4096 informational
    enable secret 5 xxxx
    enable password 7 xxxx
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.2.4
    ip dhcp excluded-address 192.168.2.5
    ip dhcp excluded-address 192.168.2.106
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    class-map match-all voice
    match ip precedence 5
    !
    !
    policy-map LLQ
    class voice
    priority 300
    class class-default
    fair-queue
    policy-map shape
    class class-default
    shape average 3250000
    service-policy LLQ
    !
    !
    !
    interface Ethernet0
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    service-policy output shape
    !
    interface Ethernet1
    ip address dhcp
    ip nat outside
    duplex auto
    !
    ip nat inside source list 102 interface Ethernet1 overload
    ip nat inside source static tcp 192.168.2.4 21 interface Ethernet1 21
    ip nat inside source static tcp 192.168.2.4 80 interface Ethernet1 80
    ip nat inside source static tcp 192.168.2.4 6000 interface Ethernet1
    6000
    ip nat inside source static udp 192.168.2.4 177 interface Ethernet1 177
    ip nat inside source static tcp 192.168.2.4 20 interface Ethernet1 20
    ip nat inside source static tcp 192.168.2.4 22 interface Ethernet1 22
    ip nat inside source static tcp 192.168.2.5 8180 interface Ethernet1
    8180
    ip nat inside source static tcp 192.168.2.106 3389 interface Ethernet1
    3389
    ip nat inside source static tcp 192.168.2.106 5800 interface Ethernet1
    5800
    ip nat inside source static tcp 192.168.2.106 5900 interface Ethernet1
    5900
    ip nat inside source static tcp 192.168.2.5 80 interface Ethernet1 81
    ip classless
    no ip http server
    no ip http secure-server
    !
    access-list 102 permit ip 192.168.2.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    exec-timeout 120 0
    password 7 xxxx
    login
    length 0
    !
    scheduler max-task-time 5000
    !
    end
    , Apr 9, 2006
    #1
    1. Advertising

  2. Scooby Guest

    <> wrote in message
    news:...
    >I have a Cisco 831 Router running code version 12.3. I am trying to
    > setup QOS for VoIP (using SunRocket). I have set a couple things up,
    > but while I'm talking if I do an upload test quality is terrible.
    > Downstream is fine even during a test.
    >
    > I have Charter as my ISP, and I consistently get 2.9 Mb down/240 Kb up
    > using Speakeasy's test.
    >
    > Here is my current config:
    >
    > Current configuration : 2077 bytes
    > !
    > version 12.3
    > no service pad
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname Thomas
    > !
    > logging buffered 4096 informational
    > enable secret 5 xxxx
    > enable password 7 xxxx
    > !
    > no aaa new-model
    > ip subnet-zero
    > ip dhcp excluded-address 192.168.2.4
    > ip dhcp excluded-address 192.168.2.5
    > ip dhcp excluded-address 192.168.2.106
    > !
    > !
    > ip audit notify log
    > ip audit po max-events 100
    > no ftp-server write-enable
    > !
    > !
    > !
    > !
    > !
    > !
    > class-map match-all voice
    > match ip precedence 5
    > !
    > !
    > policy-map LLQ
    > class voice
    > priority 300
    > class class-default
    > fair-queue
    > policy-map shape
    > class class-default
    > shape average 3250000
    > service-policy LLQ
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.2.1 255.255.255.0
    > ip nat inside
    > service-policy output shape
    > !
    > interface Ethernet1
    > ip address dhcp
    > ip nat outside
    > duplex auto
    > !


    <snip>

    It seems to me that you only have the QOS policy applied one way. Output on
    your LAN port would indicate that you are shaping on Downloads. If you want
    to shape on uploads, apply a QOS policy output on E1 as well. However, you
    may wish to create a new policy due to the fact that your connection is not
    symetrical.

    Hope that helps,

    Jim
    Scooby, Apr 10, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jimmyzshack
    Replies:
    1
    Views:
    523
    Claude LeFort
    Nov 19, 2003
  2. online

    Cisco 831 & QOS

    online, Apr 29, 2004, in forum: Cisco
    Replies:
    0
    Views:
    485
    online
    Apr 29, 2004
  3. online

    Cisco 831 & QOS

    online, Apr 29, 2004, in forum: Cisco
    Replies:
    0
    Views:
    498
    online
    Apr 29, 2004
  4. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,493
  5. Giuen
    Replies:
    0
    Views:
    865
    Giuen
    Sep 12, 2008
Loading...

Share This Page