Setting up QOS in for video conferencing.

Discussion in 'Cisco' started by rsjimmy, Mar 6, 2006.

  1. rsjimmy

    rsjimmy Guest

    I work in a large enterprise using video conferencing daily. I have
    read much about QOS, studied for it, but never really seen it in
    action. I just wanted to ask if there are techs here who have
    implemented it in their production networks and what sort of pitfalls
    to look out for with it. At this point I'm mostly interested in using
    it for our video and voice locations, but wanted to know if when doing
    so( I assume) it must be implemented all the way through the chain.
    ie... remote site - to - core site - to - other remote. Maybe see some
    stripped down interface configs to see it in action. Also some areas
    cross routers on slower wan circuits and other locations are routed but
    are connected gigabit; so I'm a bit interested as to how things are
    treated differently over layer 2 connections and layer 3 connections. I
    have read all about the ip precedence, the DIffServ, and QOS in
    general, but am just really curious to see how it has been done by
    someone in the real world out there. I hope I can get som egood input
    here.. Thanks
    rsjimmy, Mar 6, 2006
    #1
    1. Advertising

  2. rsjimmy

    Charlie Root Guest

    "rsjimmy" <> wrote in message
    news:...
    >I work in a large enterprise using video conferencing daily. I have
    > read much about QOS, studied for it, but never really seen it in
    > action. I just wanted to ask if there are techs here who have
    > implemented it in their production networks and what sort of pitfalls
    > to look out for with it. At this point I'm mostly interested in using
    > it for our video and voice locations, but wanted to know if when doing
    > so( I assume) it must be implemented all the way through the chain.
    > ie... remote site - to - core site - to - other remote. Maybe see some
    > stripped down interface configs to see it in action. Also some areas
    > cross routers on slower wan circuits and other locations are routed but
    > are connected gigabit; so I'm a bit interested as to how things are
    > treated differently over layer 2 connections and layer 3 connections. I
    > have read all about the ip precedence, the DIffServ, and QOS in
    > general, but am just really curious to see how it has been done by
    > someone in the real world out there. I hope I can get som egood input
    > here.. Thanks
    >


    The most important thing is to understand your traffic profiles (what kind
    of traffic, how much, from where, to where and how does it go), link
    utilisation, queueing capabilities of the devices (how many queues
    supported, scheduling of transit and self-originated traffic), how to treat
    traffic on L2/L3 devices (i.e. do routers need to care about 802.1p settings
    or not). Bear in mind that QoS configurations kick-in only when there is
    congestion (that is when there is no space left in TX-ring buffer, which is
    often much before your link is 90% loaded), all other time it's FIFO. Also,
    enabling QoS does increase load on the devices, and more so if configuration
    is suboptimal.

    While you don't actually have to enable QoS all the way through the chain,
    you do need to understand behaviour of the equipment when they don't have
    QoS configuration explicitly applied. Obviously the overloaded 2Mbps links
    are the first one where you should consider deployment of QoS policies,
    while barely loaded gigabit links will hardly show any difference with or
    without QoS applied.

    If you have more specific questions - feel free to ask.

    As for general reading you could start here
    http://www.cisco.com/en/US/products/ps6558/products_ios_technology_home.html,
    or get a book like "End-to-End QoS Network Design" (ISBN: 1-58705-176-1).

    Kind regards,
    iLya
    Charlie Root, Mar 6, 2006
    #2
    1. Advertising

  3. rsjimmy

    J.Cottingim Guest

    It's always good practice to implement QoS clear through the network
    path that the video/voice traffic would take. That would include Layer
    2 in your core network even if it's gigabit attached.
    That being said, one thing to remember that QoS only affects traffic on
    an interface when there's contention for the available bandwidth. (ie.
    Your link is)
    Here's some hints...
    * Bandwidth monitoring will not necessarily show the need for QoS as
    it's normally monitored on an average over 5 minutes.
    * If you're using ATM or Frame-Relay, do not oversubscribe the
    physical link. Cisco's QoS works on a per-interface (or sub-interface)
    basis. If you oversubscribe the link, all bets are off with regards to
    QoS.
    * If your using a managed MPLS WAN, you'll need to work with your
    provider.

    ======================================================
    There are probably a thousand different ways to implement QoS. Here's a
    L3 EXAMPLE config for you as requested: (CBWFQ)

    Ploycom<--->LAN<--->router-A <--->WAN<---> router-B<--->LAN<--->Polycom

    Both routers have similar configs so only one is listed here.
    ======================================================
    class-map match-all AUDIO-CLASS
    match access-group name NEW-AUDIO-ACL
    class-map match-all VIDEO-CLASS
    match access-group name NEW-VIDEO-ACL
    !
    policy-map VID-CONF-POLICY
    class AUDIO-CLASS
    priority 96
    class VIDEO-CLASS
    bandwidth 320
    class class-default
    fair-queue
    !
    interface ATM0/0.11 point-to-point
    description PVC to Remote Site
    ip address 10.1.1.10 255.255.255.248
    pvc 1/65
    vbr-rt 768 768
    oam-pvc manage
    service-policy output VID-CONF-POLICY
    !
    interface FastEthernet0/0
    ip address 10.11.1.1 255.255.255.0
    !
    ip access-list extended NEW-AUDIO-ACL
    permit ip host 10.11.1.25 any dscp af41
    ip access-list extended NEW-VIDEO-ACL
    permit ip any host 10.11.1.25 dscp af42
    ======================================================

    Here's the break down:
    The ACL's and class-map's are used to classify the traffic.
    The Policy-map assigns priority and bandwidth according to needs.
    Then tie it all together on the interface the traffic would exit
    from. with the service policy.

    Remember that any QoS config is specific to the individual needs. -
    taking in account for bandwidth needs, WAN speeds, etc. The example
    above does not take in to account anything for routing protocol for
    example.

    J.Cottingim
    J.Cottingim, Mar 6, 2006
    #3
  4. rsjimmy

    rsjimmy Guest

    I wanted to say thanks to all that replied. It has been a good help for
    me to take the next step.

    Thanks again
    rsjimmy, Mar 7, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Melbourne

    IP-IP Gateway for Video Conferencing

    Matthew Melbourne, Oct 15, 2005, in forum: Cisco
    Replies:
    0
    Views:
    476
    Matthew Melbourne
    Oct 15, 2005
  2. PWB

    Web-Camera/Video Conferencing

    PWB, Sep 19, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    474
  3. Replies:
    7
    Views:
    779
    Sir Woogie
    Aug 12, 2006
  4. Replies:
    0
    Views:
    639
  5. Giuen
    Replies:
    0
    Views:
    875
    Giuen
    Sep 12, 2008
Loading...

Share This Page