Session Restore issue with Firefox 2.0

Discussion in 'Firefox' started by Trevor Smithson, Oct 31, 2006.

  1. I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    my computer without first closing Firefox, Session Restore will pop up
    and say that Firefox did not shut down correctly.

    Is there any way to modify Firefox so that a user-initiated system
    shutdown will not trigger Session Restore, even if Firefox is not closed
    beforehand?

    This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.
    Trevor Smithson, Oct 31, 2006
    #1
    1. Advertising

  2. Trevor Smithson wrote:
    > I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    > my computer without first closing Firefox, Session Restore will pop up
    > and say that Firefox did not shut down correctly.
    >
    > Is there any way to modify Firefox so that a user-initiated system
    > shutdown will not trigger Session Restore, even if Firefox is not closed
    > beforehand?
    >
    > This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.


    No, you can either disable session restore entirely, or remember to shut
    down FF properly before closing. You can't have it both ways.

    This is a problem with the extension, rather then with Firefox. Contact
    the creators, and let them know of your problem:

    http://minimizetotray.mozdev.org/

    Lee
    Leonidas Jones, Oct 31, 2006
    #2
    1. Advertising

  3. Trevor Smithson

    Jim S Guest

    On Tue, 31 Oct 2006 23:27:29 GMT, Leonidas Jones wrote:

    > Trevor Smithson wrote:
    >> I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    >> my computer without first closing Firefox, Session Restore will pop up
    >> and say that Firefox did not shut down correctly.
    >>
    >> Is there any way to modify Firefox so that a user-initiated system
    >> shutdown will not trigger Session Restore, even if Firefox is not closed
    >> beforehand?
    >>
    >> This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.

    >
    > No, you can either disable session restore entirely, or remember to shut
    > down FF properly before closing. You can't have it both ways.
    >
    > This is a problem with the extension, rather then with Firefox. Contact
    > the creators, and let them know of your problem:
    >
    > http://minimizetotray.mozdev.org/
    >
    > Lee


    I was not the OP, but tell me how to get rid of Session Restore Purleez!
    --
    Jim S
    Tyneside UK
    http://www.jimscott.co.uk
    Jim S, Nov 1, 2006
    #3
  4. Jim S wrote:
    > On Tue, 31 Oct 2006 23:27:29 GMT, Leonidas Jones wrote:
    >
    >> Trevor Smithson wrote:
    >>> I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    >>> my computer without first closing Firefox, Session Restore will pop up
    >>> and say that Firefox did not shut down correctly.
    >>>
    >>> Is there any way to modify Firefox so that a user-initiated system
    >>> shutdown will not trigger Session Restore, even if Firefox is not closed
    >>> beforehand?
    >>>
    >>> This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.

    >> No, you can either disable session restore entirely, or remember to shut
    >> down FF properly before closing. You can't have it both ways.
    >>
    >> This is a problem with the extension, rather then with Firefox. Contact
    >> the creators, and let them know of your problem:
    >>
    >> http://minimizetotray.mozdev.org/
    >>
    >> Lee

    >
    > I was not the OP, but tell me how to get rid of Session Restore Purleez!


    about:config

    Filter for session

    browser.sessionstore.enabled

    Set the value to false.

    Lee
    Leonidas Jones, Nov 1, 2006
    #4
  5. Trevor Smithson

    Dan Guest

    "Leonidas Jones" <> wrote in message
    news:qgS1h.627$...
    >
    > about:config
    >
    > Filter for session
    >
    > browser.sessionstore.enabled
    >
    > Set the value to false.
    >
    > Lee


    Thought I had this one, but nope.

    browser.sessionstore.enabled = FALSE
    browser.sessionstore.resume_session = FALSE
    browser startup page=1

    Tried every combination, still does it.

    Dan
    Dan, Nov 1, 2006
    #5
  6. Trevor Smithson

    Dan Guest

    "Dan" <> wrote in message
    news:...
    > "Leonidas Jones" <> wrote in message
    > news:qgS1h.627$...
    >>
    >> about:config
    >>
    >> Filter for session
    >>
    >> browser.sessionstore.enabled
    >>
    >> Set the value to false.
    >>
    >> Lee

    >
    > Thought I had this one, but nope.
    >
    > browser.sessionstore.enabled = FALSE
    > browser.sessionstore.resume_session = FALSE
    > browser startup page=1
    >
    > Tried every combination, still does it.
    >
    > Dan


    Tried adding this:

    browser.sessionstore.resume_from_crash=FALSE

    We'll see.
    Dan, Nov 1, 2006
    #6
  7. Trevor Smithson

    Dan Guest

    "Dan" <> wrote in message
    > Tried adding this:
    >
    > browser.sessionstore.resume_from_crash=FALSE
    >
    > We'll see.
    >


    Nope still does it.

    This really is a PITA...

    Dan
    Dan, Nov 1, 2006
    #7
  8. On Wed, 01 Nov 2006 00:55:50 GMT, Leonidas Jones <> wrote: I was
    not the OP, but tell me how to get rid of Session Restore Purleez!
    >
    >about:config
    >
    >Filter for session
    >
    >browser.sessionstore.enabled
    >
    >Set the value to false.
    >
    >Lee



    Well, this one does it for me.
    Thanks, Lee!


    Old enough . . . .
    .... to know I don't really know a thing.
    Old enough . ., Nov 1, 2006
    #8
  9. Old enough . . wrote:
    > On Wed, 01 Nov 2006 00:55:50 GMT, Leonidas Jones <> wrote: I was
    > not the OP, but tell me how to get rid of Session Restore Purleez!
    >> about:config
    >>
    >> Filter for session
    >>
    >> browser.sessionstore.enabled
    >>
    >> Set the value to false.
    >>
    >> Lee

    >
    >
    > Well, this one does it for me.
    > Thanks, Lee!
    >
    >
    > Old enough . . . .
    > ... to know I don't really know a thing.


    I don't know why its working for you and not for Dan.

    Lee
    Leonidas Jones, Nov 1, 2006
    #9
  10. Dan wrote:
    > "Dan" <> wrote in message
    >> Tried adding this:
    >>
    >> browser.sessionstore.resume_from_crash=FALSE
    >>
    >> We'll see.
    >>

    >
    > Nope still does it.
    >
    > This really is a PITA...
    >
    > Dan
    >
    >


    Have you tried in Safe Mode?

    Lee
    Leonidas Jones, Nov 1, 2006
    #10
  11. Thank you for your reply. I'm a bit confused because no other
    application I use exhibits this behavior. I always have apps like
    Google Desktop, 3M Notes, a clipboard tool, etc open when I
    shut down my computer.

    Is it a choice by Firefox's developers to not gracefully handle a
    shutdown, or is it a bug of some sort? Or is the extension causing the
    problem? Meaning, would Firefox shut down properly if I stopped using
    the extension?

    Actually, I think I will go try that now.

    On Tue, 31 Oct 2006 23:27:29 GMT, Leonidas Jones <> wrote:

    >Trevor Smithson wrote:
    >> I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    >> my computer without first closing Firefox, Session Restore will pop up
    >> and say that Firefox did not shut down correctly.
    >>
    >> Is there any way to modify Firefox so that a user-initiated system
    >> shutdown will not trigger Session Restore, even if Firefox is not closed
    >> beforehand?
    >>
    >> This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.

    >
    >No, you can either disable session restore entirely, or remember to shut
    >down FF properly before closing. You can't have it both ways.
    >
    >This is a problem with the extension, rather then with Firefox. Contact
    >the creators, and let them know of your problem:
    >
    >http://minimizetotray.mozdev.org/
    >
    >Lee
    Trevor Smithson, Nov 1, 2006
    #11
  12. Trevor Smithson

    Dan Guest

    "Leonidas Jones" <> wrote in message
    news:%QU1h.1151$...
    > Old enough . . wrote:
    >> On Wed, 01 Nov 2006 00:55:50 GMT, Leonidas Jones <> wrote:
    >> I was
    >> not the OP, but tell me how to get rid of Session Restore Purleez!
    >>> about:config
    >>>
    >>> Filter for session
    >>>
    >>> browser.sessionstore.enabled
    >>>
    >>> Set the value to false.
    >>>
    >>> Lee

    >>
    >>
    >> Well, this one does it for me.
    >> Thanks, Lee!
    >>
    >>
    >> Old enough . . . .
    >> ... to know I don't really know a thing.

    >
    > I don't know why its working for you and not for Dan.
    >
    > Lee


    Might be because I have altered a number of registry entries to speed up
    shut down (WaitToKillAppTimeout, HungAppTimeout & WaitToKillServiceTimeout
    values are all set to 1000). Perhaps FF is misinterpreting this rapid
    shutdown at turn off as a "crash". Still, you'd think changing all the
    settings I have done to "false" would kill it...

    Dan
    Dan, Nov 1, 2006
    #12
  13. Trevor Smithson

    Jim S Guest

    On Wed, 01 Nov 2006 00:55:50 GMT, Leonidas Jones wrote:

    > Jim S wrote:
    >> On Tue, 31 Oct 2006 23:27:29 GMT, Leonidas Jones wrote:
    >>
    >>> Trevor Smithson wrote:
    >>>> I use the MinimizeToTray extension with Firefox 2.0. When I shut down
    >>>> my computer without first closing Firefox, Session Restore will pop up
    >>>> and say that Firefox did not shut down correctly.
    >>>>
    >>>> Is there any way to modify Firefox so that a user-initiated system
    >>>> shutdown will not trigger Session Restore, even if Firefox is not closed
    >>>> beforehand?
    >>>>
    >>>> This is on Windows XP, with version 0.0.1.2006102615+ of MinimizeToTray.
    >>> No, you can either disable session restore entirely, or remember to shut
    >>> down FF properly before closing. You can't have it both ways.
    >>>
    >>> This is a problem with the extension, rather then with Firefox. Contact
    >>> the creators, and let them know of your problem:
    >>>
    >>> http://minimizetotray.mozdev.org/
    >>>
    >>> Lee

    >>
    >> I was not the OP, but tell me how to get rid of Session Restore Purleez!

    >
    > about:config
    >
    > Filter for session
    >
    > browser.sessionstore.enabled
    >
    > Set the value to false.
    >
    > Lee


    Ah
    Now
    I have not got that one!
    However I have got several which refer to 'tabmix' which apparently did not
    go away when I unimstalled 'tabmix' extension.
    AND i have one which says browser.sessionstore.resume_session_once but that
    is already set to 'false'.
    --
    Jim S
    Tyneside UK
    http://www.jimscott.co.uk
    Jim S, Nov 1, 2006
    #13
  14. Trevor Smithson

    Dan Guest

    Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    from oldversion.com & I'm going to go back to that until when/if they sort
    this out with 2.0.

    BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    they release 1.5.0.8 when they
    just released 2.0???

    Dan
    Dan, Nov 3, 2006
    #14
  15. Dan wrote:
    > Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    > from oldversion.com & I'm going to go back to that until when/if they sort
    > this out with 2.0.
    >
    > BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    > they release 1.5.0.8 when they
    > just released 2.0???
    >
    > Dan
    >
    >


    Mozilla maintains the previous version with security updates for about 6
    months after the new release.

    Also, 1.5.0.8 is supposed to have a new updater which will allow the
    major upgrade to a new version release.

    Lee
    Leonidas Jones, Nov 3, 2006
    #15
  16. Trevor Smithson

    Dan Guest

    "Leonidas Jones" <> wrote in message
    news:WJx2h.175201$...
    > Dan wrote:
    >> Well, I can't get my installation to stop this annoyance. I've dl'd
    >> 1.5.0.7 from oldversion.com & I'm going to go back to that until when/if
    >> they sort this out with 2.0.
    >>
    >> BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    >> they release 1.5.0.8 when they
    >> just released 2.0???
    >>
    >> Dan

    >
    > Mozilla maintains the previous version with security updates for about 6
    > months after the new release.
    >
    > Also, 1.5.0.8 is supposed to have a new updater which will allow the major
    > upgrade to a new version release.
    >
    > Lee


    Thanks for the reply!

    Dan
    Dan, Nov 3, 2006
    #16
  17. On 11/02/2006 06:16 PM, Dan wrote:
    > Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    > from oldversion.com & I'm going to go back to that until when/if they sort
    > this out with 2.0.
    >


    Disabling Session Saving in FX 2.0:
    http://kb.mozillazine.org/Browser.sessionstore.enabled


    > BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    > they release 1.5.0.8 when they
    > just released 2.0???
    >
    > Dan
    >
    >


    FX 1.5.0.8 will be a security update. Mozilla.org will continue to
    provide security updates for FX 1.5 for another six months; some people
    (the smart ones ;-) ) don't want to upgrade just because something new
    is available.


    --
    Mumia W. (reading news), Nov 3, 2006
    #17
  18. Trevor Smithson

    Jim S Guest

    On Fri, 03 Nov 2006 02:22:46 GMT, Leonidas Jones wrote:

    > Dan wrote:
    >> Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    >> from oldversion.com & I'm going to go back to that until when/if they sort
    >> this out with 2.0.
    >>
    >> BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    >> they release 1.5.0.8 when they
    >> just released 2.0???
    >>
    >> Dan
    >>

    >
    > Mozilla maintains the previous version with security updates for about 6
    > months after the new release.
    >
    > Also, 1.5.0.8 is supposed to have a new updater which will allow the
    > major upgrade to a new version release.
    >
    > Lee


    Hi Lee
    Going back up the thread a couple of steps.
    How do I get rid of the tabmix references?
    --
    Jim S
    Tyneside UK
    http://www.jimscott.co.uk
    Jim S, Nov 3, 2006
    #18
  19. Jim S wrote:
    > On Fri, 03 Nov 2006 02:22:46 GMT, Leonidas Jones wrote:
    >
    >> Dan wrote:
    >>> Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    >>> from oldversion.com & I'm going to go back to that until when/if they sort
    >>> this out with 2.0.
    >>>
    >>> BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    >>> they release 1.5.0.8 when they
    >>> just released 2.0???
    >>>
    >>> Dan
    >>>

    >> Mozilla maintains the previous version with security updates for about 6
    >> months after the new release.
    >>
    >> Also, 1.5.0.8 is supposed to have a new updater which will allow the
    >> major upgrade to a new version release.
    >>
    >> Lee

    >
    > Hi Lee
    > Going back up the thread a couple of steps.
    > How do I get rid of the tabmix references?


    Actually I would go back a little further. You don't have:

    browser.sessionstore.enabled

    That's a little odd. Please check again and confirm.

    Lee
    Leonidas Jones, Nov 3, 2006
    #19
  20. Trevor Smithson

    Jim S Guest

    On Fri, 03 Nov 2006 17:16:12 GMT, Leonidas Jones wrote:

    > Jim S wrote:
    >> On Fri, 03 Nov 2006 02:22:46 GMT, Leonidas Jones wrote:
    >>
    >>> Dan wrote:
    >>>> Well, I can't get my installation to stop this annoyance. I've dl'd 1.5.0.7
    >>>> from oldversion.com & I'm going to go back to that until when/if they sort
    >>>> this out with 2.0.
    >>>>
    >>>> BTW saw the posts about 1.5.0.8. I must be missing something. Why would
    >>>> they release 1.5.0.8 when they
    >>>> just released 2.0???
    >>>>
    >>>> Dan
    >>>>
    >>> Mozilla maintains the previous version with security updates for about 6
    >>> months after the new release.
    >>>
    >>> Also, 1.5.0.8 is supposed to have a new updater which will allow the
    >>> major upgrade to a new version release.
    >>>
    >>> Lee

    >>
    >> Hi Lee
    >> Going back up the thread a couple of steps.
    >> How do I get rid of the tabmix references?

    >
    > Actually I would go back a little further. You don't have:
    >
    > browser.sessionstore.enabled
    >
    > That's a little odd. Please check again and confirm.
    >
    > Lee


    Confirmed.
    It is as I said.
    --
    Jim S
    Tyneside UK
    http://www.jimscott.co.uk
    Jim S, Nov 3, 2006
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    703
    David Harrison
    Feb 4, 2005
  2. Cueball
    Replies:
    7
    Views:
    3,457
    Leonidas Jones
    Mar 25, 2005
  3. kalim
    Replies:
    0
    Views:
    1,079
    kalim
    Jul 12, 2007
  4. Dan C
    Replies:
    5
    Views:
    551
    Dan C
    Nov 8, 2007
  5. yogi22

    FF3 Session Restore

    yogi22, Jun 18, 2008, in forum: Firefox
    Replies:
    1
    Views:
    424
    yogi22
    Jun 18, 2008
Loading...

Share This Page