Select Specific MAC Address

Discussion in 'Wireless Networking' started by Skier7667, Aug 5, 2007.

  1. Skier7667

    Skier7667 Guest

    Hi
    I have a Netgear wireless adaptor connected to my PC via USB and it is
    functioning properly.

    I have Windows XP and problem that I'm faced with is that I have two MAC
    addresses being picked up by my wireless adaptor. One signal is stronger
    than
    the other and it always defaults to the stronger signal for obvious reasons.
    How can I force Windows or configure it to "lock in" to the weaker incoming
    MAC address. The driver for the wireless adaptor does show both and even if
    i
    select the weaker signal MAC address, it ill select the stronger one. So
    forcing Windows to select the MAC address that I want would be desired.

    How can I do that? I didn't see anywhere for example in TCP/IP Properties to
    force it. I can see my MAC physical address and you can select IP addresses,
    Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    the
    "incoming" MAC address.

    Please help!

    Thanks
    Skier7667, Aug 5, 2007
    #1
    1. Advertising

  2. Skier7667

    Barb Bowman Guest

    I can't tell what you mean by mac addresses. do you mean SSID's? do
    they both have the same name? do you have a router? change YOUR SSID
    to something other than the default. turn on security, WPA2 if
    possible, otherwise WPA.

    If this does not answer your question, what exactly do you mean by
    incoming MAC address? example?

    On Sun, 5 Aug 2007 11:18:35 -0400, "Skier7667" <>
    wrote:

    >Hi
    >I have a Netgear wireless adaptor connected to my PC via USB and it is
    >functioning properly.
    >
    >I have Windows XP and problem that I'm faced with is that I have two MAC
    >addresses being picked up by my wireless adaptor. One signal is stronger
    >than
    >the other and it always defaults to the stronger signal for obvious reasons.
    >How can I force Windows or configure it to "lock in" to the weaker incoming
    >MAC address. The driver for the wireless adaptor does show both and even if
    >i
    >select the weaker signal MAC address, it ill select the stronger one. So
    >forcing Windows to select the MAC address that I want would be desired.
    >
    >How can I do that? I didn't see anywhere for example in TCP/IP Properties to
    >force it. I can see my MAC physical address and you can select IP addresses,
    >Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    >the
    >"incoming" MAC address.
    >
    >Please help!
    >
    >Thanks
    >

    --

    Barb Bowman
    MS Windows-MVP
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
    Barb Bowman, Aug 5, 2007
    #2
    1. Advertising

  3. Skier7667 wrote:
    > Hi
    > I have a Netgear wireless adaptor connected to my PC via USB and it is
    > functioning properly.
    >
    > I have Windows XP and problem that I'm faced with is that I have two MAC
    > addresses being picked up by my wireless adaptor. One signal is stronger
    > than
    > the other and it always defaults to the stronger signal for obvious reasons.
    > How can I force Windows or configure it to "lock in" to the weaker incoming
    > MAC address. The driver for the wireless adaptor does show both and even if
    > i
    > select the weaker signal MAC address, it ill select the stronger one. So
    > forcing Windows to select the MAC address that I want would be desired.
    >
    > How can I do that? I didn't see anywhere for example in TCP/IP Properties to
    > force it. I can see my MAC physical address and you can select IP addresses,
    > Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    > the
    > "incoming" MAC address.
    >
    > Please help!
    >
    > Thanks
    >
    >


    I don't have a wireless machine in front of me at the moment, so I'm
    hazy about exact names and settings, but if you look for "Advanced
    Settings" in the dialogue where you select a particular connection,
    you'll see "profiles" or "preferred networks". Delete the one you don't
    want, and look for options to connect only to preferred networks. That
    should fix it.

    Phil, London
    Philip Herlihy, Aug 5, 2007
    #3
  4. Skier7667 wrote:
    > Hi
    > I have a Netgear wireless adaptor connected to my PC via USB and it is
    > functioning properly.
    >
    > I have Windows XP and problem that I'm faced with is that I have two MAC
    > addresses being picked up by my wireless adaptor. One signal is stronger
    > than
    > the other and it always defaults to the stronger signal for obvious reasons.
    > How can I force Windows or configure it to "lock in" to the weaker incoming
    > MAC address. The driver for the wireless adaptor does show both and even if
    > i
    > select the weaker signal MAC address, it ill select the stronger one. So
    > forcing Windows to select the MAC address that I want would be desired.
    >
    > How can I do that? I didn't see anywhere for example in TCP/IP Properties to
    > force it. I can see my MAC physical address and you can select IP addresses,
    > Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    > the
    > "incoming" MAC address.
    >
    > Please help!
    >
    > Thanks
    >
    >


    In my previous post I was assuming you're using the Windows built-in
    client software (Windows Zero Configuration thingy). The principle is
    the same for any client, so if you're using the Netgear one, it'll be
    along the same lines.

    By the way, you might like to make sure the two networks are on
    different channels. It's difficult (impossible?) to tell via the
    Windows client, but you could download NetStumber (free) which will tell
    you.

    Phil
    Philip Herlihy, Aug 5, 2007
    #4
  5. Hi
    Clean up the preferred Networks list in the Wireless manger (WZC), and leave
    there only the Wireless Network that you want to connect to.
    Uncheck the Automatically connect to none-preferred networks (in the advance
    menu to the right).
    Looks like this, http://www.ezlan.net/wireless/wzc3.jpg
    Jack (MVP-Networking).

    "Skier7667" <> wrote in message
    news:...
    > Hi
    > I have a Netgear wireless adaptor connected to my PC via USB and it is
    > functioning properly.
    >
    > I have Windows XP and problem that I'm faced with is that I have two MAC
    > addresses being picked up by my wireless adaptor. One signal is stronger
    > than
    > the other and it always defaults to the stronger signal for obvious
    > reasons.
    > How can I force Windows or configure it to "lock in" to the weaker
    > incoming
    > MAC address. The driver for the wireless adaptor does show both and even
    > if i
    > select the weaker signal MAC address, it ill select the stronger one. So
    > forcing Windows to select the MAC address that I want would be desired.
    >
    > How can I do that? I didn't see anywhere for example in TCP/IP Properties
    > to
    > force it. I can see my MAC physical address and you can select IP
    > addresses,
    > Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    > the
    > "incoming" MAC address.
    >
    > Please help!
    >
    > Thanks
    >
    >
    Jack \(MVP-Networking\)., Aug 5, 2007
    #5
  6. Skier7667

    Pavel A. Guest

    Hi,
    The behavior you're seing is called roaming.
    The concept is that several Access Points can have same network name (a.k.a. ESSID or SSID ), so the wireless card can
    automatically switch to one that has the best signal.
    This setup assumes that all APs that share same SSID are connected to same backbone network -
    any one of them provides exactly same network connectivity to the client.

    By default, most wireless drivers assume this type of setup.

    It seems that this is not the case for you: your two APs have same SSID name but do not sit on same backbone (otherwise you
    would not want to distinguish them).

    Solution: give different SSID names to APs/routers that are not related.

    Regards,
    --PA


    "Skier7667" <> wrote in message news:...
    > Hi
    > I have a Netgear wireless adaptor connected to my PC via USB and it is
    > functioning properly.
    >
    > I have Windows XP and problem that I'm faced with is that I have two MAC
    > addresses being picked up by my wireless adaptor. One signal is stronger than
    > the other and it always defaults to the stronger signal for obvious reasons.
    > How can I force Windows or configure it to "lock in" to the weaker incoming
    > MAC address. The driver for the wireless adaptor does show both and even if i
    > select the weaker signal MAC address, it ill select the stronger one. So
    > forcing Windows to select the MAC address that I want would be desired.
    >
    > How can I do that? I didn't see anywhere for example in TCP/IP Properties to
    > force it. I can see my MAC physical address and you can select IP addresses,
    > Default gateway, DNS server, Subnet Mask setting, etc., but nothing about the
    > "incoming" MAC address.
    >
    > Please help!
    >
    > Thanks
    >
    >
    Pavel A., Aug 6, 2007
    #6
  7. Skier7667

    Skier7667 Guest

    Sorry I haven't gotten back, I've read all your responses. Let me explain a
    little more.

    My wireless adaptor is a Netgear adaptor and when you install the software
    for the drivers, it also installs its Configuration Manager. It by default
    will disable the Windows one. When this Config manager loads it shows me the
    available networks and their signal strengths. There are two with the name
    or SSID - Netgear and each has a reported MAC address which is of course
    different. Even when I select the one I desire, which happens to have a
    weaker signal, it will still connect me to the one with the stronger signal.
    I've tried even using the keyboard hoping that it would respond quicker than
    moving the mouse to select, apply, etc., but every time it will connect to
    the stronger signal which I do not want.

    That is why I'm asking, if I can force my PC to lock onto a specific MAC
    address. If I was able to do this, than it would not matter that the SSID
    are the same. A few times when the signal strengths are close to each other,
    it has connected to the weaker signal, but the minute there is a slight
    variation, it will lock back to the stronger one and I lose my connection.

    It was recommended that I change the SSID, but that has to be done at the
    router level - Am I correct?

    When I disable the Netgear Config Manager and let Windows manage my wireless
    connections, it seems that Windows sees the two, but only reports the one
    with the stronger signal, so I can't locate the weaker signal one to select
    it. I've tried using IPCONFIG/RELEASE and IPCONFIG/RENEW, but this has made
    no difference.

    Is there something I can tweak in the registry that would allow me to bypass
    this MAC address selection manually. I guess Windows is trying to be "dummy
    proof" and has a mind of its own in trying to help me connect to the
    stronger signal, which would normally be the objective. Hope this helps
    clarify what I was saying in my original comment on this thread. Any ideas
    or suggestions?





    "Pavel A." <> wrote in message
    news:uhmz%...
    > Hi,
    > The behavior you're seing is called roaming.
    > The concept is that several Access Points can have same network name
    > (a.k.a. ESSID or SSID ), so the wireless card can automatically switch to
    > one that has the best signal.
    > This setup assumes that all APs that share same SSID are connected to same
    > backbone network -
    > any one of them provides exactly same network connectivity to the client.
    >
    > By default, most wireless drivers assume this type of setup.
    >
    > It seems that this is not the case for you: your two APs have same SSID
    > name but do not sit on same backbone (otherwise you would not want to
    > distinguish them).
    >
    > Solution: give different SSID names to APs/routers that are not related.
    >
    > Regards,
    > --PA
    >
    >
    > "Skier7667" <> wrote in message
    > news:...
    >> Hi
    >> I have a Netgear wireless adaptor connected to my PC via USB and it is
    >> functioning properly.
    >>
    >> I have Windows XP and problem that I'm faced with is that I have two MAC
    >> addresses being picked up by my wireless adaptor. One signal is stronger
    >> than
    >> the other and it always defaults to the stronger signal for obvious
    >> reasons.
    >> How can I force Windows or configure it to "lock in" to the weaker
    >> incoming
    >> MAC address. The driver for the wireless adaptor does show both and even
    >> if i
    >> select the weaker signal MAC address, it ill select the stronger one. So
    >> forcing Windows to select the MAC address that I want would be desired.
    >>
    >> How can I do that? I didn't see anywhere for example in TCP/IP Properties
    >> to
    >> force it. I can see my MAC physical address and you can select IP
    >> addresses,
    >> Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    >> the
    >> "incoming" MAC address.
    >>
    >> Please help!
    >>
    >> Thanks
    >>
    >>

    >
    >
    Skier7667, Aug 11, 2007
    #7
  8. Skier7667

    Barb Bowman Guest

    You REALLY need to login to the router and change the name from the
    default name of Netgear. That is the solution you want to use.

    On Sat, 11 Aug 2007 14:01:20 -0400, "Skier7667" <>
    wrote:

    >That is why I'm asking, if I can force my PC to lock onto a specific MAC
    >address. If I was able to do this, than it would not matter that the SSID
    >are the same. A few times when the signal strengths are close to each other,
    >it has connected to the weaker signal, but the minute there is a slight
    >variation, it will lock back to the stronger one and I lose my connection.
    >
    >It was recommended that I change the SSID, but that has to be done at the
    >router level - Am I correct?

    --

    Barb Bowman
    MS Windows-MVP
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
    Barb Bowman, Aug 11, 2007
    #8
  9. Skier7667

    Chuck [MVP] Guest

    On Sat, 11 Aug 2007 14:01:20 -0400, "Skier7667" <> wrote:

    >"Pavel A." <> wrote in message
    >news:uhmz%...


    >> "Skier7667" <> wrote in message
    >> news:...
    >>> Hi
    >>> I have a Netgear wireless adaptor connected to my PC via USB and it is
    >>> functioning properly.
    >>>
    >>> I have Windows XP and problem that I'm faced with is that I have two MAC
    >>> addresses being picked up by my wireless adaptor. One signal is stronger
    >>> than
    >>> the other and it always defaults to the stronger signal for obvious
    >>> reasons.
    >>> How can I force Windows or configure it to "lock in" to the weaker
    >>> incoming
    >>> MAC address. The driver for the wireless adaptor does show both and even
    >>> if i
    >>> select the weaker signal MAC address, it ill select the stronger one. So
    >>> forcing Windows to select the MAC address that I want would be desired.
    >>>
    >>> How can I do that? I didn't see anywhere for example in TCP/IP Properties
    >>> to
    >>> force it. I can see my MAC physical address and you can select IP
    >>> addresses,
    >>> Default gateway, DNS server, Subnet Mask setting, etc., but nothing about
    >>> the
    >>> "incoming" MAC address.
    >>>
    >>> Please help!
    >>>
    >>> Thanks


    >> Hi,
    >> The behavior you're seing is called roaming.
    >> The concept is that several Access Points can have same network name
    >> (a.k.a. ESSID or SSID ), so the wireless card can automatically switch to
    >> one that has the best signal.
    >> This setup assumes that all APs that share same SSID are connected to same
    >> backbone network -
    >> any one of them provides exactly same network connectivity to the client.
    >>
    >> By default, most wireless drivers assume this type of setup.
    >>
    >> It seems that this is not the case for you: your two APs have same SSID
    >> name but do not sit on same backbone (otherwise you would not want to
    >> distinguish them).
    >>
    >> Solution: give different SSID names to APs/routers that are not related.


    >Sorry I haven't gotten back, I've read all your responses. Let me explain a
    >little more.
    >
    >My wireless adaptor is a Netgear adaptor and when you install the software
    >for the drivers, it also installs its Configuration Manager. It by default
    >will disable the Windows one. When this Config manager loads it shows me the
    >available networks and their signal strengths. There are two with the name
    >or SSID - Netgear and each has a reported MAC address which is of course
    >different. Even when I select the one I desire, which happens to have a
    >weaker signal, it will still connect me to the one with the stronger signal.
    >I've tried even using the keyboard hoping that it would respond quicker than
    >moving the mouse to select, apply, etc., but every time it will connect to
    >the stronger signal which I do not want.
    >
    >That is why I'm asking, if I can force my PC to lock onto a specific MAC
    >address. If I was able to do this, than it would not matter that the SSID
    >are the same. A few times when the signal strengths are close to each other,
    >it has connected to the weaker signal, but the minute there is a slight
    >variation, it will lock back to the stronger one and I lose my connection.
    >
    >It was recommended that I change the SSID, but that has to be done at the
    >router level - Am I correct?
    >
    >When I disable the Netgear Config Manager and let Windows manage my wireless
    >connections, it seems that Windows sees the two, but only reports the one
    >with the stronger signal, so I can't locate the weaker signal one to select
    >it. I've tried using IPCONFIG/RELEASE and IPCONFIG/RENEW, but this has made
    >no difference.
    >
    >Is there something I can tweak in the registry that would allow me to bypass
    >this MAC address selection manually. I guess Windows is trying to be "dummy
    >proof" and has a mind of its own in trying to help me connect to the
    >stronger signal, which would normally be the objective. Hope this helps
    >clarify what I was saying in my original comment on this thread. Any ideas
    >or suggestions?


    The SSID will have to be changed at the router. Hoping that the "Netgear"
    router, with weaker signal, is yours, just change the SSID.

    Of course, one should ask why the signal from your router is so weak?
    <http://nitecruzr.blogspot.com/2005/10/wifi-will-never-be-as-fast-as-ethernet.html>
    http://nitecruzr.blogspot.com/2005/10/wifi-will-never-be-as-fast-as-ethernet.html

    Or is it not your router?

    --
    Cheers,
    Chuck, MS-MVP 2005-2007 [Windows - Networking]
    http://nitecruzr.blogspot.com/
    Paranoia is not a problem, when it's a normal response from experience.
    My email is AT DOT
    actual address pchuck mvps org.
    Chuck [MVP], Aug 11, 2007
    #9
  10. Skier7667

    Pavel A. Guest

    "Skier7667" <> wrote in message news:...
    ....
    > Is there something I can tweak in the registry that would allow me to bypass this MAC address selection manually.


    Yes, some wireless drivers and their management software allow
    this option (like "mandatory AP" in PROset ).
    But this really depends on the driver, and your's does not seem to allow this.
    So the common working
    solution is that you change the SSID of your AP.

    >I guess Windows is trying to be "dummy proof" and has a mind of its own in trying to help me connect to the stronger signal,
    >which would normally be the objective.


    Yep, this is what it tries to do.

    Regards,
    --PA
    Pavel A., Aug 12, 2007
    #10
  11. Skier7667

    Jimbo Daggit Guest

    I have a similar problem.

    At the university where I attend there are two wireless access points on one of the floors of the building I have all my classes in. half of my classes are on one side of the building where I am able to get internet just fine the other half of my classes are on the other half where the access point will not allow me to connect. I have notified the Network admins of the problem however until they get it fixed I am unable to connect to the internet in half my classes.

    I know that in vista you can select a specific MAC address to connect to however I haven't found that functionality yet in XP if it exists.

    If anyone knows how to specify which MAC address a computer will connect to with both access points sharing the same SSID I would appreciate this knowledge so I can have a temporary fix until a more permanent one can be found.

    Thanks

    Jim
    Jimbo Daggit, Oct 7, 2008
    #11
  12. Hi
    Disable temporarily the Windows Wireless Utility (WZC) and try the original
    Utility that came with the Wireless Card.
    Some manufactures utilities would have such feature. may be you would be
    lucky.
    Jack (MS, MVP-Networking)

    "Jimbo Daggit" wrote in message
    news:...
    >I have a similar problem.
    >
    > At the university where I attend there are two wireless access points on
    > one of the floors of the building I have all my classes in. half of my
    > classes are on one side of the building where I am able to get internet
    > just fine the other half of my classes are on the other half where the
    > access point will not allow me to connect. I have notified the Network
    > admins of the problem however until they get it fixed I am unable to
    > connect to the internet in half my classes.
    >
    > I know that in vista you can select a specific MAC address to connect to
    > however I haven't found that functionality yet in XP if it exists.
    >
    > If anyone knows how to specify which MAC address a computer will connect
    > to with both access points sharing the same SSID I would appreciate this
    > knowledge so I can have a temporary fix until a more permanent one can be
    > found.
    >
    > Thanks
    >
    > Jim
    Jack \(MVP-Networking\)., Oct 7, 2008
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ProgDario
    Replies:
    17
    Views:
    3,609
    ProgDario
    May 6, 2005
  2. mimiseh
    Replies:
    3
    Views:
    842
  3. Albie
    Replies:
    1
    Views:
    469
    Walter Roberson
    Nov 15, 2005
  4. Julian Dragut

    PIX Firewall MAC address VPN IP address

    Julian Dragut, Feb 7, 2006, in forum: Cisco
    Replies:
    1
    Views:
    790
    Walter Roberson
    Feb 7, 2006
  5. ttripp
    Replies:
    5
    Views:
    2,196
    Thrill5
    Feb 5, 2010
Loading...

Share This Page