Security Update for Microsoft .Net Framework

Discussion in 'Computer Support' started by Geoff, Sep 11, 2007.

  1. Geoff

    Geoff Guest

    Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    (KB928366)
    Win XP Home edition on Advent Laptop

    Despite various attempts, I have been unable to install the above Security
    Update. The answers given by Googling don't work for one reason or
    another. According to the "Add Remove Program" list, I have the following
    installed:
    Microsoft .Net Framework 1.1
    Microsoft .Net Framework 2.0
    Security Update for 2.0 (928365)

    1. Do I need Vers 1.1 still or can I remove it.

    2. I have decided to give up on the KB928366, but how do I stop Update from
    reminding me that it has not been installed. I have got Auto Update set to
    "Notify me but don't download" At the moment, I just untick the box next to
    928366, but I would like to be able to ignore it permanently.

    Any help please?

    Geoff
     
    Geoff, Sep 11, 2007
    #1
    1. Advertising

  2. Geoff

    why? Guest

    On Tue, 11 Sep 2007 11:38:49 +0100, Geoff wrote:

    >Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    >(KB928366)


    <snip>
    >Despite various attempts, I have been unable to install the above Security
    >Update. The answers given by Googling don't work for one reason or


    <snip>
    >Microsoft .Net Framework 1.1
    >Microsoft .Net Framework 2.0
    >Security Update for 2.0 (928365)
    >
    >1. Do I need Vers 1.1 still or can I remove it.


    If you have installed something that needs 1.1 you can't uninstall it.

    >2. I have decided to give up on the KB928366, but how do I stop Update from
    >reminding me that it has not been installed. I have got Auto Update set to
    >"Notify me but don't download" At the moment, I just untick the box next to
    >928366, but I would like to be able to ignore it permanently.


    Wait for the 1000' s of other posts in MS newsgroups, other newsgroups
    and forums asking the same question. It happens with many patch
    releases.

    >Any help please?
    >
    >Geoff
    >


    Me
     
    why?, Sep 11, 2007
    #2
    1. Advertising

  3. Geoff

    Bob B Guest

    "Geoff" <> wrote in message
    news:...
    > Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    > (KB928366)
    > Win XP Home edition on Advent Laptop
    >
    > Despite various attempts, I have been unable to install the above Security
    > Update. The answers given by Googling don't work for one reason or
    > another. According to the "Add Remove Program" list, I have the following
    > installed:
    > Microsoft .Net Framework 1.1
    > Microsoft .Net Framework 2.0
    > Security Update for 2.0 (928365)
    >
    > 1. Do I need Vers 1.1 still or can I remove it.
    >
    > 2. I have decided to give up on the KB928366, but how do I stop Update
    > from reminding me that it has not been installed. I have got Auto Update
    > set to "Notify me but don't download" At the moment, I just untick the
    > box next to 928366, but I would like to be able to ignore it permanently.
    >
    > Any help please?
    >
    > Geoff


    I remember this solved the problem a while back.. all I had to do was remove
    the net Framework form my computer and instal the update

    Anyway here it is in full

    Here is EXACTLY what you do to solve this problem for Windows XP 32
    bit. If you happen to have a rarer 64 bit version, server OS, or
    SOMETHING else follow the same general instructions but get the
    version of the files appropriate for your system but first, Microsoft
    has pissed me off beyond belief. I looked in my log and this same
    thing happened 6/2006...thanks MSFT for torturing us again this year.
    I thought it was a familiar feeling...nice branding...this is a huge
    humiliation for their .NET team in my opinion or perhaps we should
    start calling them the .NOT team...anyway....

    Steps:
    1) Go to the control panel and select the add/remove software tool
    then TRY and remove everything with .NET in the name. If you can
    remove everything go to step 3. If you cannot remove everything go to
    step 2.

    2) Go and download the windows installer clean up tool at:
    http://support.microsoft.com/kb/290301

    run the windows installer clean up tool and BE CAREFUL to only select
    the .NET items from the list and remove them. Note: this will likely
    leave the names as "dead links" in the Add/Remove Software list
    (ahhh ...Microsoft thoroughness at its best) but not to worry they
    will do no harm and will get fixed when we finish. It's possible to
    clean them up but let's stay out of the registry :)

    3) Go and get the file "dotnetfx.exe" this is ".NET 1.1" from:

    http://www.microsoft.com/downloads/...E3-F589-4842-8157-034D1E7CF3A3&displaylang=en

    install it.

    4) Go and get the file "NDP1.1sp1-KB867460-X86.exe" this is the ".NET
    1.1 service pack 1" from: my personal website (JUST KIDDING,
    RELAX...get everything of course from a microsoft.com domain)

    http://www.microsoft.com/downloads/...4F-088E-40B2-BBDB-A83353618B38&displaylang=en

    install it.

    5) Install the SECURITY patch, the dreaded KB928366, we have all grown
    to hate. You can install it from the Windows Update program (be sure
    to ONLY select the KB928366 patch and NOTHING else, we dont want to
    put back 2.0 or 3.0 yet). It's OK go ahead and click ...it will be
    alright...you can do it...it's just one more time... :)

    6) Re-run the Windows Update and you can add back in .NET 2.0 and 3.0



    >
    >
     
    Bob B, Sep 11, 2007
    #3
  4. Geoff

    RobV Guest

    Geoff wrote:
    > Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    > (KB928366)
    > Win XP Home edition on Advent Laptop
    >
    > Despite various attempts, I have been unable to install the above
    > Security Update. The answers given by Googling don't work for one
    > reason or another. According to the "Add Remove Program" list, I have
    > the following installed:
    > Microsoft .Net Framework 1.1
    > Microsoft .Net Framework 2.0
    > Security Update for 2.0 (928365)
    >
    > 1. Do I need Vers 1.1 still or can I remove it.
    >
    > 2. I have decided to give up on the KB928366, but how do I stop
    > Update from reminding me that it has not been installed. I have got
    > Auto Update set to "Notify me but don't download" At the moment, I
    > just untick the box next to 928366, but I would like to be able to
    > ignore it permanently.
    > Any help please?
    >
    > Geoff


    It won't update because you have a later hotfix installed, blocking the
    installation of the SP. When it doesn't install, there should be a link
    to tell you which hotfix is causing the problem. If you have that
    hotfix installed, just uninstall it, update with the SP, then reinstall
    the hotfix.

    I had the same thing happen, but the supposed hotfix wasn't installed on
    my system. I had to uninstall .Net Framework (all of them), then
    reinstall one at a time in the proper numeric order.
     
    RobV, Sep 11, 2007
    #4
  5. Geoff

    RobV Guest

    RobV wrote:
    > Geoff wrote:
    >> Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    >> (KB928366)
    >> Win XP Home edition on Advent Laptop
    >>
    >> Despite various attempts, I have been unable to install the above
    >> Security Update. The answers given by Googling don't work for one
    >> reason or another. According to the "Add Remove Program" list, I have
    >> the following installed:
    >> Microsoft .Net Framework 1.1
    >> Microsoft .Net Framework 2.0
    >> Security Update for 2.0 (928365)
    >>
    >> 1. Do I need Vers 1.1 still or can I remove it.
    >>
    >> 2. I have decided to give up on the KB928366, but how do I stop
    >> Update from reminding me that it has not been installed. I have got
    >> Auto Update set to "Notify me but don't download" At the moment, I
    >> just untick the box next to 928366, but I would like to be able to
    >> ignore it permanently.
    >> Any help please?
    >>
    >> Geoff

    >
    > It won't update because you have a later hotfix installed, blocking
    > the installation of the SP. When it doesn't install, there should be
    > a link to tell you which hotfix is causing the problem. If you have
    > that hotfix installed, just uninstall it, update with the SP, then
    > reinstall the hotfix.
    >
    > I had the same thing happen, but the supposed hotfix wasn't installed
    > on my system. I had to uninstall .Net Framework (all of them), then
    > reinstall one at a time in the proper numeric order.


    I posted this before seeing Bob B's post. Excellent instructions, Bob.
    I had forgotten about the Windows installer cleanup tool when I was
    wrestling with this problem myself.

    Good job!
     
    RobV, Sep 11, 2007
    #5
  6. Geoff

    Mr. Arnold Guest

    "Geoff" <> wrote in message
    news:...
    > Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    > (KB928366)
    > Win XP Home edition on Advent Laptop
    >
    > Despite various attempts, I have been unable to install the above Security
    > Update. The answers given by Googling don't work for one reason or
    > another. According to the "Add Remove Program" list, I have the following
    > installed:
    > Microsoft .Net Framework 1.1
    > Microsoft .Net Framework 2.0
    > Security Update for 2.0 (928365)
    >
    > 1. Do I need Vers 1.1 still or can I remove it.
    >
    > 2. I have decided to give up on the KB928366, but how do I stop Update
    > from reminding me that it has not been installed. I have got Auto Update
    > set to "Notify me but don't download" At the moment, I just untick the
    > box next to 928366, but I would like to be able to ignore it permanently.
    >
    > Any help please?



    If a .Net application that uses .Net framework 1.1 is installed on your
    computer, it's going to call for .Net Framework 1.1. That's any application
    that was developed using .Net 2003, and those programs are out there on Web
    sites using .Net 2003 or it could be a Windows desktop application as well.

    ..Net 2.0 Framework and .Net Framework 3.0 are for applications developed
    using .Net 2005, which is the latest and greatest. Applications Web or
    Windows desktop developed using .Net 2005 will be looking for those .Met
    Frameworks.

    You may or may not needed any of it at this time, but I suspect that's not
    going to be the case on the MS Windows platforms for home usage, as .NET
    application development is sweeping through the corporate world at this
    time.
     
    Mr. Arnold, Sep 12, 2007
    #6
  7. Geoff

    Geoff Guest

    "Geoff" <> wrote in message
    news:...
    > Security Update for Microsoft .Net Framework Version 1.1 Service Pack
    > (KB928366)
    > Win XP Home edition on Advent Laptop
    >
    > Despite various attempts, I have been unable to install the above Security
    > Update. The answers given by Googling don't work for one reason or
    > another. According to the "Add Remove Program" list, I have the following
    > installed:
    > Microsoft .Net Framework 1.1
    > Microsoft .Net Framework 2.0
    > Security Update for 2.0 (928365)
    >
    > 1. Do I need Vers 1.1 still or can I remove it.
    >
    > 2. I have decided to give up on the KB928366, but how do I stop Update
    > from reminding me that it has not been installed. I have got Auto Update
    > set to "Notify me but don't download" At the moment, I just untick the
    > box next to 928366, but I would like to be able to ignore it permanently.
    >
    > Any help please?
    >
    > Geoff
    >

    Thanks for all the help guys. I'll see what happens.

    Geoff
     
    Geoff, Sep 12, 2007
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?c2VyZ2UgY2FsZGVyYXJh?=

    Help : Security in .net framework

    =?Utf-8?B?c2VyZ2UgY2FsZGVyYXJh?=, Mar 30, 2005, in forum: MCSD
    Replies:
    1
    Views:
    390
    Guest
    Apr 1, 2005
  2. John Yung
    Replies:
    6
    Views:
    1,608
    John Yung
    Dec 30, 2005
  3. Giuen
    Replies:
    0
    Views:
    1,462
    Giuen
    Sep 12, 2008
  4. Dutchman

    update problem Net framework

    Dutchman, May 25, 2009, in forum: Computer Support
    Replies:
    2
    Views:
    521
    chuckcar
    May 25, 2009
  5. ECLiPSE 2002

    net framework update files- do I need them?

    ECLiPSE 2002, Oct 10, 2010, in forum: Computer Support
    Replies:
    5
    Views:
    791
    ECLiPSE 2002
    Oct 11, 2010
Loading...

Share This Page