Secondary addresses and static DHCP

Discussion in 'Cisco' started by Daryle A. Tilroe, Apr 28, 2006.

  1. My bloody ISP has gone and broken my setup and being only
    a bi-occasional IOS hack I've exhausted my alternatives.

    I have a 1605R.

    I have 5 static IPs from the ISP and previously I used the
    first as primary and the rest as secondaries for linking
    several inside services to the outside (eg. 3 different
    ftp servers that I want assessable from the outside):

    interface Ethernet0
    description connected to ADSL
    ip address xxx.xxx.207.104 255.255.248.0 secondary
    ip address xxx.xxx.207.105 255.255.248.0 secondary
    ip address xxx.xxx.207.106 255.255.248.0 secondary
    ip address xxx.xxx.207.107 255.255.248.0 secondary
    ip address xxx.xxx.207.103 255.255.248.0
    ip access-group 101 in
    ip nat outside

    Now the ISP has change something whereby things will not
    route unless you request your static IP via DHCP (it is
    mapped by registering the MAC address of the interface).
    So basically I have to change the above to:

    interface Ethernet0
    description connected to ADSL
    ip address dhcp
    ip access-group 101 in
    ip nat outside

    and remove:

    ip route 0.0.0.0 0.0.0.0 xxx.xxx.200.1

    Everything on the xxx.xxx.200.103 then works fine and 90%
    of things work as they used to. However without the secondaries
    I loose things like having outside access to other ftp and web
    servers mapped like these examples:

    ip nat inside source static tcp 172.16.0.4 21 xxx.xxx.207.105 21
    extendable
    ip nat inside source static tcp 172.16.0.4 20 xxx.xxx.207.105 20
    extendable
    ip nat inside source static tcp 172.16.0.10 80 xxx.xxx.207.105 80
    extendable

    Now there may be some way to fix/kludge this with static
    routes and/or playing around with arp but I can't get it
    to work. I also suspect I need to tweak the rip settings
    since without the secondary entries on the interface I loose
    automatic advertising and setting Ethernet0 to passive may
    not work. This is my current rip section:

    router rip
    version 2
    passive-interface Ethernet0
    network 172.16.0.0
    no auto-summary

    Thanks for any help!

    --
    Daryle Tilroe
     
    Daryle A. Tilroe, Apr 28, 2006
    #1
    1. Advertising

  2. Daryle A. Tilroe wrote:

    > interface Ethernet0
    > description connected to ADSL
    > ip address xxx.xxx.207.104 255.255.248.0 secondary
    > ip address xxx.xxx.207.105 255.255.248.0 secondary
    > ip address xxx.xxx.207.106 255.255.248.0 secondary
    > ip address xxx.xxx.207.107 255.255.248.0 secondary
    > ip address xxx.xxx.207.103 255.255.248.0
    > ip access-group 101 in
    > ip nat outside



    So just to follow-up to my previous message; I think that the
    above secondary listings may (when things were working fine
    before the ISP fubar'd things) have been redundant. It appears
    that the mappings like the ones below below:

    > ip nat inside source static tcp 172.16.0.4 21 xxx.xxx.207.105 21 extendable
    > ip nat inside source static tcp 172.16.0.4 20 xxx.xxx.207.105 20 extendable
    > ip nat inside source static tcp 172.16.0.10 80 xxx.xxx.207.105 80
    > extendable


    etc. serve to make the correct arp entries:

    Internet xxx.xxx.207.106 - 0030.94be.yyyy ARPA Ethernet0
    Internet xxx.xxx.207.107 - 0030.94be.yyyy ARPA Ethernet0
    Internet xxx.xxx.207.104 - 0030.94be.yyyy ARPA Ethernet0
    Internet xxx.xxx.207.105 - 0030.94be.yyyy ARPA Ethernet0
    Internet xxx.xxx.207.103 - 0030.94be.yyyy ARPA Ethernet0

    (where all the 0030.94be.yyyy are identical MAC addresses)

    Anyhow, it now seems that the main problem is the need to trigger the
    static DHCP request to the ISP in order to get their router to route
    to any of my IPs. Of course their system does not allow you to put in
    the same MAC for multiple IPs. I wonder if there is some way to
    have the router make the multiple DHCP requests for different MACs
    and then have the Ethernet0 interface with multiple MACS bound to it?

    --
    Daryle Tilroe
     
    Daryle A. Tilroe, Apr 29, 2006
    #2
    1. Advertising

  3. Daryle A. Tilroe

    Merv Guest

    It would seem that you are going to have to change from routing to
    bridging and setup each of your PC's to reuest an IP address via DHCP.
    Those DHCP requests will be need to be bridged to the Ethernet
    interface facing the ISP.
     
    Merv, Apr 29, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. chaidan
    Replies:
    1
    Views:
    1,839
    Pete Mainwaring
    Aug 25, 2004
  2. Mikhael47
    Replies:
    1
    Views:
    10,842
    mcaissie
    Sep 21, 2004
  3. branigan

    DHCP and secondary networks

    branigan, Mar 13, 2007, in forum: Cisco
    Replies:
    3
    Views:
    718
    Martin Gallagher
    Mar 15, 2007
  4. Greg

    Secondary IP Addresses

    Greg, Mar 4, 2008, in forum: Cisco
    Replies:
    3
    Views:
    444
    Doug McIntyre
    Mar 5, 2008
  5. peterwn

    Three strikes and static internet addresses

    peterwn, Nov 2, 2011, in forum: NZ Computing
    Replies:
    13
    Views:
    1,098
    Bruce Sinclair
    Nov 7, 2011
Loading...

Share This Page