Saving as '.jpeg' in IE/XP?

Discussion in 'NZ Computing' started by ~misfit~, Oct 9, 2003.

  1. ~misfit~

    ~misfit~ Guest

    I've had this problem before and mentioned it here before. I can't remember
    how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg files as
    ..jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    again. It's more of an annoyance than anything else.

    Anyone know how I can fix this?

    Thanks,
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
     
    ~misfit~, Oct 9, 2003
    #1
    1. Advertising

  2. ~misfit~

    Red Ribbon Guest

    ..jpeg and .jpg are the same. It is more likely that the website has the file
    named as ".jpeg" and hence, IE is keeping the same file extension.

    just rename the file manually, or saving the image using quotation marks
    around the file name, i.e. if you want to save an image file PICTURE.JPEG
    from the website, in the filename textbox type in "PICTURE.JPG" and save.



    "~misfit~" <~misfit~@his-desk.com> wrote in message
    news:GH1hb.172272$...
    > I've had this problem before and mentioned it here before. I can't

    remember
    > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg files

    as
    > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    > again. It's more of an annoyance than anything else.
    >
    > Anyone know how I can fix this?
    >
    > Thanks,
    > --
    > ~misfit~
    >
    >
    > ---
    > Outgoing mail is certified Virus Free.
    > Checked by AVG anti-virus system (http://www.grisoft.com).
    > Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
    >
    >
     
    Red Ribbon, Oct 9, 2003
    #2
    1. Advertising

  3. ~misfit~

    Mainlander Guest

    In article <GH1hb.172272$>, ~misfit~@his-
    desk.com says...
    > I've had this problem before and mentioned it here before. I can't remember
    > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg files as
    > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    > again. It's more of an annoyance than anything else.



    Methinks you doth complain too much. jpeg is perfectly acceptable as an
    extension for JPEG files and the extensions are treated interchangeably.
    Generally the extension saved is specified in the file that is
    downloaded.
     
    Mainlander, Oct 9, 2003
    #3
  4. ~misfit~

    ~misfit~ Guest

    "Red Ribbon" <> wrote in message
    news:rU2hb.7356$...
    > .jpeg and .jpg are the same. It is more likely that the website has the

    file
    > named as ".jpeg" and hence, IE is keeping the same file extension.


    Nah, I've tried from several websites. IE says 'save as JPEG (.jpeg)' in the
    file type box.

    > just rename the file manually, or saving the image using quotation marks
    > around the file name, i.e. if you want to save an image file PICTURE.JPEG
    > from the website, in the filename textbox type in "PICTURE.JPG" and save.


    Yeah, I can do that. It's just a hassle and I hate it when things seem to
    change inexplicably like it has.
    --
    ~misfit~

    > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > news:GH1hb.172272$...
    > > I've had this problem before and mentioned it here before. I can't

    > remember
    > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg

    files
    > as
    > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    > > again. It's more of an annoyance than anything else.
    > >
    > > Anyone know how I can fix this?
    > >
    > > Thanks,
    > > --
    > > ~misfit~
    > >
    > >
    > > ---
    > > Outgoing mail is certified Virus Free.
    > > Checked by AVG anti-virus system (http://www.grisoft.com).
    > > Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
    > >
    > >

    >
    >



    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
     
    ~misfit~, Oct 9, 2003
    #4
  5. ~misfit~

    ~misfit~ Guest

    "Mainlander" <*@*.*> wrote in message
    news:...
    > In article <GH1hb.172272$>, ~misfit~@his-
    > desk.com says...
    > > I've had this problem before and mentioned it here before. I can't

    remember
    > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg

    files as
    > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    > > again. It's more of an annoyance than anything else.

    >
    >
    > Methinks you doth complain too much. jpeg is perfectly acceptable as an
    > extension for JPEG files and the extensions are treated interchangeably.
    > Generally the extension saved is specified in the file that is
    > downloaded.


    As I said in my reply to Red Ribbon, it's not the way it's named on the
    website. it's IE doing it. I've tried saving form various sites and, even
    though the file originally has the .jpg extension IE changes it to .jpeg. I
    find it annoying as in the 'save' dialogue box that comes up it doesn't show
    what other .jpeg files are in that location as it does with .jpg files.
    (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least by XP)
    and it isn't 'perfectly acceptable'.) That can be a pain as I often re-name
    files when I save them according to my own system and I use the other files
    in that folder as a reference. To do that now I have to open the folder
    seperately and check the other files that way.

    Also, I want to know why IE has changed the extension it uses for jpegs. I
    dislike mysteries like this. I think it's since I updated to IE with sp1
    from a PC world cover-disc but am not sure of that. And of course I can't
    un-install it, or at least I'm unable to find how to, if it's possible. I've
    tried installing an earlier version of IE6, without the service pack, but of
    course windows tells me I'm already running a later version of the software
    and won't let me.

    Maybe I do complain too much but I don't like changes happening on my 'puter
    that I can't explain or change back myself (yet). Especially when it makes
    tasks more difficult or complicated for me.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
     
    ~misfit~, Oct 9, 2003
    #5
  6. ~misfit~

    T.N.O. Guest

    "~misfit~" wrote
    > > just rename the file manually, or saving the image using quotation marks
    > > around the file name, i.e. if you want to save an image file

    PICTURE.JPEG
    > > from the website, in the filename textbox type in "PICTURE.JPG" and

    save.

    > Yeah, I can do that. It's just a hassle and I hate it when things seem to
    > change inexplicably like it has.


    Search the registry for jpeg and see what comes up... is it really that
    important that it has that file extn?
     
    T.N.O., Oct 9, 2003
    #6
  7. ~misfit~

    ~misfit~ Guest

    "T.N.O." <> wrote in message
    news:...
    > "~misfit~" wrote
    > > > just rename the file manually, or saving the image using quotation

    marks
    > > > around the file name, i.e. if you want to save an image file

    > PICTURE.JPEG
    > > > from the website, in the filename textbox type in "PICTURE.JPG" and

    > save.
    >
    > > Yeah, I can do that. It's just a hassle and I hate it when things seem

    to
    > > change inexplicably like it has.

    >
    > Search the registry for jpeg and see what comes up... is it really that
    > important that it has that file extn?


    I don't usually delve into the registry and wouldn't know what to do with
    the search results.

    It's not really *that* important I guess but I just like things how I like
    them if you know what I mean.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.524 / Virus Database: 321 - Release Date: 6/10/2003
     
    ~misfit~, Oct 9, 2003
    #7
  8. ~misfit~

    Red Ribbon Guest

    *snip*
    >
    > As I said in my reply to Red Ribbon, it's not the way it's named on the
    > website. it's IE doing it. I've tried saving form various sites and, even
    > though the file originally has the .jpg extension IE changes it to .jpeg.

    I
    > find it annoying as in the 'save' dialogue box that comes up it doesn't

    show
    > what other .jpeg files are in that location as it does with .jpg files.
    > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least by

    XP)
    > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    re-name
    > files when I save them according to my own system and I use the other

    files
    > in that folder as a reference. To do that now I have to open the folder
    > seperately and check the other files that way.



    ACTUALLY JPEG and JPG are interchangable regardless what OS you are using.
     
    Red Ribbon, Oct 10, 2003
    #8
  9. ~misfit~

    Rider Guest

    "Red Ribbon" <> wrote in message
    news:kWlhb.12$...
    > *snip*
    > >
    > > As I said in my reply to Red Ribbon, it's not the way it's named on the
    > > website. it's IE doing it. I've tried saving form various sites and,

    even
    > > though the file originally has the .jpg extension IE changes it to

    ..jpeg.
    > I
    > > find it annoying as in the 'save' dialogue box that comes up it doesn't

    > show
    > > what other .jpeg files are in that location as it does with .jpg files.
    > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least by

    > XP)
    > > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    > re-name
    > > files when I save them according to my own system and I use the other

    > files
    > > in that folder as a reference. To do that now I have to open the folder
    > > seperately and check the other files that way.

    >
    >
    > ACTUALLY JPEG and JPG are interchangable regardless what OS you are using.
    >
    >


    Does it matter at all "WHY" he wants to do it his way??? If thats the way he
    wants it fine, just answer the question if you can.

    On my XP machine if I save a picture from the net and its a jpg, its says
    down the bottom of the save dialog JPEG(*.jpg). Misfit ... does your say
    JPEG(*.jpeg)?

    Rider
     
    Rider, Oct 10, 2003
    #9
  10. ~misfit~

    Eagle Eye Guest

    "~misfit~" <~misfit~@his-desk.com> wrote in message
    news:Qx5hb.172482$...
    >
    > "Mainlander" <*@*.*> wrote in message
    > news:...
    > > In article <GH1hb.172272$>, ~misfit~@his-
    > > desk.com says...
    > > > I've had this problem before and mentioned it here before. I can't

    > remember
    > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg

    > files as
    > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's

    happening
    > > > again. It's more of an annoyance than anything else.

    > >
    > >
    > > Methinks you doth complain too much. jpeg is perfectly acceptable as an
    > > extension for JPEG files and the extensions are treated interchangeably.
    > > Generally the extension saved is specified in the file that is
    > > downloaded.

    >
    > As I said in my reply to Red Ribbon, it's not the way it's named on the
    > website. it's IE doing it. I've tried saving form various sites and, even
    > though the file originally has the .jpg extension IE changes it to .jpeg.

    I
    > find it annoying as in the 'save' dialogue box that comes up it doesn't

    show
    > what other .jpeg files are in that location as it does with .jpg files.
    > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least by

    XP)
    > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    re-name
    > files when I save them according to my own system and I use the other

    files
    > in that folder as a reference. To do that now I have to open the folder
    > seperately and check the other files that way.
    >
    > Also, I want to know why IE has changed the extension it uses for jpegs. I
    > dislike mysteries like this. I think it's since I updated to IE with sp1
    > from a PC world cover-disc but am not sure of that. And of course I can't
    > un-install it, or at least I'm unable to find how to, if it's possible.

    I've
    > tried installing an earlier version of IE6, without the service pack, but

    of
    > course windows tells me I'm already running a later version of the

    software
    > and won't let me.
    >
    > Maybe I do complain too much but I don't like changes happening on my

    'puter
    > that I can't explain or change back myself (yet). Especially when it makes
    > tasks more difficult or complicated for me.
    > --
    > ~misfit~
    >
    >


    I don't have Win XP, as I am still using Win 98, but in Win 98 in the
    'Folder Options' (File Types) for JPEG, if you go into "Edit", there is a
    box where you can select the default extension. Maybe there is a similar
    thing in Win XP and somehow the default has been changed from ".jpg" to
    ".jpeg"? Just my thoughts...
     
    Eagle Eye, Oct 10, 2003
    #10
  11. ~misfit~

    ~misfit~ Guest

    "Eagle Eye" <> wrote in message
    news:bm4ruu$iq22o$-berlin.de...
    >
    > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > news:Qx5hb.172482$...
    > >
    > > "Mainlander" <*@*.*> wrote in message
    > > news:...
    > > > In article <GH1hb.172272$>, ~misfit~@his-
    > > > desk.com says...
    > > > > I've had this problem before and mentioned it here before. I can't

    > > remember
    > > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg

    > > files as
    > > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's

    > happening
    > > > > again. It's more of an annoyance than anything else.
    > > >
    > > >
    > > > Methinks you doth complain too much. jpeg is perfectly acceptable as

    an
    > > > extension for JPEG files and the extensions are treated

    interchangeably.
    > > > Generally the extension saved is specified in the file that is
    > > > downloaded.

    > >
    > > As I said in my reply to Red Ribbon, it's not the way it's named on the
    > > website. it's IE doing it. I've tried saving form various sites and,

    even
    > > though the file originally has the .jpg extension IE changes it to

    ..jpeg.
    > I
    > > find it annoying as in the 'save' dialogue box that comes up it doesn't

    > show
    > > what other .jpeg files are in that location as it does with .jpg files.
    > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least by

    > XP)
    > > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    > re-name
    > > files when I save them according to my own system and I use the other

    > files
    > > in that folder as a reference. To do that now I have to open the folder
    > > seperately and check the other files that way.
    > >
    > > Also, I want to know why IE has changed the extension it uses for jpegs.

    I
    > > dislike mysteries like this. I think it's since I updated to IE with sp1
    > > from a PC world cover-disc but am not sure of that. And of course I

    can't
    > > un-install it, or at least I'm unable to find how to, if it's possible.

    > I've
    > > tried installing an earlier version of IE6, without the service pack,

    but
    > of
    > > course windows tells me I'm already running a later version of the

    > software
    > > and won't let me.
    > >
    > > Maybe I do complain too much but I don't like changes happening on my

    > 'puter
    > > that I can't explain or change back myself (yet). Especially when it

    makes
    > > tasks more difficult or complicated for me.
    > > --
    > > ~misfit~
    > >
    > >

    >
    > I don't have Win XP, as I am still using Win 98, but in Win 98 in the
    > 'Folder Options' (File Types) for JPEG, if you go into "Edit", there is a
    > box where you can select the default extension. Maybe there is a similar
    > thing in Win XP and somehow the default has been changed from ".jpg" to
    > ".jpeg"? Just my thoughts...


    Interesting, thanks, I hadn't looked in there, just in IE's settings. In
    mine it has JPE, JPEG and JPG all listed as JPEG image. I don't have the
    same options for 'edit' as you do in 98 but I can delete or add registered
    file types, I may delete JPE and JPEG and see what happens. I can always put
    them back if it just stops me from opening them with a default proggy but IE
    still saves as *.jpeg.

    Cheers, I'll have a play.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #11
  12. ~misfit~

    ~misfit~ Guest

    "Rider" <> wrote in message
    news:bm4qt2$vm1$...
    >
    > "Red Ribbon" <> wrote in message
    > news:kWlhb.12$...
    > > *snip*
    > > >
    > > > As I said in my reply to Red Ribbon, it's not the way it's named on

    the
    > > > website. it's IE doing it. I've tried saving form various sites and,

    > even
    > > > though the file originally has the .jpg extension IE changes it to

    > .jpeg.
    > > I
    > > > find it annoying as in the 'save' dialogue box that comes up it

    doesn't
    > > show
    > > > what other .jpeg files are in that location as it does with .jpg

    files.
    > > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least

    by
    > > XP)
    > > > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    > > re-name
    > > > files when I save them according to my own system and I use the other

    > > files
    > > > in that folder as a reference. To do that now I have to open the

    folder
    > > > seperately and check the other files that way.

    > >
    > >
    > > ACTUALLY JPEG and JPG are interchangable regardless what OS you are

    using.
    > >
    > >

    >
    > Does it matter at all "WHY" he wants to do it his way??? If thats the way

    he
    > wants it fine, just answer the question if you can.


    Thank you. At last, someone who wants to help and not tell me how to run my
    machine.

    > On my XP machine if I save a picture from the net and its a jpg, its says
    > down the bottom of the save dialog JPEG(*.jpg). Misfit ... does your say
    > JPEG(*.jpeg)?


    No, it says JPEG (*.jpg), same as yours, but in the filename box above it
    has a .jpeg extension. I don't know why it's changed. I'm going to play in
    'folder options' - 'file types' as suggested by Eagle Eye.

    Thanks,
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #12
  13. ~misfit~

    T.N.O. Guest

    "~misfit~" wrote
    > Thank you. At last, someone who wants to help and not tell me how to run

    my
    > machine.


    Hey... I asked why, and said you could probably do it in the registry... you
    said not interested, I tried, you just wearnt willing :)

    > No, it says JPEG (*.jpg), same as yours, but in the filename box above it
    > has a .jpeg extension. I don't know why it's changed. I'm going to play in
    > 'folder options' - 'file types' as suggested by Eagle Eye.


    yeah, that sounds like it could be a good idea.
     
    T.N.O., Oct 10, 2003
    #13
  14. ~misfit~

    ~misfit~ Guest

    "~misfit~" <~misfit~@his-desk.com> wrote in message
    news:QUphb.173553$...
    >
    > "Eagle Eye" <> wrote in message
    > news:bm4ruu$iq22o$-berlin.de...
    > >
    > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > news:Qx5hb.172482$...
    > > >
    > > > "Mainlander" <*@*.*> wrote in message
    > > > news:...
    > > > > In article <GH1hb.172272$>, ~misfit~@his-
    > > > > desk.com says...
    > > > > > I've had this problem before and mentioned it here before. I can't
    > > > remember
    > > > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving

    ..jpg
    > > > files as
    > > > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's

    > > happening
    > > > > > again. It's more of an annoyance than anything else.
    > > > >
    > > > >
    > > > > Methinks you doth complain too much. jpeg is perfectly acceptable as

    > an
    > > > > extension for JPEG files and the extensions are treated

    > interchangeably.
    > > > > Generally the extension saved is specified in the file that is
    > > > > downloaded.
    > > >
    > > > As I said in my reply to Red Ribbon, it's not the way it's named on

    the
    > > > website. it's IE doing it. I've tried saving form various sites and,

    > even
    > > > though the file originally has the .jpg extension IE changes it to

    > .jpeg.
    > > I
    > > > find it annoying as in the 'save' dialogue box that comes up it

    doesn't
    > > show
    > > > what other .jpeg files are in that location as it does with .jpg

    files.
    > > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least

    by
    > > XP)
    > > > and it isn't 'perfectly acceptable'.) That can be a pain as I often

    > > re-name
    > > > files when I save them according to my own system and I use the other

    > > files
    > > > in that folder as a reference. To do that now I have to open the

    folder
    > > > seperately and check the other files that way.
    > > >
    > > > Also, I want to know why IE has changed the extension it uses for

    jpegs.
    > I
    > > > dislike mysteries like this. I think it's since I updated to IE with

    sp1
    > > > from a PC world cover-disc but am not sure of that. And of course I

    > can't
    > > > un-install it, or at least I'm unable to find how to, if it's

    possible.
    > > I've
    > > > tried installing an earlier version of IE6, without the service pack,

    > but
    > > of
    > > > course windows tells me I'm already running a later version of the

    > > software
    > > > and won't let me.
    > > >
    > > > Maybe I do complain too much but I don't like changes happening on my

    > > 'puter
    > > > that I can't explain or change back myself (yet). Especially when it

    > makes
    > > > tasks more difficult or complicated for me.
    > > > --
    > > > ~misfit~
    > > >
    > > >

    > >
    > > I don't have Win XP, as I am still using Win 98, but in Win 98 in the
    > > 'Folder Options' (File Types) for JPEG, if you go into "Edit", there is

    a
    > > box where you can select the default extension. Maybe there is a similar
    > > thing in Win XP and somehow the default has been changed from ".jpg" to
    > > ".jpeg"? Just my thoughts...

    >
    > Interesting, thanks, I hadn't looked in there, just in IE's settings. In
    > mine it has JPE, JPEG and JPG all listed as JPEG image. I don't have the
    > same options for 'edit' as you do in 98 but I can delete or add registered
    > file types, I may delete JPE and JPEG and see what happens. I can always

    put
    > them back if it just stops me from opening them with a default proggy but

    IE
    > still saves as *.jpeg.
    >
    > Cheers, I'll have a play.


    Oh well. Deleted the JPE and JPEG entries and re-booted my 'puter but no
    change. Guess I'll put the entries back (if I can :) ).
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #14
  15. Hi there,

    ~misfit~ wrote:
    > I've had this problem before and mentioned it here before. I can't remember
    > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving .jpg files as
    > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's happening
    > again. It's more of an annoyance than anything else.
    >
    > Anyone know how I can fix this?


    Not sure, but isn't '.jpeg' an accepted mimetype for JPEG's
    anyway? Any and all apps I use to see JPEG's here happily use
    that suffix, and the only reason I could think to worry about
    it is if you need 8.3 format filenames...

    Kind regards,

    Chris Wilkinson, Christchurch.
     
    Chris Wilkinson, Oct 10, 2003
    #15
  16. Hi there,

    ~misfit~ wrote:
    >
    > As I said in my reply to Red Ribbon, it's not the way it's named on the
    > website. it's IE doing it.


    M$ software has a habit of 'bastardising' files. Just try loading
    a hand-coded HTML file into Frontpage and see what it does to the
    source...

    Kind regards,

    Chris Wilkinson, Christchurch.
     
    Chris Wilkinson, Oct 10, 2003
    #16
  17. ~misfit~

    Mainlander Guest

    In article <K7qhb.173572$>, ~misfit~@his-
    desk.com says...
    >
    > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > news:QUphb.173553$...
    > >
    > > "Eagle Eye" <> wrote in message
    > > news:bm4ruu$iq22o$-berlin.de...
    > > >
    > > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > > news:Qx5hb.172482$...
    > > > >
    > > > > "Mainlander" <*@*.*> wrote in message
    > > > > news:...
    > > > > > In article <GH1hb.172272$>, ~misfit~@his-
    > > > > > desk.com says...
    > > > > > > I've had this problem before and mentioned it here before. I can't
    > > > > remember
    > > > > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving

    > .jpg
    > > > > files as
    > > > > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's
    > > > happening
    > > > > > > again. It's more of an annoyance than anything else.
    > > > > >
    > > > > >
    > > > > > Methinks you doth complain too much. jpeg is perfectly acceptable as

    > > an
    > > > > > extension for JPEG files and the extensions are treated

    > > interchangeably.
    > > > > > Generally the extension saved is specified in the file that is
    > > > > > downloaded.
    > > > >
    > > > > As I said in my reply to Red Ribbon, it's not the way it's named on

    > the
    > > > > website. it's IE doing it. I've tried saving form various sites and,

    > > even
    > > > > though the file originally has the .jpg extension IE changes it to

    > > .jpeg.
    > > > I
    > > > > find it annoying as in the 'save' dialogue box that comes up it

    > doesn't
    > > > show
    > > > > what other .jpeg files are in that location as it does with .jpg

    > files.
    > > > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at least

    > by
    > > > XP)
    > > > > and it isn't 'perfectly acceptable'.) That can be a pain as I often
    > > > re-name
    > > > > files when I save them according to my own system and I use the other
    > > > files
    > > > > in that folder as a reference. To do that now I have to open the

    > folder
    > > > > seperately and check the other files that way.
    > > > >
    > > > > Also, I want to know why IE has changed the extension it uses for

    > jpegs.
    > > I
    > > > > dislike mysteries like this. I think it's since I updated to IE with

    > sp1
    > > > > from a PC world cover-disc but am not sure of that. And of course I

    > > can't
    > > > > un-install it, or at least I'm unable to find how to, if it's

    > possible.
    > > > I've
    > > > > tried installing an earlier version of IE6, without the service pack,

    > > but
    > > > of
    > > > > course windows tells me I'm already running a later version of the
    > > > software
    > > > > and won't let me.
    > > > >
    > > > > Maybe I do complain too much but I don't like changes happening on my
    > > > 'puter
    > > > > that I can't explain or change back myself (yet). Especially when it

    > > makes
    > > > > tasks more difficult or complicated for me.
    > > > > --
    > > > > ~misfit~
    > > > >
    > > > >
    > > >
    > > > I don't have Win XP, as I am still using Win 98, but in Win 98 in the
    > > > 'Folder Options' (File Types) for JPEG, if you go into "Edit", there is

    > a
    > > > box where you can select the default extension. Maybe there is a similar
    > > > thing in Win XP and somehow the default has been changed from ".jpg" to
    > > > ".jpeg"? Just my thoughts...

    > >
    > > Interesting, thanks, I hadn't looked in there, just in IE's settings. In
    > > mine it has JPE, JPEG and JPG all listed as JPEG image. I don't have the
    > > same options for 'edit' as you do in 98 but I can delete or add registered
    > > file types, I may delete JPE and JPEG and see what happens. I can always

    > put
    > > them back if it just stops me from opening them with a default proggy but

    > IE
    > > still saves as *.jpeg.
    > >
    > > Cheers, I'll have a play.

    >
    > Oh well. Deleted the JPE and JPEG entries and re-booted my 'puter but no
    > change. Guess I'll put the entries back (if I can :) ).


    Not a great idea, you can't add them in that dialog. They are entered as
    registry settings in HKEY_CLASSES_ROOT.

    The following works in Windows 95. Use at your own risk:

    1. Browse to HKEY_CLASSES_ROOT\.jpg
    2. On the Registry menu, click Export Registry
    3. Ensure that the radio button that reads "Selected branch
    HKEY_CLASSES_ROOT\.jpg" is selected.
    4. Type a file name and click OK
    5. Open the .reg file in a text editor
    6. Change the file type in each line reading "HKEY_CLASSES_ROOT\.jpg" to
    the correct file type.
    7. Save the file.
    8. Double click the file to apply the changes to the registry.
    9. In my installation of windows, the GUID value in the last line
    (preceded by @ in the reg file) was not put in for some reason so you may
    have to enter this by hand

    Repeat steps 5 to 8 as necessary for additional file types.

    When you select the file type and click Edit there is a field that
    clearly reads "Default extension for content type", what is selecte in
    this field?
     
    Mainlander, Oct 10, 2003
    #17
  18. ~misfit~

    ~misfit~ Guest

    "T.N.O." <> wrote in message
    news:bm5b0m$irkak$-berlin.de...
    > "~misfit~" wrote
    > > Thank you. At last, someone who wants to help and not tell me how to run

    > my
    > > machine.

    >
    > Hey... I asked why, and said you could probably do it in the registry...

    you
    > said not interested, I tried, you just wearnt willing :)


    Here's our exchange:

    <> Search the registry for jpeg and see what comes up... is it really that
    > important that it has that file extn?


    I don't usually delve into the registry and wouldn't know what to do with
    the search results.>

    After reading your reply I had a look in the registry and didn't really know
    what I was doing. Searching the registry for 'jpeg' and 'JPEG' (without
    quotes) didn't bring up anything. I couldn't find the relevant entry. After
    I said (quoted above) I wouldn't know what to do with the search results
    (subtle hint for help) and you didn't reply I figured you had better things
    to do than help further.

    > > No, it says JPEG (*.jpg), same as yours, but in the filename box above

    it
    > > has a .jpeg extension. I don't know why it's changed. I'm going to play

    in
    > > 'folder options' - 'file types' as suggested by Eagle Eye.

    >
    > yeah, that sounds like it could be a good idea.


    It didn't help though. It just stopped me from automatically opening the
    alternate .jpg names and prompted me for a proggy. IE still saved as .jpeg.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #18
  19. ~misfit~

    ~misfit~ Guest

    "Mainlander" <*@*.*> wrote in message
    news:...
    > In article <K7qhb.173572$>, ~misfit~@his-
    > desk.com says...
    > >
    > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > news:QUphb.173553$...
    > > >
    > > > "Eagle Eye" <> wrote in message
    > > > news:bm4ruu$iq22o$-berlin.de...
    > > > >
    > > > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > > > news:Qx5hb.172482$...
    > > > > >
    > > > > > "Mainlander" <*@*.*> wrote in message
    > > > > > news:...
    > > > > > > In article <GH1hb.172272$>,

    ~misfit~@his-
    > > > > > > desk.com says...
    > > > > > > > I've had this problem before and mentioned it here before. I

    can't
    > > > > > remember
    > > > > > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving

    > > .jpg
    > > > > > files as
    > > > > > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's
    > > > > happening
    > > > > > > > again. It's more of an annoyance than anything else.
    > > > > > >
    > > > > > >
    > > > > > > Methinks you doth complain too much. jpeg is perfectly

    acceptable as
    > > > an
    > > > > > > extension for JPEG files and the extensions are treated
    > > > interchangeably.
    > > > > > > Generally the extension saved is specified in the file that is
    > > > > > > downloaded.
    > > > > >
    > > > > > As I said in my reply to Red Ribbon, it's not the way it's named

    on
    > > the
    > > > > > website. it's IE doing it. I've tried saving form various sites

    and,
    > > > even
    > > > > > though the file originally has the .jpg extension IE changes it to
    > > > .jpeg.
    > > > > I
    > > > > > find it annoying as in the 'save' dialogue box that comes up it

    > > doesn't
    > > > > show
    > > > > > what other .jpeg files are in that location as it does with .jpg

    > > files.
    > > > > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at

    least
    > > by
    > > > > XP)
    > > > > > and it isn't 'perfectly acceptable'.) That can be a pain as I

    often
    > > > > re-name
    > > > > > files when I save them according to my own system and I use the

    other
    > > > > files
    > > > > > in that folder as a reference. To do that now I have to open the

    > > folder
    > > > > > seperately and check the other files that way.
    > > > > >
    > > > > > Also, I want to know why IE has changed the extension it uses for

    > > jpegs.
    > > > I
    > > > > > dislike mysteries like this. I think it's since I updated to IE

    with
    > > sp1
    > > > > > from a PC world cover-disc but am not sure of that. And of course

    I
    > > > can't
    > > > > > un-install it, or at least I'm unable to find how to, if it's

    > > possible.
    > > > > I've
    > > > > > tried installing an earlier version of IE6, without the service

    pack,
    > > > but
    > > > > of
    > > > > > course windows tells me I'm already running a later version of the
    > > > > software
    > > > > > and won't let me.
    > > > > >
    > > > > > Maybe I do complain too much but I don't like changes happening on

    my
    > > > > 'puter
    > > > > > that I can't explain or change back myself (yet). Especially when

    it
    > > > makes
    > > > > > tasks more difficult or complicated for me.
    > > > > > --
    > > > > > ~misfit~
    > > > > >
    > > > > >
    > > > >
    > > > > I don't have Win XP, as I am still using Win 98, but in Win 98 in

    the
    > > > > 'Folder Options' (File Types) for JPEG, if you go into "Edit", there

    is
    > > a
    > > > > box where you can select the default extension. Maybe there is a

    similar
    > > > > thing in Win XP and somehow the default has been changed from ".jpg"

    to
    > > > > ".jpeg"? Just my thoughts...
    > > >
    > > > Interesting, thanks, I hadn't looked in there, just in IE's settings.

    In
    > > > mine it has JPE, JPEG and JPG all listed as JPEG image. I don't have

    the
    > > > same options for 'edit' as you do in 98 but I can delete or add

    registered
    > > > file types, I may delete JPE and JPEG and see what happens. I can

    always
    > > put
    > > > them back if it just stops me from opening them with a default proggy

    but
    > > IE
    > > > still saves as *.jpeg.
    > > >
    > > > Cheers, I'll have a play.

    > >
    > > Oh well. Deleted the JPE and JPEG entries and re-booted my 'puter but no
    > > change. Guess I'll put the entries back (if I can :) ).

    >
    > Not a great idea, you can't add them in that dialog. They are entered as
    > registry settings in HKEY_CLASSES_ROOT.
    >
    > The following works in Windows 95. Use at your own risk:
    >
    > 1. Browse to HKEY_CLASSES_ROOT\.jpg
    > 2. On the Registry menu, click Export Registry
    > 3. Ensure that the radio button that reads "Selected branch
    > HKEY_CLASSES_ROOT\.jpg" is selected.
    > 4. Type a file name and click OK
    > 5. Open the .reg file in a text editor
    > 6. Change the file type in each line reading "HKEY_CLASSES_ROOT\.jpg" to
    > the correct file type.
    > 7. Save the file.
    > 8. Double click the file to apply the changes to the registry.
    > 9. In my installation of windows, the GUID value in the last line
    > (preceded by @ in the reg file) was not put in for some reason so you may
    > have to enter this by hand
    >
    > Repeat steps 5 to 8 as necessary for additional file types.
    >
    > When you select the file type and click Edit there is a field that
    > clearly reads "Default extension for content type", what is selecte in
    > this field?


    Ok, thanks for that. I'm using XP so am not sure if it will be similar or
    not and have never become aquainted with the registry before. I will however
    look into it.

    Many thanks.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #19
  20. ~misfit~

    ~misfit~ Guest

    "Mainlander" <*@*.*> wrote in message
    news:...
    > In article <K7qhb.173572$>, ~misfit~@his-
    > desk.com says...
    > >
    > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > news:QUphb.173553$...
    > > >
    > > > "Eagle Eye" <> wrote in message
    > > > news:bm4ruu$iq22o$-berlin.de...
    > > > >
    > > > > "~misfit~" <~misfit~@his-desk.com> wrote in message
    > > > > news:Qx5hb.172482$...
    > > > > >
    > > > > > "Mainlander" <*@*.*> wrote in message
    > > > > > news:...
    > > > > > > In article <GH1hb.172272$>,

    ~misfit~@his-
    > > > > > > desk.com says...
    > > > > > > > I've had this problem before and mentioned it here before. I

    can't
    > > > > > remember
    > > > > > > > how I fixed it. IE 6 (sp1) running on XP Pro insists on saving

    > > .jpg
    > > > > > files as
    > > > > > > > .jpeg. I've re-installed and XP and IE6sp1 (new HDD) and it's
    > > > > happening
    > > > > > > > again. It's more of an annoyance than anything else.
    > > > > > >
    > > > > > >
    > > > > > > Methinks you doth complain too much. jpeg is perfectly

    acceptable as
    > > > an
    > > > > > > extension for JPEG files and the extensions are treated
    > > > interchangeably.
    > > > > > > Generally the extension saved is specified in the file that is
    > > > > > > downloaded.
    > > > > >
    > > > > > As I said in my reply to Red Ribbon, it's not the way it's named

    on
    > > the
    > > > > > website. it's IE doing it. I've tried saving form various sites

    and,
    > > > even
    > > > > > though the file originally has the .jpg extension IE changes it to
    > > > .jpeg.
    > > > > I
    > > > > > find it annoying as in the 'save' dialogue box that comes up it

    > > doesn't
    > > > > show
    > > > > > what other .jpeg files are in that location as it does with .jpg

    > > files.
    > > > > > (Therefore .jpeg and .jpg *aren't* treated interchangeably (at

    least
    > > by
    > > > > XP)
    > > > > > and it isn't 'perfectly acceptable'.) That can be a pain as I

    often
    > > > > re-name
    > > > > > files when I save them according to my own system and I use the

    other
    > > > > files
    > > > > > in that folder as a reference. To do that now I have to open the

    > > folder
    > > > > > seperately and check the other files that way.
    > > > > >
    > > > > > Also, I want to know why IE has changed the extension it uses for

    > > jpegs.
    > > > I
    > > > > > dislike mysteries like this. I think it's since I updated to IE

    with
    > > sp1
    > > > > > from a PC world cover-disc but am not sure of that. And of course

    I
    > > > can't
    > > > > > un-install it, or at least I'm unable to find how to, if it's

    > > possible.
    > > > > I've
    > > > > > tried installing an earlier version of IE6, without the service

    pack,
    > > > but
    > > > > of
    > > > > > course windows tells me I'm already running a later version of the
    > > > > software
    > > > > > and won't let me.
    > > > > >
    > > > > > Maybe I do complain too much but I don't like changes happening on

    my
    > > > > 'puter
    > > > > > that I can't explain or change back myself (yet). Especially when

    it
    > > > makes
    > > > > > tasks more difficult or complicated for me.
    > > > > > --
    > > > > > ~misfit~
    > > > > >
    > > > > >
    > > > >
    > > > > I don't have Win XP, as I am still using Win 98, but in Win 98 in

    the
    > > > > 'Folder Options' (File Types) for JPEG, if you go into "Edit", there

    is
    > > a
    > > > > box where you can select the default extension. Maybe there is a

    similar
    > > > > thing in Win XP and somehow the default has been changed from ".jpg"

    to
    > > > > ".jpeg"? Just my thoughts...
    > > >
    > > > Interesting, thanks, I hadn't looked in there, just in IE's settings.

    In
    > > > mine it has JPE, JPEG and JPG all listed as JPEG image. I don't have

    the
    > > > same options for 'edit' as you do in 98 but I can delete or add

    registered
    > > > file types, I may delete JPE and JPEG and see what happens. I can

    always
    > > put
    > > > them back if it just stops me from opening them with a default proggy

    but
    > > IE
    > > > still saves as *.jpeg.
    > > >
    > > > Cheers, I'll have a play.

    > >
    > > Oh well. Deleted the JPE and JPEG entries and re-booted my 'puter but no
    > > change. Guess I'll put the entries back (if I can :) ).

    >
    > Not a great idea, you can't add them in that dialog. They are entered as
    > registry settings in HKEY_CLASSES_ROOT.


    Forgot to mention in previous reply. I did add them back through that
    dialogue. It worked fine too.

    I'll look at where you mentioned in the reg. though.
    --
    ~misfit~


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.525 / Virus Database: 322 - Release Date: 9/10/2003
     
    ~misfit~, Oct 10, 2003
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. kl
    Replies:
    6
    Views:
    1,009
    Martin Brown
    Nov 12, 2003
  2. certsnsearches

    Exiff-jpeg and jpeg

    certsnsearches, Jan 7, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    3,382
    Jim Townsend
    Jan 7, 2004
  3. Amit
    Replies:
    3
    Views:
    1,361
    Ed Ruf (REPLY to E-MAIL IN SIG!)
    Mar 17, 2006
  4. Conrad

    jpeg and jpeg 2000

    Conrad, Jan 25, 2007, in forum: Digital Photography
    Replies:
    72
    Views:
    1,787
    Barry Pearson
    Feb 3, 2007
  5. Paul D. Sullivan

    Better JPEG program - minimized JPEG degredation

    Paul D. Sullivan, Jan 26, 2007, in forum: Digital Photography
    Replies:
    14
    Views:
    870
Loading...

Share This Page