Running old Dos games on my Computer?

Discussion in 'Computer Support' started by graeme@invalid, Oct 31, 2004.

  1. Eystein Finne wrote:
    From my memory, from times where we worked with win3.0 and real-mode

    network

    drivers together with a lot of tsrs, you should tune your config. sys and
    autoexec. bat like
    --- config. sys ---
    DEVICE=C:\windows\himem. sys
    DOS=HIGH, UMB
    DEVICE=C:\windows\emm386. exe NOEMS
    and then, if you have other DEVICE entries following that line, try to
    substitute DEVICE by DEVICEHIGH for each of them.
    Same goes for autoexec. bat, where you should substitute "load" with
    "loadhigh" or even better consider to REM out the stuff if not really
    necessary for your game. Remember, in win98 you can create a icon for your
    game and - under properties - chose to start into dos mode with even own
    startup files (config. sys and autoexec. bat) which you may streamline.
    However DON'T FORGET to SAVE your working current config. sys and
    autoexec. bat under different names, and prepare a (tested) startup floppy
    or use the bootable cdrom from '98, BEFORE you really change something.


    I'm not good at this but my settings in configsys are:

    DOS=HIGH, UMB
    Device=C:\WINDOWS\Himem. Sys
    DeviceHigh=C:\WINDOWS\EMM386. Exe

    Is it correct to change them to:

    DEVICE=C:\windows\himem. sys
    DOS=HIGH, UMB
    DEVICE=C:\windows\emm386. exe NOEMS

    And in autoexec bat I can't find any "load"

    It looks like this:

    SET TMP=C:\WINDOWS\TEMP
    SET TEMP=C:\WINDOWS\TEMP
    SET PROMPT=$p$g
    SET winbootdir=C:\WINDOWS
    SET PATH=C:\WINDOWS; C:\WINDOWS\COMMAND
    SET BLASTER=A220 I7 D1 H5 P330 T6

    Please help me a step further







    StripMail removes '' and '' characters from received e-mail text
    in case you want to forward a message or use its content elsewhere.

    Please send comments and suggestions to

    Copyright (c) 1989-2001 Datasoft Ltd.

    ----- Original Message -----
    From: Tahir Belenli <

    When replying or forwarding an e-mail that contains '' characters at
    the beginning of each line:

    Open your mail client's editor to compose a reply or to forward a
    message. Right click on the message text and select "Select All" item
    from menu. Right click again and select "Copy" menu item. This will
    place entire text of the message on clipboard.

    Run StripMail or return back StripMail window and click "Paste"
    button.
    The text of message will appear in place of these instructions.

    By clicking "Do It All" button, you can strip, paragraph, and copy
    text
    back to clipboard at once. StripMail will minimize leaving your mail
    editor on top. You will only need to paste the cleaned text back to
    the editor.

    Operations can also be performed one by one. Click "Strip" button to
    remove unwanted characters from the beginning of message
    lines. Click "Paragraph" button to reformat each part of text
    separated
    by blank lines into paragraphs.

    Press "Copy" button to copy the message text back to clipboard. Return
    to your message, right click on "already selected" message text and
    select "Paste" menu option.

    Now your message is clear and ready to send to your friend(s) or to
    use in another application.

    "Indent" button breaks text paragraphs into fixed length lines,
    placing
    indent character ('') at the beginning of each line. After indenting,
    "Strip" will remove indent characters added, provided that
    "AutoParagraph" option turned off.

    Indent character can be changed by selecting a single character of the
    text and executing "Indent char is : " option from popup menu.

    My Config.sys was designed for DOS games

    DEVICE=C:\WINDOWS\HIMEM.SYS
    DEVICE=C:\WINDOWS\EMM386.EXE NOEMS
    DEVICEHIGH=C:\WINDOWS\COMMAND\ANSI.SYS
    DOS=HIGH,UMB
    BUFFERS=50
    FILES=60
    SHELL=C:\WINDOWS\COMMAND.COM /P /E:1024
     
    graeme@invalid, Oct 31, 2004
    #1
    1. Advertising

  2. graeme@invalid

    Pennywise Guest

    On Mon, 01 Nov 2004 00:34:24 +0100, Walter Mautner
    <> wrote:

    |>> I'm not good at this but my settings in configsys are:
    |>>
    |>> DOS=HIGH,UMB
    |>> Device=C:\WINDOWS\Himem.Sys
    |>> DeviceHigh=C:\WINDOWS\EMM386.Exe
    |>>
    |>> Is it correct to change them to:
    |>>
    |>> DEVICE=C:\windows\himem.sys
    |>> DOS=HIGH,UMB
    |>> DEVICE=C:\windows\emm386.exe NOEMS
    |>>
    |>Well you don't need to change the order, just append the "noems".

    The order has to be changed.
    You have to load Himem.sys before Dos=high,UMB or it doesn't do
    anything.
    (high memory is where Dos goes).
     
    Pennywise, Oct 31, 2004
    #2
    1. Advertising

  3. Hi

    I'm trying to run an old game (The Legacy - Microprose) on my PC with
    win98se (don't know the dos version)
    When starting the game I get the message that I need at least 610 000 bytes
    of conventional memory.


    Earlier I used a program called memmaker to free some memory - but my
    current version of Dos doesn't seem to have it. Is there any easy way for me
    to make this game play?

    Eystein Finne
     
    Eystein Finne, Oct 31, 2004
    #3
  4. graeme@invalid

    Toolman Tim Guest

    >| Hi
    >|
    >| I'm trying to run an old game (The Legacy - Microprose) on my PC with
    >| win98se (don't know the dos version)
    >| When starting the game I get the message that I need at least 610
    >| 000 bytes of conventional memory.
    >|
    >|
    >| Earlier I used a program called memmaker to free some memory - but my
    >| current version of Dos doesn't seem to have it. Is there any easy
    >| way for me to make this game play?
    >|
    >| Eystein Finne


    Memmaker was a nice tool to optimize memory managment in DOS 6. Win98
    doesn't have DOS 6. You would have to set up your memory managment manually
    now instead.

    I believe you need to edit your c:\config.sys file, putting these two lines
    at the beginning:

    device=c:\windows\himem.sys /testmem:eek:ff
    device=c:\windows\emm386.exe

    After that, you may have the memory you need, or you may need to tweak the
    emm386 settings. (Type emm386 /? at the DOS prompt to get the
    options/parameters/syntax.)

    --
    "If there are no dogs in Heaven, then when I die, I want to go where
    THEY went." ~Will Rogers~
     
    Toolman Tim, Oct 31, 2004
    #4
  5. Eystein Finne wrote:

    > Hi
    >
    > I'm trying to run an old game (The Legacy - Microprose) on my PC with
    > win98se (don't know the dos version)
    > When starting the game I get the message that I need at least 610 000
    > bytes of conventional memory.
    >
    >
    > Earlier I used a program called memmaker to free some memory - but my
    > current version of Dos doesn't seem to have it. Is there any easy way for
    > me to make this game play?
    >

    From my memory, from times where we worked with win3.0 and real-mode network
    drivers together with a lot of tsrs, you should tune your config.sys and
    autoexec.bat like
    --- config.sys ---
    DEVICE=C:\windows\himem.sys
    DOS=HIGH,UMB
    DEVICE=C:\windows\emm386.exe NOEMS
    and then, if you have other DEVICE entries following that line, try to
    substitute DEVICE by DEVICEHIGH for each of them.
    Same goes for autoexec.bat, where you should substitute "load" with
    "loadhigh" or even better consider to REM out the stuff if not really
    necessary for your game. Remember, in win98 you can create a icon for your
    game and - under properties - chose to start into dos mode with even own
    startup files (config.sys and autoexec.bat) which you may streamline.
    However DON'T FORGET to SAVE your working current config.sys and
    autoexec.bat under different names, and prepare a (tested) startup floppy
    or use the bootable cdrom from '98, BEFORE you really change something.

    --
    Longhorn error#4711: TCPA / NGSCB VIOLATION: Microsoft optical mouse
    detected penguin patterns on mousepad. Partition scan in progress
     to remove offending incompatible products.  Reactivate your MS software.
    Linux woodpecker.homnet.at 2.6.8reiser4pkt [LinuxCounter#295241]
     
    Walter Mautner, Oct 31, 2004
    #5

  6. > From my memory, from times where we worked with win3.0 and real-mode

    network
    > drivers together with a lot of tsrs, you should tune your config.sys and
    > autoexec.bat like
    > --- config.sys ---
    > DEVICE=C:\windows\himem.sys
    > DOS=HIGH,UMB
    > DEVICE=C:\windows\emm386.exe NOEMS
    > and then, if you have other DEVICE entries following that line, try to
    > substitute DEVICE by DEVICEHIGH for each of them.
    > Same goes for autoexec.bat, where you should substitute "load" with
    > "loadhigh" or even better consider to REM out the stuff if not really
    > necessary for your game. Remember, in win98 you can create a icon for your
    > game and - under properties - chose to start into dos mode with even own
    > startup files (config.sys and autoexec.bat) which you may streamline.
    > However DON'T FORGET to SAVE your working current config.sys and
    > autoexec.bat under different names, and prepare a (tested) startup floppy
    > or use the bootable cdrom from '98, BEFORE you really change something.


    I'm not good at this but my settings in configsys are:

    DOS=HIGH,UMB
    Device=C:\WINDOWS\Himem.Sys
    DeviceHigh=C:\WINDOWS\EMM386.Exe

    Is it correct to change them to:

    DEVICE=C:\windows\himem.sys
    DOS=HIGH,UMB
    DEVICE=C:\windows\emm386.exe NOEMS

    And in autoexec bat I can't find any "load"

    It looks like this:

    SET TMP=C:\WINDOWS\TEMP
    SET TEMP=C:\WINDOWS\TEMP
    SET PROMPT=$p$g
    SET winbootdir=C:\WINDOWS
    SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
    SET BLASTER=A220 I7 D1 H5 P330 T6

    Please help me a step further
     
    Eystein Finne, Oct 31, 2004
    #6
  7. Eystein Finne wrote:

    >
    >> From my memory, from times where we worked with win3.0 and real-mode

    > network
    >> drivers together with a lot of tsrs, you should tune your config.sys and
    >> autoexec.bat like
    >> --- config.sys ---
    >> DEVICE=C:\windows\himem.sys
    >> DOS=HIGH,UMB
    >> DEVICE=C:\windows\emm386.exe NOEMS
    >> and then, if you have other DEVICE entries following that line, try to
    >> substitute DEVICE by DEVICEHIGH for each of them.
    >> Same goes for autoexec.bat, where you should substitute "load" with
    >> "loadhigh" or even better consider to REM out the stuff if not really
    >> necessary for your game. Remember, in win98 you can create a icon for
    >> your game and - under properties - chose to start into dos mode with even
    >> own startup files (config.sys and autoexec.bat) which you may streamline.
    >> However DON'T FORGET to SAVE your working current config.sys and
    >> autoexec.bat under different names, and prepare a (tested) startup floppy
    >> or use the bootable cdrom from '98, BEFORE you really change something.

    >
    > I'm not good at this but my settings in configsys are:
    >
    > DOS=HIGH,UMB
    > Device=C:\WINDOWS\Himem.Sys
    > DeviceHigh=C:\WINDOWS\EMM386.Exe
    >
    > Is it correct to change them to:
    >
    > DEVICE=C:\windows\himem.sys
    > DOS=HIGH,UMB
    > DEVICE=C:\windows\emm386.exe NOEMS
    >

    Well you don't need to change the order, just append the "noems".
    And please post a printout from "mem /c /p" when you started to DOS-only.
    There should also be the utility "msd" which gives a interesting memory map
    (I think it's F3).
    You may then try to add something like "I=B200-B7FF" but don't worry when
    your system doesn't boot afterwards: Press F5 and delete. There are also
    other, bigger UMB ranges you may be able to include, but my braincells left
    me this time :)

    > And in autoexec bat I can't find any "load"
    >

    ok, so you have no extra drivers.

    > Please help me a step further


    You will most probably have to start your game from plain dos, not from a
    windows command prompt. Win98 (think I already said) has this pifedit
    feature (right-click on icon or program link in start menue, select
    "properties") and a "advanced" button therein. You can make it restart in
    DOS mode and start the game automagically.
    --
    Longhorn error#4711: TCPA / NGSCB VIOLATION: Microsoft optical mouse
    detected penguin patterns on mousepad. Partition scan in progress
     to remove offending incompatible products.  Reactivate your MS software.
    Linux woodpecker.homnet.at 2.6.8reiser4pkt [LinuxCounter#295241]
     
    Walter Mautner, Oct 31, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ÆnÎGmÃ

    Running old dos games in XP

    ÆnÎGmÃ, Jul 19, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    710
    Ron Martell
    Jul 19, 2003
  2. Trevor Smith

    Re: Old Dos games on XP?

    Trevor Smith, Jul 19, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    503
    Trevor Smith
    Jul 19, 2003
  3. Ron Martell

    Re: Old Dos games on XP?

    Ron Martell, Jul 19, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    493
    Ron Martell
    Jul 19, 2003
  4. Auric__

    Re: Old Dos games on XP?

    Auric__, Jul 20, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    501
    Auric__
    Jul 20, 2003
  5. Mr.G  (@¿@)

    Old DOS games not running

    Mr.G (@¿@), Jan 10, 2009, in forum: Computer Support
    Replies:
    9
    Views:
    515
    Mr.G (@¿@)
    Jan 18, 2009
Loading...

Share This Page