Routing between ethernet interfaces on 1605r

Discussion in 'Cisco' started by Jeff Patton, Sep 18, 2006.

  1. Jeff Patton

    Jeff Patton Guest

    I am just wanting to configure a simple Lan to Lan router. I bought the
    1605r because it was the cheapest on ebay. I am beginning to wonder if
    I should have bought a different router.

    I have two networks that I want to be able to connect to each other. I
    don't need to get them to the internet I have an ISA box that does
    that. I would like to have the 192.168.1.0/24 on ethernet 0 and
    192.168.2.0/24 on ethernet 1.

    Running the QuickStart allows me to configure the appropriate IP's on
    each interface, but I think it does not enable IP routing between. I
    have just started playing with this today, here is the output of the
    show configuration command:

    Using 756 out of 7506 bytes
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname 1605r-w2
    !
    enable secret
    !
    username 1605r-w2 password
    ip subnet-zero
    no ip source-route
    !
    !
    !
    interface Ethernet0
    ip address 192.168.2.254 255.255.255.0
    no ip directed-broadcast
    no ip proxy-arp
    ip rip send version 1 2
    ip rip receive version 1 2
    !
    interface Ethernet1
    ip address 192.168.1.150 255.255.255.0
    no ip directed-broadcast
    no ip proxy-arp
    ip rip send version 1 2
    ip rip receive version 1 2
    !
    router rip
    network 192.168.1.0
    network 192.168.2.0
    !
    ip classless
    !
    !
    line con 0
    exec-timeout 120 0
    transport input none
    line vty 0 4
    exec-timeout 0 0
    login local
    !
    end
     
    Jeff Patton, Sep 18, 2006
    #1
    1. Advertising

  2. Hi Jeff,

    You may wish to investigate Cisco 1600 Series Router Documentation:

    http://www.cisco.com/en/US/products/hw/routers/ps214/tsd_products_support_eol_series_home.html

    Sincerely,

    Brad Reese
    BradReese.Com - Cisco Power Supply Headquarters
    http://www.bradreese.com/cisco-power-supply-inventory.htm
    1293 Hendersonville Road, Suite 17
    Asheville, North Carolina USA 28803
    USA & Canada: 877-549-2680
    International: 828-277-7272
    Fax: 775-254-3558
    AIM: R2MGrant
    BradReese.Com - Cisco Salary and Compensation Rates
    http://www.bradreese.com/compensation-database.htm
     
    www.BradReese.Com, Sep 19, 2006
    #2
    1. Advertising

  3. On Mon, 18 Sep 2006 13:59:21 -0700, Jeff Patton wrote:

    ....
    >
    > I have two networks that I want to be able to connect to each other. I
    > don't need to get them to the internet I have an ISA box that does
    > that. I would like to have the 192.168.1.0/24 on ethernet 0 and
    > 192.168.2.0/24 on ethernet 1.
    >
    > Running the QuickStart allows me to configure the appropriate IP's on
    > each interface, but I think it does not enable IP routing between. I
    > have just started playing with this today, here is the output of the
    > show configuration command:
    >
    > Using 756 out of 7506 bytes
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > !
    > hostname 1605r-w2
    > !
    > enable secret
    > !
    > username 1605r-w2 password
    > ip subnet-zero
    > no ip source-route
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.2.254 255.255.255.0
    > no ip directed-broadcast
    > no ip proxy-arp
    > ip rip send version 1 2
    > ip rip receive version 1 2
    > !
    > interface Ethernet1
    > ip address 192.168.1.150 255.255.255.0
    > no ip directed-broadcast
    > no ip proxy-arp
    > ip rip send version 1 2
    > ip rip receive version 1 2
    > !
    > router rip
    > network 192.168.1.0
    > network 192.168.2.0
    > !
    > ip classless
    > !

    ....
    > !
    > end


    Routing "between" the interfaces on the router is automatic once the
    interfaces have an address and are in the up/up state.

    How are the hosts on the two networks configured?

    Assume the ISA box is on 192.168.1.0/24 and it isn't running RIP.

    The hosts on the 192.168.2.0/24 network need a default gateway of
    192.168.2.254.

    If you want all your hosts to have internet access the router needs a
    default route pointing at the ISA box.

    !
    ip route 0.0.0.0 0.0.0.0 <ip address of ISA box>
    !

    The ISA box also needs a specific route for the local network it isn't
    connected to.

    route add 192.168.2.0 mask 255.255.255.0 192.168.1.150 <? syntax>

    The hosts on the same network as the ISA box need a default gateway of
    the ISA box and and a specifc route for the network across the router.

    route add 0.0.0.0 mask 0.0.0.0 <ip address of ISA box> <? syntax>
    route add 192.168.2.0 mask 255.255.255.0 192.168.1.150 <? syntax>

    The router probably doesn't need to be running RIP. Do "show ip
    protocols" and look at the "Routing Information Sources". If there aren't
    any the router has noone to talk to and you can take it out.

    To see if, e.g., 192.168.2.24 is properly configured, ping (1)
    192.168.2.254, then (2) 192.168.1.150, then (3) the ISA box, then (4)
    some well known address in the internet.

    If you can do 1 but not 2, check your host config and that the router
    interfaces are line up/protocol up.

    If you can do 2 but not 3, the ISA box doesn't know how to get back to
    you.

    If you can do 3 but not 4, check the NAT/etc. configuration in the ISA
    box.

    --
    Rgds,
    Martin
     
    Martin Gallagher, Sep 19, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    657
    aservin
    Jul 4, 2005
  2. rob
    Replies:
    8
    Views:
    4,659
    Wayne
    Jul 9, 2005
  3. Replies:
    3
    Views:
    495
  4. corb
    Replies:
    0
    Views:
    355
  5. ve7eje
    Replies:
    2
    Views:
    969
    Doug McIntyre
    Mar 25, 2010
Loading...

Share This Page