Router RIP Network Command Help

Discussion in 'Cisco' started by David Jones, Aug 29, 2004.

  1. David Jones

    David Jones Guest

    Hey gang,
    I'm working with a pair of 2501's connected directly together S0-S1
    back to back. In working towards my CCNA, I'm trying to make them talk
    and have hit a problem.

    To make it all work with my existing network, I'm staying within my
    private 192.168.X.X network. On my serial interfaces, I'm using the
    192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    have successfully gotten network 192.168.0.0 and network 192.168.2.0
    working, but network 192.168.2.4 won't hold. When I enter the command,
    I get no indication of an error, but when I show run, it does not
    appear. I have tried it with both no ip classless and ip classless.

    Below you'll find my running-config. Please let me know what I'm
    missing, or what I need to change.

    This may seem to be a stupid question, but I'm a relative newbie. :)

    Thanks ~ David

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname "Router2501T"
    !
    enable secret 5 $1$KBFL$nyWLe9tSecG9O.7MdklTw0
    !
    no ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.0.254 255.255.255.0
    no mop enabled
    !
    interface Serial0
    ip address 192.168.2.1 255.255.255.252
    !
    interface Serial1
    ip address 192.168.2.5 255.255.255.252
    !
    router rip
    network 192.168.0.0
    network 192.168.2.0
    !
    ip classless
    no ip http server
    !
    !
    !
    line con 0
    line aux 0
    line vty 0
    password nyesh#4olada
    login
    length 50
    line vty 1 4
    password nyesh#4olada
    login
    length 25
    !
    end
    David Jones, Aug 29, 2004
    #1
    1. Advertising

  2. David Jones

    PES Guest

    "David Jones" <> wrote in message
    news:...
    > Hey gang,
    > I'm working with a pair of 2501's connected directly together S0-S1
    > back to back. In working towards my CCNA, I'm trying to make them talk
    > and have hit a problem.
    >
    > To make it all work with my existing network, I'm staying within my
    > private 192.168.X.X network. On my serial interfaces, I'm using the
    > 192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    > have successfully gotten network 192.168.0.0 and network 192.168.2.0
    > working, but network 192.168.2.4 won't hold. When I enter the command,
    > I get no indication of an error, but when I show run, it does not
    > appear. I have tried it with both no ip classless and ip classless.


    192.168.2.0 and 192.168.2.4 are the same classful network. When you enter
    the router rip - network commands it will assume classful. When used in
    conjunction with the ip classless commands, it should assume that all
    192.168.2.x subnetworks are the same as the ones it has. If you switch
    to rip v2 subnet masks should be carried with all route entries in the
    rip packet, giving you more flexibility and functionality.

    >
    > Below you'll find my running-config. Please let me know what I'm
    > missing, or what I need to change.
    >
    > This may seem to be a stupid question, but I'm a relative newbie. :)
    >
    > Thanks ~ David
    >
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname "Router2501T"
    > !
    > enable secret 5 $1$KBFL$nyWLe9tSecG9O.7MdklTw0
    > !
    > no ip subnet-zero
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.0.254 255.255.255.0
    > no mop enabled
    > !
    > interface Serial0
    > ip address 192.168.2.1 255.255.255.252
    > !
    > interface Serial1
    > ip address 192.168.2.5 255.255.255.252
    > !
    > router rip
    > network 192.168.0.0
    > network 192.168.2.0
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0
    > password nyesh#4olada
    > login
    > length 50
    > line vty 1 4
    > password nyesh#4olada
    > login
    > length 25
    > !
    > end
    PES, Aug 29, 2004
    #2
    1. Advertising

  3. "David Jones" <> wrote in message
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname "Router2501T"
    > !
    > enable secret 5 $1$KBFL$nyWLe9tSecG9O.7MdklTw0
    > !
    > no ip subnet-zero



    Try : ip subnet-zero

    HTH
    Martin Bilgrav
    Martin Bilgrav, Aug 29, 2004
    #3
  4. David Jones

    Jonathan Guest

    "Martin Bilgrav" <> wrote in message
    news:i1sYc.41688$...
    >
    > "David Jones" <> wrote in message
    >> version 12.2
    >> service timestamps debug uptime
    >> service timestamps log uptime
    >> no service password-encryption
    >> service udp-small-servers
    >> service tcp-small-servers
    >> !
    >> hostname "Router2501T"
    >> !
    >> enable secret 5 $1$KBFL$nyWLe9tSecG9O.7MdklTw0
    >> !
    >> no ip subnet-zero

    >
    >
    > Try : ip subnet-zero
    >


    Which will have no effect on the way RIP works.



    Jonathan
    Jonathan, Aug 29, 2004
    #4
  5. David Jones

    AnyBody43 Guest

    (David Jones) wrote
    > I'm working with a pair of 2501's connected directly together S0-S1
    > back to back. In working towards my CCNA, I'm trying to make them talk
    > and have hit a problem.
    >
    > To make it all work with my existing network, I'm staying within my
    > private 192.168.X.X network. On my serial interfaces, I'm using the
    > 192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    > have successfully gotten network 192.168.0.0 and network 192.168.2.0
    > working, but network 192.168.2.4 won't hold. When I enter the command,
    > I get no indication of an error, but when I show run, it does not
    > appear. I have tried it with both no ip classless and ip classless.


    It does appear! I see it in your config!
    > ip address 192.168.2.5 255.255.255.252


    Maybe you mean
    ip address 192.168.2.4 255.255.255.252
    doesn't work.

    This won't work since the host portion of the adderss is zero
    which is not allowed.

    192. 168. 2. 4
    . 128 + 16+. .
    128 + 64 . 8 + 4 + 2. 2 . 4
    Address 1100-0000. 1001-1110. 0000-0010. 0000-01 00
    mask 1111-1111. 1111-1111. 1111-1111. 1111-11 00
    ########## network portion ########### #host#

    Host portion cannot be all 1's or all 0's
    00 0 not allowed (obsolete broadcast) 00
    01 1 valid host 01
    10 2 valid host 10
    11 3 IP 'directed' broadcast 11

    The allowed addersses for network 192.168.2.4 255.255.255.252
    are 192.168.2.5, 192.168.2.6.


    > Below you'll find my running-config. Please let me know what I'm
    > missing, or what I need to change.


    > no ip subnet-zero
    > !
    > interface Ethernet0
    > ip address 192.168.0.254 255.255.255.0
    > no mop enabled
    > !
    > interface Serial0
    > ip address 192.168.2.1 255.255.255.252
    > !
    > interface Serial1
    > ip address 192.168.2.5 255.255.255.252
    > !
    > router rip
    > network 192.168.0.0
    > network 192.168.2.0
    > !
    > ip classless


    There are issues with RIP v1 (I don't know what happens if ver
    is not specified in config) which only understands one subnet
    mask and here you are using two different ones. It will choose
    one of other of the ones that you have used, I don't know the
    process.

    I suggest:-
    Simplify matters by using addresses as follows:-
    I believe that 192.168.0.254/24 will be OK but
    I am not 100% sure, (only 99%). Ditch that too.

    Router1:-
    interface Ethernet0
    ip address 192.168.1.254 255.255.255.0
    !
    interface Serial0
    description Connected to Router2 S0
    ip address 192.168.20.1 255.255.255.0
    !
    interface Serial1
    description Connected to Router2 S1
    ip address 192.168.30.1 255.255.255.0
    !
    router rip
    network 192.168.1.0
    network 192.168.20.0
    network 192.168.30.0


    Router2:-
    interface Ethernet0
    ip address 192.168.2.254 255.255.255.0
    !
    interface Serial0
    description Connected to Router1 S0
    ip address 192.168.20.2 255.255.255.0
    !
    interface Serial1
    description Connected to Router1 S1
    ip address 192.168.30.2 255.255.255.0
    !
    router rip
    network 192.168.2.0
    network 192.168.20.0
    network 192.168.30.0

    Once you get it working you can them make incremental changes
    until you get it working the way you want.

    There is of course no reason that your original addressing scheme
    will not work with another dynamic routing protocol such as
    RIP V2, EIGRP, OSPF.

    Good luck.
    AnyBody43, Aug 30, 2004
    #5
  6. David Jones

    mh Guest

    This behavious is as it should be as the RIP network commands to not
    support wildcard masks for subnets.

    The command "ip classless" will not change this behaviour; nor will
    configuring "version 2" under the rip routing process



    STUB(config)#router rip
    STUB(config-router)#network 4.1.1.1
    STUB(config-router)#exit
    STUB(config)#exit



    STUB#sh run | beg router rip
    router rip
    network 4.0.0.0
    mh, Aug 30, 2004
    #6
  7. "mh" <> wrote in message
    >
    > STUB#sh run | beg router rip
    > router rip
    > network 4.0.0.0


    This isnt version 2.

    try these;

    #sho ip protocols
    Routing Protocol is "rip"
    Sending updates every 30 seconds, next due in 21 seconds
    Invalid after 180 seconds, hold down 180, flushed after 240
    Outgoing update filter list for all interfaces is not set
    Incoming update filter list for all interfaces is not set
    Redistributing: static, rip
    Default version control: send version 2, receive version 2
    Interface Send Recv Triggered RIP Key-chain
    Ethernet0 2 2
    Automatic network summarization is not in effect
    Maximum path: 4
    Routing for Networks:
    192.168.0.0
    Routing Information Sources:
    Gateway Distance Last Update
    Distance: (default is 120)


    ************

    router rip
    version 2
    network 192.168.0.0
    no auto-summary

    ************
    Martin Bilgrav, Aug 30, 2004
    #7
  8. David Jones

    VolatileAcid Guest

    With so many conflicting answers... I feel sorry for you.
    VolatileAcid, Aug 31, 2004
    #8
  9. David Jones

    carl Guest

    Hi

    if you are entering the following in config mode:

    router rip
    network 192.168.0.0
    network 192.168.2.0
    network 192.168.2.4

    you will only see the following in the running config:

    router rip
    network 192.168.0.0
    network 192.168.2.0

    you can only specify major networks under the rip process (version 1 and
    version 2) BUT this should not stop the routing from working. If there is an
    interface that falls into this major network on your router but you do not
    want RIP to run on the interface then use the 'passive-interface' command.

    Carl

    "David Jones" <> wrote in message
    news:...
    > Hey gang,
    > I'm working with a pair of 2501's connected directly together S0-S1
    > back to back. In working towards my CCNA, I'm trying to make them talk
    > and have hit a problem.
    >
    > To make it all work with my existing network, I'm staying within my
    > private 192.168.X.X network. On my serial interfaces, I'm using the
    > 192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    > have successfully gotten network 192.168.0.0 and network 192.168.2.0
    > working, but network 192.168.2.4 won't hold. When I enter the command,
    > I get no indication of an error, but when I show run, it does not
    > appear. I have tried it with both no ip classless and ip classless.
    >
    > Below you'll find my running-config. Please let me know what I'm
    > missing, or what I need to change.
    >
    > This may seem to be a stupid question, but I'm a relative newbie. :)
    >
    > Thanks ~ David
    >
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname "Router2501T"
    > !
    > enable secret 5 $1$KBFL$nyWLe9tSecG9O.7MdklTw0
    > !
    > no ip subnet-zero
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.0.254 255.255.255.0
    > no mop enabled
    > !
    > interface Serial0
    > ip address 192.168.2.1 255.255.255.252
    > !
    > interface Serial1
    > ip address 192.168.2.5 255.255.255.252
    > !
    > router rip
    > network 192.168.0.0
    > network 192.168.2.0
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0
    > password nyesh#4olada
    > login
    > length 50
    > line vty 1 4
    > password nyesh#4olada
    > login
    > length 25
    > !
    > end
    carl, Sep 1, 2004
    #9
  10. David Jones

    Hansang Bae Guest

    In article <>,
    says...
    > Hey gang,
    > I'm working with a pair of 2501's connected directly together S0-S1
    > back to back. In working towards my CCNA, I'm trying to make them talk
    > and have hit a problem.
    >
    > To make it all work with my existing network, I'm staying within my
    > private 192.168.X.X network. On my serial interfaces, I'm using the
    > 192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    > have successfully gotten network 192.168.0.0 and network 192.168.2.0
    > working, but network 192.168.2.4 won't hold. When I enter the command,
    > I get no indication of an error, but when I show run, it does not
    > appear. I have tried it with both no ip classless and ip classless.


    You are entering "network 192.168.2.0" under rip which tells the router
    to run RIP instance on *all* interfaces that are in the 192.168.2.0 /24
    address space.

    >
    > Below you'll find my running-config. Please let me know what I'm
    > missing, or what I need to change.
    >
    > This may seem to be a stupid question, but I'm a relative newbie. :)


    There's nothing wrong. But since you are using the zero subnet, "ip
    subnet-zero" would be a good idea.

    [snip config}

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Sep 4, 2004
    #10
  11. David Jones

    PJML Guest

    Hansang Bae wrote:
    > In article <>,
    > says...
    >
    >>Hey gang,
    >>I'm working with a pair of 2501's connected directly together S0-S1
    >>back to back. In working towards my CCNA, I'm trying to make them talk
    >>and have hit a problem.
    >>
    >>To make it all work with my existing network, I'm staying within my
    >>private 192.168.X.X network. On my serial interfaces, I'm using the
    >>192.168.2.0 and 192.168.2.4 networks, each with the 30 bit mask. I
    >>have successfully gotten network 192.168.0.0 and network 192.168.2.0
    >>working, but network 192.168.2.4 won't hold. When I enter the command,
    >>I get no indication of an error, but when I show run, it does not
    >>appear. I have tried it with both no ip classless and ip classless.

    >
    >
    > You are entering "network 192.168.2.0" under rip which tells the router
    > to run RIP instance on *all* interfaces that are in the 192.168.2.0 /24
    > address space.


    Also remember that RIP is quite an old protocol which
    [in default guise] dates from before CIDE and so still
    assumes classful subnetting; I've not used it for so
    long that I can't remember the details but I believe
    RIP1 cannot differentiate a subnet smaller than a /24

    Solutions: either use RIP2 [assuming your release
    supports it] or use 2 networks in different /24s
    PJML, Sep 6, 2004
    #11
  12. David Jones

    Hansang Bae Guest

    In article <>, back says...
    > Also remember that RIP is quite an old protocol which
    > [in default guise] dates from before CIDE and so still
    > assumes classful subnetting; I've not used it for so
    > long that I can't remember the details but I believe
    > RIP1 cannot differentiate a subnet smaller than a /24
    >
    > Solutions: either use RIP2 [assuming your release
    > supports it] or use 2 networks in different /24s


    Cisco boxes infer the mask from the interface. So if you have a /28
    10.x.x.x, it assumes everyone in 10.0.0.0 is a /28.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Sep 7, 2004
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jh3ang

    2 way of router rip command ?

    jh3ang, Apr 10, 2006, in forum: Cisco
    Replies:
    1
    Views:
    955
  2. Wendell

    converting accuset 1200 HW rip to software rip

    Wendell, Jun 5, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    1,028
    Wendell
    Jun 5, 2004
  3. chuckcar
    Replies:
    11
    Views:
    9,404
    §ñühw¤£f
    Apr 21, 2009
  4. Evan Platt
    Replies:
    1
    Views:
    843
    John Holmes
    Apr 18, 2009
  5. §ñühw¤£f
    Replies:
    2
    Views:
    1,478
    §ñühw¤£f
    Apr 19, 2009
Loading...

Share This Page