Router - Pix -Switch

Discussion in 'Hardware' started by harrymiller, Nov 9, 2006.

  1. harrymiller

    harrymiller

    Joined:
    Oct 9, 2006
    Messages:
    3
    Guys,


    my current scenario is firewall [pix515]-linksys[dhcp]- switch

    Now i am planning to go for
    Router 2500- firewall - switch scenario

    i cannot use NAT for 30 pc's on firewall as this blocks my VPN (secure computing vpn)
    can I use cisco2500 for NATing. I got only 16IPs.

    Please give me the configuration for the cisco 2500 series and how I would cahnge the below firewall settings

    my current config for firewall is
    Written by harry at 22:34:16.637 UTC Tue Oct 17 2006
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto shutdown
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 dmz security10
    enable password 2KFQnbNIdI.2KYOU encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname mypix
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol esp-ike
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol pptp 1723
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit esp host x.x.x.x any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    mtu dmz 1500
    ip address outside 55.22.22.243 255.255.255.0
    ip address inside 192.168.30.1 255.255.255.0
    no ip address dmz
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.15.105 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    static (inside,outside) 55.22.22.244 192.168.30.2 netmask 255.255.255.255 0 0 [192.168.30.2 is my linksys switch which NATs my rest of PC's]
    access-group 101 in interface outside
    route outside 0.0.0.0 0.0.0.0 55.22.22.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http x.x.x.x 255.255.255.255 outside
    http 192.168.30.2 255.255.255.255 inside
    http 192.0.0.0 255.0.0.0 inside
    http 192.168.15.105 255.255.255.255 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    telnet 192.168.30.0 255.255.255.0 inside
    telnet timeout 5
    ssh x.x.x.x 255.255.255.255 outside
    ssh 192.168.30.2 255.255.255.255 inside
    ssh timeout 5
    console timeout 0
     
    harrymiller, Nov 9, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. runjasonrun

    PIX, switch, and a router

    runjasonrun, Jul 23, 2006, in forum: Cisco
    Replies:
    1
    Views:
    753
    runjasonrun
    Jul 26, 2006
  2. qazmlp1209@rediffmail.com
    Replies:
    4
    Views:
    2,918
    Doug McIntyre
    Aug 16, 2006
  3. Ryan
    Replies:
    1
    Views:
    561
    Walter Roberson
    Oct 28, 2006
  4. nazeth
    Replies:
    0
    Views:
    2,765
    nazeth
    Mar 28, 2007
  5. John Strow
    Replies:
    2
    Views:
    665
    John Strow
    Mar 1, 2008
Loading...

Share This Page