Router on a stick

Discussion in 'Cisco' started by Fred Atkinson, Nov 1, 2005.

  1. Folks, I was planning to set up a lab experiment involving
    router-on-a-stick. We have Cisco 2600 series routers.

    However, when I try to configure the FastEthernet interface,
    the commands (from the Cisco book) don't seem to work.

    Any idea how to do this on a Cisco 2600 router?



    Fred
    Fred Atkinson, Nov 1, 2005
    #1
    1. Advertising

  2. Fred Atkinson

    Merv Guest

    Post the IOS version in use and the commands that you tried to config
    Merv, Nov 1, 2005
    #2
    1. Advertising

  3. Fred Atkinson

    Cen Guest

    http://www.cisco.com/warp/public/473/50.shtml


    "Fred Atkinson" <> wrote in message
    news:...
    > Folks, I was planning to set up a lab experiment involving
    > router-on-a-stick. We have Cisco 2600 series routers.
    >
    > However, when I try to configure the FastEthernet interface,
    > the commands (from the Cisco book) don't seem to work.
    >
    > Any idea how to do this on a Cisco 2600 router?
    >
    >
    >
    > Fred
    Cen, Nov 2, 2005
    #3
  4. On 1 Nov 2005 11:19:41 -0800, "Merv" <> wrote:

    >Post the IOS version in use and the commands that you tried to config


    Well,

    I got an email from Juan Carlos. I believe he has solved the
    mystery. Read his response below.

    I am able to create the trunk link between the router and
    the switch now.

    Regards,



    Fred

    From: "Juan Carlos" <>
    To: "Fred Atkinson" <>
    Sent: Wednesday, November 02, 2005 10:28 AM
    Subject: Re: Router on a stick


    > Hi,
    >
    > How are you?
    >
    > Look:
    >
    > In the interface f0/0 create the subinterfaces
    >
    > for example for two Vlan2 an Vlan3 in different subnets:
    >
    > in the router:
    > interface f0/0.2
    > encapsulation dot1q 2 --> for vlan2
    > exit...
    > ip address 192.168.0.65 255.255.255.240
    > interface f0/0.3
    > encapsulation dot1q 3 --> for vlan3
    > ip address 192.168.0.5 255.255.255.240
    > exit..
    >
    > no shutdown to physical interface
    >
    > Remember in the switch interface to Router use the: switchport mode
    > trunk (don`t use ISL)
    >
    >
    > Good luck!
    >
    > regards
    > Juan Carlos Spichiger
    >
    Fred Atkinson, Nov 6, 2005
    #4
  5. I set up the Router on a stick lab. I seem to have followed
    all the instructions. The weird thing is that the VLANs in the switch
    are showing adminstratively down.

    I am showing the vlan status followed by the switch
    configuration followed by the router configuration. Can anyone tell
    me what is wrong?



    Fred

    VLAN interfaces in switch:

    VLAN1 is up, line protocol is up
    Hardware is CPU Interface, address is 0004.27da.0980 (bia
    0004.27da.0980)
    Internet address is 192.168.1.200/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:47:28, output 00:54:15, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    488 packets input, 51619 bytes, 0 no buffer
    Received 488 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    2 packets output, 120 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    VLAN2 is administratively down, line protocol is down
    Hardware is CPU Interface, address is 0004.27da.0980 (bia
    0004.27da.0980)
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA
    ARP type: ARPA, ARP Timeout 04:00:00
    VLAN3 is administratively down, line protocol is down
    Hardware is CPU Interface, address is 0004.27da.0980 (bia
    0004.27da.0980)
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA
    ARP type: ARPA, ARP Timeout 04:00:00
    VLAN4 is administratively down, line protocol is down
    Hardware is CPU Interface, address is 0004.27da.0980 (bia
    0004.27da.0980)
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA
    ARP type: ARPA, ARP Timeout 04:00:00
    VLAN5 is administratively down, line protocol is down
    Hardware is CPU Interface, address is 0004.27da.0980 (bia
    0004.27da.0980)
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA
    ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0/1 is up, line protocol is up
    Hardware is Fast Ethernet, address is 0004.27da.0981 (bia
    0004.27da.0981)
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:24, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 1000 bits/sec, 6 packets/sec
    434 packets input, 52955 bytes
    Received 107 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 107 multicast
    0 input packets with dribble condition detected
    20219 packets output, 783079 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/2 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0982 (bia
    0004.27da.0982)
    MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:47:43, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    569 packets input, 60884 bytes
    Received 565 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 25 multicast
    0 input packets with dribble condition detected
    388 packets output, 19280 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/3 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0983 (bia
    0004.27da.0983)
    MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:34:17, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    296 packets input, 26764 bytes
    Received 295 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    857 packets output, 35880 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/4 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0984 (bia
    0004.27da.0984)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:33, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    7 packets output, 1192 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/5 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0985 (bia
    0004.27da.0985)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:35, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    7 packets output, 1192 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/6 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0986 (bia
    0004.27da.0986)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:37, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    7 packets output, 1192 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/7 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0987 (bia
    0004.27da.0987)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:37, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 880 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/8 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0988 (bia
    0004.27da.0988)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:39, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 880 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/9 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.0989 (bia
    0004.27da.0989)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:40, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 880 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/10 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.098a (bia
    0004.27da.098a)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:42, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 882 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/11 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.098b (bia
    0004.27da.098b)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:44, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 882 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    FastEthernet0/12 is down, line protocol is down
    Hardware is Fast Ethernet, address is 0004.27da.098c (bia
    0004.27da.098c)
    MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , Auto Speed , 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:46, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast
    0 input packets with dribble condition detected
    8 packets output, 882 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    GigabitEthernet0/1 is down, line protocol is down
    Hardware is Gigabit Ethernet, address is 0004.27da.098d (bia
    0004.27da.098d)
    MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , link type is autonegotiation, media type is SX
    output flow-control is off, input flow-control is off
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:47, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    8 packets output, 896 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out
    GigabitEthernet0/2 is down, line protocol is down
    Hardware is Gigabit Ethernet, address is 0004.27da.098e (bia
    0004.27da.098e)
    MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    Auto-duplex , link type is autonegotiation, media type is SX
    output flow-control is off, input flow-control is off
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input never, output 00:54:49, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    8 packets output, 896 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out


    Switch configuration


    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    interface FastEthernet0/1
    switchport access vlan 2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    switchport access vlan 2
    spanning-tree portfast
    !
    interface FastEthernet0/4
    switchport access vlan 3
    spanning-tree portfast
    !
    interface FastEthernet0/5
    switchport access vlan 4
    spanning-tree portfast
    !
    interface FastEthernet0/6
    switchport access vlan 5
    spanning-tree portfast
    !
    interface FastEthernet0/7
    switchport access vlan 2
    !
    interface FastEthernet0/8
    switchport access vlan 3
    !
    interface FastEthernet0/9
    switchport access vlan 4
    !
    interface FastEthernet0/10
    switchport access vlan 5
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface VLAN1
    ip address 192.168.1.200 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    !
    interface VLAN2
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN3
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN4
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN5
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    ip default-gateway 192.168.1.1
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    login
    line vty 5 15
    login
    !
    end



    Router configuration


    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    logging queue-limit 100
    !
    ip subnet-zero
    !
    !
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0
    !
    interface FastEthernet0/0.4
    encapsulation dot1Q 4
    ip address 192.168.4.1 255.255.255.0
    !
    interface FastEthernet0/0.5
    encapsulation dot1Q 5
    ip address 192.168.5.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    ip address 192.168.0.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    !
    interface FastEthernet0/1.2
    !
    interface FastEthernet0/1.3
    !
    interface FastEthernet0/1.4
    !
    interface FastEthernet0/1.5
    !
    interface FastEthernet0/1.6
    !
    ip classless
    ip http server
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end
    Fred Atkinson, Nov 8, 2005
    #5
  6. Fred Atkinson

    mike jones Guest

    do a 'no shutdown' on each VLAN. they are default shutdown when you create
    them

    '"Fred Atkinson" <> wrote in message
    news:...
    > I set up the Router on a stick lab. I seem to have followed
    > all the instructions. The weird thing is that the VLANs in the switch
    > are showing adminstratively down.
    >
    > I am showing the vlan status followed by the switch
    > configuration followed by the router configuration. Can anyone tell
    > me what is wrong?
    >
    >
    >
    > Fred
    >
    > VLAN interfaces in switch:
    >
    > VLAN1 is up, line protocol is up
    > Hardware is CPU Interface, address is 0004.27da.0980 (bia
    > 0004.27da.0980)
    > Internet address is 192.168.1.200/24
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input 00:47:28, output 00:54:15, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 488 packets input, 51619 bytes, 0 no buffer
    > Received 488 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 input packets with dribble condition detected
    > 2 packets output, 120 bytes, 0 underruns
    > 0 output errors, 0 collisions, 0 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > VLAN2 is administratively down, line protocol is down
    > Hardware is CPU Interface, address is 0004.27da.0980 (bia
    > 0004.27da.0980)
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA
    > ARP type: ARPA, ARP Timeout 04:00:00
    > VLAN3 is administratively down, line protocol is down
    > Hardware is CPU Interface, address is 0004.27da.0980 (bia
    > 0004.27da.0980)
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA
    > ARP type: ARPA, ARP Timeout 04:00:00
    > VLAN4 is administratively down, line protocol is down
    > Hardware is CPU Interface, address is 0004.27da.0980 (bia
    > 0004.27da.0980)
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA
    > ARP type: ARPA, ARP Timeout 04:00:00
    > VLAN5 is administratively down, line protocol is down
    > Hardware is CPU Interface, address is 0004.27da.0980 (bia
    > 0004.27da.0980)
    > MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA
    > ARP type: ARPA, ARP Timeout 04:00:00
    > FastEthernet0/1 is up, line protocol is up
    > Hardware is Fast Ethernet, address is 0004.27da.0981 (bia
    > 0004.27da.0981)
    > MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input 00:00:24, output 00:00:00, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 1000 bits/sec, 6 packets/sec
    > 434 packets input, 52955 bytes
    > Received 107 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 107 multicast
    > 0 input packets with dribble condition detected
    > 20219 packets output, 783079 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/2 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0982 (bia
    > 0004.27da.0982)
    > MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:47:43, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 569 packets input, 60884 bytes
    > Received 565 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 25 multicast
    > 0 input packets with dribble condition detected
    > 388 packets output, 19280 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/3 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0983 (bia
    > 0004.27da.0983)
    > MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:34:17, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 296 packets input, 26764 bytes
    > Received 295 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 857 packets output, 35880 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/4 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0984 (bia
    > 0004.27da.0984)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:33, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 7 packets output, 1192 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/5 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0985 (bia
    > 0004.27da.0985)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:35, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 7 packets output, 1192 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/6 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0986 (bia
    > 0004.27da.0986)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:37, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 7 packets output, 1192 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/7 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0987 (bia
    > 0004.27da.0987)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:37, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 880 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/8 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0988 (bia
    > 0004.27da.0988)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:39, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 880 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/9 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.0989 (bia
    > 0004.27da.0989)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:40, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 880 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/10 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.098a (bia
    > 0004.27da.098a)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:42, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 882 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/11 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.098b (bia
    > 0004.27da.098b)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:44, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 882 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > FastEthernet0/12 is down, line protocol is down
    > Hardware is Fast Ethernet, address is 0004.27da.098c (bia
    > 0004.27da.098c)
    > MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , Auto Speed , 100BaseTX/FX
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:46, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast
    > 0 input packets with dribble condition detected
    > 8 packets output, 882 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier
    > 0 output buffer failures, 0 output buffers swapped out
    > GigabitEthernet0/1 is down, line protocol is down
    > Hardware is Gigabit Ethernet, address is 0004.27da.098d (bia
    > 0004.27da.098d)
    > MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , link type is autonegotiation, media type is SX
    > output flow-control is off, input flow-control is off
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:47, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes, 0 no buffer
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast, 0 pause input
    > 8 packets output, 896 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier, 0 pause output
    > 0 output buffer failures, 0 output buffers swapped out
    > GigabitEthernet0/2 is down, line protocol is down
    > Hardware is Gigabit Ethernet, address is 0004.27da.098e (bia
    > 0004.27da.098e)
    > MTU 1500 bytes, BW 0 Kbit, DLY 0 usec,
    > reliability 255/255, txload 1/255, rxload 1/255
    > Encapsulation ARPA, loopback not set
    > Keepalive not set
    > Auto-duplex , link type is autonegotiation, media type is SX
    > output flow-control is off, input flow-control is off
    > ARP type: ARPA, ARP Timeout 04:00:00
    > Last input never, output 00:54:49, output hang never
    > Last clearing of "show interface" counters never
    > Queueing strategy: fifo
    > Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    > 5 minute input rate 0 bits/sec, 0 packets/sec
    > 5 minute output rate 0 bits/sec, 0 packets/sec
    > 1 packets input, 64 bytes, 0 no buffer
    > Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    > 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    > 0 watchdog, 0 multicast, 0 pause input
    > 8 packets output, 896 bytes, 0 underruns
    > 0 output errors, 0 collisions, 1 interface resets
    > 0 babbles, 0 late collision, 0 deferred
    > 0 lost carrier, 0 no carrier, 0 pause output
    > 0 output buffer failures, 0 output buffers swapped out
    >
    >
    > Switch configuration
    >
    >
    > !
    > version 12.0
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Switch
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > interface FastEthernet0/1
    > switchport access vlan 2
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    > !
    > interface FastEthernet0/2
    > !
    > interface FastEthernet0/3
    > switchport access vlan 2
    > spanning-tree portfast
    > !
    > interface FastEthernet0/4
    > switchport access vlan 3
    > spanning-tree portfast
    > !
    > interface FastEthernet0/5
    > switchport access vlan 4
    > spanning-tree portfast
    > !
    > interface FastEthernet0/6
    > switchport access vlan 5
    > spanning-tree portfast
    > !
    > interface FastEthernet0/7
    > switchport access vlan 2
    > !
    > interface FastEthernet0/8
    > switchport access vlan 3
    > !
    > interface FastEthernet0/9
    > switchport access vlan 4
    > !
    > interface FastEthernet0/10
    > switchport access vlan 5
    > !
    > interface FastEthernet0/11
    > !
    > interface FastEthernet0/12
    > !
    > interface GigabitEthernet0/1
    > !
    > interface GigabitEthernet0/2
    > !
    > interface VLAN1
    > ip address 192.168.1.200 255.255.255.0
    > no ip directed-broadcast
    > no ip route-cache
    > !
    > interface VLAN2
    > no ip directed-broadcast
    > no ip route-cache
    > shutdown
    > !
    > interface VLAN3
    > no ip directed-broadcast
    > no ip route-cache
    > shutdown
    > !
    > interface VLAN4
    > no ip directed-broadcast
    > no ip route-cache
    > shutdown
    > !
    > interface VLAN5
    > no ip directed-broadcast
    > no ip route-cache
    > shutdown
    > !
    > ip default-gateway 192.168.1.1
    > !
    > line con 0
    > transport input none
    > stopbits 1
    > line vty 0 4
    > login
    > line vty 5 15
    > login
    > !
    > end
    >
    >
    >
    > Router configuration
    >
    >
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router
    > !
    > logging queue-limit 100
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > call rsvp-sync
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > interface FastEthernet0/0
    > no ip address
    > shutdown
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0/0.1
    > encapsulation dot1Q 1 native
    > ip address 192.168.1.1 255.255.255.0
    > !
    > interface FastEthernet0/0.2
    > encapsulation dot1Q 2
    > ip address 192.168.2.1 255.255.255.0
    > !
    > interface FastEthernet0/0.3
    > encapsulation dot1Q 3
    > ip address 192.168.3.1 255.255.255.0
    > !
    > interface FastEthernet0/0.4
    > encapsulation dot1Q 4
    > ip address 192.168.4.1 255.255.255.0
    > !
    > interface FastEthernet0/0.5
    > encapsulation dot1Q 5
    > ip address 192.168.5.1 255.255.255.0
    > !
    > interface Serial0/0
    > no ip address
    > shutdown
    > !
    > interface FastEthernet0/1
    > ip address 192.168.0.1 255.255.255.0
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0/1.1
    > encapsulation dot1Q 1 native
    > !
    > interface FastEthernet0/1.2
    > !
    > interface FastEthernet0/1.3
    > !
    > interface FastEthernet0/1.4
    > !
    > interface FastEthernet0/1.5
    > !
    > interface FastEthernet0/1.6
    > !
    > ip classless
    > ip http server
    > !
    > !
    > !
    > dial-peer cor custom
    > !
    > !
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > !
    > end
    >
    mike jones, Nov 8, 2005
    #6
  7. Fred Atkinson

    Guest

    you should not have vlan interfaces on the switch (other than the one
    you choose to manage the switch by). in the global config no interface
    vlanx on all vlans except #1. Then (depending on the ios version) add
    the vlans you want to route using the "vlan" command or vlan database
    (not in config mode for db). If you create vlan interfaces on the
    switch, you are making layer 3 devices. You are trying to perform layer
    three functions on the router though, so there is no need for the
    interfaces on the switch. Also, only 1 vlan interface on the switch
    will ever go up up. All others will be admin down. The only exception
    to this is if you have a layer 3 switch and are routing in the switch
    itself.
    , Nov 8, 2005
    #7
  8. Thanks to everyone who replied.

    I have no explanation for it, but we did it in the lab (as
    opposed to the equipment in my office) and it worked fine for everyone
    who tried it, even me.

    I did discover that most of the routers in the lab do not have
    the right IOS to support ROAST (Router on a Stick). I've opened a
    case with Cisco about the possibility of upgrading them to the best
    operating system for the lab instruction we provide.

    Weird. I didn't have to spend all that time up to 10:45 PM
    working on it.

    Regards,


    Fred




    On 8 Nov 2005 13:46:27 -0800, "" <>
    wrote:

    >you should not have vlan interfaces on the switch (other than the one
    >you choose to manage the switch by). in the global config no interface
    >vlanx on all vlans except #1. Then (depending on the ios version) add
    >the vlans you want to route using the "vlan" command or vlan database
    >(not in config mode for db). If you create vlan interfaces on the
    >switch, you are making layer 3 devices. You are trying to perform layer
    >three functions on the router though, so there is no need for the
    >interfaces on the switch. Also, only 1 vlan interface on the switch
    >will ever go up up. All others will be admin down. The only exception
    >to this is if you have a layer 3 switch and are routing in the switch
    >itself.
    Fred Atkinson, Nov 9, 2005
    #8
  9. Fred Atkinson

    Guest

    The ports are assign to their respective vlan, i.e. "switchport access
    vlan n"
    Basically, when doing roast, you only need 1 vlan interface active.
    This allows ip management of the switch. Older switches use the vlan
    database (configured in enable mode, NOT config mode). Newer switches
    use the vlan n statement in config mode. Either way, you won't see the
    vlans defined in the configuration (exeception is CATOS). You will find
    them by "show vlan". They are stored in flash:vlan.dat. Which, btw,
    needs to be deleted whenever you want to slick a switch. You can wr
    erase, but the vlans will still be there.

    Vlan interfaces on a switch are primarily for routing. A good example
    is a L3 6500 or even a 3550 with the smi or emi ios image. A 3550 with
    an emi image can be used as a very fast LAN router for instance. In
    this case, you would configure vlan interfaces and add the vlans to the
    database if they were not automatically created when adding the
    interface.

    a simple roast config would look like so:
    router:
    interface fa0/0
    no ip add
    speed 100
    du full

    interface fa0/0.10
    encap dot1q 10
    ip add 10.0.10.1 255.255.255.0

    interface fa0/0.20
    encap dot1q 20
    ip add 10.0.20.1 255.255.255.0

    switch:
    interface vlan 10
    ip add 10.0.10.1 255.255.255.0
    no shut

    interface vlan 1
    shut
    ! this is because it is defined by default

    ip route 0.0.0.0 0.0.0 10.0.10.1

    !
    non-configuration mode:
    vlan 10 name testvlan10
    vlan 10 state active
    vlan 20 name testvlan20
    vlan 20 state active

    or

    vlan database
    >vlan 10 name testvlan10
    >vlan 20 name testvlan20
    >apply
    >exit



    Sorry for the long winded reply. Hope this helps.
    , Nov 10, 2005
    #9
  10. Fred Atkinson

    Guest

    correction:
    switch:
    interface vlan 10
    ip add 10.0.10.2 255.255.255.0
    no shut

    Also, the port connected to the router would be hard code 100full and
    set to dot1q trunk

    switchport trunk encap dot1q
    switchport mode trunk
    , Nov 10, 2005
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jwv

    Sony Memory Stick Pro vs Standard Memory Stick

    jwv, Jul 17, 2003, in forum: Digital Photography
    Replies:
    13
    Views:
    1,004
    Godfrey DiGiorgi
    Jul 19, 2003
  2. Barry Lovelace

    Sony DSC-U30 Memory Stick vs. Memory Stick Pro

    Barry Lovelace, Feb 11, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    745
  3. fanfaron

    Memory stick pro is cheaper than normal memory stick

    fanfaron, Jun 6, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    501
    fanfaron
    Jun 7, 2004
  4. zxcvar
    Replies:
    3
    Views:
    845
    Joe Hotchkiss
    Nov 28, 2004
  5. eb7g
    Replies:
    3
    Views:
    517
    Larry
    Dec 9, 2004
Loading...

Share This Page