Router on a stick

Discussion in 'Cisco' started by Peter, Oct 15, 2003.

  1. Peter

    Peter Guest

    Router on a stick

    Hi,

    I am trying to set up Router on a stick in my RouterSim3.2 and after 2
    days fighting it still doesn't work. I looked around on the net and in
    newsgroups and I think I am using the correct commands. Is it possible
    RouterSim3.2 doesn't support this type of setup or am I missing
    something?

    I set up two hosts with different subnets:

    192.168.1.1/24
    192.168.2.1/24

    Then I create 2 VLANs on the 1900 switch and put interface 5 and 10 in
    the VLANs, then I turn trunking on on the fastethernet port:

    >enable

    #config t
    Enter configuration commands, one per line. End with CNTL/Z.
    (config)#vlan 2 name First
    (config)#vlan 3 name Second
    (config)#int e0/5
    (config-if)#vlan-membership static 2
    (config-if)#int e0/10
    (config-if)#vlan-membership static 3
    (config-if)#int f0/26
    (config-if)#trunk on

    Then I set up the router as everybody says, two subinterfaces, and set
    up routing:

    Router>enable
    Router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#int f0/0
    Router(config-if)#no shut
    00:05:10 %LINK-3-UPDOWN: Interface Fastethernet0/0, changed state to
    up
    00:05:10 %LINEPROTO-5-UPDOWN: Line protocol on Interface
    Fastethernet0/0, changed state to up
    Router(config-if)#int f0/0.1
    Router(config-subif)#ip address 192.168.1.2 255.255.255.0
    Router(config-subif)#encapsulation isl 1
    Router(config-subif)#int f0/0.2
    Router(config-subif)#ip address 192.168.2.2 255.255.255.0
    Router(config-subif)#encapsulation isl 2
    Router(config-subif)#exit
    Router(config)#router rip
    Router(config-router)#network 192.168.1.0
    Router(config-router)#network 192.168.2.0

    But the damn thing still doesn't work. Am I missing something?

    Thanks,

    Peter
    Peter, Oct 15, 2003
    #1
    1. Advertising

  2. Peter

    Brian V Guest

    no shut on the sub-interfaces


    "Peter" <> wrote in message
    news:...
    > Router on a stick
    >
    > Hi,
    >
    > I am trying to set up Router on a stick in my RouterSim3.2 and after 2
    > days fighting it still doesn't work. I looked around on the net and in
    > newsgroups and I think I am using the correct commands. Is it possible
    > RouterSim3.2 doesn't support this type of setup or am I missing
    > something?
    >
    > I set up two hosts with different subnets:
    >
    > 192.168.1.1/24
    > 192.168.2.1/24
    >
    > Then I create 2 VLANs on the 1900 switch and put interface 5 and 10 in
    > the VLANs, then I turn trunking on on the fastethernet port:
    >
    > >enable

    > #config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > (config)#vlan 2 name First
    > (config)#vlan 3 name Second
    > (config)#int e0/5
    > (config-if)#vlan-membership static 2
    > (config-if)#int e0/10
    > (config-if)#vlan-membership static 3
    > (config-if)#int f0/26
    > (config-if)#trunk on
    >
    > Then I set up the router as everybody says, two subinterfaces, and set
    > up routing:
    >
    > Router>enable
    > Router#config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > Router(config)#int f0/0
    > Router(config-if)#no shut
    > 00:05:10 %LINK-3-UPDOWN: Interface Fastethernet0/0, changed state to
    > up
    > 00:05:10 %LINEPROTO-5-UPDOWN: Line protocol on Interface
    > Fastethernet0/0, changed state to up
    > Router(config-if)#int f0/0.1
    > Router(config-subif)#ip address 192.168.1.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 1
    > Router(config-subif)#int f0/0.2
    > Router(config-subif)#ip address 192.168.2.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 2
    > Router(config-subif)#exit
    > Router(config)#router rip
    > Router(config-router)#network 192.168.1.0
    > Router(config-router)#network 192.168.2.0
    >
    > But the damn thing still doesn't work. Am I missing something?
    >
    > Thanks,
    >
    > Peter
    Brian V, Oct 15, 2003
    #2
    1. Advertising

  3. Hi,

    Your switch uses vlan 2 and 3 while the router uses vlan 1 and 2 (... isl 1
    and ... isl 2).

    Erik

    "Peter" <> wrote in message
    news:...
    > Router on a stick
    >
    > Hi,
    >
    > I am trying to set up Router on a stick in my RouterSim3.2 and after 2
    > days fighting it still doesn't work. I looked around on the net and in
    > newsgroups and I think I am using the correct commands. Is it possible
    > RouterSim3.2 doesn't support this type of setup or am I missing
    > something?
    >
    > I set up two hosts with different subnets:
    >
    > 192.168.1.1/24
    > 192.168.2.1/24
    >
    > Then I create 2 VLANs on the 1900 switch and put interface 5 and 10 in
    > the VLANs, then I turn trunking on on the fastethernet port:
    >
    > >enable

    > #config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > (config)#vlan 2 name First
    > (config)#vlan 3 name Second
    > (config)#int e0/5
    > (config-if)#vlan-membership static 2
    > (config-if)#int e0/10
    > (config-if)#vlan-membership static 3
    > (config-if)#int f0/26
    > (config-if)#trunk on
    >
    > Then I set up the router as everybody says, two subinterfaces, and set
    > up routing:
    >
    > Router>enable
    > Router#config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > Router(config)#int f0/0
    > Router(config-if)#no shut
    > 00:05:10 %LINK-3-UPDOWN: Interface Fastethernet0/0, changed state to
    > up
    > 00:05:10 %LINEPROTO-5-UPDOWN: Line protocol on Interface
    > Fastethernet0/0, changed state to up
    > Router(config-if)#int f0/0.1
    > Router(config-subif)#ip address 192.168.1.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 1
    > Router(config-subif)#int f0/0.2
    > Router(config-subif)#ip address 192.168.2.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 2
    > Router(config-subif)#exit
    > Router(config)#router rip
    > Router(config-router)#network 192.168.1.0
    > Router(config-router)#network 192.168.2.0
    >
    > But the damn thing still doesn't work. Am I missing something?
    >
    > Thanks,
    >
    > Peter
    Erik Tamminga, Oct 15, 2003
    #3
  4. Peter

    Richard Deal Guest

    Peter,

    Yes, there is a problem with your configuration--on the 1900, you use VLANs
    2 and 3, but on the router you use VLANs 1 and 2. Just fix the router's
    configuration and you should be set...just make sure the VLAN # on the
    router matches the right IP network number.

    Cheers!
    --

    Richard A. Deal

    Visit my home page at http://home.cfl.rr.com/dealgroup/

    Author of CCNA Cisco Certified Network Associate Study Guide (Exam 640-801),
    Cisco PIX Firewalls, CCNA Secrets Revealed!, CCNP Remote Access Exam Prep,
    CCNP Switching Exam Cram, and CCNP Cisco LAN Switch Configuration Exam Cram

    Cisco Test Prep author for QuizWare, providing the most comprehensive Cisco
    exams on the market.





    "Peter" <> wrote in message
    news:...
    > Router on a stick
    >
    > Hi,
    >
    > I am trying to set up Router on a stick in my RouterSim3.2 and after 2
    > days fighting it still doesn't work. I looked around on the net and in
    > newsgroups and I think I am using the correct commands. Is it possible
    > RouterSim3.2 doesn't support this type of setup or am I missing
    > something?
    >
    > I set up two hosts with different subnets:
    >
    > 192.168.1.1/24
    > 192.168.2.1/24
    >
    > Then I create 2 VLANs on the 1900 switch and put interface 5 and 10 in
    > the VLANs, then I turn trunking on on the fastethernet port:
    >
    > >enable

    > #config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > (config)#vlan 2 name First
    > (config)#vlan 3 name Second
    > (config)#int e0/5
    > (config-if)#vlan-membership static 2
    > (config-if)#int e0/10
    > (config-if)#vlan-membership static 3
    > (config-if)#int f0/26
    > (config-if)#trunk on
    >
    > Then I set up the router as everybody says, two subinterfaces, and set
    > up routing:
    >
    > Router>enable
    > Router#config t
    > Enter configuration commands, one per line. End with CNTL/Z.
    > Router(config)#int f0/0
    > Router(config-if)#no shut
    > 00:05:10 %LINK-3-UPDOWN: Interface Fastethernet0/0, changed state to
    > up
    > 00:05:10 %LINEPROTO-5-UPDOWN: Line protocol on Interface
    > Fastethernet0/0, changed state to up
    > Router(config-if)#int f0/0.1
    > Router(config-subif)#ip address 192.168.1.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 1
    > Router(config-subif)#int f0/0.2
    > Router(config-subif)#ip address 192.168.2.2 255.255.255.0
    > Router(config-subif)#encapsulation isl 2
    > Router(config-subif)#exit
    > Router(config)#router rip
    > Router(config-router)#network 192.168.1.0
    > Router(config-router)#network 192.168.2.0
    >
    > But the damn thing still doesn't work. Am I missing something?
    >
    > Thanks,
    >
    > Peter
    >
    Richard Deal, Oct 15, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jwv

    Sony Memory Stick Pro vs Standard Memory Stick

    jwv, Jul 17, 2003, in forum: Digital Photography
    Replies:
    13
    Views:
    1,002
    Godfrey DiGiorgi
    Jul 19, 2003
  2. Barry Lovelace

    Sony DSC-U30 Memory Stick vs. Memory Stick Pro

    Barry Lovelace, Feb 11, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    734
  3. fanfaron

    Memory stick pro is cheaper than normal memory stick

    fanfaron, Jun 6, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    497
    fanfaron
    Jun 7, 2004
  4. zxcvar
    Replies:
    3
    Views:
    838
    Joe Hotchkiss
    Nov 28, 2004
  5. eb7g
    Replies:
    3
    Views:
    511
    Larry
    Dec 9, 2004
Loading...

Share This Page