router not routing

Discussion in 'Cisco' started by GC, Jan 21, 2004.

  1. GC

    GC Guest

    Hi-
    I have an 831 that gets its external IP through DHCP and it doesn't seem to
    be routing traffic from the internal int to the external one. Here is my
    config, can anyone see anything that would prevent this? Thanks!

    RTR01#ping 4.2.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:
    ......
    Success rate is 0 percent (0/5)
    RTR01#




    Building configuration...

    Current configuration : 1327 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname RTR01
    !
    enable password 7 @@@@@@@
    !
    ip subnet-zero
    no ip domain lookup
    ip dhcp excluded-address 192.168.3.1 192.168.3.99
    ip dhcp excluded-address 192.168.3.201 192.168.3.255
    !
    ip dhcp pool 192.168.3.0/24
    network 192.168.3.0 255.255.255.0
    default-router 192.168.3.1
    dns-server 65.83.241.167 65.83.241.165
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !
    !
    interface Ethernet0
    description Connected to local LAN
    ip address 192.168.3.1 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    no cdp enable
    !
    interface Ethernet1
    description Connected to the Internet
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    no cdp enable
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet1
    ip http server
    !
    !
    access-list 102 permit ip 192.0.0.0 0.255.255.255 any
    no cdp run
    no snmp-server enable traps tty
    !
    line con 0
    exec-timeout 0 0
    password 7 @@@@@@@
    login
    no modem enable
    stopbits 1
    line aux 0
    login local
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    password 7 @@@@@@@
    login local
    length 0
    !
    scheduler max-task-time 5000
    end
     
    GC, Jan 21, 2004
    #1
    1. Advertising

  2. GC

    KR Guest

    GC wrote:
    > Hi-
    > I have an 831 that gets its external IP through DHCP and it doesn't seem to
    > be routing traffic from the internal int to the external one. Here is my
    > config, can anyone see anything that would prevent this? Thanks!


    I see no "ip nat inside" on eth0, nor any "ip nat" statement that would
    cause the router to NAT traffic from the internal LAN behind the valid
    address on eth1.

    Also, access list 102 is a bit weird, as it refers to 192.0.0.0/8, a
    supernet containing both valid and nonroutable addresses. On the other
    hand, that access list isn't actually used anywhere.

    Anyway, you should still be able to ping from the router console. Does
    "sh int eth1" confirm that you have been given an IP address via DHCP?
    Have you tried traceroute?
     
    KR, Jan 22, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bistri
    Replies:
    0
    Views:
    627
    bistri
    Nov 27, 2003
  2. zher
    Replies:
    2
    Views:
    9,011
  3. joeblow
    Replies:
    3
    Views:
    1,239
    Philip D'Ath
    Mar 14, 2005
  4. Sied@r
    Replies:
    3
    Views:
    8,493
    Sied@r
    Oct 20, 2005
  5. Craig
    Replies:
    4
    Views:
    444
    Craig
    Dec 15, 2006
Loading...

Share This Page