route wan trafic to wireless adapter; lan through wired

Discussion in 'Wireless Networking' started by G. Leavitt, Apr 29, 2009.

  1. G. Leavitt

    G. Leavitt Guest

    I have a wired gigabit connection to my corporate network and a USB wireless
    connection to our internet hotspot. Both connections have access to the
    internet, but the wired connection is filtered through a proxy server and the
    nature of my job is such that I need unfiltered access to the internet. What
    I am trying to do is figure out a way to route all my internet traffic
    through the wireless nic, and all my local traffic over the wired nic.

    The first thing I tried was setting up my static routes so that the wireless
    was the default route and then set up a static route for local traffic with a
    lower metric. The problem is that our internal network is so heavily
    subnetted that this solution isn't practical. I would have to create like 35
    static routes to all our disparate subnets to make that work.

    I have also tried setting the IProuteEnable registry key to 1 and setting my
    wireless nic as the proxy server in my browser as someone in another forum
    suggested, but that doesn't seem to work either.

    I'm just about ready to give up, but thought I would ask here first. If
    anyone can offer some advice or even just tell me I'm an idiot and this can't
    be done I would really appreciate it.
     
    G. Leavitt, Apr 29, 2009
    #1
    1. Advertising

  2. I am not sure why you need to "create like 35 static routes". If this is the
    case, you may add a router and configure the router to do the job.

    RoutingNo internet access - Destination net unreachable. One router goes to
    the corporation email server and another one goes to the Internet ...
    www.chicagotech.net/routing.htm


    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com


    "G. Leavitt" <> wrote in message
    news:D...
    >I have a wired gigabit connection to my corporate network and a USB
    >wireless
    > connection to our internet hotspot. Both connections have access to the
    > internet, but the wired connection is filtered through a proxy server and
    > the
    > nature of my job is such that I need unfiltered access to the internet.
    > What
    > I am trying to do is figure out a way to route all my internet traffic
    > through the wireless nic, and all my local traffic over the wired nic.
    >
    > The first thing I tried was setting up my static routes so that the
    > wireless
    > was the default route and then set up a static route for local traffic
    > with a
    > lower metric. The problem is that our internal network is so heavily
    > subnetted that this solution isn't practical. I would have to create like
    > 35
    > static routes to all our disparate subnets to make that work.
    >
    > I have also tried setting the IProuteEnable registry key to 1 and setting
    > my
    > wireless nic as the proxy server in my browser as someone in another forum
    > suggested, but that doesn't seem to work either.
    >
    > I'm just about ready to give up, but thought I would ask here first. If
    > anyone can offer some advice or even just tell me I'm an idiot and this
    > can't
    > be done I would really appreciate it.
     
    Bob Lin \(MS-MVP\), Apr 29, 2009
    #2
    1. Advertising

  3. G. Leavitt

    G. Leavitt Guest

    I was thinking I would have to add a static route for each subnet, and I am
    not in a position to add any new hardware to our infrastructure. I did find
    a solution though. It turns out the mask you use on your route doesn't
    actually have to match the mask used for the network. Our network is
    subnetted using a /24 mask (i.e. 255.255.255.0) and I was thinking I would
    have to do the same with my static routes. Since every subnet in our network
    uses the same value for the first octet I just needed to make a route that
    used 255.0.0.0

    In case anyone ends up looking for this same answer I got it working
    finally. Here is what I had to do.

    1. Added a new static route:
    route add 172.0.0.0 mask 255.0.0.0 172.18.74.1 metric 5 if 3

    2. Then I raised the metric of the default route for my wired interface:
    route change 0.0.0.0 mask 0.0.0.0 172.18.74.1 metric 25 if 3

    3. Then (metric was already 25) I lowered the metric of my wireless
    interface to 20:
    route change 0.0.0.0 mask 0.0.0.0 172.18.253.2 metric 20 if 2

    4. I had also enabled IP routing in the registry, but I'm not sure if that
    was a factor in the success of this method.

    After these changes everything works perfectly All internal traffic
    (anything with 172 in the first octet) gets routed to the wired interface.
    Even the local intranet pages work flawlessly. And anything going to any
    other address gets routed to the wireless interface, i.e. the internet.

    note: the command lines I show here do not include the -p switch to make the
    changes persistent. I would strongly recommend doing everything without the
    -p switch until you are absolutely certain the changes you are making do what
    you want them to do. If you make a change that causes your system to slow
    down or crash you can just restart and it will go back to the original
    settings.

    "Bob Lin (MS-MVP)" wrote:

    > I am not sure why you need to "create like 35 static routes". If this is the
    > case, you may add a router and configure the router to do the job.
    >
    > RoutingNo internet access - Destination net unreachable. One router goes to
    > the corporation email server and another one goes to the Internet ...
    > www.chicagotech.net/routing.htm
    >
    >
    > --
    > Bob Lin, MS-MVP, MCSE & CNE
    > Networking, Internet, Routing, VPN Troubleshooting on
    > http://www.ChicagoTech.net
    > How to Setup Windows, Network, VPN & Remote Access on
    > http://www.HowToNetworking.com
     
    G. Leavitt, Apr 29, 2009
    #3
  4. "G. Leavitt" <> wrote in message
    news:...

    > 1. Added a new static route:
    > route add 172.0.0.0 mask 255.0.0.0 172.18.74.1 metric 5 if 3


    A. Don't screw around with the metrics.
    B. You can't use that as the mask because it will overlap real internet
    addresses
    The RFC range is 172.16.0.0 -- 172.31.255.255
    C. Use 172.16.0.0 mask 255.240.0.0 (that is true identification for the
    RFC "B" Range

    > 2. Then I raised the metric of the default route for my wired interface:
    > route change 0.0.0.0 mask 0.0.0.0 172.18.74.1 metric 25 if 3


    A. Don't screw around with the metrics
    B. Remove the Default Gateway,..leave it blank,...the Static Route
    covers it.

    > 3. Then (metric was already 25) I lowered the metric of my wireless
    > interface to 20:
    > route change 0.0.0.0 mask 0.0.0.0 172.18.253.2 metric 20 if 2


    A. Don't screw around with the metrics
    B. This nic should be the only one with the Default Gateway. It will
    take care of itself.

    > 4. I had also enabled IP routing in the registry, but I'm not sure if that
    > was a factor in the success of this method.


    A. Completely irrelevant. Remove the setting. Put it back the way it
    was originally.

    > After these changes everything works perfectly


    It doesn't work perfectly,...it just works "luckily",...but it is a "hack
    job",...the way I outlined is the correct way to handle it.

    1. Remove any "proxy settings" from the browser if there are any
    2. Remove the Default Gateway on the Wired Nic
    3. Run the command "route /f" from a command prompt to clear the routing
    table
    4. Reboot the machine
    5. Enter the correct Static Route as I described.

    When finished, the Static Route tells one nic what to do,...the Default
    Gateway tells the other Nic what to do,...everything will be
    happy,...everything will work,...and the Metrics won't be molested.

    For future reference,...multi-homing is usually bad,...mulitple default
    gateways across mulitple nics is even worse. Don't do it. If you are going
    to multi-home a machine, then do it correctly if you want consistant
    behavor.

    Then there are all these:.....

    157025 - Default Gateway Configuration for Multihomed Computers
    http://support.microsoft.com/default.aspx?scid=kb;en-us;157025&Product=win2000

    Default gateways
    http://www.microsoft.com/technet/pr...elp/6c7c7ab2-cfdc-4dfe-8560-570d3859f5b1.mspx

    Default Gateway Behavior for Windows TCP/IP
    http://www.microsoft.com/technet/community/columns/cableguy/cg0903.mspx

    159168 - Multiple Default Gateways Can Cause Connectivity Problems
    http://support.microsoft.com/kb/159168/EN-US/

    272294 - Active Directory Communication Fails on Multihomed Domain
    Controllers
    http://support.microsoft.com/default.aspx?scid=kb;en-us;272294

    191611 - Symptoms of Multihomed Browsers
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;191611

    Microsoft Windows XP - Multihoming Considerations
    http://www.microsoft.com/resources/documentation/windows/xp/all/reskit/en-us/prcc_tcp_qpzj.asp?

    --
    Phillip Windell
    www.wandtv.com

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------
     
    Phillip Windell, Apr 29, 2009
    #4
  5. Thank you for the update.

    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com


    "G. Leavitt" <> wrote in message
    news:...
    >I was thinking I would have to add a static route for each subnet, and I am
    > not in a position to add any new hardware to our infrastructure. I did
    > find
    > a solution though. It turns out the mask you use on your route doesn't
    > actually have to match the mask used for the network. Our network is
    > subnetted using a /24 mask (i.e. 255.255.255.0) and I was thinking I would
    > have to do the same with my static routes. Since every subnet in our
    > network
    > uses the same value for the first octet I just needed to make a route that
    > used 255.0.0.0
    >
    > In case anyone ends up looking for this same answer I got it working
    > finally. Here is what I had to do.
    >
    > 1. Added a new static route:
    > route add 172.0.0.0 mask 255.0.0.0 172.18.74.1 metric 5 if 3
    >
    > 2. Then I raised the metric of the default route for my wired interface:
    > route change 0.0.0.0 mask 0.0.0.0 172.18.74.1 metric 25 if 3
    >
    > 3. Then (metric was already 25) I lowered the metric of my wireless
    > interface to 20:
    > route change 0.0.0.0 mask 0.0.0.0 172.18.253.2 metric 20 if 2
    >
    > 4. I had also enabled IP routing in the registry, but I'm not sure if that
    > was a factor in the success of this method.
    >
    > After these changes everything works perfectly All internal traffic
    > (anything with 172 in the first octet) gets routed to the wired interface.
    > Even the local intranet pages work flawlessly. And anything going to any
    > other address gets routed to the wireless interface, i.e. the internet.
    >
    > note: the command lines I show here do not include the -p switch to make
    > the
    > changes persistent. I would strongly recommend doing everything without
    > the
    > -p switch until you are absolutely certain the changes you are making do
    > what
    > you want them to do. If you make a change that causes your system to slow
    > down or crash you can just restart and it will go back to the original
    > settings.
    >
    > "Bob Lin (MS-MVP)" wrote:
    >
    >> I am not sure why you need to "create like 35 static routes". If this is
    >> the
    >> case, you may add a router and configure the router to do the job.
    >>
    >> RoutingNo internet access - Destination net unreachable. One router goes
    >> to
    >> the corporation email server and another one goes to the Internet ...
    >> www.chicagotech.net/routing.htm
    >>
    >>
    >> --
    >> Bob Lin, MS-MVP, MCSE & CNE
    >> Networking, Internet, Routing, VPN Troubleshooting on
    >> http://www.ChicagoTech.net
    >> How to Setup Windows, Network, VPN & Remote Access on
    >> http://www.HowToNetworking.com

    >
     
    Bob Lin \(MS-MVP\), Apr 30, 2009
    #5
  6. G. Leavitt

    G. Leavitt Guest

    Thank you for the clarification. Is there a way to remove the default
    gateway for an interface that is using DHCP without switching to static
    address assignments? The reason I am altering the metrics instead of
    removing the default gateway on my wired interface is because both interfaces
    get their configurations through DHCP and for irrational political reasons
    our sysadmins are "reluctant" to reserve an address for me on the local
    network.

    "Phillip Windell" wrote:

    > "G. Leavitt" <> wrote in message
    > news:...
    >
    > > 1. Added a new static route:
    > > route add 172.0.0.0 mask 255.0.0.0 172.18.74.1 metric 5 if 3

    >
    > A. Don't screw around with the metrics.
    > B. You can't use that as the mask because it will overlap real internet
    > addresses
    > The RFC range is 172.16.0.0 -- 172.31.255.255
    > C. Use 172.16.0.0 mask 255.240.0.0 (that is true identification for the
    > RFC "B" Range
    >
    > > 2. Then I raised the metric of the default route for my wired interface:
    > > route change 0.0.0.0 mask 0.0.0.0 172.18.74.1 metric 25 if 3

    >
    > A. Don't screw around with the metrics
    > B. Remove the Default Gateway,..leave it blank,...the Static Route
    > covers it.
    >
    > > 3. Then (metric was already 25) I lowered the metric of my wireless
    > > interface to 20:
    > > route change 0.0.0.0 mask 0.0.0.0 172.18.253.2 metric 20 if 2

    >
    > A. Don't screw around with the metrics
    > B. This nic should be the only one with the Default Gateway. It will
    > take care of itself.
    >
    > > 4. I had also enabled IP routing in the registry, but I'm not sure if that
    > > was a factor in the success of this method.

    >
    > A. Completely irrelevant. Remove the setting. Put it back the way it
    > was originally.
    >
    > > After these changes everything works perfectly

    >
    > It doesn't work perfectly,...it just works "luckily",...but it is a "hack
    > job",...the way I outlined is the correct way to handle it.
    >
    > 1. Remove any "proxy settings" from the browser if there are any
    > 2. Remove the Default Gateway on the Wired Nic
    > 3. Run the command "route /f" from a command prompt to clear the routing
    > table
    > 4. Reboot the machine
    > 5. Enter the correct Static Route as I described.
    >
    > When finished, the Static Route tells one nic what to do,...the Default
    > Gateway tells the other Nic what to do,...everything will be
    > happy,...everything will work,...and the Metrics won't be molested.
    >
    > For future reference,...multi-homing is usually bad,...mulitple default
    > gateways across mulitple nics is even worse. Don't do it. If you are going
    > to multi-home a machine, then do it correctly if you want consistant
    > behavor.
    >
    > Then there are all these:.....
    >
    > 157025 - Default Gateway Configuration for Multihomed Computers
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;157025&Product=win2000
    >
    > Default gateways
    > http://www.microsoft.com/technet/pr...elp/6c7c7ab2-cfdc-4dfe-8560-570d3859f5b1.mspx
    >
    > Default Gateway Behavior for Windows TCP/IP
    > http://www.microsoft.com/technet/community/columns/cableguy/cg0903.mspx
    >
    > 159168 - Multiple Default Gateways Can Cause Connectivity Problems
    > http://support.microsoft.com/kb/159168/EN-US/
    >
    > 272294 - Active Directory Communication Fails on Multihomed Domain
    > Controllers
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;272294
    >
    > 191611 - Symptoms of Multihomed Browsers
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;191611
    >
    > Microsoft Windows XP - Multihoming Considerations
    > http://www.microsoft.com/resources/documentation/windows/xp/all/reskit/en-us/prcc_tcp_qpzj.asp?
    >
    > --
    > Phillip Windell
    > www.wandtv.com
    >
    > The views expressed, are my own and not those of my employer, or Microsoft,
    > or anyone else associated with me, including my cats.
    > -----------------------------------------------------
    >
    >
    >
     
    G. Leavitt, Apr 30, 2009
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom D
    Replies:
    4
    Views:
    4,311
    Tom D
    Jan 24, 2005
  2. =?Utf-8?B?ZGZhdG92aWM=?=

    wireless can't access wired. But Wired can access wireless

    =?Utf-8?B?ZGZhdG92aWM=?=, Feb 4, 2005, in forum: Wireless Networking
    Replies:
    5
    Views:
    1,327
    Carey Holzman
    Feb 5, 2005
  3. Replies:
    10
    Views:
    622
  4. Casper
    Replies:
    1
    Views:
    616
    headsetadapter.com
    Aug 17, 2007
  5. Replies:
    9
    Views:
    5,614
    Scott Perry
    Aug 7, 2008
Loading...

Share This Page