route-map question

Discussion in 'Cisco' started by Daniel Eyholzer, Dec 6, 2004.

  1. Hi


    I have configured a test route-map without any match/set clause. I do
    not understand why nothing goes through this route-map. I thought that
    if there is no match clause all packets will go through.


    router eigrp 1
    redistribute connected route-map mymap
    redistribute static route-map mymap
    network 192.168.1.0
    network 192.168.2.0
    no auto-summary
    no eigrp log-neighbor-changes
    !
    route-map mymap permit 10
    !


    #show route-map mymap
    route-map mymap, permit, sequence 10
    Match clauses:
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes


    Any idea?


    Daniel
     
    Daniel Eyholzer, Dec 6, 2004
    #1
    1. Advertising

  2. Daniel,
    I'm not sure what you are expecting to see. There is no policy routing
    involved here, so the matches there should be zeroes.

    Policy routing involves the use of the IP LOCAL POLICY ROUTE-MAP global
    command or the IP POLICY ROUTE-MAP interface command.

    What is happening here is that connected and static routes are being
    redistributed as if there is no route-map subcommand. However, if you were
    to remove the original route-map command and change it to:

    ROUTE-MAP MYMAP DENY 10

    you would find that no static or connected routes would be redistributed at
    all. So the route-map is being invoked properly.

    FWIW,
    Robert

    "Daniel Eyholzer" <> wrote in message
    news:...
    > Hi
    >
    >
    > I have configured a test route-map without any match/set clause. I do
    > not understand why nothing goes through this route-map. I thought that
    > if there is no match clause all packets will go through.
    >
    >
    > router eigrp 1
    > redistribute connected route-map mymap
    > redistribute static route-map mymap
    > network 192.168.1.0
    > network 192.168.2.0
    > no auto-summary
    > no eigrp log-neighbor-changes
    > !
    > route-map mymap permit 10
    > !
    >
    >
    > #show route-map mymap
    > route-map mymap, permit, sequence 10
    > Match clauses:
    > Set clauses:
    > Policy routing matches: 0 packets, 0 bytes
    >
    >
    > Any idea?
    >
    >
    > Daniel
     
    Bob by the Bay, Dec 6, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Wrate

    route-map question

    John Wrate, Oct 31, 2003, in forum: Cisco
    Replies:
    14
    Views:
    3,970
    CCIE8122
    Nov 8, 2003
  2. Nicolas Meaux

    route-map and as-path question

    Nicolas Meaux, Jan 10, 2005, in forum: Cisco
    Replies:
    2
    Views:
    514
    Ivan OstreŇ°
    Jan 11, 2005
  3. AM
    Replies:
    3
    Views:
    646
  4. Replies:
    1
    Views:
    5,206
    Barry Margolin
    Aug 13, 2005
  5. Replies:
    9
    Views:
    5,195
    Scott Perry
    Aug 7, 2008
Loading...

Share This Page