RH9 Ethernet/Internet Not Working

Discussion in 'NZ Computing' started by Howard, Sep 9, 2003.

  1. Howard

    Howard Guest

    Hello all,

    I have just loaded RH9 onto this machine and my Redhat 9.0 Ethernet/Internet
    Connection is playing up.

    I have a "Realtek RTL8139 Family PCI Fast Ethernet Card" NIC (as identified
    when I bought it, and by Windows 2k)
    http://www.realtek.com.tw/products/products1-2.aspx?modelid=6

    and a "Lectron AR800C2-A" External ADSL Router
    http://www.lectron.com.tw/xdsl.html

    If I try to specify the Realtek 8139 driver under Main Menu | System
    Settings | Network, I get

    "Command failed: /sbin/modprobe 8139cp
    Output:
    /lib/modules/2.4.20-8/kernel/drivers/net/8139cp.o: init_module: No such
    device
    /lib/modules/2.4.20-8/kernel/drivers/net/8139cp.o: insmod
    /lib/modules/2.4.20-8/kernel/drivers/net/8139cp.o failed
    /lib/modules/2.4.20-8/kernel/drivers/net/8139cp.o: insmod 8139cp failed
    Hint: insmod errors can be caused by incorrect module parameters, including
    invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg"

    If I ignore that error message and nevertheless add a Device using the
    Realtek Driver, when I attempt to activate the device I get:

    "Cannot activate network device eth0!
    Determining IP information for eth0... failed; no link present. Check
    cable?"

    My NIC is RH Linux Compatible
    http://hardware.redhat.com/hcl/?pagename=details&hid=660
    and again in
    http://www.tldp.org/HOWTO/Ethernet-HOWTO-4.html#rtl8139

    But RH9's Hardware Browser identifies my NIC as a
    SURECOM EP-320X-S 100/10M Ethernet PCI Adapter
    Manufacturer: MYSON Technologies Inc
    Driver: fealnx
    Device: /dev/eth

    This driver is also "supported' according to
    http://www.tldp.org/HOWTO/Ethernet-HOWTO-4.html but only has a "Community
    knowledge" rating from Redhat
    http://hardware.redhat.com/hcl/?pagename=details&hid=570

    The fealnx default driver was loaded into the Network Configuration Hardware
    Tab during RH installation. When I add a Device using this fealnx driver,
    everything appears to proceed correctly, the device activates and I can ping
    10.0.0.2 (my router's ip) successfully. I can browse to the router and
    reviews its config on http://10.0.02.

    I can't however access the internet. Typing a url in the browser gives the
    alert
    "<url> could not be found. Please check the name and try again." in Mozilla.

    pinging xtra.co.nz gives
    ping: unknown host xtra.co.nz

    pinging 202.27.184.102 (xtra's ip) gives
    connect: Network is unreachable

    The Network settings I have tried using so far are:

    DNS Tab
    Hostname: localhost.localdomain
    Primary DNS:I have tried each of <blank>,10.0.0.2 and 202.27.184.3/5 (being
    Xtra's DNS servers)
    Secondary: Different combinations of the 3 options above.
    Tertiary: <blank>
    DNS Search Path: localdomain

    Hosts Tab
    127.0.0.1 left untouched

    I have tried setting the device to autoget its IP via DHCP , and manually
    setting it to 10.0.0.3 which I have checked is in the allowed range for the
    router.

    Both Win2k & Knoppix can access the net fine on this host without any
    changes, so its not a hardware &/or router config issue.

    Can anyone tell me what I am doing wrong?

    Thanks in advance.

    -H


    [root@localhost root]# lspci
    02:0b.0 Ethernet controller: MYSON Technology Inc SURECOM EP-320X-S 100/10M
    Ethernet PCI Adapter
    Howard, Sep 9, 2003
    #1
    1. Advertising

  2. On Tue, 9 Sep 2003 20:45:08 +1200, "Howard" <>
    wrote:

    >If I try to specify the Realtek 8139 driver under Main Menu | System
    >Settings | Network, I get
    >


    >"Command failed: /sbin/modprobe 8139cp


    Sounds like it's having trouble loading the 8139cp driver module to
    "enable" the card, therefore subsequent commands like setting ip, dns
    etc don't work.

    Try using modprobe to load it with the "8139too" module, seems to work
    better here with that one. Hotplug seems to choose the 8139cp driver
    for some reason.

    ]# modprobe 8139too

    Not sure how to do it under RedHat, under my Slackware System it's in
    /etc/rc.d/rc.modules but I believe other distros changed this, I do
    not use a GUI either so cannot help in this regard.

    Run the 'ifconfig' command at a console to see the current NIC's.. if
    eth0 is not present then the system is definitely not talking to the
    NIC.


    --
    Kristofer Clayton (KJClayton)
    Gisborne, New Zealand
    Kristofer Clayton, Sep 9, 2003
    #2
    1. Advertising

  3. On Tue, 09 Sep 2003 20:45:08 +1200, Howard wrote:

    > I have just loaded RH9 onto this machine and my Redhat 9.0
    > Ethernet/Internet Connection is playing up.
    >
    > I have a "Realtek RTL8139 Family PCI Fast Ethernet Card" NIC (as
    > identified when I bought it, and by Windows 2k)
    > http://www.realtek.com.tw/products/products1-2.aspx?modelid=6
    >
    > and a "Lectron AR800C2-A" External ADSL Router
    > http://www.lectron.com.tw/xdsl.html
    >
    > If I try to specify the Realtek 8139 driver under Main Menu | System
    > Settings | Network, I get


    Is this a PCI card or PCMCIA/Cardbus in a laptop?

    DSE were flogging a PCMCIA card which identified to windows as Realtek
    8139, but which in fact turned out to be something else (Asix AX88190)
    with fudged windows drivers (which is why the windows realtek drivers
    didn't work on it)

    Have you tried booting up on a Knoppix CD to see what it says the card is
    after probing?

    > [root@localhost root]# lspci
    > 02:0b.0 Ethernet controller: MYSON Technology Inc SURECOM EP-320X-S
    > 100/10M Ethernet PCI Adapter


    --
    There are 2 sorts of email opt-in lists:
    1: Those which can demonstrate the provenance of every subscription request.
    2: Fraud
    Uncle StoatWarbler, Sep 9, 2003
    #3
  4. Howard

    Gordon Smith Guest

    Sounds like there are a couple of issues:

    Firstly, it looks like that Realtek isn't a real realtek (pardon
    the pun) :)

    Use the other driver, since that appears to work.

    The reason URL's are not resolving can be caused by a couple
    of things - firstly, make sure that in /etc/resolv.conf you
    have entries for your ISP's DNS servers e.g.
    nameserver 123.456.789.123
    (put correct IP address in)

    Secondly, check your default gateway:

    route -n

    There should be an entry that points to your DSL router
    IP address. If not, edit /etc/sysconfig/network and add
    a gateway address:

    GATEWAY=10.0.0.1

    (should be the internal address of your DSL router)
    Gordon Smith, Sep 9, 2003
    #4
  5. Howard

    Howard Guest

    Thanks Uncle, Kristopher and Gordon. Following your suggestions I have
    been able to get it all working now (as you might be able to confirm from
    my headers :) )

    Yes the Realtek 8139 Driver was not the one to use; fealnx does the job in
    both Knoppix3.2 and Redhat9.0.

    The rest of this post is for posterity's sake - nothing I found on the web
    was quite specfic enough to help me so maybe this post might help someone
    in the future...

    I had my ISP's DNS servers IPs in /etc/resolv.conf - whereas I should have
    had my router's IP in there instead. It makes sense since I have
    already told my router what DNSs to refer to.

    route -n in Knopix showed two records

    Destination Gateway Gen Mask
    10.0.0.0 0.0.0.0 255.0.0.0
    0.0.0.0 10.0.0.2 0.0.0.0

    route -n in Redhat showed different records consistent with a DHCP network
    (ie no 10.0.0.0 record expected by the router).

    So the answer was in Neat (Main Menu | System Settings | Network) to
    Statically set ip addresses to
    10.0.0.3|255.0.0.0
    (consistent with the router's ip of 10.0.0.2|255.0.0.0)
    and to specify the default gateway address of the router's ip = 10.0.0.2.

    Actually the greatest difficulty I had today was I wanted to start with a
    clean slate so I deleted all ethernet devices and hardware drivers - and
    then I found the hard way that I couldn't just select "fealnx" to reload
    it... it wasn't in the list of available drivers in the Neat dropdown list.

    After a bit of hunting around the web (where I started getting quite
    worried as some of the threads suggested I compile the driver from source
    ??) I found out how to load a driver which isn't available in the
    Neat dropdown.

    The answer was to add a line
    "alias eth0 fealnx" into /etc/modules.conf.

    There after it was a simple matter to use Neat to add the device, point it
    at the fealnx driver, and specify the manual ip settings.

    Thanks again to those that helped.
    Howard, Sep 10, 2003
    #5
  6. Howard

    Enkidu Guest

    On Wed, 10 Sep 2003 12:05:26 +1200, "Howard" <>
    wrote:
    >
    >I had my ISP's DNS servers IPs in /etc/resolv.conf - whereas I should have
    >had my router's IP in there instead. It makes sense since I have
    >already told my router what DNSs to refer to.
    >

    Shouldn't have made any difference. So long as your system knows where
    to send the packets *first*, ie your router, then it should be able to
    find any address on the Internet. So it should be able to look up
    Domain Names in *any* DNS server on the planet or off it.

    >route -n in Knopix showed two records
    >
    >Destination Gateway Gen Mask
    >10.0.0.0 0.0.0.0 255.0.0.0
    >0.0.0.0 10.0.0.2 0.0.0.0
    >
    >route -n in Redhat showed different records consistent with a DHCP network
    >(ie no 10.0.0.0 record expected by the router).
    >

    That should still work the second line says "send everything (else) to
    10.0.0.2" - the router. The router doesn't "expect" anything. All you
    have to do is be consistent across the board. The workstation should
    have an IP address in the range (in your case) of 10.0.0.0/8 (first
    octet significant.), whether it comes from DHCP or is hardcoded. The
    correct gateway address should be specified and be part of the same
    range. *ALL* devices should follow this rule and it should *just
    work*.

    It is more usual to subnet a 10.0.0.0/8 though. Say you chose a
    netmask of 24 and a network address of 10.23.45.0/24. Then all IP
    addresses, be they host names of gateway addresses would have to start
    with 10.23.45. and all netmasks should be 255.255.255.0.

    >So the answer was in Neat (Main Menu | System Settings | Network) to
    >Statically set ip addresses to
    >10.0.0.3|255.0.0.0
    >(consistent with the router's ip of 10.0.0.2|255.0.0.0)
    >and to specify the default gateway address of the router's ip = 10.0.0.2.
    >

    This was the crucial thing, I bet. Consistency.

    Cheers,

    Cliff


    --

    The complete lack of evidence is the surest sign
    that the conspiracy is working.
    Enkidu, Sep 10, 2003
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RHJhZ29ueA==?=

    wifi not working on new hp, or not working after live update

    =?Utf-8?B?RHJhZ29ueA==?=, Oct 2, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    912
    =?Utf-8?B?RHJhZ29ueA==?=
    Oct 2, 2005
  2. Peter
    Replies:
    2
    Views:
    1,018
  3. JoEyCrAcK

    No internet connection with my RH9 through Router

    JoEyCrAcK, Sep 28, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    457
    Meat-->Plow
    Oct 1, 2003
  4. Norman L. DeForest

    Re: Recommendations for spam filtering on RH9+ servers?

    Norman L. DeForest, Nov 24, 2004, in forum: Digital Photography
    Replies:
    21
    Views:
    551
    Norman L. DeForest
    Nov 25, 2004
  5. Paul Welch

    AOL working, Internet Explorer not working

    Paul Welch, Aug 12, 2006, in forum: Computer Support
    Replies:
    3
    Views:
    3,752
    Thoronwen
    Aug 13, 2006
Loading...

Share This Page