Req: 801 Tinyrom1.4.(1)

Discussion in 'Cisco' started by Oliver Doll, Aug 20, 2005.

  1. Oliver Doll

    Oliver Doll Guest

    All,

    I have a broken Cisco801 which I can only access via the console port.
    I need to replace it with a another 801, but this one only has the
    TinyROM1.2 in flash. As I need to run 12.3 I need the 1.4 version.

    I searched for the Tinyrom version at www.cisco.com and ftp.cisco.com
    (ls-lr.Z), but I coulnd't get hold of it.

    Does anybody know where to find it. I tried several hours already to
    get it out of the broken Ciscos flash (e.g. uprading via Xmodem etc.
    but Xmodem works only into one direction and after having a running
    IOS on it I can't "copy flash:Tinyrom xmodem:t"?!

    So any help is appreciated!
    --
    tnx & cheers
    Oliver
     
    Oliver Doll, Aug 20, 2005
    #1
    1. Advertising

  2. Hi Oliver,

    You may wish to investigate the Cisco Sofware Search.

    Search for software images and image metadata:

    http://www.cisco.com/cgi-bin/Software/SWSearch/SWSearch.cgi

    Any problems call Cisco in Germany:

    http://www.bradreese.com/cisco-tac-contacts-worldwide.htm#GERMANY

    Sincerely,

    Brad Reese
    BradReese.Com Cisco Repair Service Experts
    http://www.bradreese.com/index.htm#EXPERTS
    1293 Hendersonville Road, Suite 17
    Asheville, North Carolina USA 28803
    USA/Canada Toll Free: 877-549-2680
    International: 828-277-7272
    United Kingdom: 44-20-70784294
     
    www.BradReese.Com, Aug 20, 2005
    #2
    1. Advertising

  3. Oliver Doll

    Oliver Doll Guest

    On 20 Aug 2005 15:23:57 -0700, "www.BradReese.Com"
    <> wrote:

    >http://www.cisco.com/cgi-bin/Software/SWSearch/SWSearch.cgi


    tnx - this brought me onto the right track.

    I already came across c800u-tinyrom-mw in the FTP sites ls-lR.Z
    listing, but I was scared by the file size (126 KB vs 48 KB in flash).

    But as the SW search for tinyrom mentioned the version# 1.4.1 I gave
    it a try - and voila - I'm there :)

    Life can be see easy if you know what to do ...
    --
    tnx & cheers
    Oliver
     
    Oliver Doll, Aug 21, 2005
    #3
  4. Oliver Doll

    Oliver Doll Guest

    NVRAM corrupt? (was: 801 Tinyrom1.4.(1))

    Now I ran into another issue:

    I can't write files to the NVRAM. The 801

    IOS (tm) C800 Software (C800-K9OSY6-MW), Version 12.3(15a), RELEASE
    SOFTWARE (fc2)
    ROM: TinyROM version 1.4(1)
    Cisco C801 (MPC850) processor (revision 1) with 56024K bytes of
    virtual memory.
    8K bytes of non-volatile configuration memory

    reports failures of the kind:

    router#dir nvram:
    Directory of nvram:/

    1 -rw- 7331 <no date> startup-config
    2 ---- 0 <no date> private-config
    3 -rw- 7331 <no date> underlying-config

    No space information available

    *Mar 1 00:41:44.629: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize
    the geometry of nvram

    A hint at Cisco for this error message recommends:

    "Explanation The software has detected that it failed to initialize
    the NVRAM block geometry (a part of the NVRAM that hosts
    non-configuration data files). Typically, these files are used by SNMP
    to store and retrieve non-configuration persistent data across a
    system reload. This condition may occur when the entire NVRAM is
    packed with the configuration, and the newer version of software that
    supports this feature could not find enough room in the NVRAM to
    initialize the block file system.

    Recommended Action Reduce the configurations in the NVRAM by at
    least 2Kb."

    router#erase /all nvram:
    Erasing the nvram filesystem will remove all files! Continue?
    [confirm]
    %Error erasing nvram: (No such file or directory)
    *Mar 1 00:50:03.813: %SYS-4-NV_BLOCK_INITFAIL: Unable to initialize
    the geometry of nvram

    Do I simply have to consider the NVRAM to be broken or is there
    another way to initialise it again?
    --
    tnx & cheers
    Oliver
     
    Oliver Doll, Aug 21, 2005
    #4
  5. www.BradReese.Com, Aug 21, 2005
    #5
  6. Oliver Doll

    Oliver Doll Guest

    Re: NVRAM corrupt? (was: 801 Tinyrom1.4.(1))

    Brad,

    On 21 Aug 2005 06:34:08 -0700, "www.BradReese.Com"
    <> wrote:

    >You may find the Cisco Router TAC Knowledge Base of assistance:
    >
    >http://129.41.16.73/core/home


    tnx again, but this time I think I couldn't find a solution rather
    than: "Issue the write erase command and reload the router. If the
    issue persists, the hardware will need to be replaced."
    --
    Cheers
    Oliver
     
    Oliver Doll, Aug 21, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Thomas Perl
    Replies:
    4
    Views:
    8,457
    jonathan fernandes
    Jul 16, 2003
  2. C.S.Mager

    Cisco 801 (ISDN)

    C.S.Mager, Oct 23, 2003, in forum: Cisco
    Replies:
    8
    Views:
    567
    C.S.Mager
    Oct 24, 2003
  3. C.S.Mager

    Cisco 801 (ISDN): DNS Relay

    C.S.Mager, Oct 24, 2003, in forum: Cisco
    Replies:
    2
    Views:
    4,281
    Aaron Leonard
    Oct 27, 2003
  4. ph12
    Replies:
    1
    Views:
    416
    Walter Roberson
    Oct 31, 2003
  5. Olufemi

    CCNA 640-801 Resources

    Olufemi, Nov 4, 2003, in forum: Cisco
    Replies:
    1
    Views:
    469
Loading...

Share This Page