Repost: OSPF and type 4 LSAs

Discussion in 'Cisco' started by Mikey, Aug 3, 2004.

  1. Mikey

    Mikey Guest

    I originally posted this to alt.certification.cisco. I wanted to repost it
    here and see if someone can straighten me out on OSPF type 4 LSAs.

    Thanks in advance,

    Mikey
    ------------------------------------------------------------------------
    Thanks for the reply Hansang...Your right...E1 on R1 is not being used.
    Also, I failed to mention in my description that there actually is a Linux
    server running zebra and ospfd that is in the picture. The it has one
    interface on the same network as E0 on both of the 2514s and another
    interface on a different network. Both of it's interfaces are in area 0.
    The configurations of both 2514s and their OSPF databases are listed
    first....without the Linux server connected. In that scenerio, only 1 type
    4 LSA shows in area 1. That makes sense to me. But, I found that one the
    Linux server is brought online and forms an adjacency on the same network as
    the e0 interfaces on the 2 2514s, the second type 4 LSA shows up in area 1.
    That I don't understand. The last 2 database listings are from both 2514s,
    once the Linux server is online.

    Thanks again,

    Mike

    Router 1

    interface Loopback0
    ip address 192.168.254.1 255.255.255.255
    !
    interface Ethernet0
    ip address 192.168.2.254 255.255.255.0
    !
    interface Ethernet1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.2.0 0.0.0.255 area 0
    default-information originate always
    !

    OSPF Router with ID (192.168.254.1) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.254.1 192.168.254.1 313 0x80000002 0x8C42 1
    192.168.254.2 192.168.254.2 313 0x80000002 0x23F9 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.2.175 192.168.254.2 314 0x80000001 0xB030

    Summary Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.75.0 192.168.254.2 344 0x80000001 0xEE25

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 192.168.254.1 373 0x80000001 0x3019 1


    Router 2

    interface Loopback0
    ip address 192.168.254.2 255.255.255.255
    !
    interface Ethernet0
    ip address 192.168.2.175 255.255.255.0
    !
    interface Ethernet1
    ip address 192.168.75.1 255.255.255.0
    no keepalive
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.75.0 0.0.0.255 area 1
    !

    OSPF Router with ID (192.168.254.2) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.254.1 192.168.254.1 171 0x80000002 0x8C42 1
    192.168.254.2 192.168.254.2 171 0x80000002 0x23F9 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.2.175 192.168.254.2 171 0x80000001 0xB030

    Summary Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.75.0 192.168.254.2 200 0x80000001 0xEE25

    Router Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.254.2 192.168.254.2 210 0x80000001 0x599 1

    Summary Net Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum
    192.168.2.0 192.168.254.2 160 0x80000003 0x114A

    Summary ASB Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum
    192.168.254.1 192.168.254.2 156 0x80000001 0x1E40

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 192.168.254.1 231 0x80000001 0x3019 1


    Router 1 with Linux server online

    OSPF Router with ID (192.168.254.1) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.2.253 192.168.2.253 114 0x8000009F 0x4689 2
    192.168.254.1 192.168.254.1 594 0x80000002 0x8C42 1
    192.168.254.2 192.168.254.2 118 0x80000003 0x21FA 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.2.175 192.168.254.2 118 0x80000002 0x8AE7

    Summary Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.75.0 192.168.2.175 1223 0x80000001 0xC79B
    192.168.75.0 192.168.254.2 624 0x80000001 0xEE25

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 192.168.254.1 118 0x80000081 0x2F99 1


    Router 2 with Linux server online

    OSPF Router with ID (192.168.254.2) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.2.253 192.168.2.253 54 0x8000009F 0x4689 2
    192.168.254.1 192.168.254.1 534 0x80000002 0x8C42 1
    192.168.254.2 192.168.254.2 58 0x80000003 0x21FA 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.2.175 192.168.254.2 57 0x80000002 0x8AE7

    Summary Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum
    192.168.75.0 192.168.2.175 1163 0x80000001 0xC79B
    192.168.75.0 192.168.254.2 563 0x80000001 0xEE25

    Router Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum Link count
    192.168.254.2 192.168.254.2 573 0x80000001 0x599 1

    Summary Net Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum
    192.168.1.0 192.168.254.2 43 0x80000001 0x84CF
    192.168.2.0 192.168.254.2 523 0x80000003 0x114A

    Summary ASB Link States (Area 1)

    Link ID ADV Router Age Seq# Checksum
    192.168.254.1 192.168.254.2 519 0x80000001 0x1E40
    192.168.254.2 192.168.254.2 58 0x80000001 0x91F5

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 192.168.254.1 58 0x80000081 0x2F99 1

    "Hansang Bae" <> wrote in message
    news:...
    > In article <>,
    > says...
    > > I've noticed something in a lab environment that I don't understand.

    I'm
    > > going to try to keep this simple. I've got 2 2514 routers that I'm

    playing
    > > with. The e0 interface on both routers is connected to a common

    network.
    > > Both interfaces are in area 0. Router 1 is originating a default route

    with
    > > the 'default information originate always' statement. Looking at the

    link
    > > state databases on either router, no type 4 LSAs. Now, the e1 interface

    on
    > > Router 2 is assigned an address on a different network and placed in

    area 1.
    > > Router 2 is now an ABR. Router 2's link state database now shows 2 type

    4
    > > LSAs...one with the link state id of Router 1's router ID and the other

    with
    > > the link state id of of Router 2's router ID...both sourced from Router

    2.
    > > If I drop the default route originated by Router 1, the type 4 LSA with

    the
    > > link state id of Router 1's router ID, disappears, but the other stays.

    Why
    > > is that type 4 LSA left? I think I need a better understanding of type

    4
    > > LSAs. I know by definition they are sourced by the ABR and refer to the
    > > ASBR, but my lab result has me a little puzzled.
    > >
    > > Thanks in advance,

    >
    > CAn you post the ospf and interface commands from your routers.
    >
    > And as I understand it, E0 on both routers are in area 0 and E1 on R2 is
    > in a different area. So E1 from R1 is not in use?
    >
    > --
    >
    > hsb
    >
    > "Somehow I imagined this experience would be more rewarding" Calvin
    > *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    > ********************************************************************
    > Due to the volume of email that I receive, I may not not be able to
    > reply to emails sent to my account. Please post a followup instead.
    > ********************************************************************
    Mikey, Aug 3, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    477
  2. philbo30
    Replies:
    1
    Views:
    629
  3. darfun
    Replies:
    1
    Views:
    560
  4. darfun

    lsas.blaster.keylogger virus

    darfun, May 4, 2010, in forum: Cisco
    Replies:
    7
    Views:
    660
  5. dfinc

    lsas.blaster.keylogger virus removal guide

    dfinc, May 10, 2010, in forum: Computer Security
    Replies:
    0
    Views:
    1,257
    dfinc
    May 10, 2010
Loading...

Share This Page