Replacing two routers with a single (multi)modular one: help withroutes

Discussion in 'Cisco' started by gb, Aug 27, 2009.

  1. gb

    gb Guest

    Hi,

    I need to replace a cisco 837 (connected to an adsl circuit) and a
    1720 (connected to an HDSL circuit via a serial modem) with a new 1841
    having 2 WICS (Adsl and serial).

    The 837 and the 1720 are perimeter routers, used by an internal router
    and a couple of PIX firewalls to manage a few VPNs.
    So it's important that the new 1841 will work exactly as the 837 and
    the 1720.

    I post below the relevant parts of the 837 and 1720 configs, plus a
    tantative config of the 1841.

    My problem is how to manage the (default) routes on the new 1841...
    can you point me to the right direction please?
    Any help is greatly appreciated

    Thanks in advance
    Guido



    837 (manages ADSL circuit)
    ----------------------------
    interface Ethernet0
    ip address aaa.aaa.aaa.aaa 255.255.255.248
    hold-queue 100 out
    !!
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0.1 point-to-point
    bandwidth 1280
    ip address bbb.bbb.bbb.bbb 255.255.255.252
    no snmp trap link-status
    pvc 8/35
    encapsulation aal5snap
    !
    !
    interface FastEthernet1
    duplex auto
    speed auto
    !
    interface FastEthernet2
    duplex auto
    speed auto
    !
    interface FastEthernet3
    duplex auto
    speed auto
    !
    interface FastEthernet4
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 ATM0.1



    1720 (manages HDSL circuit)
    ----------------------------
    interface FastEthernet0
    bandwidth 100000
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    speed auto
    !
    interface Serial0
    bandwidth 256
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0.1 point-to-point
    bandwidth 2048
    ip address yyy.yyy.yyy.yyy 255.255.255.252
    no arp frame-relay
    no cdp enable
    frame-relay interface-dlci 345 IETF
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.1



    1841 (new router with WIC ADSL & serial WIC x to replace both 837 and
    1720)
    ------------------------------------------------------------------------
    interface FastEthernet0/0
    description ** replaces 1720 FastEthernet0 **
    bandwidth 100000
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    speed auto
    !
    interface FastEthernet0/1
    description ** replaces 837 Ethernet0 **
    bandwidth 100000
    ip address aaa.aaa.aaa.aaa 255.255.255.248
    speed auto
    !
    interface Serial0/0/0
    bandwidth 256
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0/0.1 point-to-point
    description ** replaces 1720 serial0.1 **
    bandwidth 2048
    ip address yyy.yyy.yyy.yyy 255.255.255.252
    no arp frame-relay
    no cdp enable
    frame-relay interface-dlci 345 IETF
    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0/1/0.1 point-to-point
    description ** replaces 837 ATM0.1 **
    bandwidth 1280
    ip address bbb.bbb.bbb.bbb 255.255.255.252
    no snmp trap link-status
    pvc 8/35
    encapsulation aal5snap
    !
    ip classless
    ip route ---> *** how should I set this to have this 1841 behave
    exactly as 1720+837? ***
    gb, Aug 27, 2009
    #1
    1. Advertising

  2. gb

    Techno_Guy Guest

    On Aug 27, 3:38 am, gb <> wrote:
    > Hi,
    >
    > I need to replace a cisco 837 (connected to an adsl circuit) and a
    > 1720 (connected to an HDSL circuit via a serial modem) with a new 1841
    > having 2 WICS (Adsl and serial).
    >
    > The 837 and the 1720 are perimeter routers, used by an internal router
    > and a couple of PIX firewalls to manage a few VPNs.
    > So it's important that the new 1841 will work exactly as the 837 and
    > the 1720.
    >
    > I post below the relevant parts of the 837 and 1720 configs, plus a
    > tantative config of the 1841.
    >
    > My problem is how to manage the (default) routes on the new 1841...
    > can you point me to the right direction please?
    > Any help is greatly appreciated
    >
    > Thanks in advance
    > Guido
    >
    > 837 (manages ADSL circuit)
    > ----------------------------
    > interface Ethernet0
    > ip address aaa.aaa.aaa.aaa 255.255.255.248
    > hold-queue 100 out
    > !!
    > interface ATM0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > hold-queue 224 in
    > !
    > interface ATM0.1 point-to-point
    > bandwidth 1280
    > ip address bbb.bbb.bbb.bbb 255.255.255.252
    > no snmp trap link-status
    > pvc 8/35
    > encapsulation aal5snap
    > !
    > !
    > interface FastEthernet1
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet2
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet3
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet4
    > duplex auto
    > speed auto
    > !
    > ip forward-protocol nd
    > ip route 0.0.0.0 0.0.0.0 ATM0.1
    >
    > 1720 (manages HDSL circuit)
    > ----------------------------
    > interface FastEthernet0
    > bandwidth 100000
    > ip address xxx.xxx.xxx.xxx 255.255.255.248
    > speed auto
    > !
    > interface Serial0
    > bandwidth 256
    > no ip address
    > encapsulation frame-relay IETF
    > !
    > interface Serial0.1 point-to-point
    > bandwidth 2048
    > ip address yyy.yyy.yyy.yyy 255.255.255.252
    > no arp frame-relay
    > no cdp enable
    > frame-relay interface-dlci 345 IETF
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Serial0.1
    >
    > 1841 (new router with WIC ADSL & serial WIC x to replace both 837 and
    > 1720)
    > ------------------------------------------------------------------------
    > interface FastEthernet0/0
    > description ** replaces 1720 FastEthernet0 **
    > bandwidth 100000
    > ip address xxx.xxx.xxx.xxx 255.255.255.248
    > speed auto
    > !
    > interface FastEthernet0/1
    > description ** replaces 837 Ethernet0 **
    > bandwidth 100000
    > ip address aaa.aaa.aaa.aaa 255.255.255.248
    > speed auto
    > !
    > interface Serial0/0/0
    > bandwidth 256
    > no ip address
    > encapsulation frame-relay IETF
    > !
    > interface Serial0/0/0.1 point-to-point
    > description ** replaces 1720 serial0.1 **
    > bandwidth 2048
    > ip address yyy.yyy.yyy.yyy 255.255.255.252
    > no arp frame-relay
    > no cdp enable
    > frame-relay interface-dlci 345 IETF
    > !
    > interface ATM0/1/0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > hold-queue 224 in
    > !
    > interface ATM0/1/0.1 point-to-point
    > description ** replaces 837 ATM0.1 **
    > bandwidth 1280
    > ip address bbb.bbb.bbb.bbb 255.255.255.252
    > no snmp trap link-status
    > pvc 8/35
    > encapsulation aal5snap
    > !
    > ip classless
    > ip route ---> *** how should I set this to have this 1841 behave
    > exactly as 1720+837? ***


    If I understand this correctly, your going to have 1 router, 2
    different circuits and you need to route traffic out different
    interfaces based on the circuit it should route. If that is correct
    you can use policy based routing to route by source address.

    iF i did not understand you correctly then please clarify.
    Techno_Guy, Aug 28, 2009
    #2
    1. Advertising

  3. gb

    gb Guest

    Yes, I need to do exactly that.

    To clarify further:
    if a packet enters the 1841 from interface FastEthernet0/0 then send
    it out to Serial0/0/0.1
    if it enters from FastEthernet0/1 then send it out to ATM0/0/0.1

    Could you please help me with the commands and the syntax I should use
    to implement policy based routing in my specific case?

    Thanks in advance
    Guido
    gb, Aug 28, 2009
    #3
  4. gb

    Techno_Guy Guest

    On Aug 28, 1:10 pm, gb <> wrote:
    > Yes, I need to do exactly that.
    >
    > To clarify further:
    > if a packet enters the 1841 from interface FastEthernet0/0  then send
    > it out to Serial0/0/0.1
    > if it enters from FastEthernet0/1  then send it out to ATM0/0/0.1
    >
    > Could you please help me with the commands and the syntax I should use
    > to implement policy based routing in my specific case?
    >
    > Thanks in advance
    > Guido


    http://www.itsyourip.com/cisco/how-to-setup-ip-policy-based-routing-in-cisco-routerios/

    Here ya go.

    http://www.cisco.com/en/US/docs/ios...TSD_Products_Configuration_Guide_Chapter.html

    Either website will tell you just what to do. Good luck and let me
    know if you dont understand. I think howerver, after reading these
    links you will be in good shape.
    Techno_Guy, Aug 29, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. James Parks

    Two ISP -Two Routers - 1 PIX

    James Parks, Dec 8, 2003, in forum: Cisco
    Replies:
    5
    Views:
    3,646
    James Parks
    Dec 11, 2003
  2. samul888@vip.163.com
    Replies:
    1
    Views:
    836
    Jayesh Sharma
    Nov 13, 2005
  3. BlueRinse
    Replies:
    25
    Views:
    5,523
    Marc H.Popek
    May 23, 2005
  4. samul888@vip.163.com
    Replies:
    0
    Views:
    839
    samul888@vip.163.com
    Nov 12, 2005
  5. samul888@vip.163.com
    Replies:
    0
    Views:
    738
    samul888@vip.163.com
    Nov 12, 2005
Loading...

Share This Page