remote desktop (complex setup)

Discussion in 'MCSE' started by Cheri Holloway, Aug 16, 2006.

  1. Ok, here's my scenerio. I am studying for my MCDST and came across remote
    desktop configuration and decided to play around with my own network using
    port forwarding on my router. I sucessfully forwarded all incoming
    connections to port 3389 to my server (running Exchange Server 2003) and was
    able to connect sucessfully from inside and outside my local network. But
    here is what I want to do. I want to ALSO set up a connection to my desktop
    computer running XP Pro. Because I can only forward port 3389 to one
    computer, I was wondering how I can configure another connection to forward
    to the other computer. I researched microsoft's knowledge base and found out
    I can use the 255.255.255.255:1234 (IP being the IP of the network and the
    port being the configured port) to connect remotely using a different port,
    so I configured my router to forward 3390 to my desktop, enabled remote
    desktop on the my desktop, opened the port on my firewall, and tested it. It
    didn't work. I am able to remote to the desktop from INSIDE the network, but
    not from outside. What can I do?
    Cheri Holloway, Aug 16, 2006
    #1
    1. Advertising

  2. Cheri Holloway

    LRM Guest

    "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and
    > was able to connect sucessfully from inside and outside my local network.
    > But here is what I want to do. I want to ALSO set up a connection to my
    > desktop computer running XP Pro. Because I can only forward port 3389 to
    > one computer, I was wondering how I can configure another connection to
    > forward to the other computer. I researched microsoft's knowledge base and
    > found out I can use the 255.255.255.255:1234 (IP being the IP of the
    > network and the port being the configured port) to connect remotely using
    > a different port, so I configured my router to forward 3390 to my desktop,
    > enabled remote desktop on the my desktop, opened the port on my firewall,
    > and tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?
    >

    Which kb are you referencing? I don't bother with setting up a second
    forwarder. When I login to the first box I can create as many rdp
    connections to my internal network as I like.

    --
    LRM
    MCNGP 7^2
    www.mcngp.com home of the bogosity singularity.
    LRM, Aug 16, 2006
    #2
    1. Advertising

  3. "LRM" <> wrote in message
    news:...
    > "Cheri Holloway" <> wrote in message
    > news:...
    >> Ok, here's my scenerio. I am studying for my MCDST and came across remote
    >> desktop configuration and decided to play around with my own network
    >> using port forwarding on my router. I sucessfully forwarded all incoming
    >> connections to port 3389 to my server (running Exchange Server 2003) and
    >> was able to connect sucessfully from inside and outside my local network.
    >> But here is what I want to do. I want to ALSO set up a connection to my
    >> desktop computer running XP Pro. Because I can only forward port 3389 to
    >> one computer, I was wondering how I can configure another connection to
    >> forward to the other computer. I researched microsoft's knowledge base
    >> and found out I can use the 255.255.255.255:1234 (IP being the IP of the
    >> network and the port being the configured port) to connect remotely using
    >> a different port, so I configured my router to forward 3390 to my
    >> desktop, enabled remote desktop on the my desktop, opened the port on my
    >> firewall, and tested it. It didn't work. I am able to remote to the
    >> desktop from INSIDE the network, but not from outside. What can I do?
    >>

    > Which kb are you referencing? I don't bother with setting up a second
    > forwarder. When I login to the first box I can create as many rdp
    > connections to my internal network as I like.
    >
    > --
    > LRM
    > MCNGP 7^2
    > www.mcngp.com home of the bogosity singularity.
    >


    I saw it at: http://support.microsoft.com/?kbid=304304 I have been able to
    remote into my server and then remote into the desktop from the server
    (basically a piggy-back remote connection, if you will) if that's what
    you're talking about) but it interests me to find out if there is another
    way to do it, but upon searching for that KB article, I came across another
    article referencing how to change the port that remote desktop listens on
    through registry editor, so I'm gonna give that a shot. I'll let you know if
    it works.
    Cheri Holloway, Aug 16, 2006
    #3
  4. Cheri Holloway

    LRM Guest

    "Cheri Holloway" <> wrote in message
    news:...
    >
    >
    > "LRM" <> wrote in message
    > news:...
    >> "Cheri Holloway" <> wrote in message
    >> news:...
    >>> Ok, here's my scenerio. I am studying for my MCDST and came across
    >>> remote desktop configuration and decided to play around with my own
    >>> network using port forwarding on my router. I sucessfully forwarded all
    >>> incoming connections to port 3389 to my server (running Exchange Server
    >>> 2003) and was able to connect sucessfully from inside and outside my
    >>> local network. But here is what I want to do. I want to ALSO set up a
    >>> connection to my desktop computer running XP Pro. Because I can only
    >>> forward port 3389 to one computer, I was wondering how I can configure
    >>> another connection to forward to the other computer. I researched
    >>> microsoft's knowledge base and found out I can use the
    >>> 255.255.255.255:1234 (IP being the IP of the network and the port being
    >>> the configured port) to connect remotely using a different port, so I
    >>> configured my router to forward 3390 to my desktop, enabled remote
    >>> desktop on the my desktop, opened the port on my firewall, and tested
    >>> it. It didn't work. I am able to remote to the desktop from INSIDE the
    >>> network, but not from outside. What can I do?
    >>>

    >> Which kb are you referencing? I don't bother with setting up a second
    >> forwarder. When I login to the first box I can create as many rdp
    >> connections to my internal network as I like.
    >>
    >> --
    >> LRM
    >> MCNGP 7^2
    >> www.mcngp.com home of the bogosity singularity.
    >>

    >
    > I saw it at: http://support.microsoft.com/?kbid=304304 I have been able
    > to remote into my server and then remote into the desktop from the server
    > (basically a piggy-back remote connection, if you will) if that's what
    > you're talking about) but it interests me to find out if there is another
    > way to do it, but upon searching for that KB article, I came across
    > another article referencing how to change the port that remote desktop
    > listens on through registry editor, so I'm gonna give that a shot. I'll
    > let you know if it works.
    >

    Please do. I was too lazy. Just out of curiosity, what is your layer 3
    device? A DSL modem? a Router? Could change things.
    LRM, Aug 16, 2006
    #4
  5. Cheri Holloway

    lowdes Guest

    http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx

    lowdes

    "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and
    > was able to connect sucessfully from inside and outside my local network.
    > But here is what I want to do. I want to ALSO set up a connection to my
    > desktop computer running XP Pro. Because I can only forward port 3389 to
    > one computer, I was wondering how I can configure another connection to
    > forward to the other computer. I researched microsoft's knowledge base and
    > found out I can use the 255.255.255.255:1234 (IP being the IP of the
    > network and the port being the configured port) to connect remotely using
    > a different port, so I configured my router to forward 3390 to my desktop,
    > enabled remote desktop on the my desktop, opened the port on my firewall,
    > and tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?
    >
    lowdes, Aug 16, 2006
    #5
  6. Cheri Holloway

    Kurt Guest

    "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and
    > was able to connect sucessfully from inside and outside my local network.
    > But here is what I want to do. I want to ALSO set up a connection to my
    > desktop computer running XP Pro. Because I can only forward port 3389 to
    > one computer, I was wondering how I can configure another connection to
    > forward to the other computer. I researched microsoft's knowledge base and
    > found out I can use the 255.255.255.255:1234 (IP being the IP of the
    > network and the port being the configured port) to connect remotely using
    > a different port, so I configured my router to forward 3390 to my desktop,
    > enabled remote desktop on the my desktop, opened the port on my firewall,
    > and tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?
    >


    Run Regedit, go to
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal
    Server\WinStations\RDP-Tcp. Change the "PortNumber" subkey from 3389
    (00000D3D hex) To whatever you want your RDP to listen on. Sometimes you
    have to reboot, sometimes not.

    ....kurt
    Kurt, Aug 16, 2006
    #6
  7. "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and

    was
    > able to connect sucessfully from inside and outside my local network. But
    > here is what I want to do. I want to ALSO set up a connection to my

    desktop
    > computer running XP Pro. Because I can only forward port 3389 to one
    > computer, I was wondering how I can configure another connection to

    forward
    > to the other computer. I researched microsoft's knowledge base and found

    out
    > I can use the 255.255.255.255:1234 (IP being the IP of the network and the
    > port being the configured port) to connect remotely using a different

    port,
    > so I configured my router to forward 3390 to my desktop, enabled remote
    > desktop on the my desktop, opened the port on my firewall, and tested it.

    It
    > didn't work. I am able to remote to the desktop from INSIDE the network,

    but
    > not from outside. What can I do?
    >
    >


    You missed one step. You need to configure RDP on the XP box to use the
    revised port#.
    Jonathan Roberts, Aug 16, 2006
    #7
  8. Cheri Holloway

    Frisbee® Guest

    "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and
    > was able to connect sucessfully from inside and outside my local network.
    > But here is what I want to do. I want to ALSO set up a connection to my
    > desktop computer running XP Pro. Because I can only forward port 3389 to
    > one computer, I was wondering how I can configure another connection to
    > forward to the other computer. I researched microsoft's knowledge base and
    > found out I can use the 255.255.255.255:1234 (IP being the IP of the
    > network and the port being the configured port) to connect remotely using
    > a different port, so I configured my router to forward 3390 to my desktop,
    > enabled remote desktop on the my desktop, opened the port on my firewall,
    > and tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?


    R U Hawt?
    Frisbee®, Aug 16, 2006
    #8
  9. "LRM" <> wrote in message
    news:%...
    > "Cheri Holloway" <> wrote in message
    > news:...
    >>
    >>
    >> "LRM" <> wrote in message
    >> news:...
    >>> "Cheri Holloway" <> wrote in message
    >>> news:...
    >>>> Ok, here's my scenerio. I am studying for my MCDST and came across
    >>>> remote desktop configuration and decided to play around with my own
    >>>> network using port forwarding on my router. I sucessfully forwarded all
    >>>> incoming connections to port 3389 to my server (running Exchange Server
    >>>> 2003) and was able to connect sucessfully from inside and outside my
    >>>> local network. But here is what I want to do. I want to ALSO set up a
    >>>> connection to my desktop computer running XP Pro. Because I can only
    >>>> forward port 3389 to one computer, I was wondering how I can configure
    >>>> another connection to forward to the other computer. I researched
    >>>> microsoft's knowledge base and found out I can use the
    >>>> 255.255.255.255:1234 (IP being the IP of the network and the port being
    >>>> the configured port) to connect remotely using a different port, so I
    >>>> configured my router to forward 3390 to my desktop, enabled remote
    >>>> desktop on the my desktop, opened the port on my firewall, and tested
    >>>> it. It didn't work. I am able to remote to the desktop from INSIDE the
    >>>> network, but not from outside. What can I do?
    >>>>
    >>> Which kb are you referencing? I don't bother with setting up a second
    >>> forwarder. When I login to the first box I can create as many rdp
    >>> connections to my internal network as I like.
    >>>
    >>> --
    >>> LRM
    >>> MCNGP 7^2
    >>> www.mcngp.com home of the bogosity singularity.
    >>>

    >>
    >> I saw it at: http://support.microsoft.com/?kbid=304304 I have been able
    >> to remote into my server and then remote into the desktop from the server
    >> (basically a piggy-back remote connection, if you will) if that's what
    >> you're talking about) but it interests me to find out if there is another
    >> way to do it, but upon searching for that KB article, I came across
    >> another article referencing how to change the port that remote desktop
    >> listens on through registry editor, so I'm gonna give that a shot. I'll
    >> let you know if it works.
    >>

    > Please do. I was too lazy. Just out of curiosity, what is your layer 3
    > device? A DSL modem? a Router? Could change things.
    >

    I changed the port in regedit. No success. I'm going to revert all changes
    to the router, server, and desktop, and then just set up one connection just
    to the desktop and see if that works. I know I can connect from the inside
    of the network, but maybe there is something else going on that I'm not
    seeing as far as being able to connect from the outside, customized
    connection or not. Anyhow, I've got a cable modem hooked into a router. Will
    update later.
    Cheri Holloway, Aug 16, 2006
    #9
  10. "Jonathan Roberts" wrote:

    > You missed one step. You need to configure RDP on the XP box to use the
    > revised port#.
    >
    >


    True. By default, RDP on the XP box only listen to port 3389. What you can
    do is to modify the RDP file. You can create an RDP connection file using a
    text editor. The simplest way to do it initially, though, is to run the
    mstsc client, configure basic settings you want, then choose "Save As..." on
    the General tab. You can then open the resulting file in Notepad and work
    with it. From there, you can change the server port to suite your need.
    Neat huh ?
    =?Utf-8?B?RHJhZ29uIFdpdGhvdXQgV2luZ3M=?=, Aug 16, 2006
    #10
  11. Cheri Holloway

    TBone Guest

    And on the eigth day "Cheri Holloway" <> did
    cause the electrons to come together and form the following words:

    > I researched microsoft's knowledge base and found out I can
    > use the 255.255.255.255:1234 (IP being the IP of the network and the
    > port being the configured port) to connect remotely using a different
    > port, so I configured my router to forward 3390 to my desktop, enabled
    > remote desktop on the my desktop, opened the port on my firewall, and
    > tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?


    I have a setup like this at home. You have to tell the router to redirect
    port 3390 to port 3389 on your desktop.

    --
    T-Bone
    MCNGP XL
    TBone, Aug 16, 2006
    #11
  12. Yeah - I've done 5 RDP Sessions - one inside another before.

    I had an issue with some routers an data flow so we were unable to push past
    3 routers form out side the network, but I was able to push inside from one
    hop to another one at a time. So to get to the problem router I had to RDP
    into each subnet from inside the last RDP. After which I was able to hit the
    routers remote console.

    Terminal Services is a lot of fun. :)

    --
    ..rev - mct.mcngp.44
    ..
    "It is the mark of an educated man to be able to entertain a thought without
    accepting it"
    ~Aristotle.
    ..
    "LRM" <> wrote in message
    news:...
    > "Cheri Holloway" <> wrote in message
    > news:...
    >> Ok, here's my scenerio. I am studying for my MCDST and came across remote
    >> desktop configuration and decided to play around with my own network
    >> using port forwarding on my router. I sucessfully forwarded all incoming
    >> connections to port 3389 to my server (running Exchange Server 2003) and
    >> was able to connect sucessfully from inside and outside my local network.
    >> But here is what I want to do. I want to ALSO set up a connection to my
    >> desktop computer running XP Pro. Because I can only forward port 3389 to
    >> one computer, I was wondering how I can configure another connection to
    >> forward to the other computer. I researched microsoft's knowledge base
    >> and found out I can use the 255.255.255.255:1234 (IP being the IP of the
    >> network and the port being the configured port) to connect remotely using
    >> a different port, so I configured my router to forward 3390 to my
    >> desktop, enabled remote desktop on the my desktop, opened the port on my
    >> firewall, and tested it. It didn't work. I am able to remote to the
    >> desktop from INSIDE the network, but not from outside. What can I do?
    >>

    > Which kb are you referencing? I don't bother with setting up a second
    > forwarder. When I login to the first box I can create as many rdp
    > connections to my internal network as I like.
    >
    > --
    > LRM
    > MCNGP 7^2
    > www.mcngp.com home of the bogosity singularity.
    >
    The Rev [MCT], Aug 16, 2006
    #12
  13. Cheri Holloway

    Consultant Guest

    double true

    "Frisbee®" <> wrote in message
    news:%...
    > "Cheri Holloway" <> wrote in message
    > news:...
    >> Ok, here's my scenerio. I am studying for my MCDST and came across remote
    >> desktop configuration and decided to play around with my own network
    >> using port forwarding on my router. I sucessfully forwarded all incoming
    >> connections to port 3389 to my server (running Exchange Server 2003) and
    >> was able to connect sucessfully from inside and outside my local network.
    >> But here is what I want to do. I want to ALSO set up a connection to my
    >> desktop computer running XP Pro. Because I can only forward port 3389 to
    >> one computer, I was wondering how I can configure another connection to
    >> forward to the other computer. I researched microsoft's knowledge base
    >> and found out I can use the 255.255.255.255:1234 (IP being the IP of the
    >> network and the port being the configured port) to connect remotely using
    >> a different port, so I configured my router to forward 3390 to my
    >> desktop, enabled remote desktop on the my desktop, opened the port on my
    >> firewall, and tested it. It didn't work. I am able to remote to the
    >> desktop from INSIDE the network, but not from outside. What can I do?

    >
    > R U Hawt?
    >
    Consultant, Aug 16, 2006
    #13
  14. Cheri Holloway

    Guest

    Dragon Without Wings wrote:
    > "Jonathan Roberts" wrote:
    >
    > > You missed one step. You need to configure RDP on the XP box to use the
    > > revised port#.
    > >
    > >

    >
    > True. By default, RDP on the XP box only listen to port 3389. What you can
    > do is to modify the RDP file. You can create an RDP connection file using a
    > text editor. The simplest way to do it initially, though, is to run the
    > mstsc client, configure basic settings you want, then choose "Save As..." on
    > the General tab. You can then open the resulting file in Notepad and work
    > with it. From there, you can change the server port to suite your need.
    > Neat huh ?


    Unless I mis-understand you, you would still need to modify the
    listening port.
    , Aug 16, 2006
    #14
  15. Cheri Holloway

    Briscobar Guest

    "Cheri Holloway" <> wrote in message
    news:...
    > Ok, here's my scenerio. I am studying for my MCDST and came across remote
    > desktop configuration and decided to play around with my own network using
    > port forwarding on my router. I sucessfully forwarded all incoming
    > connections to port 3389 to my server (running Exchange Server 2003) and
    > was able to connect sucessfully from inside and outside my local network.
    > But here is what I want to do. I want to ALSO set up a connection to my
    > desktop computer running XP Pro. Because I can only forward port 3389 to
    > one computer, I was wondering how I can configure another connection to
    > forward to the other computer. I researched microsoft's knowledge base and
    > found out I can use the 255.255.255.255:1234 (IP being the IP of the
    > network and the port being the configured port) to connect remotely using
    > a different port, so I configured my router to forward 3390 to my desktop,
    > enabled remote desktop on the my desktop, opened the port on my firewall,
    > and tested it. It didn't work. I am able to remote to the desktop from
    > INSIDE the network, but not from outside. What can I do?


    I don't have the exact key handy, but you'll have to edit the registry to
    get RDP to listen to a different port. IIRC it's 2 keys' values you'll have
    to change. Or, alternatively, and this is what I frequently do, is set up a
    RD to one machine, then on that machine, set up more RD's to other machines.
    This way, when I'm outside my network, I can remote into my network, then
    hop nimbly-bimbly from machine to machine via other RD's.

    HTH.
    Briscobar, Aug 22, 2006
    #15
  16. Cheri Holloway

    Briscobar Guest

    "Dragon Without Wings" <> wrote in message
    news:...
    > "Jonathan Roberts" wrote:
    >
    >> You missed one step. You need to configure RDP on the XP box to use the
    >> revised port#.
    >>
    >>

    >
    > True. By default, RDP on the XP box only listen to port 3389. What you
    > can
    > do is to modify the RDP file. You can create an RDP connection file using
    > a
    > text editor. The simplest way to do it initially, though, is to run the
    > mstsc client, configure basic settings you want, then choose "Save As..."
    > on
    > the General tab. You can then open the resulting file in Notepad and work
    > with it. From there, you can change the server port to suite your need.
    > Neat huh ?


    Huh. Learn somethin new every day. I didn't know RDP files were
    text-editable. Sweet.
    Briscobar, Aug 22, 2006
    #16
  17. Cheri Holloway

    Simon Dobson Guest

    Briscobar wrote:
    >
    > I don't have the exact key handy, but you'll have to edit the registry to
    > get RDP to listen to a different port. IIRC it's 2 keys' values you'll have
    > to change. Or, alternatively, and this is what I frequently do, is set up a
    > RD to one machine, then on that machine, set up more RD's to other machines.
    > This way, when I'm outside my network, I can remote into my network, then
    > hop nimbly-bimbly from machine to machine via other RD's.


    The OP could always port forward say 3390 (WAN side) to 3389 on the LAN
    side on a different machine. So:

    ExternalIP:3389 --> Router:3389 --> PC1:3389
    ExternalIP:3390 --> Router:3390 --> PC2:3389

    Most routers can do this. Far better than buggering about with the
    registry to change RDP's default port; avoid this as it means
    remembering to specify a different port number internally too.
    Simon Dobson, Aug 25, 2006
    #17
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter Sale
    Replies:
    1
    Views:
    11,940
    Robin Walker
    Dec 11, 2004
  2. Dave Marden
    Replies:
    16
    Views:
    10,661
    Dave Marden
    Jan 24, 2004
  3. AJ
    Replies:
    1
    Views:
    534
    Walter Roberson
    Apr 11, 2006
  4. Vik

    Setup domain name for Remote desktop

    Vik, Apr 25, 2007, in forum: Computer Support
    Replies:
    1
    Views:
    895
    Mr. Arnold
    Apr 25, 2007
  5. Vik

    Setup domain name for Remote desktop

    Vik, Apr 25, 2007, in forum: Computer Support
    Replies:
    0
    Views:
    416
Loading...

Share This Page