Redundant Design.

Discussion in 'Cisco' started by Shaun, Jan 19, 2005.

  1. Shaun

    Shaun Guest

    I am attempting to setup a level of redundancy on my network and to m
    provider. I went out and bought 2xc3550-24-EI cisco switches an
    2xc2950G-48 switches. I plan on using the 2950G-48's as the edge t
    my customer and the 3550's for my core/aggrigation. My current setu
    looks somthing like this..

    ------------------------
    | PROVIDER
    ------------------------
    |
    |
    ---------- ----------
    | Primary |___| Secondary
    | C3550-EI | | C3550-EI
    ---------- -----------
    | \ /
    | \/
    | /\
    | / \
    ---------- ----------
    | C2950G | | C2950G
    ---------- ----------
    | |
    Customer#1 Customer#
    Rack Rac


    right now on both 3550's fa 0/1 is connected to my provider and ha
    vlan 2 assigned to them. My provider assigned me a /29 and i a
    running HSRP. They also told me i should run ospf so that if on
    3550 fails the traffic will know of the other path out. I have bee
    bugging them alot so i figured i would post here and get your input.
    I'm not sure if my confuration is correct

    provider assigned me 10.23.174.16/2
    There routers are 10.23.174.17 and 10.23.174.18
    There virtual router is 10.23.174.1
    my ip space is 10.10.36.0/2

    Here is my current config..

    [code:1:92f16e6d32
    3550 #
    ----------------------------------------------------------------------
    interface FastEthernet0/
    switchport access vlan
    switchport mode acces

    interface FastEthernet0/
    description link to Second 355
    switchport trunk encapsulation dot1
    switchport mode trun

    interface Vlan
    ip address 10.23.174.20 255.255.255.24
    no ip redirect
    standby 1 ip 10.23.174.2
    standby 1 timers 2
    standby 1 priority 11
    standby 1 preempt delay minimum 4

    router ospf
    log-adjacency-change
    redistribute connected subnet
    redistribute static subnet
    network 10.23.174.16 0.0.0.7 area
    default-information originat

    ----------------------------------------------------------------------

    3550 #
    ----------------------------------------------------------------------
    interface FastEthernet0/
    switchport access vlan
    switchport mode acces

    interface FastEthernet0/
    description Link to First 355
    switchport trunk encapsulation dot1
    switchport mode trun

    interface Vlan
    ip address 10.23.174.21 255.255.255.24
    no ip redirect
    standby 1 ip 10.23.174.2
    standby 1 timers 2
    standby 1 preempt delay minimum 4

    router ospf
    log-adjacency-change
    redistribute connected subnet
    redistribute static subnet
    network 10.23.174.16 0.0.0.7 area
    default-information originat

    ----------------------------------------------------------------------
    [/code:1:92f16e6d32

    I plan on setting up a etherchannel/portchannel between the 2 3550'
    but for now i just have 1 link between them. Also both 3550's are
    VTP Server and the 2950's are VTP Client. Right now with the curren
    setup it seams to work but i have to add the customers vlan to bot
    3550's which seams like the wrong thing to do because i would have
    ip conflict since both switches would be trying to say they own th
    gateway/vlan ip. Doing HSRP for each customer isnt really a optio
    since these 3550's dont support that many HSRP interfaces and i woul
    have to give every customer a additional 2 ips.

    The reason vlan2 is setup with the HSRP config rather than fa0/1 i
    because they told me that if there link went down to one of ther
    routers that ospf would go down. I think i may be taking what the
    are telling me wrong because when i just read over there responc
    he's telling me i need assign a vlan to the trunk that connects the
    3550's and then run ospf on that.

    I'm just getting so confused. Hopefully somebody can shine some ligh
    here. Thanks in advance![/code
     
    Shaun, Jan 19, 2005
    #1
    1. Advertising

  2. Shaun

    Ivan Ostreš Guest

    In article <>, shaun.reitan@ndchost-
    dot-com.no-spam.invalid says...

    I would like to give you some advices, hope you'll find them usefull...

    > I plan on setting up a etherchannel/portchannel between the 2 3550's
    > but for now i just have 1 link between them. Also both 3550's are a
    > VTP Server and the 2950's are VTP Client. Right now with the current
    > setup it seams to work but i have to add the customers vlan to both
    > 3550's which seams like the wrong thing to do because i would have a
    > ip conflict since both switches would be trying to say they own the
    > gateway/vlan ip. Doing HSRP for each customer isnt really a option
    > since these 3550's dont support that many HSRP interfaces and i would
    > have to give every customer a additional 2 ips.
    >


    It seems you have a problem that you don't really know what do you want
    to do. I would first put requirements on the paper and think about them.
    Next, you should find the theoretical solution that would solve that
    requirements. Then, you should find appropriate mehanisms that can
    accomplish your theoretical solutions.

    All this will require a lot of knowledge on high avabillity and
    protocols mechanisms so you could define which actual protocols should
    you use (is GLBP better than HSRP or VRRP for your purpose? Is ISIS or
    BGP better option than OSPF in your envirnoment? Should you connect
    servers to both access switches? How to accomplish all this? Why would
    you use VTP if trying to achieve High avabillity? Just too many
    qustions....)

    It is not a trivial mission if you want some usefull results... maybe
    engaging a knowlegable consultant would be best in this case...

    Just a note: I used to be hack-type person until I've run into a similar
    job (much more equipment than yours) and found out it can't be done like
    that. I've learned that theory from Telecom systems avability class from
    University really can be applied in practice :).

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Jan 19, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Stuart Kendrick

    redundant switches / redundant server NICs

    Stuart Kendrick, Aug 9, 2004, in forum: Cisco
    Replies:
    4
    Views:
    4,502
    Stuart Kendrick
    Aug 10, 2004
  2. Joris Deschacht
    Replies:
    7
    Views:
    1,441
  3. lfnetworking
    Replies:
    0
    Views:
    690
    lfnetworking
    May 20, 2005
  4. TomTom
    Replies:
    2
    Views:
    826
    TomTom
    Oct 9, 2004
  5. Replies:
    5
    Views:
    409
    Baloo
    Feb 16, 2008
Loading...

Share This Page