Redistribution between IS-IS, EIGRP & OSPF

Discussion in 'Cisco' started by Sam Soh, Aug 12, 2003.

  1. Sam Soh

    Sam Soh Guest

    Termserver---R1---R3
    \--R7--/
    R1, R7, and R3 connect altogether in ethernet interfaces.
    Termserver connect to R1 thru serial to R1
    Termserver connect to R7 thru serial to R7

    Termserver, R1 and R7 are running IS-IS.
    R1, R7 and R3 are running EIGRP.
    R3 is running OSPF and attached to the OSPF network.
    All the redistribution looks just fine, EXCEPT the serial interfaces
    between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
    network) cannot be seen in routing tables of R3 and the continuing
    OSPF network.

    TermServer#
    interface Loopback11
    ip address 135.3.251.11 255.255.255.192
    ip router isis
    !
    interface Serial0
    ip address 135.3.117.11 255.255.255.240 (isis network connect to
    R1&R7)
    ip router isis
    clockrate 64000
    !
    interface Serial1
    ip address 135.3.117.12 255.255.255.240 (isis network connect to
    R1&R7)
    ip router isis
    clockrate 64000
    !
    router isis
    net 49.0001.0000.0000.000a.00

    R1#
    interface Loopback10
    ip address 135.3.1.1 255.255.255.0
    !
    interface Loopback11
    ip address 135.3.11.1 255.255.255.192
    ip router isis
    !
    interface Ethernet0
    ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
    !
    interface Serial0
    ip address 135.3.117.1 255.255.255.240 (isis network connect to
    Termserver&R7)
    ip router isis
    !
    router eigrp 1
    redistribute isis level-1-2 metric 1 100 255 150 1500
    network 135.3.1.0 0.0.0.255
    network 135.3.137.0 0.0.0.255
    no auto-summary
    !
    router isis
    net 49.0001.0000.0000.000b.00
    redistribute eigrp 1 metric 20

    R7#
    interface Loopback10
    ip address 135.3.7.7 255.255.255.0
    !
    interface Loopback77
    ip address 135.3.77.7 255.255.255.192
    ip router isis
    !
    interface Ethernet0
    ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
    !
    interface Serial0
    ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
    Termserver)
    ip router isis
    !
    router eigrp 1
    redistribute isis level-1-2 metric 1 100 255 150 1500
    network 135.3.7.0 0.0.0.255
    network 135.3.137.0 0.0.0.255
    no auto-summary
    !
    router isis
    net 49.0001.0000.0000.000c.00
    redistribute eigrp 1 metric 20

    R3#
    interface Loopback10
    ip address 135.3.3.3 255.255.255.0
    !
    interface Loopback20
    ip address 135.3.33.33 255.255.255.0
    !
    interface Ethernet0
    ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
    !
    router eigrp 1
    redistribute ospf 1
    network 135.3.33.0 0.0.0.255
    network 135.3.137.0 0.0.0.255
    default-metric 10000 100 255 1 1500
    no auto-summary
    !
    router ospf 1
    router-id 135.3.3.3
    log-adjacency-changes
    redistribute eigrp 1 subnets
    network 135.3.3.0 0.0.0.255 area 0
    network 135.3.34.0 0.0.0.7 area 0
    network 135.3.53.0 0.0.0.255 area 5
    neighbor 135.3.53.5 priority 1

    Network 135.3.117.X can not be seen in R3. Help, please anybody.

    Best Regards,
    Sam
    Sam Soh, Aug 12, 2003
    #1
    1. Advertising

  2. On R1 and R7, you need to do a redistribute connected under the EIGRP
    process. Networks that are part of the ISIS process on directly connected
    interfaces on a router DO NOT get redistributed into the receiving protocol
    (EIGRP in your case) - you have to do a redistribute connected to get them
    there. This is NOT the case with any other IGP - it is unique to ISIS on
    cisco boxes.

    This is the reason that R3 cannot see the two serial interface routes.

    This is a common trap in the real world and on certain cisco "practical"
    exams!!


    "Sam Soh" <> wrote in message
    news:...
    > Termserver---R1---R3
    > \--R7--/
    > R1, R7, and R3 connect altogether in ethernet interfaces.
    > Termserver connect to R1 thru serial to R1
    > Termserver connect to R7 thru serial to R7
    >
    > Termserver, R1 and R7 are running IS-IS.
    > R1, R7 and R3 are running EIGRP.
    > R3 is running OSPF and attached to the OSPF network.
    > All the redistribution looks just fine, EXCEPT the serial interfaces
    > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
    > network) cannot be seen in routing tables of R3 and the continuing
    > OSPF network.
    >
    > TermServer#
    > interface Loopback11
    > ip address 135.3.251.11 255.255.255.192
    > ip router isis
    > !
    > interface Serial0
    > ip address 135.3.117.11 255.255.255.240 (isis network connect to
    > R1&R7)
    > ip router isis
    > clockrate 64000
    > !
    > interface Serial1
    > ip address 135.3.117.12 255.255.255.240 (isis network connect to
    > R1&R7)
    > ip router isis
    > clockrate 64000
    > !
    > router isis
    > net 49.0001.0000.0000.000a.00
    >
    > R1#
    > interface Loopback10
    > ip address 135.3.1.1 255.255.255.0
    > !
    > interface Loopback11
    > ip address 135.3.11.1 255.255.255.192
    > ip router isis
    > !
    > interface Ethernet0
    > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
    > !
    > interface Serial0
    > ip address 135.3.117.1 255.255.255.240 (isis network connect to
    > Termserver&R7)
    > ip router isis
    > !
    > router eigrp 1
    > redistribute isis level-1-2 metric 1 100 255 150 1500
    > network 135.3.1.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > no auto-summary
    > !
    > router isis
    > net 49.0001.0000.0000.000b.00
    > redistribute eigrp 1 metric 20
    >
    > R7#
    > interface Loopback10
    > ip address 135.3.7.7 255.255.255.0
    > !
    > interface Loopback77
    > ip address 135.3.77.7 255.255.255.192
    > ip router isis
    > !
    > interface Ethernet0
    > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
    > !
    > interface Serial0
    > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
    > Termserver)
    > ip router isis
    > !
    > router eigrp 1
    > redistribute isis level-1-2 metric 1 100 255 150 1500
    > network 135.3.7.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > no auto-summary
    > !
    > router isis
    > net 49.0001.0000.0000.000c.00
    > redistribute eigrp 1 metric 20
    >
    > R3#
    > interface Loopback10
    > ip address 135.3.3.3 255.255.255.0
    > !
    > interface Loopback20
    > ip address 135.3.33.33 255.255.255.0
    > !
    > interface Ethernet0
    > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
    > !
    > router eigrp 1
    > redistribute ospf 1
    > network 135.3.33.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > default-metric 10000 100 255 1 1500
    > no auto-summary
    > !
    > router ospf 1
    > router-id 135.3.3.3
    > log-adjacency-changes
    > redistribute eigrp 1 subnets
    > network 135.3.3.0 0.0.0.255 area 0
    > network 135.3.34.0 0.0.0.7 area 0
    > network 135.3.53.0 0.0.0.255 area 5
    > neighbor 135.3.53.5 priority 1
    >
    > Network 135.3.117.X can not be seen in R3. Help, please anybody.
    >
    > Best Regards,
    > Sam
    The Real Slim Shady, Aug 12, 2003
    #2
    1. Advertising

  3. Sam Soh

    slarmas Guest

    Wow, somone actually running ISIS? Talk about shock and awe :)


    "Sam Soh" <> wrote in message
    news:...
    > Termserver---R1---R3
    > \--R7--/
    > R1, R7, and R3 connect altogether in ethernet interfaces.
    > Termserver connect to R1 thru serial to R1
    > Termserver connect to R7 thru serial to R7
    >
    > Termserver, R1 and R7 are running IS-IS.
    > R1, R7 and R3 are running EIGRP.
    > R3 is running OSPF and attached to the OSPF network.
    > All the redistribution looks just fine, EXCEPT the serial interfaces
    > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
    > network) cannot be seen in routing tables of R3 and the continuing
    > OSPF network.
    >
    > TermServer#
    > interface Loopback11
    > ip address 135.3.251.11 255.255.255.192
    > ip router isis
    > !
    > interface Serial0
    > ip address 135.3.117.11 255.255.255.240 (isis network connect to
    > R1&R7)
    > ip router isis
    > clockrate 64000
    > !
    > interface Serial1
    > ip address 135.3.117.12 255.255.255.240 (isis network connect to
    > R1&R7)
    > ip router isis
    > clockrate 64000
    > !
    > router isis
    > net 49.0001.0000.0000.000a.00
    >
    > R1#
    > interface Loopback10
    > ip address 135.3.1.1 255.255.255.0
    > !
    > interface Loopback11
    > ip address 135.3.11.1 255.255.255.192
    > ip router isis
    > !
    > interface Ethernet0
    > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
    > !
    > interface Serial0
    > ip address 135.3.117.1 255.255.255.240 (isis network connect to
    > Termserver&R7)
    > ip router isis
    > !
    > router eigrp 1
    > redistribute isis level-1-2 metric 1 100 255 150 1500
    > network 135.3.1.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > no auto-summary
    > !
    > router isis
    > net 49.0001.0000.0000.000b.00
    > redistribute eigrp 1 metric 20
    >
    > R7#
    > interface Loopback10
    > ip address 135.3.7.7 255.255.255.0
    > !
    > interface Loopback77
    > ip address 135.3.77.7 255.255.255.192
    > ip router isis
    > !
    > interface Ethernet0
    > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
    > !
    > interface Serial0
    > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
    > Termserver)
    > ip router isis
    > !
    > router eigrp 1
    > redistribute isis level-1-2 metric 1 100 255 150 1500
    > network 135.3.7.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > no auto-summary
    > !
    > router isis
    > net 49.0001.0000.0000.000c.00
    > redistribute eigrp 1 metric 20
    >
    > R3#
    > interface Loopback10
    > ip address 135.3.3.3 255.255.255.0
    > !
    > interface Loopback20
    > ip address 135.3.33.33 255.255.255.0
    > !
    > interface Ethernet0
    > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
    > !
    > router eigrp 1
    > redistribute ospf 1
    > network 135.3.33.0 0.0.0.255
    > network 135.3.137.0 0.0.0.255
    > default-metric 10000 100 255 1 1500
    > no auto-summary
    > !
    > router ospf 1
    > router-id 135.3.3.3
    > log-adjacency-changes
    > redistribute eigrp 1 subnets
    > network 135.3.3.0 0.0.0.255 area 0
    > network 135.3.34.0 0.0.0.7 area 0
    > network 135.3.53.0 0.0.0.255 area 5
    > neighbor 135.3.53.5 priority 1
    >
    > Network 135.3.117.X can not be seen in R3. Help, please anybody.
    >
    > Best Regards,
    > Sam
    slarmas, Aug 14, 2003
    #3
  4. You are welcome. Bear in mind that ISIS only works in broadcast networks
    and point to point links. It does not work on multipoint or NBMA networks.
    I understand Cisco are addressing this. However, in the meantime this has
    design and IP address implications in networks that currently run OSPF and
    are migrating to ISIS.

    Slim


    "Sam Soh" <> wrote in message
    news:...
    > WOW....Thanks alot, Real Slim Shady.
    > I really appreciate the answer. For a whole day, I thought my weird
    > problem won't be solved. Thank you alot.
    >
    > Best Regards,
    > Sam
    >
    > "The Real Slim Shady" <> wrote in message

    news:<bhaiei$105uga$-berlin.de>...
    > > On R1 and R7, you need to do a redistribute connected under the EIGRP
    > > process. Networks that are part of the ISIS process on directly

    connected
    > > interfaces on a router DO NOT get redistributed into the receiving

    protocol
    > > (EIGRP in your case) - you have to do a redistribute connected to get

    them
    > > there. This is NOT the case with any other IGP - it is unique to ISIS

    on
    > > cisco boxes.
    > >
    > > This is the reason that R3 cannot see the two serial interface routes.
    > >
    > > This is a common trap in the real world and on certain cisco "practical"
    > > exams!!
    > >
    > >
    > > "Sam Soh" <> wrote in message
    > > news:...
    > > > Termserver---R1---R3
    > > > \--R7--/
    > > > R1, R7, and R3 connect altogether in ethernet interfaces.
    > > > Termserver connect to R1 thru serial to R1
    > > > Termserver connect to R7 thru serial to R7
    > > >
    > > > Termserver, R1 and R7 are running IS-IS.
    > > > R1, R7 and R3 are running EIGRP.
    > > > R3 is running OSPF and attached to the OSPF network.
    > > > All the redistribution looks just fine, EXCEPT the serial interfaces
    > > > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
    > > > network) cannot be seen in routing tables of R3 and the continuing
    > > > OSPF network.
    > > >
    > > > TermServer#
    > > > interface Loopback11
    > > > ip address 135.3.251.11 255.255.255.192
    > > > ip router isis
    > > > !
    > > > interface Serial0
    > > > ip address 135.3.117.11 255.255.255.240 (isis network connect to
    > > > R1&R7)
    > > > ip router isis
    > > > clockrate 64000
    > > > !
    > > > interface Serial1
    > > > ip address 135.3.117.12 255.255.255.240 (isis network connect to
    > > > R1&R7)
    > > > ip router isis
    > > > clockrate 64000
    > > > !
    > > > router isis
    > > > net 49.0001.0000.0000.000a.00
    > > >
    > > > R1#
    > > > interface Loopback10
    > > > ip address 135.3.1.1 255.255.255.0
    > > > !
    > > > interface Loopback11
    > > > ip address 135.3.11.1 255.255.255.192
    > > > ip router isis
    > > > !
    > > > interface Ethernet0
    > > > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
    > > > !
    > > > interface Serial0
    > > > ip address 135.3.117.1 255.255.255.240 (isis network connect to
    > > > Termserver&R7)
    > > > ip router isis
    > > > !
    > > > router eigrp 1
    > > > redistribute isis level-1-2 metric 1 100 255 150 1500
    > > > network 135.3.1.0 0.0.0.255
    > > > network 135.3.137.0 0.0.0.255
    > > > no auto-summary
    > > > !
    > > > router isis
    > > > net 49.0001.0000.0000.000b.00
    > > > redistribute eigrp 1 metric 20
    > > >
    > > > R7#
    > > > interface Loopback10
    > > > ip address 135.3.7.7 255.255.255.0
    > > > !
    > > > interface Loopback77
    > > > ip address 135.3.77.7 255.255.255.192
    > > > ip router isis
    > > > !
    > > > interface Ethernet0
    > > > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
    > > > !
    > > > interface Serial0
    > > > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
    > > > Termserver)
    > > > ip router isis
    > > > !
    > > > router eigrp 1
    > > > redistribute isis level-1-2 metric 1 100 255 150 1500
    > > > network 135.3.7.0 0.0.0.255
    > > > network 135.3.137.0 0.0.0.255
    > > > no auto-summary
    > > > !
    > > > router isis
    > > > net 49.0001.0000.0000.000c.00
    > > > redistribute eigrp 1 metric 20
    > > >
    > > > R3#
    > > > interface Loopback10
    > > > ip address 135.3.3.3 255.255.255.0
    > > > !
    > > > interface Loopback20
    > > > ip address 135.3.33.33 255.255.255.0
    > > > !
    > > > interface Ethernet0
    > > > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
    > > > !
    > > > router eigrp 1
    > > > redistribute ospf 1
    > > > network 135.3.33.0 0.0.0.255
    > > > network 135.3.137.0 0.0.0.255
    > > > default-metric 10000 100 255 1 1500
    > > > no auto-summary
    > > > !
    > > > router ospf 1
    > > > router-id 135.3.3.3
    > > > log-adjacency-changes
    > > > redistribute eigrp 1 subnets
    > > > network 135.3.3.0 0.0.0.255 area 0
    > > > network 135.3.34.0 0.0.0.7 area 0
    > > > network 135.3.53.0 0.0.0.255 area 5
    > > > neighbor 135.3.53.5 priority 1
    > > >
    > > > Network 135.3.117.X can not be seen in R3. Help, please anybody.
    > > >
    > > > Best Regards,
    > > > Sam
    The Real Slim Shady, Aug 14, 2003
    #4
  5. ISIS is a very powerful protocol that can scale to many thousands of nodes.
    It does not employ the area 0 principle in the way that OSPF does so you do
    not have to connect every area to area 0 - only to the set of contiguous L2
    routers. The ISIS book by Abe Martey is a must read if you are into this
    protocol.

    Slim


    "slarmas" <> wrote in message
    news:...
    > Wow, somone actually running ISIS? Talk about shock and awe :)
    >
    >
    > "Sam Soh" <> wrote in message
    > news:...
    > > Termserver---R1---R3
    > > \--R7--/
    > > R1, R7, and R3 connect altogether in ethernet interfaces.
    > > Termserver connect to R1 thru serial to R1
    > > Termserver connect to R7 thru serial to R7
    > >
    > > Termserver, R1 and R7 are running IS-IS.
    > > R1, R7 and R3 are running EIGRP.
    > > R3 is running OSPF and attached to the OSPF network.
    > > All the redistribution looks just fine, EXCEPT the serial interfaces
    > > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
    > > network) cannot be seen in routing tables of R3 and the continuing
    > > OSPF network.
    > >
    > > TermServer#
    > > interface Loopback11
    > > ip address 135.3.251.11 255.255.255.192
    > > ip router isis
    > > !
    > > interface Serial0
    > > ip address 135.3.117.11 255.255.255.240 (isis network connect to
    > > R1&R7)
    > > ip router isis
    > > clockrate 64000
    > > !
    > > interface Serial1
    > > ip address 135.3.117.12 255.255.255.240 (isis network connect to
    > > R1&R7)
    > > ip router isis
    > > clockrate 64000
    > > !
    > > router isis
    > > net 49.0001.0000.0000.000a.00
    > >
    > > R1#
    > > interface Loopback10
    > > ip address 135.3.1.1 255.255.255.0
    > > !
    > > interface Loopback11
    > > ip address 135.3.11.1 255.255.255.192
    > > ip router isis
    > > !
    > > interface Ethernet0
    > > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
    > > !
    > > interface Serial0
    > > ip address 135.3.117.1 255.255.255.240 (isis network connect to
    > > Termserver&R7)
    > > ip router isis
    > > !
    > > router eigrp 1
    > > redistribute isis level-1-2 metric 1 100 255 150 1500
    > > network 135.3.1.0 0.0.0.255
    > > network 135.3.137.0 0.0.0.255
    > > no auto-summary
    > > !
    > > router isis
    > > net 49.0001.0000.0000.000b.00
    > > redistribute eigrp 1 metric 20
    > >
    > > R7#
    > > interface Loopback10
    > > ip address 135.3.7.7 255.255.255.0
    > > !
    > > interface Loopback77
    > > ip address 135.3.77.7 255.255.255.192
    > > ip router isis
    > > !
    > > interface Ethernet0
    > > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
    > > !
    > > interface Serial0
    > > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
    > > Termserver)
    > > ip router isis
    > > !
    > > router eigrp 1
    > > redistribute isis level-1-2 metric 1 100 255 150 1500
    > > network 135.3.7.0 0.0.0.255
    > > network 135.3.137.0 0.0.0.255
    > > no auto-summary
    > > !
    > > router isis
    > > net 49.0001.0000.0000.000c.00
    > > redistribute eigrp 1 metric 20
    > >
    > > R3#
    > > interface Loopback10
    > > ip address 135.3.3.3 255.255.255.0
    > > !
    > > interface Loopback20
    > > ip address 135.3.33.33 255.255.255.0
    > > !
    > > interface Ethernet0
    > > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
    > > !
    > > router eigrp 1
    > > redistribute ospf 1
    > > network 135.3.33.0 0.0.0.255
    > > network 135.3.137.0 0.0.0.255
    > > default-metric 10000 100 255 1 1500
    > > no auto-summary
    > > !
    > > router ospf 1
    > > router-id 135.3.3.3
    > > log-adjacency-changes
    > > redistribute eigrp 1 subnets
    > > network 135.3.3.0 0.0.0.255 area 0
    > > network 135.3.34.0 0.0.0.7 area 0
    > > network 135.3.53.0 0.0.0.255 area 5
    > > neighbor 135.3.53.5 priority 1
    > >
    > > Network 135.3.117.X can not be seen in R3. Help, please anybody.
    > >
    > > Best Regards,
    > > Sam

    >
    >
    The Real Slim Shady, Aug 14, 2003
    #5
  6. Sam Soh

    Sam Soh Guest

    Slim,
    I really do appreciate your commentary and help solving my problem. In
    the mean time I have been reading the RFC about this powerful ISIS. I
    sure will buy the book. Thanks Slim.

    Best Regards,
    Sam Soh

    p.s.
    May I have your email, Slim?

    "The Real Slim Shady" <> wrote in message news:<bhfvu0$b2p1$-berlin.de>...
    > ISIS is a very powerful protocol that can scale to many thousands of nodes.
    > It does not employ the area 0 principle in the way that OSPF does so you do
    > not have to connect every area to area 0 - only to the set of contiguous L2
    > routers. The ISIS book by Abe Martey is a must read if you are into this
    > protocol.
    >
    > Slim
    Sam Soh, Aug 15, 2003
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. slipstream_242

    route redistribution RIP and EIGRP

    slipstream_242, Jul 15, 2004, in forum: Cisco
    Replies:
    1
    Views:
    10,604
  2. ciscokid

    bgp redistribution into Eigrp

    ciscokid, Nov 22, 2004, in forum: Cisco
    Replies:
    2
    Views:
    25,663
    daricha74
    Jun 25, 2012
  3. Rob
    Replies:
    14
    Views:
    7,159
  4. phillip
    Replies:
    2
    Views:
    2,942
    mos33
    Sep 19, 2008
  5. Replies:
    3
    Views:
    4,490
Loading...

Share This Page