redistributing static via rip

Discussion in 'Cisco' started by Ivana, Apr 14, 2006.

  1. Ivana

    Ivana Guest

    Hi all,

    I have a Cisco 3640 (12.1(2)T) that serves as ISDN backup router and I want
    to make it to redistribute ISDN static routes to another router with
    starting number of hops 10. As far as I know only thing I should make is
    "redistribute static metric 10" under router rip config.

    But Catalyst 4500 (on the same LAN as 3640) continues to receives static
    routes via rip with hop metric 1. Any clue why? Something else to make in
    the config to force Cisco 3640 to send static routes via RIP with starting
    metric 10?

    regards,
    Ivana
     
    Ivana, Apr 14, 2006
    #1
    1. Advertising

  2. Ivana

    Merv Guest

    post your configs and show ip route from both routers
     
    Merv, Apr 14, 2006
    #2
    1. Advertising

  3. Ivana

    Ivana Guest

    Ok, these are the configs:

    Cisco 3640 (10.10.100.3):

    router rip
    version 2
    timers basic 30 60 60 70
    redistribute static metric 12
    passive-interface Dialer1
    passive-interface Dialer4
    network 10.0.0.0
    !

    3640#sho ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static
    route
    o - ODR, P - periodic downloaded static route

    10.0.0.0/8 is variably subnetted, 18 subnets, 4 masks
    C 10.10.0.0/16 is directly connected, Ethernet0/0
    S 10.0.14.0/24 is directly connected, Dialer4
    S 10.0.15.0/24 is directly connected, Dialer1


    Catalyst:

    interface Vlan100
    ip address 10.10.100.1 255.255.0.0
    !
    router rip
    version 2
    timers basic 30 60 60 70
    passive-interface Vlan100
    network 10.0.0.0
    !


    Catalyst#sho ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static
    route
    o - ODR, P - periodic downloaded static route


    10.0.0.0/8 is variably subnetted, 17 subnets, 4 masks
    C 10.10.0.0/16 is directly connected, Vlan100
    R 10.0.14.0/24 [120/1] via 10.10.100.3, 00:00:06, Vlan100
    R 10.0.15.0/24 [120/1] via 10.10.100.3, 00:00:06, Vlan100

    You can see that Catalyst is receiving route 10.0.14.0 with metric 1,
    instead f 13. Am I missed smth in the config?

    Thanks,
    Ivana
     
    Ivana, May 4, 2006
    #3
  4. Ivana

    Merv Guest

    I think this is a bug

    try setting metric via route-map:

    router rip
    no redistribute static metric 10
    redistribute static route-map STATIC_TO_RIP
    exit

    route-map STATIC_TO_RIP permit 10
    set metric 10
    exit
     
    Merv, May 4, 2006
    #4
  5. Ivana

    MC Guest

    Merv wrote:
    > I think this is a bug
    >
    > try setting metric via route-map:
    >
    > router rip
    > no redistribute static metric 10
    > redistribute static route-map STATIC_TO_RIP
    > exit
    >
    > route-map STATIC_TO_RIP permit 10
    > set metric 10
    > exit
    >

    been having some weird redistribution into rip from static routes also
    with metrics.

    Think I will this suggestion a try myself.

    Thanks
     
    MC, May 6, 2006
    #5
  6. Ivana

    Ivana Guest

    It's working:), thanks!

    "Merv" <> wrote in message
    news:...
    >I think this is a bug
    >
    > try setting metric via route-map:
    >
    > router rip
    > no redistribute static metric 10
    > redistribute static route-map STATIC_TO_RIP
    > exit
    >
    > route-map STATIC_TO_RIP permit 10
    > set metric 10
    > exit
    >
     
    Ivana, May 9, 2006
    #6
  7. Ivana

    Merv Guest

    good to hear
     
    Merv, May 9, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. phillip
    Replies:
    5
    Views:
    3,642
    Bob by the Bay
    Dec 7, 2004
  2. Replies:
    0
    Views:
    886
  3. TJ Sackville-West

    Partition Magic 5 hangs up redistributing freespace under WIN 98

    TJ Sackville-West, Jan 6, 2005, in forum: Computer Support
    Replies:
    1
    Views:
    483
    Sue Mommie
    Jan 7, 2005
  4. Dave Ward
    Replies:
    1
    Views:
    4,979
  5. gagankalra1

    Redistributing static in Eigrp...

    gagankalra1, Jul 1, 2008, in forum: Cisco
    Replies:
    1
    Views:
    632
    donjohnston
    Jul 2, 2008
Loading...

Share This Page