Reaction of Equipment after Change of IP-Number?

Discussion in 'VOIP' started by Wolfgang Barth, May 22, 2005.

  1. I'm using VoIP behind a NAT Modem-Router from Netgear and a Sipura
    SPA3000 for inbound and outbound telephony from all my phones.

    But I get a new IP-number at least once a day from my DSL Provider.
    After this number change the Sipura failes to reregister correctly.

    Does anybody have problems with these IP-number changes?
    How do you solve this?

    Wolfgang
     
    Wolfgang Barth, May 22, 2005
    #1
    1. Advertising

  2. Wolfgang Barth

    Rick Merrill Guest

    Wolfgang Barth wrote:
    > I'm using VoIP behind a NAT Modem-Router from Netgear and a Sipura
    > SPA3000 for inbound and outbound telephony from all my phones.
    >
    > But I get a new IP-number at least once a day from my DSL Provider.
    > After this number change the Sipura failes to reregister correctly.
    >
    > Does anybody have problems with these IP-number changes?
    > How do you solve this?
    >
    > Wolfgang


    Your configuration should look like this:
    Modem<==>SPA3000<==>Router<==>pc(s)

    and all four devices should use DHCP to get IP and DNS addresses.
     
    Rick Merrill, May 22, 2005
    #2
    1. Advertising

  3. Wolfgang Barth

    Miguel Cruz Guest

    Wolfgang Barth <> wrote:
    > I'm using VoIP behind a NAT Modem-Router from Netgear and a Sipura
    > SPA3000 for inbound and outbound telephony from all my phones.
    >
    > But I get a new IP-number at least once a day from my DSL Provider.
    > After this number change the Sipura failes to reregister correctly.
    >
    > Does anybody have problems with these IP-number changes?
    > How do you solve this?


    Fortunately my IP address only changes every two or three weeks. But my
    Sipura 1001 has the same problem.

    If I go to any of the admin pages on its web interface and click the button
    to save changes (even though I haven't made any changes) it immediately
    re-registers properly.

    I imagine that after some timeout interval it might straighten itself out as
    well but I've never been patient enough to wait and see.

    miguel
    --
    Hit The Road! Photos from 36 countries on 5 continents: http://travel.u.nu
    Latest photos: Queens Day in Amsterdam; the Grand Canyon; Amman, Jordan
     
    Miguel Cruz, May 22, 2005
    #3
  4. Wolfgang Barth

    Ivor Jones Guest

    Miguel Cruz wrote:
    > Wolfgang Barth <> wrote:
    >> I'm using VoIP behind a NAT Modem-Router from Netgear and a Sipura
    >> SPA3000 for inbound and outbound telephony from all my phones.
    >>
    >> But I get a new IP-number at least once a day from my DSL Provider.
    >> After this number change the Sipura failes to reregister correctly.
    >>
    >> Does anybody have problems with these IP-number changes?
    >> How do you solve this?

    >
    > Fortunately my IP address only changes every two or three weeks.
    > But my Sipura 1001 has the same problem.
    >
    > If I go to any of the admin pages on its web interface and click
    > the button to save changes (even though I haven't made any changes)
    > it immediately re-registers properly.
    >
    > I imagine that after some timeout interval it might straighten
    > itself out as well but I've never been patient enough to wait and
    > see.


    You are using DHCP on the router and using private IP addresses on all the
    connected devices, aren't you..?

    Ivor
     
    Ivor Jones, May 22, 2005
    #4
  5. Ivor Jones wrote:
    >
    > You are using DHCP on the router and using private IP addresses on all the
    > connected devices, aren't you..?
    >

    Yes. I do use a modem-router from Netgear with port restricted cone NAT.

    This is my DHCP source for my private LAN, where the SIPURA is in.

    Everything works properly. Even NAT traversal.
    The only problem is that reregistering(?) and/or NAT stay alive(?) tend
    to fail after change of the EXTERNAL IP-Number.

    Wolfgang
     
    Wolfgang Barth, May 22, 2005
    #5
  6. Rick Merrill wrote:
    >
    > Your configuration should look like this:
    > Modem<==>SPA3000<==>Router<==>pc(s)

    But I have a modem-router with DHCP and behind that there is the SPA3000
    and the PCs. I cannot change this configuration.
    >
    > and all four devices should use DHCP to get IP and DNS addresses.

    PCs and Sipura do use DHCP to get local IP and DNS addresses.
    The modem-router gets its via PPPoE.

    Wolfgang
     
    Wolfgang Barth, May 22, 2005
    #6
  7. Wolfgang Barth

    Rick Merrill Guest

    Wolfgang Barth wrote:
    > Rick Merrill wrote:
    >
    >>
    >> Your configuration should look like this:
    >> Modem<==>SPA3000<==>Router<==>pc(s)

    >
    > But I have a modem-router with DHCP and behind that there is the SPA3000
    > and the PCs. I cannot change this configuration.


    Why not? How do you expect the SPA3000 to do QoS?

    >
    >>
    >> and all four devices should use DHCP to get IP and DNS addresses.

    >
    > PCs and Sipura do use DHCP to get local IP and DNS addresses.
    > The modem-router gets its via PPPoE.


    Why is that?
     
    Rick Merrill, May 23, 2005
    #7
  8. Wolfgang Barth

    Miguel Cruz Guest

    Ivor Jones <> wrote:
    > Miguel Cruz wrote:
    >> Fortunately my IP address only changes every two or three weeks.
    >> But my Sipura 1001 has the same problem.
    >>
    >> If I go to any of the admin pages on its web interface and click
    >> the button to save changes (even though I haven't made any changes)
    >> it immediately re-registers properly.
    >>
    >> I imagine that after some timeout interval it might straighten
    >> itself out as well but I've never been patient enough to wait and
    >> see.

    >
    > You are using DHCP on the router and using private IP addresses on all the
    > connected devices, aren't you..?


    Yes, the problem is that the Sipura device doesn't have any way of being
    actively alerted that the external IP of the router has changed, so it
    constructs its SIP headers incorrectly.

    I suppose it could be configured to check more frequently (with the STUN
    server or something); I haven't been sufficiently motivated to look into it
    further yet though.

    miguel
    --
    Hit The Road! Photos from 36 countries on 5 continents: http://travel.u.nu
    Latest photos: Queens Day in Amsterdam; the Grand Canyon; Amman, Jordan
     
    Miguel Cruz, May 23, 2005
    #8
  9. Wolfgang Barth

    wkearney99 Guest

    > Fortunately my IP address only changes every two or three weeks. But my
    > Sipura 1001 has the same problem.


    If it's DHCP then it should come with a lease time. Does the sipura ignore
    the lease time?
     
    wkearney99, May 23, 2005
    #9
  10. Wolfgang Barth

    Ivor Jones Guest

    Miguel Cruz wrote:
    > Ivor Jones <> wrote:


    [snip]

    >> You are using DHCP on the router and using private IP addresses on
    >> all the connected devices, aren't you..?

    >
    > Yes, the problem is that the Sipura device doesn't have any way of
    > being actively alerted that the external IP of the router has
    > changed, so it constructs its SIP headers incorrectly.


    It doesn't *need* to know. All the Sipura needs to know is the private IP
    address of the router, usually 192.168.1.1 or something similar. It
    doesn't know or care about the public IP address, only the router does.

    My connection has what I call a semi-static IP address, in that it can
    stay the same for weeks on end then change for no apparent reason..! My
    Sipura has never failed to register because of it.

    Ivor
     
    Ivor Jones, May 23, 2005
    #10
  11. "Rick Merrill" <> wrote in message
    news:...
    > Wolfgang Barth wrote:
    > > Rick Merrill wrote:
    > >
    > >>
    > >> Your configuration should look like this:
    > >> Modem<==>SPA3000<==>Router<==>pc(s)

    > >
    > > But I have a modem-router with DHCP and behind that there is
    > > the SPA3000 and the PCs. I cannot change this configuration.

    >
    > Why not? How do you expect the SPA3000 to do QoS?


    For example, because the router handles the PPPoE decoding and NATting.

    > >> and all four devices should use DHCP to get IP and DNS addresses.

    > >
    > > PCs and Sipura do use DHCP to get local IP and DNS addresses.
    > > The modem-router gets its via PPPoE.

    >
    > Why is that?


    Because that's how things work when your provider uses PPPoE and gives
    you only one IP address (assigned through PPPoE), which obviously can't
    be shared among devices: hence the need for NAT functionality, and
    often the DHCP service to assign the local IP addresses, both of which
    can be provided by the route.

    That said, I have the same configuration as Wolfgang's (SPA-3000 behind
    the NAT router) and never noticed that problem. On the other hand, I
    used to have a different type of problem with a Netgear MR814v2
    (http://voxilla.com/index.php?name=PNphpBB2&file=viewtopic&p=13986#13986
    ). Now I'm running Linux on a Linksys WRT54G (http://openwrt.org ) and
    Netgear is only a painful memory :)

    The nice thing of using Linux as router is that one can run tcpdump to
    capture packets to a file, transfer the file to a bigger machine and
    inspect them with Ethereal. This would tell you more about why the
    re-registration fails: which is a quite unusual thing. Wolfgang, are
    you sure it fails? Or perhaps is it not repeated often enough, so that
    after the change of IP address the remote SIP registrar still remembers
    the old address? In that case, you could try to reduce the
    re-registration interval of the SPA-3000 to, say, a couple of minutes.
    You can do this putting 60 (the number of seconds) in the "Register
    Expires:" field of the "Line 1" and "PSTN Line" screens of the Admin
    interface.

    Another way of inspecting the SIP packets would be installing a NON
    switching 10baseT hub between router and SPA-3000, and use it just like
    a T-joint to tap into the traffic with a monitoring machine directly
    running Ethereal. Unfortunately, in these days non-switching hubs are
    hard to find.

    Enzo
     
    Enzo Michelangeli, May 24, 2005
    #11
  12. Ivor Jones wrote:
    > Miguel Cruz wrote:
    > > Ivor Jones <> wrote:

    >
    > [snip]
    >
    > >> You are using DHCP on the router and using private IP addresses on
    > >> all the connected devices, aren't you..?

    > >
    > > Yes, the problem is that the Sipura device doesn't have any way of
    > > being actively alerted that the external IP of the router has
    > > changed, so it constructs its SIP headers incorrectly.

    >
    > It doesn't *need* to know. All the Sipura needs to know is the
    > private IP address of the router, usually 192.168.1.1 or something
    > similar. It doesn't know or care about the public IP address, only
    > the router does.


    Actually it _should_ care, in order to meet the SIP specifications; but
    some registrar proxies flat-out ignore the SIP headers and use, as IP
    address and UDP port, the same present as source on the headers of the
    packet that contained the registration request. This violation of the
    SIP specs often saves the day, but sometimes the results turn out to be
    annoying because it prevents third-party registration. Before
    understanding what was going on, I wasted days trying to register a
    Sipura SPA-3000 on multiple registrars using a utility, Sipsak
    (www.sipsak.org) running on a PC on the same LAN. I did that because
    the SPA-3000, due to a silly firmware limitation, can place calls
    through several outbound proxies BUT can register only on one of them.
    Well, it didn't work, despite the fact that I passed all the right
    parameters to Sipsak and Sipsak prepared the SIP headers accordingly:
    the registrar always registered the SPA-3000 at the UDP port mapped as
    source by the NAT router for the packets coming from the Sipsak client,
    which of course was different from the one I had specified for the
    SPA-3000 :-(

    Moral of this story: if you deal with NATs, whenever possible avoid SIP
    like the plague, and use IAX2.

    Enzo
     
    Enzo Michelangeli, May 24, 2005
    #12
  13. Wolfgang Barth

    Miguel Cruz Guest

    Ivor Jones <> wrote:
    > Miguel Cruz wrote:
    >> Ivor Jones <> wrote:
    >>> You are using DHCP on the router and using private IP addresses on
    >>> all the connected devices, aren't you..?

    >>
    >> Yes, the problem is that the Sipura device doesn't have any way of
    >> being actively alerted that the external IP of the router has
    >> changed, so it constructs its SIP headers incorrectly.

    >
    > It doesn't *need* to know. All the Sipura needs to know is the private IP
    > address of the router, usually 192.168.1.1 or something similar. It
    > doesn't know or care about the public IP address, only the router does.


    I think we can take it for granted that if the thing is doing anything at
    all, it knows its proximal router's address.

    But if you sniff SIP traffic you will probably see your external (outside of
    NAT) IP address communicated in the payload (not just in packet headers). At
    least I do between my Sipura (inside NAT) and Asterisk server (in the wild).

    miguel
    --
    Hit The Road! Photos from 36 countries on 5 continents: http://travel.u.nu
    Latest photos: Queens Day in Amsterdam; the Grand Canyon; Amman, Jordan
     
    Miguel Cruz, May 24, 2005
    #13
  14. Enzo Michelangeli wrote:
    > ... Or perhaps is it not repeated often enough, so that
    > after the change of IP address the remote SIP registrar still remembers
    > the old address? In that case, you could try to reduce the
    > re-registration interval of the SPA-3000 to, say, a couple of minutes.
    > You can do this putting 60 (the number of seconds) in the "Register
    > Expires:" field of the "Line 1" and "PSTN Line" screens of the Admin
    > interface.

    Register expires is 3600 seconds in the moment. But reregistering failed
    several times after IP-change. At least for 10 hours. But I will give it
    a try an reregister earlier.
    >
    > Another way of inspecting the SIP packets would be installing a NON
    > switching 10baseT hub between router and SPA-3000, and use it just like
    > a T-joint to tap into the traffic with a monitoring machine directly
    > running Ethereal. Unfortunately, in these days non-switching hubs are
    > hard to find.

    In this moment I have this combined modem-router, so I do not want to
    change hardware.

    Thanks for the hints.

    Wolfgang
     
    Wolfgang Barth, May 24, 2005
    #14
  15. wkearney99 wrote:
    >>Fortunately my IP address only changes every two or three weeks. But my
    >>Sipura 1001 has the same problem.

    >
    >
    > If it's DHCP then it should come with a lease time. Does the sipura ignore
    > the lease time?
    >

    Seams so.

    Wolfgang
     
    Wolfgang Barth, May 24, 2005
    #15
  16. Wolfgang Barth

    Ivor Jones Guest

    "Wolfgang Barth" <> wrote in message
    news:...

    [snip]

    >> Another way of inspecting the SIP packets would be installing a NON
    >> switching 10baseT hub between router and SPA-3000, and use it just like
    >> a T-joint to tap into the traffic with a monitoring machine directly
    >> running Ethereal. Unfortunately, in these days non-switching hubs are
    >> hard to find.

    > In this moment I have this combined modem-router, so I do not want to
    > change hardware.


    I've got a 16 port 10-base-T hub if anyone wants it..! Redundant since I
    upgraded all my stuff to 100-base-T.

    Ivor
     
    Ivor Jones, May 25, 2005
    #16
  17. Wolfgang Barth wrote:
    > Enzo Michelangeli wrote:
    > > ... Or perhaps is it not repeated often enough, so that
    > > after the change of IP address the remote SIP registrar still remembers
    > > the old address? In that case, you could try to reduce the
    > > re-registration interval of the SPA-3000 to, say, a couple of minutes.
    > > You can do this putting 60 (the number of seconds) in the "Register
    > > Expires:" field of the "Line 1" and "PSTN Line" screens of the Admin
    > > interface.

    > Register expires is 3600 seconds in the moment. But reregistering failed
    > several times after IP-change. At least for 10 hours. But I will give it
    > a try an reregister earlier.
    > >
    > > Another way of inspecting the SIP packets would be installing a NON
    > > switching 10baseT hub between router and SPA-3000, and use it just like
    > > a T-joint to tap into the traffic with a monitoring machine directly
    > > running Ethereal. Unfortunately, in these days non-switching hubs are
    > > hard to find.

    > In this moment I have this combined modem-router, so I do not want to
    > change hardware.


    By the way, which NAT-related options have you set under "NAT Support
    Parameters" in the SIP screen of the Admin interface? I have set
    everything to "yes" with the exception of "Send Resp To Src Port:"
    which is a "no"; "STUN Server:" points to "stun.fwdnet.net:3478"; "EXT
    RTP Port Min:" and "EXT IP:" are both blank, and "NAT Keep Alive
    Intvl:" is set to "15".

    Enzo
     
    Enzo Michelangeli, May 25, 2005
    #17
  18. Wolfgang Barth

    Rick Merrill Guest

    Wolfgang Barth wrote:
    > wkearney99 wrote:
    >
    >>> Fortunately my IP address only changes every two or three weeks. But my
    >>> Sipura 1001 has the same problem.

    >>
    >>
    >>
    >> If it's DHCP then it should come with a lease time. Does the sipura
    >> ignore
    >> the lease time?
    >>

    > Seams so.
    >
    > Wolfgang


    I thought you said the sipura was given a fixed IP...
     
    Rick Merrill, May 25, 2005
    #18
  19. Enzo Michelangeli wrote:
    >
    > By the way, which NAT-related options have you set under "NAT Support
    > Parameters" in the SIP screen of the Admin interface? I have set
    > everything to "yes" with the exception of "Send Resp To Src Port:"
    > which is a "no"; "STUN Server:" points to "stun.fwdnet.net:3478"; "EXT
    > RTP Port Min:" and "EXT IP:" are both blank, and "NAT Keep Alive
    > Intvl:" is set to "15".
    >

    Ok. I'll think about this. But as far as I understood its necessary to
    set "Send Resp to src port" to yes because my router users "port
    restricted cone NAT".

    But its working ok since two days now. No idea why.

    Wolfgang
     
    Wolfgang Barth, May 25, 2005
    #19
  20. Rick Merrill wrote:

    > I thought you said the sipura was given a fixed IP...


    Internally it uses DHCP but based on the MAC it will always be the same.

    But the problem is with the EXTERNAL IP-number which is very different
    each day.

    Wolfgang
     
    Wolfgang Barth, May 25, 2005
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Frisbee®
    Replies:
    37
    Views:
    1,144
  2. Silverstrand
    Replies:
    0
    Views:
    650
    Silverstrand
    Feb 2, 2006
  3. loftydon

    Delayed reaction...

    loftydon, Jul 7, 2003, in forum: Computer Support
    Replies:
    3
    Views:
    451
  4. sunny

    slow reaction times in explorer

    sunny, Aug 29, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    651
    Shep©
    Aug 30, 2003
  5. 7

    Re: MA Reaction

    7, Sep 27, 2005, in forum: Computer Support
    Replies:
    3
    Views:
    457
    Aragorn
    Sep 27, 2005
Loading...

Share This Page