Re: Win7 shows only 3GB usable memory

Discussion in 'Windows 64bit' started by Dominic Payer, Dec 20, 2009.

  1. Enable memory remapping in the BIOS.


    On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    > I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    > 4GB or memory. 2xHD3870 ATI video cards
    >
    > Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    > used all 4GB of memory with exactly the same hardware! Baring teeth
    > smile emoticon
     
    Dominic Payer, Dec 20, 2009
    #1
    1. Advertising

  2. Ya, I've read that on other forums too but my bios doesn't have that option.
    Also, the bios settings haven't changed since I had Vista64 working with the
    4GB of memory...

    "Dominic Payer" <> wrote in message
    news:#N#...
    > Enable memory remapping in the BIOS.
    >
    >
    > On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    >> I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    >> 4GB or memory. 2xHD3870 ATI video cards
    >>
    >> Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    >> used all 4GB of memory with exactly the same hardware! Baring teeth
    >> smile emoticon
     
    WIN_7_64bit_user, Dec 20, 2009
    #2
    1. Advertising

  3. Vista tended to report the full memory, even when it couldn't actually use
    the "hidden" memory on a machine. Win7 is actually telling you a more
    accurate amount.

    --
    Charlie.
    http://msmvps.com/blogs/russel




    "WIN_7_64bit_user" <> wrote in message
    news:...
    > Ya, I've read that on other forums too but my bios doesn't have that
    > option. Also, the bios settings haven't changed since I had Vista64
    > working with the 4GB of memory...
    >
    > "Dominic Payer" <> wrote in message
    > news:#N#...
    >> Enable memory remapping in the BIOS.
    >>
    >>
    >> On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    >>> I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    >>> 4GB or memory. 2xHD3870 ATI video cards
    >>>
    >>> Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    >>> used all 4GB of memory with exactly the same hardware! Baring teeth
    >>> smile emoticon

    >
     
    Charlie Russel - MVP, Dec 20, 2009
    #3
  4. What does your Resource Monitor say about memory usage?
    Start - Accessories - System Tools - Resource Monitor - memory tab.


    On 20/12/2009 14:30, WIN_7_64bit_user wrote:
    > Ya, I've read that on other forums too but my bios doesn't have that
    > option. Also, the bios settings haven't changed since I had Vista64
    > working with the 4GB of memory...
    >
    > "Dominic Payer" <> wrote in message
    > news:#N#...
    >> Enable memory remapping in the BIOS.
    >>
    >>
    >> On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    >>> I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    >>> 4GB or memory. 2xHD3870 ATI video cards
    >>>
    >>> Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    >>> used all 4GB of memory with exactly the same hardware! Baring teeth
    >>> smile emoticon

    >
     
    Dominic Payer, Dec 20, 2009
    #4
  5. Dominic Payer

    John Barnes Guest

    Vista had the same problem until service pack 1

    "WIN_7_64bit_user" <> wrote in message
    news:...
    > Ya, I've read that on other forums too but my bios doesn't have that
    > option. Also, the bios settings haven't changed since I had Vista64
    > working with the 4GB of memory...
    >
    > "Dominic Payer" <> wrote in message
    > news:#N#...
    >> Enable memory remapping in the BIOS.
    >>
    >>
    >> On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    >>> I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    >>> 4GB or memory. 2xHD3870 ATI video cards
    >>>
    >>> Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    >>> used all 4GB of memory with exactly the same hardware! Baring teeth
    >>> smile emoticon

    >
     
    John Barnes, Dec 20, 2009
    #5
  6. Re: Win7 shows only 3GB usable memory - SOLUTION

    K, I found a solution... weird though...

    I was using MSCONFIG to make sure windows started with all four cpu cores
    (i.e. msconfig / Boot / Advanced Options / number of processors).

    I guess I also selected use max memory option as well.

    In windows Resource Monitor 1026 MB was set aside for "Hardware Reserved"

    I unselected the "use max memory" and now Win7 reports the full memory and
    the Hardware Reserved dropped to zero. :)

    Hope it helps someone else.








    "WIN_7_64bit_user" <> wrote in message
    news:...
    > Ya, I've read that on other forums too but my bios doesn't have that
    > option. Also, the bios settings haven't changed since I had Vista64
    > working with the 4GB of memory...
    >
    > "Dominic Payer" <> wrote in message
    > news:#N#...
    >> Enable memory remapping in the BIOS.
    >>
    >>
    >> On 20/12/2009 02:18, WIN_7_64bit_user wrote:
    >>> I've got Win7-*64bit* installed on a Gigabyte EP45-UD3P with a Q9550 and
    >>> 4GB or memory. 2xHD3870 ATI video cards
    >>>
    >>> Win7 shows that only 3GB is usable... how do I fix this problem? Vista64
    >>> used all 4GB of memory with exactly the same hardware! Baring teeth
    >>> smile emoticon

    >
     
    WIN_7_64bit_user, Dec 20, 2009
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gert-Jaap Glasbergen
    Replies:
    1
    Views:
    570
    Dennis Pack
    Nov 20, 2006
  2. Dan
    Replies:
    39
    Views:
    1,473
    Charlie Russel - MVP
    Dec 20, 2007
  3. Warren Postma
    Replies:
    6
    Views:
    1,582
    FlopShot
    Nov 20, 2009
  4. Replies:
    19
    Views:
    3,938
    Bobby Johnson
    Jan 12, 2010
  5. Replies:
    6
    Views:
    2,497
    Carlos
    May 18, 2010
Loading...

Share This Page