Re: which IOS for following cisco 3640

Discussion in 'Cisco' started by Walter Roberson, Jul 22, 2003.

  1. In article <>,
    NNTP <> wrote:
    :I need the latest and greatest IOS, which one should I get? can I get
    :12.3?

    Yes in the sense that 12.3(1a) is supported on the 3640.
    You appear to have enough DRAM and flash to hold the IP image,
    but if I read your output properly, you do not have enough DRAM to
    go for any feature set that includes PLUS. Your output did not
    give me enough information to determine which features you have.

    Note though that you will have to pay to go beyond your current 12.0.
    The part number for the IP feature set would be S364C-12301=
    but I do not seem to find anyone with a posted price for it.

    --
    Feep if you love VT-52's.
    Walter Roberson, Jul 22, 2003
    #1
    1. Advertising

  2. Walter Roberson

    NNTP Guest

    -cnrc.gc.ca (Walter Roberson) wrote in message news:<bfkcuu$coq$>...
    > In article <>,
    > NNTP <> wrote:
    > :I need the latest and greatest IOS, which one should I get? can I get
    > :12.3?
    >
    > Yes in the sense that 12.3(1a) is supported on the 3640.
    > You appear to have enough DRAM and flash to hold the IP image,
    > but if I read your output properly, you do not have enough DRAM to
    > go for any feature set that includes PLUS. Your output did not
    > give me enough information to determine which features you have.
    >
    > Note though that you will have to pay to go beyond your current 12.0.
    > The part number for the IP feature set would be S364C-12301=
    > but I do not seem to find anyone with a posted price for it.


    sorry, I come from sun/linux world, kinda new to cisco.

    - what command is used to know what features I have. I am running a
    fast ethernet running IPX, a ethernet with one IP network b/h it, and
    two T-1 off of that router. (no bgp/ospf but I am doing RIP/static
    routs, no ipv6, no firewall/access lists etc.)


    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Router_3640
    !
    boot system flash:aaa0751.bin
    enable password
    !
    !
    !
    !
    !
    clock timezone xxx-5
    clock summer-time xxx recurring
    ip subnet-zero
    ip name-server xxx.xxx.x.xxx
    !
    ipx routing xxxx.xxxx.xxxx
    !
    !
    process-max-time 200
    !
    interface Ethernet0/0
    description connected to ABC
    bandwidth 10000
    ip address 192.168.52.4 255.255.255.0
    no ip directed-broadcast
    no ip mroute-cache
    ipx network xxxxxx
    !
    interface Serial0/0
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay IETF
    no ip mroute-cache
    no fair-queue
    service-module t1 timeslots 1-12
    cdp enable
    !
    interface Serial0/0.1 point-to-point
    description Connection to ABCDEF
    ip address 10.100.10.1 255.255.255.0
    no ip directed-broadcast
    frame-relay interface-dlci 101 IETF
    !
    interface Serial0/0.2 point-to-point
    description Connection to ABCDEFGHI
    ip address 10.100.11.1 255.255.255.0
    no ip directed-broadcast
    frame-relay interface-dlci 102 IETF
    !
    interface Serial0/0.3 point-to-point
    description Connection to ABCDEFGHIJK
    ip address 10.100.12.1 255.255.255.0
    no ip directed-broadcast
    frame-relay interface-dlci 103 IETF
    !
    interface Ethernet0/1
    description IPX Interface
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    ipx network xxxxxx
    !
    interface Serial0/1
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface FastEthernet1/0
    description internal LAN
    ip address 192.168.75.1 255.255.255.240
    no ip directed-broadcast
    full-duplex
    !
    router rip
    version 1
    redistribute static
    network 10.0.0.0
    network 192.168.0.0
    no auto-summary
    !
    ip classless
    ip route 192.168.71.0 255.255.255.0 192.168.75.2
    ip route 192.168.73.0 255.255.255.0 192.168.75.2 permanent
    ip route 192.168.75.16 255.255.255.240 Serial0/0.1 10.100.10.2
    ip route 192.168.75.32 255.255.255.240 Serial0/0.2 10.100.11.2
    ip route 192.168.75.48 255.255.255.240 Serial0/0.3 10.100.12.2
    no ip http server
    !
    !
    !
    !
    snmp-server engineID local xxxxxxxxxxxxxxxxxxxxxxxx
    snmp-server community xxxxxx RO
    snmp-server community xxxxxx RW
    snmp-server community xxxxxx view xxxxxxxxx RO
    snmp-server location ABC CO.
    snmp-server contact
    snmp-server enable traps snmp
    snmp-server host 192.168.71.201
    snmp-server host 192.168.71.201
    !
    line con 0
    exec-timeout 0 0
    password x xxxxxxxxxxxxxx
    login
    transport input none
    line aux 0
    line vty 0 4
    exec-timeout 5 0
    password x xxxxxxxxxxxxxx
    login
    !
    end

    - Thanks
    NNTP, Jul 23, 2003
    #2
    1. Advertising

  3. Walter Roberson

    NNTP Guest

    Found solution to my own question....

    Not any easy way.. not untill cisco comes out with 'show ios
    feature-set" command ... but here a dirty way to do it.

    1. tftp the running ios to a linux box
    2. open the ios in vim
    3. :%!xxd
    4. search for string CW_FEATURE or version or operating

    mine looks like something as follows
    0004a40: 240a 4357 5f46 4541 5455 5245 2449 507c $.CW_FEATURE$IP|
    0004a50: 4950 587c 4154 7c44 4543 240a 4357 5f56 IPX|AT|DEC$.CW_V
    0004a60: 4552 5349 4f4e 2431 322e 3028 3529 5431 ERSION$12.0(5)T1


    that tells me its got IP/IPX/Appletalk protocol feature set. I
    confirmed that with configmaker which grabs this off of IOS
    somehow!@!@!%@#@()(

    anyways,

    hope this helps.



    Kin Ser <> wrote in message news:<>...
    > It is also a question for me to identify the feature set of the
    > router/switch under my supervision. Is there any way for user to check
    > the feature set in the devices?
    >
    > NNTP wrote:
    > > -cnrc.gc.ca (Walter Roberson) wrote in message news:<bfkcuu$coq$>...
    > >
    > >>In article <>,
    > >>NNTP <> wrote:
    > >>:I need the latest and greatest IOS, which one should I get? can I get
    > >>:12.3?
    > >>
    > >>Yes in the sense that 12.3(1a) is supported on the 3640.
    > >>You appear to have enough DRAM and flash to hold the IP image,
    > >>but if I read your output properly, you do not have enough DRAM to
    > >>go for any feature set that includes PLUS. Your output did not
    > >>give me enough information to determine which features you have.
    > >>
    > >>Note though that you will have to pay to go beyond your current 12.0.
    > >>The part number for the IP feature set would be S364C-12301=
    > >>but I do not seem to find anyone with a posted price for it.

    > >
    > >
    > > sorry, I come from sun/linux world, kinda new to cisco.
    > >
    > > - what command is used to know what features I have. I am running a
    > > fast ethernet running IPX, a ethernet with one IP network b/h it, and
    > > two T-1 off of that router. (no bgp/ospf but I am doing RIP/static
    > > routs, no ipv6, no firewall/access lists etc.)
    > >
    > >
    > > !
    > > version 12.0
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > service password-encryption
    > > !
    > > hostname Router_3640
    > > !
    > > boot system flash:aaa0751.bin
    > > enable password
    > > !
    > > !
    > > !
    > > !
    > > !
    > > clock timezone xxx-5
    > > clock summer-time xxx recurring
    > > ip subnet-zero
    > > ip name-server xxx.xxx.x.xxx
    > > !
    > > ipx routing xxxx.xxxx.xxxx
    > > !
    > > !
    > > process-max-time 200
    > > !
    > > interface Ethernet0/0
    > > description connected to ABC
    > > bandwidth 10000
    > > ip address 192.168.52.4 255.255.255.0
    > > no ip directed-broadcast
    > > no ip mroute-cache
    > > ipx network xxxxxx
    > > !
    > > interface Serial0/0
    > > no ip address
    > > no ip directed-broadcast
    > > encapsulation frame-relay IETF
    > > no ip mroute-cache
    > > no fair-queue
    > > service-module t1 timeslots 1-12
    > > cdp enable
    > > !
    > > interface Serial0/0.1 point-to-point
    > > description Connection to ABCDEF
    > > ip address 10.100.10.1 255.255.255.0
    > > no ip directed-broadcast
    > > frame-relay interface-dlci 101 IETF
    > > !
    > > interface Serial0/0.2 point-to-point
    > > description Connection to ABCDEFGHI
    > > ip address 10.100.11.1 255.255.255.0
    > > no ip directed-broadcast
    > > frame-relay interface-dlci 102 IETF
    > > !
    > > interface Serial0/0.3 point-to-point
    > > description Connection to ABCDEFGHIJK
    > > ip address 10.100.12.1 255.255.255.0
    > > no ip directed-broadcast
    > > frame-relay interface-dlci 103 IETF
    > > !
    > > interface Ethernet0/1
    > > description IPX Interface
    > > no ip address
    > > no ip directed-broadcast
    > > no ip mroute-cache
    > > ipx network xxxxxx
    > > !
    > > interface Serial0/1
    > > no ip address
    > > no ip directed-broadcast
    > > shutdown
    > > !
    > > interface FastEthernet1/0
    > > description internal LAN
    > > ip address 192.168.75.1 255.255.255.240
    > > no ip directed-broadcast
    > > full-duplex
    > > !
    > > router rip
    > > version 1
    > > redistribute static
    > > network 10.0.0.0
    > > network 192.168.0.0
    > > no auto-summary
    > > !
    > > ip classless
    > > ip route 192.168.71.0 255.255.255.0 192.168.75.2
    > > ip route 192.168.73.0 255.255.255.0 192.168.75.2 permanent
    > > ip route 192.168.75.16 255.255.255.240 Serial0/0.1 10.100.10.2
    > > ip route 192.168.75.32 255.255.255.240 Serial0/0.2 10.100.11.2
    > > ip route 192.168.75.48 255.255.255.240 Serial0/0.3 10.100.12.2
    > > no ip http server
    > > !
    > > !
    > > !
    > > !
    > > snmp-server engineID local xxxxxxxxxxxxxxxxxxxxxxxx
    > > snmp-server community xxxxxx RO
    > > snmp-server community xxxxxx RW
    > > snmp-server community xxxxxx view xxxxxxxxx RO
    > > snmp-server location ABC CO.
    > > snmp-server contact
    > > snmp-server enable traps snmp
    > > snmp-server host 192.168.71.201
    > > snmp-server host 192.168.71.201
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > password x xxxxxxxxxxxxxx
    > > login
    > > transport input none
    > > line aux 0
    > > line vty 0 4
    > > exec-timeout 5 0
    > > password x xxxxxxxxxxxxxx
    > > login
    > > !
    > > end
    > >
    > > - Thanks
    NNTP, Jul 25, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Bacon
    Replies:
    0
    Views:
    720
    John Bacon
    Jul 22, 2003
  2. tige
    Replies:
    1
    Views:
    7,127
    Johnson_dk
    Jun 30, 2004
  3. Mike Rahl
    Replies:
    1
    Views:
    1,194
    Trendkill
    May 30, 2007
  4. benchmark
    Replies:
    10
    Views:
    1,829
    benchmark
    Jul 29, 2007
  5. Giuen
    Replies:
    0
    Views:
    676
    Giuen
    Sep 12, 2008
Loading...

Share This Page