Re: Two PC's on crossover kills WiFi

Discussion in 'Wireless Networking' started by Phillip Windell, Apr 15, 2008.

  1. Two choices:

    Choice #1 - The easy way
    Manually configure The TCP/IP specs of the nics you're using with the
    crossover cable.
    Make them the same subnet with each other, but different than the wireless
    Nics
    Leave the Default Gateway blank,..it is used for crossing subnets and they
    are not crossing subnets,..it is therefore not supposed to be used,..leave
    it blank

    Choice #2 - The long annoying and possibly less stabile way
    Change the binding order of the nics. Set the WiFi nic as the first. I'll
    use XP as the example,..you can translate it to Vista if you run Vista.

    Properties of Network Places-->
    Advanced from the Top Menu-->
    Advanced Settings from the Dropdown Menu-->
    Use the side arrows at the Upper box the set the Nic you want to be at the
    top

    Now it should "favor" that nic if they both have conflicting Default
    Gateways

    Default Gateways are supposed to be treated as *global* for the whole
    machine, hence there should only be one on one nic. This situation is an
    example of why a machine should never have more than one Default Gateway
    unless the Default Gateway IP#s are in the same subnet and are bound to the
    same Nic (used for Dead Gateway Detection, see below). That has been the
    Rule for years since TCP/IP was invented,...things haven't changed much.

    If it doesn't work after this then you just simply will not be able to
    dependably use the Wifi at the same time as using a crossover between the
    wired nics. You'll have to pick one or the other at a given moment by
    disabling the other.

    I hope the links are still good,...they are getting kind of old.

    Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
    http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP

    Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
    http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP

    Q1157025 - Default Gateway Configuration for Multihomed Computers
    http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP

    Q175767 - Expected Behavior of Multiple Adapters on Same Network
    http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP


    --
    Phillip Windell
    www.wandtv.com

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------

    "just bob" <kilbyfan@aoldotcom> wrote in message
    news:...
    > Connecting two PC's with a crossover cable kills the wifi internet.
    >
    > When we travel we usually have two laptops connected to the same public
    > WiFi to check email and surf the web but we also need to share many very
    > large files between the two laptops. Since both computes have gigabit
    > NIC's I tried using a crossover cable to link them to get better speeds
    > than over WiFi.
    >
    > Both laptops are identical Dell D630 with internal Wifi adapters.
    >
    > Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
    > subnet mask is 255.255.255.0 and gateway is themselves.
    >
    > When I do this the two PC's see each other just fine but the WiFi to the
    > internet stops working. I believe it is a routing to default gateway issue
    > but I'm not sure how to cure this. How do you force the PC to use the WiFi
    > as the default gateway, if that will solve the problem? I have tried
    > using the route command but even though I craft the command statement
    > exactly as the help doc says it comes back with an error.
    >
    > route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
    >
    > If you have any ideas how to make this work please let me know!
    >
    > Thanks,
    > -Bob
    >
    >
    >
     
    Phillip Windell, Apr 15, 2008
    #1
    1. Advertising

  2. Hi
    May be this can Help, http://www.netsetman.com/index.php?s=nsm
    Jack (MVP-Networking).

    "just bob" <kilbyfan@aoldotcom> wrote in message
    news:...
    >A few minutes later
    >
    > Had to create two local admin accounts on each machine to use for
    > authentication since a DC is not present, added each machine name and IP
    > to each others hosts file (even ping seems slow without this) and used map
    > network drive with login with other name. Fairly pathetic but it works
    > bunch of hoops I had to go through but it does work OK.
    >
    > Is there an easier way?
    >
    >
    > "just bob" <kilbyfan@aoldotcom> wrote in message
    > news:...
    >> Choice 1 worked nice except.... XP will not let me share files.
    >>
    >> I can ping each other now and both machines can access the internet, so
    >> your tip worked. I just do not know how to share files between domain
    >> members when they are not on the domain.
    >>
    >> Any ideas?
    >>
    >> Thanks again!
    >>
    >>
    >> "Phillip Windell" <> wrote in message
    >> news:u$...
    >>> Two choices:
    >>>
    >>> Choice #1 - The easy way
    >>> Manually configure The TCP/IP specs of the nics you're using with the
    >>> crossover cable.
    >>> Make them the same subnet with each other, but different than the
    >>> wireless Nics
    >>> Leave the Default Gateway blank,..it is used for crossing subnets and
    >>> they are not crossing subnets,..it is therefore not supposed to be
    >>> used,..leave it blank
    >>>
    >>> Choice #2 - The long annoying and possibly less stabile way
    >>> Change the binding order of the nics. Set the WiFi nic as the first.
    >>> I'll use XP as the example,..you can translate it to Vista if you run
    >>> Vista.
    >>>
    >>> Properties of Network Places-->
    >>> Advanced from the Top Menu-->
    >>> Advanced Settings from the Dropdown Menu-->
    >>> Use the side arrows at the Upper box the set the Nic you want to be at
    >>> the top
    >>>
    >>> Now it should "favor" that nic if they both have conflicting Default
    >>> Gateways
    >>>
    >>> Default Gateways are supposed to be treated as *global* for the whole
    >>> machine, hence there should only be one on one nic. This situation is an
    >>> example of why a machine should never have more than one Default Gateway
    >>> unless the Default Gateway IP#s are in the same subnet and are bound to
    >>> the same Nic (used for Dead Gateway Detection, see below). That has been
    >>> the Rule for years since TCP/IP was invented,...things haven't changed
    >>> much.
    >>>
    >>> If it doesn't work after this then you just simply will not be able to
    >>> dependably use the Wifi at the same time as using a crossover between
    >>> the wired nics. You'll have to pick one or the other at a given moment
    >>> by disabling the other.
    >>>
    >>> I hope the links are still good,...they are getting kind of old.
    >>>
    >>> Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
    >>> http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP
    >>>
    >>> Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
    >>> http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP
    >>>
    >>> Q1157025 - Default Gateway Configuration for Multihomed Computers
    >>> http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP
    >>>
    >>> Q175767 - Expected Behavior of Multiple Adapters on Same Network
    >>> http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP
    >>>
    >>>
    >>> --
    >>> Phillip Windell
    >>> www.wandtv.com
    >>>
    >>> The views expressed, are my own and not those of my employer, or
    >>> Microsoft,
    >>> or anyone else associated with me, including my cats.
    >>> -----------------------------------------------------
    >>>
    >>> "just bob" <kilbyfan@aoldotcom> wrote in message
    >>> news:...
    >>>> Connecting two PC's with a crossover cable kills the wifi internet.
    >>>>
    >>>> When we travel we usually have two laptops connected to the same public
    >>>> WiFi to check email and surf the web but we also need to share many
    >>>> very large files between the two laptops. Since both computes have
    >>>> gigabit NIC's I tried using a crossover cable to link them to get
    >>>> better speeds than over WiFi.
    >>>>
    >>>> Both laptops are identical Dell D630 with internal Wifi adapters.
    >>>>
    >>>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
    >>>> subnet mask is 255.255.255.0 and gateway is themselves.
    >>>>
    >>>> When I do this the two PC's see each other just fine but the WiFi to
    >>>> the internet stops working. I believe it is a routing to default
    >>>> gateway issue but I'm not sure how to cure this. How do you force the
    >>>> PC to use the WiFi as the default gateway, if that will solve the
    >>>> problem? I have tried using the route command but even though I craft
    >>>> the command statement exactly as the help doc says it comes back with
    >>>> an error.
    >>>>
    >>>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
    >>>>
    >>>> If you have any ideas how to make this work please let me know!
    >>>>
    >>>> Thanks,
    >>>> -Bob
    >>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    Jack \(MVP-Networking\)., Apr 16, 2008
    #2
    1. Advertising

  3. "just bob" <kilbyfan@aoldotcom> wrote in message
    news:...
    > Had to create two local admin accounts on each machine to use for
    > authentication since a DC is not present, added each machine name and IP
    > to each others hosts file (even ping seems slow without this) and used map
    > network drive with login with other name. Fairly pathetic but it works
    > bunch of hoops I had to go through but it does work OK.


    The "workgroup model" is always "pathetic" to me :)

    See Jack's post. He has the links that will help with that stuff. I got
    the networking side of things cleared up,..I'm satisfied with just that.

    --
    Phillip Windell
    www.wandtv.com

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------
     
    Phillip Windell, Apr 16, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    11,120
    Walter Roberson
    Jun 30, 2005
  2. Mike
    Replies:
    5
    Views:
    945
  3. John

    Re: Two PC's on crossover kills WiFi

    John, Apr 15, 2008, in forum: Wireless Networking
    Replies:
    1
    Views:
    749
  4. Bucky Breeder

    Re: Installing Sysinternals Desktops kills WiFi

    Bucky Breeder, Dec 4, 2008, in forum: Computer Support
    Replies:
    3
    Views:
    586
    Bucky Breeder
    Dec 4, 2008
  5. Desk Rabbit

    Re: Installing Sysinternals Desktops kills WiFi

    Desk Rabbit, Dec 4, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    452
    Desk Rabbit
    Dec 4, 2008
Loading...

Share This Page