Re: Trying to get a 3640 to work as dial-in ISDN/analogue accessserver

Discussion in 'Cisco' started by Guy Dawson, Jul 24, 2003.

  1. Guy Dawson

    Guy Dawson Guest

    I've got further with my attempt to configure a 3640 as a dial-in
    access server. After moving the MICA modems to a different slot on the
    carrier I can now dial into the 3640.

    Unfortunalty I still can't get a PPP session to work. The connection
    seems to be dropped once authentication has occured.

    I've attached 4 files:

    ppp.log PPP dial-in client log
    dialup_error.log Cisco log of PPP dial-in client trying to connect
    rtr3640-confg Router config file
    debug.log Router debug settings

    Any ideas?

    Alternativly, anyone near Heathrow who can do a days consulting to
    fix this?

    TIA!
    Guy
    -- --------------------------------------------------------------------
    Guy Dawson I.T. Manager Crossflight Ltd





    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname rtr3640
    !
    logging queue-limit 100
    no logging buffered
    no logging console
    enable password 7 000842010C4F18160A2448
    !
    modem call-record terse
    modem country mica united-kingdom
    aaa new-model
    !
    !
    aaa authentication password-prompt Password:
    aaa authentication username-prompt Username:
    aaa authentication login default group radius
    aaa authentication login dialin group radius
    aaa authentication ppp default group radius
    aaa authentication ppp dialin group radius
    aaa authorization exec default if-authenticated group radius
    aaa authorization network default if-authenticated group radius
    aaa accounting delay-start
    aaa accounting network default start-stop group radius
    aaa accounting system default start-stop group radius
    aaa session-id common
    ip subnet-zero
    !
    !
    ip domain name crossflight.co.uk
    ip name-server 195.172.72.3
    !
    async-bootp gateway 195.172.72.196
    async-bootp dns-server 195.172.72.3
    isdn switch-type basic-net3
    isdn tei-negotiation first-call
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    mta receive maximum-recipients 0
    !
    !
    !
    !
    interface Ethernet0/0
    description connected to LHR Ethernet
    ip address 195.172.72.196 255.255.255.0
    half-duplex
    no keepalive
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface BRI1/0
    description connected to ISDN dial-in
    no ip address
    encapsulation ppp
    dialer rotary-group 1
    dialer-group 1
    isdn switch-type basic-net3
    isdn incoming-voice modem
    isdn answer1 1753676583
    no fair-queue
    no cdp enable
    !
    interface BRI1/1
    description connected to ISDN dial-in
    no ip address
    encapsulation ppp
    dialer rotary-group 1
    dialer-group 1
    isdn switch-type basic-net3
    isdn incoming-voice modem
    no fair-queue
    no cdp enable
    !
    interface BRI1/2
    description connected to ISDN dial-in
    no ip address
    encapsulation ppp
    dialer rotary-group 1
    dialer-group 1
    isdn switch-type basic-net3
    isdn incoming-voice modem
    no fair-queue
    no cdp enable
    !
    interface BRI1/3
    description connected to ISDN dial-in
    no ip address
    encapsulation ppp
    dialer rotary-group 1
    dialer-group 1
    isdn switch-type basic-net3
    isdn incoming-voice modem
    no fair-queue
    no cdp enable
    !
    interface Async65
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.65
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Async66
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.66
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Async67
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.67
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Async68
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.68
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Async69
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.69
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Async70
    mtu 64
    ip unnumbered Ethernet0/0
    encapsulation ppp
    load-interval 30
    dialer in-band
    dialer pool-member 1
    async default routing
    async mode interactive
    peer default ip address 192.168.16.70
    no keepalive
    ppp authentication pap dialin
    hold-queue 10 in
    !
    interface Dialer1
    description connected to ISDN dial-in
    ip unnumbered Ethernet0/0
    encapsulation ppp
    no ip split-horizon
    dialer in-band
    dialer wait-for-line-protocol 60
    dialer-group 1
    no peer default ip address
    no fair-queue
    no cdp enable
    ppp authentication pap dialin
    !
    router rip
    version 2
    network 195.172.72.0
    no auto-summary
    !
    ip default-gateway 195.172.72.10
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 195.172.72.10
    ip route 192.168.4.0 255.255.255.0 Ethernet0/0 permanent
    !
    !
    !
    logging trap debugging
    logging facility local6
    logging 195.172.72.10
    dialer-list 1 protocol ip permit
    !
    snmp-server community public RO
    snmp-server location IT Dev Office
    snmp-server enable traps tty
    radius-server host 195.172.72.126 auth-port 1812 acct-port 1813
    radius-server key 7 060507344E4C
    radius-server authorization permit missing Service-Type
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    banner exec 
    banner incoming 
    banner motd 
    banner slip-ppp 
    !
    line con 0
    exec-timeout 0 0
    password 7 03080A0C0E1B325C4B0C1D
    line 65 70
    exec-timeout 1 0
    flush-at-activation
    modem Dialin
    autocommand ppp neg
    transport input all
    transport output lat pad v120 lapb-ta telnet rlogin udptn
    autoselect during-login
    autoselect ppp
    line aux 0
    line vty 0 4
    password 7 03080A0C0E1B325C4B0C1D
    !
    !
    end

    Jul 24 14:40:12 195.172.72.196 42: *Mar 1 00:41:26.403: %SYS-5-CONFIG_I: Configured from console by USER on vty0 (195.172.72.10)
    Jul 24 14:41:24 195.172.72.196 43: *Mar 1 00:42:39.667: ISDN BR1/0 Q931: RX <- SETUP pd = 8 callref = 0x06
    Jul 24 14:41:24 195.172.72.196 44: Bearer Capability i = 0x8090A3
    Jul 24 14:41:24 195.172.72.196 45: Standard = CCITT
    Jul 24 14:41:24 195.172.72.196 46: Transer Capability = Speech
    Jul 24 14:41:24 195.172.72.196 47: Transfer Mode = Circuit
    Jul 24 14:41:24 195.172.72.196 48: Transfer Rate = 64 kbit/s
    Jul 24 14:41:24 195.172.72.196 49: Channel ID i = 0x89
    Jul 24 14:41:24 195.172.72.196 50: Progress Ind i = 0x8481 - Call not end-to-end ISDN, may have in-band info
    Jul 24 14:41:24 195.172.72.196 51: Calling Party Number i = 0x0083, '01753DESTNO'
    Jul 24 14:41:24 195.172.72.196 52: Plan:Unknown, Type:Unknown
    Jul 24 14:41:24 195.172.72.196 53: Called Party Number i = 0xA1, '1753SRCNUM'
    Jul 24 14:41:24 195.172.72.196 54: Plan:ISDN, Type:National
    Jul 24 14:41:24 195.172.72.196 55: Sending Complete
    Jul 24 14:41:24 195.172.72.196 56: *Mar 1 00:42:39.671: AAA/BIND(00000003): Bind i/f BRI1/0:1
    Jul 24 14:41:24 195.172.72.196 57: *Mar 1 00:42:39.675: CSM: MODEM_REPORT from 1/0:0, call_id=0x3, event=0x1, cause=0x0, dchan_idb=0x62EB886C
    Jul 24 14:41:24 195.172.72.196 58: *Mar 1 00:42:39.675: CSM: Next free modem = 2/1; statbits = 10020
    Jul 24 14:41:24 195.172.72.196 59: *Mar 1 00:42:39.675: Modem 2/1 CSM: modem is allocated, modems free=5
    Jul 24 14:41:24 195.172.72.196 60: *Mar 1 00:42:39.675: Modem 2/1 CSM: Incoming call from 01753DESTNO to 1753SRCNUM, id 0x3
    [snip]
    Jul 24 14:42:01 195.172.72.196 232: *Mar 1 00:43:16.751: Modem 2/1 Mica: PPP escape_map: Tx map = 0, Rx map = 0
    Jul 24 14:42:01 195.172.72.196 233: *Mar 1 00:43:16.751: As66 PPP: Phase is AUTHENTICATING, by this end
    Jul 24 14:42:01 195.172.72.196 234: *Mar 1 00:43:16.755: As66 PAP: I AUTH-REQ id 1 len 18 from "RUSER"
    Jul 24 14:42:01 195.172.72.196 235: *Mar 1 00:43:16.755: As66 PAP: Authenticating peer RUSER
    Jul 24 14:42:01 195.172.72.196 236: *Mar 1 00:43:16.759: As66 PPP: Phase is FORWARDING, Attempting Forward
    Jul 24 14:42:01 195.172.72.196 237: *Mar 1 00:43:16.759: As66 PPP: Phase is AUTHENTICATING, Unauthenticated User
    Jul 24 14:42:01 195.172.72.196 238: *Mar 1 00:43:16.759: AAA/AUTHEN/PPP (00000003): Pick method list 'dialin'
    Jul 24 14:42:01 195.172.72.196 239: *Mar 1 00:43:16.759: As66 PPP: Sent PAP LOGIN Request
    Jul 24 14:42:01 195.172.72.196 240: *Mar 1 00:43:16.767: As66 PPP: Received LOGIN Response PASS
    Jul 24 14:42:01 195.172.72.196 241: *Mar 1 00:43:16.767: As66 PPP/AAA: Check Attr: service-type
    Jul 24 14:42:01 195.172.72.196 242: *Mar 1 00:43:16.767: As66 PPP/AAA: Check Attr: Framed-Protocol
    Jul 24 14:42:01 195.172.72.196 243: *Mar 1 00:43:16.767: As66 PPP: Phase is FORWARDING, Attempting Forward
    Jul 24 14:42:01 195.172.72.196 244: *Mar 1 00:43:16.771: As66 PPP: Phase is AUTHENTICATING, Authenticated User
    Jul 24 14:42:01 195.172.72.196 245: *Mar 1 00:43:16.771: TTY66: Async Int reset: Dropping DTR
    Jul 24 14:42:01 195.172.72.196 246: *Mar 1 00:43:16.771: Modem 2/1 CSM: (CSM_PROC_CONNECTED)<--ASYNC_DTR_DOWN
    Jul 24 14:42:01 195.172.72.196 247: *Mar 1 00:43:16.771: As66 PAP: O AUTH-ACK id 1 len 5
    Jul 24 14:42:01 195.172.72.196 248: *Mar 1 00:43:16.771: As66 PPP: Phase is UP
    Jul 24 14:42:01 195.172.72.196 249: *Mar 1 00:43:16.771: As66 AAA/AUTHOR/FSM: We can start IPCP
    Jul 24 14:42:01 195.172.72.196 250: *Mar 1 00:43:16.771: As66 IPCP: O CONFREQ [Closed] id 1 len 10
    Jul 24 14:42:01 195.172.72.196 251: *Mar 1 00:43:16.771: As66 IPCP: Address 195.172.72.196 (0x0306C3AC48C4)
    Jul 24 14:42:01 195.172.72.196 252: *Mar 1 00:43:16.775: As66 PPP: Process pending packets
    Jul 24 14:42:01 195.172.72.196 253: *Mar 1 00:43:16.783: Modem 2/1 Mica: in modem state TERMINATING
    Jul 24 14:42:01 195.172.72.196 254: *Mar 1 00:43:16.783: Modem 2/1 Mica: received TerminateInfo
    Jul 24 14:42:01 195.172.72.196 255: *Mar 1 00:43:16.807: Modem 2/1 CSM: (CSM_PROC_DISCONNECTED)<--MODEM_DISCONNECTED
    Jul 24 14:42:01 195.172.72.196 256: *Mar 1 00:43:16.807: Modem 2/1 CSM: Stopping dm tone timer
    Jul 24 14:42:01 195.172.72.196 257: *Mar 1 00:43:16.807: Modem 2/1 Mica: in modem state IDLE
    Jul 24 14:42:01 195.172.72.196 258: *Mar 1 00:43:16.807: Modem 2/1 CSM: (CSM_PROC_DISCONNECTED)<--QUEUED_DISCONNECT
    Jul 24 14:42:01 195.172.72.196 259: *Mar 1 00:43:16.807: Modem 2/1 CSM: Stopping dm tone timer
    Jul 24 14:42:01 195.172.72.196 260: *Mar 1 00:43:16.839: Modem 2/1 CSM: CSM_MODEM_DEALLOCATE: modem is deallocated
    Jul 24 14:42:01 195.172.72.196 261: *Mar 1 00:43:16.839: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 01753DESTNO , call lasted 35 seconds
    Jul 24 14:42:01 195.172.72.196 262: *Mar 1 00:43:16.843: ISDN BR1/0 Q931: TX -> DISCONNECT pd = 8 callref = 0x86
    Jul 24 14:42:01 195.172.72.196 263: Cause i = 0x8090 - Normal call clearing
    Jul 24 14:42:01 195.172.72.196 264: *Mar 1 00:43:16.843: Modem 2/1 Mica: DISCONNECT after 00:00:35, due to reason (0xDF00) Host Disconnect.
    Jul 24 14:42:01 195.172.72.196 265: *Mar 1 00:43:16.847: %CALLRECORD-3-MODEM_CALL_REC_ERROR: DS0 slot/contr/chan=1/0/0, slot/port=2/1, call_id=3, userid=, ip=0.0.0.0, calling=01753DESTNO, called=1753SRCNUM, std=V90/92, prot=LAPM, comp = V42bis init-rx/tx b-rate=21600/42666, finl-rx/tx b-rate=21600/40000, rbs=0, d-pad=(invalid#256), retr=0, rx/tx chars=361/324, bad=22, rx/tx ec=16/20, bad=3, total moh time=0 sec, current moh time=0 sec, moh count=0, moh status=0x0, call waiting retrains=0, moh req=0, encoder/decoder state=0xFF/0xFF, rx/tx comp ratio=0.00:1/0.00:1, rx/tx dict reset=0/0, time=35, finl-state=STEADY, disc(modem)=DF00 Tx (host to line) data flushing - OK/Requested by host/
    Jul 24 14:42:01 195.172.72.196 266: *Mar 1 00:43:16.991: ISDN BR1/0 Q931: RX <- RELEASE pd = 8 callref = 0x06
    Jul 24 14:42:01 195.172.72.196 267: *Mar 1 00:43:16.995: CSM: MODEM_REPORT from 1/0:0, call_id=0x3, event=0x0, cause=0x0, dchan_idb=0x62EB886C
    Jul 24 14:42:01 195.172.72.196 268: *Mar 1 00:43:16.995: CSM: MODEM_REPORT rcvd DEV_IDLE for call_id 0x3, modem not found due to wrong b channel number or b channel is deallocated
    Jul 24 14:42:01 195.172.72.196 269: *Mar 1 00:43:16.999: ISDN BR1/0 **ERROR**: host_disconnect_ack: VOICE ERROR: NULL VDEV Common(0xFC): b channel 0, call id 0x3
    Jul 24 14:42:01 195.172.72.196 270: *Mar 1 00:43:16.999: ISDN BR1/0 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x86
    Jul 24 14:42:01 195.172.72.196 271: *Mar 1 00:43:17.187: TTY66: DSR was dropped
    Jul 24 14:42:01 195.172.72.196 272: *Mar 1 00:43:17.187: tty66: Modem: READY->(unknown)
    Jul 24 14:42:02 195.172.72.196 273: *Mar 1 00:43:17.187: TTY66: dropping DTR, hanging up
    Jul 24 14:42:02 195.172.72.196 274: *Mar 1 00:43:17.187: Modem 2/1 CSM: (CSM_PROC_IDLE)<--ASYNC_DTR_DOWN
    Jul 24 14:42:02 195.172.72.196 275: *Mar 1 00:43:17.187: tty66: Modem: HANGUP->(unknown)
    Jul 24 14:42:02 195.172.72.196 276: *Mar 1 00:43:18.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:02 195.172.72.196 277: *Mar 1 00:43:18.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:03 195.172.72.196 278: *Mar 1 00:43:18.763: As66 IPCP: TIMEout: State REQsent
    Jul 24 14:42:03 195.172.72.196 279: *Mar 1 00:43:18.763: As66 IPCP: O CONFREQ [REQsent] id 2 len 10
    Jul 24 14:42:03 195.172.72.196 280: *Mar 1 00:43:18.763: As66 IPCP: Address 195.172.72.196 (0x0306C3AC48C4)
    Jul 24 14:42:03 195.172.72.196 281: *Mar 1 00:43:18.771: %LINK-5-CHANGED: Interface Async66, changed state to reset
    Jul 24 14:42:04 195.172.72.196 282: *Mar 1 00:43:18.771: As66 PPP: Sending Acct Event[Down] id[3]
    Jul 24 14:42:04 195.172.72.196 283: *Mar 1 00:43:18.771: As66 IPCP: State is Closed
    Jul 24 14:42:04 195.172.72.196 284: *Mar 1 00:43:18.771: As66 PPP: Phase is TERMINATING
    Jul 24 14:42:04 195.172.72.196 285: *Mar 1 00:43:18.771: As66 LCP: State is Closed
    Jul 24 14:42:04 195.172.72.196 286: *Mar 1 00:43:18.771: As66 PPP: Phase is DOWN
    Jul 24 14:42:04 195.172.72.196 287: *Mar 1 00:43:19.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:04 195.172.72.196 288: *Mar 1 00:43:19.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:05 195.172.72.196 289: *Mar 1 00:43:20.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:05 195.172.72.196 290: *Mar 1 00:43:20.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:05 195.172.72.196 291: *Mar 1 00:43:21.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:05 195.172.72.196 292: *Mar 1 00:43:21.187: TTY66: cleanup pending. Delaying DTR
    Jul 24 14:42:07 195.172.72.196 293: *Mar 1 00:43:21.771: TTY66: no timer type 0 to destroy
    Jul 24 14:42:07 195.172.72.196 294: *Mar 1 00:43:21.771: TTY66: no timer type 1 to destroy
    Jul 24 14:42:07 195.172.72.196 295: *Mar 1 00:43:21.771: TTY66: no timer type 3 to destroy
    Jul 24 14:42:07 195.172.72.196 296: *Mar 1 00:43:21.771: TTY66: no timer type 4 to destroy
    Jul 24 14:42:07 195.172.72.196 297: *Mar 1 00:43:21.771: TTY66: destroy timer type 10
    Jul 24 14:42:07 195.172.72.196 298: *Mar 1 00:43:21.771: TTY66: no timer type 2 to destroy
    Jul 24 14:42:07 195.172.72.196 299: *Mar 1 00:43:21.771: Async66: allowing modem_process to continue hangup
    Jul 24 14:42:07 195.172.72.196 300: *Mar 1 00:43:22.187: TTY66: restoring DTR
    Jul 24 14:42:07 195.172.72.196 301: *Mar 1 00:43:22.187: Modem 2/1 CSM: received ASYNC_DTR_UP for line 66
    Jul 24 14:42:09 195.172.72.196 302: *Mar 1 00:43:23.771: %LINK-3-UPDOWN: Interface Async66, changed state to down
    Jul 24 14:42:19 195.172.72.196 303: *Mar 1 00:43:33.491: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR1/0, TEI 94 changed to down

    state <- CP_ACKSENT
    LCP[rc=8] TO+ - send Conf-Req
    BUILD LCP_CREQ:
    {MAGIC: 0x22fb628f}
    {MRU: 1500}
    {ACCM: 0}
    {PFC}
    {ACFC}
    id=4 len=20
    Sending packet of 28 bytes:
    ff 03 c0 21 01 04 00 18 05 06 22 fb 62 8f 01 04
    05 dc 02 06 00 00 00 00 07 02 08 02
    Packet of 4 bytes:
    00 00 74 c9
    Dropping skipped packet
    Packet of 28 bytes:
    ff 03 c0 21 02 04 00 18 05 06 22 fb 62 8f 01 04
    05 dc 02 06 00 00 00 00 07 02 08 02
    RCV PACKET LCP2 Configure-Ack id=4 len=24 [CP_ACKSENT]
    state <- CP_OPENED
    LCP is up
    BUILD PAP REQUEST
    Sending packet of 22 bytes:
    (PAP Request suppressed)
    WAITING FOR AUTH
    Packet of 32 bytes:
    ff 03 c0 21 01 05 00 1c 01 04 00 40 02 06 00 0a
    00 00 03 04 c0 23 05 06 d0 80 8a db 07 02 08 02
    RCV PACKET LCP1 Configure-Request id=5 len=28 [CP_OPENED]
    send Conf-Req AGAIN
    ppp_cp_down: IPCP
    state <- CP_STARTING
    BUILD LCP_CREQ:
    {MAGIC: 0x22fb628f}
    {MRU: 1500}
    {ACCM: 0}
    {PFC}
    {ACFC}
    id=5 len=20
    Sending packet of 28 bytes:
    ff 03 c0 21 01 05 00 18 05 06 22 fb 62 8f 01 04
    05 dc 02 06 00 00 00 00 07 02 08 02
    {MRU: len=4 mtu=64}
    NAK
    {ACCM: len=6 m=0xa0000}
    {AP: PAP}
    {MAGIC: len=6 m=0xd0808adb}
    {PFC: len=2}
    {ACFC: len=2}
    Sending packet of 12 bytes:
    ff 03 c0 21 03 05 00 08 01 04 00 80
    send Conf-Nak (len=12)
    state <- CP_REQSENT
    WAITING FOR LCP (again)
    Packet of 28 bytes:
    ff 03 c0 21 02 05 00 18 05 06 22 fb 62 8f 01 04
    05 dc 02 06 00 00 00 00 07 02 08 02
    RCV PACKET LCP2 Configure-Ack id=5 len=24 [CP_REQSENT]
    init restart cntr
    state <- CP_ACKRCVD
    Packet of 32 bytes:
    ff 03 c0 21 01 06 00 1c 01 04 00 80 02 06 00 0a
    00 00 03 04 c0 23 05 06 d0 80 8a db 07 02 08 02
    RCV PACKET LCP1 Configure-Request id=6 len=28 [CP_ACKRCVD]
    {MRU: len=4 mtu=128}
    {ACCM: len=6 m=0xa0000}
    {AP: PAP}
    {MAGIC: len=6 m=0xd0808adb}
    {PFC: len=2}
    {ACFC: len=2}
    send Conf-Ack (len=32)
    Sending packet of 32 bytes:
    ff 03 c0 21 02 06 00 1c 01 04 00 80 02 06 00 0a
    00 00 03 04 c0 23 05 06 d0 80 8a db 07 02 08 02
    state <- CP_OPENED
    LCP is up
    BUILD PAP REQUEST
    Sending packet of 22 bytes:
    (PAP Request suppressed)
    WAITING FOR AUTH
    Control Packet of 16 bytes:
    10 00 00 00 00 00 00 00 02 00 00 00 00 00 00 00
    LOST CARRIER DETECT
    Clr state 400
    Clr state 100
    ppp: while waiting for session to start: Network is down


    rtr3640#show debug
    General OS:
    Modem control/process activation debugging is on
    AAA Authentication debugging is on
    AAA Authorization debugging is on
    CSM Modem Management:
    Modem Management Call Switching Module debugging is on
    PPP:
    PPP authentication debugging is on
    PPP protocol negotiation debugging is on


    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is ON.
    debug isdn q931 is ON.


    rtr3640(config)#service timestamp debug date msec
    rtr3640(config)#service timestamp log date msec
    rtr3640(config)#modem call-record terse
    rtr3640(config)#no logging console
    Guy Dawson, Jul 24, 2003
    #1
    1. Advertising

  2. Guy Dawson

    Noufal

    Joined:
    Apr 17, 2007
    Messages:
    1
    Please help ISDN PRI

    Hello friends
    I want to configure Cisco router 2800 with NM-1CE1T1-PRI module for dialup access from analog telephone line. We have PRI with 10 channel. I have configured router as follows ;but It doesn't pick up the call .the configuration with debug information is attached .Could you please help me?
    isdn#show conf
    Using 2516 out of 245752 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname isdn
    !
    boot-start-marker
    boot system flash c2800nm-ipbasek9-mz.124-9.T3.bin
    boot-end-marker
    !
    card type e1 1
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    resource policy
    !
    network-clock-participate slot 1
    !
    !
    ip cef
    !
    !
    no ip domain lookup
    ip domain name yourdomain.com
    isdn switch-type primary-net5
    !
    chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T"
    chat-script offhook "" "ATH1" OK
    !
    !
    username noufal password 0 cisco
    username iweb password 0 iweb
    username islamweb privilege 15 secret 5 $1$Du/y$x.5rdaNup4m.i18U3SxEX0
    !
    !
    controller E1 1/0
    pri-group timeslots 1-10,16
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.55 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial1/0:15
    ip unnumbered FastEthernet0/0
    no ip redirects
    encapsulation ppp
    dialer pool-member 1
    no snmp trap link-status
    isdn switch-type primary-net5
    isdn incoming-voice modem
    peer default ip address pool dmz
    fair-queue
    no cdp enable
    ppp authentication chap dialinandout
    ppp multilink
    !
    interface Dialer1
    ip address 192.168.2.173 255.255.255.0
    encapsulation ppp
    dialer pool 1
    dialer remote-name iweb
    dialer-group 1
    peer default ip address pool dmz
    no cdp enable
    ppp authentication chap dialinandout
    !
    interface Group-Async0
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp header-compression
    dialer in-band
    dialer idle-timeout 120 either
    dialer-group 1
    async mode dedicated
    peer default ip address pool dmz
    ppp authentication chap dialinandout
    ppp multilink
    group-range 0/322 0/357
    !
    ip local pool iweb 172.16.14.1 172.16.14.25
    ip local pool dmz 192.168.1.85 192.168.1.96
    ip default-gateway 192.168.1.1
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    !
    line con 0
    password cisco
    line aux 0
    line 0/322 0/357
    no flush-at-activation
    login local
    modem InOut
    modem autoconfigure discovery
    transport input all
    transport output all
    autoselect during-login
    autoselect ppp
    line vty 0 4
    privilege level 15
    password cisco
    login
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    !
    end

    isdn#show isdn status
    Global ISDN Switchtype = primary-net5
    ISDN Serial1/0:15 interface
    dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x800003FF
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0

    isdn#show isdn service
    PRI Channel Statistics:
    ISDN Se1/0:15, Channel [1-31]
    Configured Isdn Interface (dsl) 0
    Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel : 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State : 0 0 0 0 0 0 0 0 0 0 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3
    Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Noufal, Apr 17, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ivana

    dial-in user fails on 3640

    Ivana, Jan 28, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,483
    Ivan Ostres
    Jan 29, 2004
  2. stef novo

    3640 : MICA MODEM DIAL-OUT OVER BRI

    stef novo, Feb 6, 2004, in forum: Cisco
    Replies:
    4
    Views:
    876
    Aaron Leonard
    Feb 9, 2004
  3. Simon Watson

    Problem with 3640's & Congo ISDN Routers

    Simon Watson, Feb 9, 2004, in forum: Cisco
    Replies:
    0
    Views:
    453
    Simon Watson
    Feb 9, 2004
  4. squid3570
    Replies:
    1
    Views:
    2,810
    Bantec
    Jul 3, 2006
  5. sync
    Replies:
    0
    Views:
    529
Loading...

Share This Page