Re: Profiles Missing

Discussion in 'Firefox' started by Rom, Jan 12, 2009.

  1. Rom

    Rom Guest

    On Sun, 11 Jan 2009 23:00:25 -0500, wrote:

    > All of a sudden, when I launch Mozilla, the box with the profiles for me and my
    > wife doesn't open. It just goes right to the browser. How do I get this back? I
    > haven't changed anything. It just disappeared. Thanks.


    You can create a separate Profile Manager shortcut by copying the
    existing Firefox shortcut, then open the copy of the Firefox
    shortcut's Properties, and in the Target box to the path append

    -ProfileManager

    which would be this if Firefox is installed to the default location:

    "C:\Program Files\Mozilla Firefox\firefox.exe" -ProfileManager


    Otherwise, start the Profile Manager by going to Start > Run and enter

    firefox.exe -ProfileManager

    When the Profile Manager opens, before selecting the profile to start,
    UNcheck

    [ ] Don't ask at startup

    --
    Rom
     
    Rom, Jan 12, 2009
    #1
    1. Advertising

  2. Rom

    yogi22 Guest

    On Jan 12, 12:00 am, Rom <> wrote:
    > On Sun, 11 Jan 2009 23:00:25 -0500, wrote:
    > > All of a sudden, when I launch Mozilla, the box with the profiles for me and my
    > > wife doesn't open. It just goes right to the browser. How do I get this back? I
    > > haven't changed anything. It just disappeared. Thanks.

    >
    > You can create a separate Profile Manager shortcut by copying the
    > existing Firefox shortcut, then open the copy of the Firefox
    > shortcut's Properties, and in the Target box to the path append
    >
    >  -ProfileManager
    >
    > which would be this if Firefox is installed to the default location:
    >
    > "C:\Program Files\Mozilla Firefox\firefox.exe" -ProfileManager
    >
    > Otherwise, start the Profile Manager by going to Start > Run and enter
    >
    > firefox.exe -ProfileManager


    I have exactly the opposite problem. I like FF to start immediately in
    a selected profile. Formerly, I had three shortcuts to different FF
    profiles. e.g.: "C:\Program Files\Mozilla Firefox\firefox.exe" -P
    "i6a2fh4y.Mary","C:\Program Files\Mozilla Firefox\firefox.exe" -P
    "rxcqldgg.Default User", etc. This worked great.

    I recently reloaded Windows, having saved the old profiles, then
    transferring them to the profiles folder of the the newly installed
    Firefox. ("C:\Documents and Settings\Administrator\Application Data
    \Mozilla\Firefox\Profiles").

    Now, no matter which shortcut I click on, Profile Manager appears,
    even tho' I have checked "[x] Don't ask at startup".

    Have I missed something? I have used this method on my Windows laptop
    and on my Linux eeePC, without the Profile Manager interjecting itself
    and causing added keystrokes/mouseing.
    kk
     
    yogi22, Jan 12, 2009
    #2
    1. Advertising

  3. Rom

    Rom Guest

    On Mon, 12 Jan 2009 07:06:49 -0800 (PST), yogi22 wrote:

    > I have exactly the opposite problem. I like FF to start immediately in
    > a selected profile. Formerly, I had three shortcuts to different FF
    > profiles. e.g.: "C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > "i6a2fh4y.Mary","C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > "rxcqldgg.Default User", etc. This worked great.


    Try changing the profile names to the same names displayed in Profile
    Manager, as it looks like "i6a2fh4y.Mary" is the folder name of the
    profile (and also in the Path in profiles.ini), so change
    "i6a2fh4y.Mary" to just "Mary" in the shortcut's Target if Mary is the
    name displayed in Profile Manager.

    > I recently reloaded Windows, having saved the old profiles, then
    > transferring them to the profiles folder of the the newly installed
    > Firefox. ("C:\Documents and Settings\Administrator\Application Data
    > \Mozilla\Firefox\Profiles").
    >
    > Now, no matter which shortcut I click on, Profile Manager appears,
    > even tho' I have checked "[x] Don't ask at startup".


    I've had that happen to a shortcut and everything looked okay to me,
    and I couldn't get the shortcut to work without the Profile Manager
    popping up, so I deleted it and started over by making a copy of
    another shortcut (say, copy from the one in the Start Menu) then
    adding -P "<profilename>".

    > Have I missed something? I have used this method on my Windows laptop
    > and on my Linux eeePC, without the Profile Manager interjecting itself
    > and causing added keystrokes/mouseing.


    Try the above and see how you go. More info here:

    Command line arguments:
    <http://kb.mozillazine.org/Command_line_arguments>

    Shortcut to a specific profile:
    <http://kb.mozillazine.org/Shortcut_to_a_specific_profile>

    Starting Firefox or Thunderbird with a specified profile:
    <http://kb.mozillazine.org/Starting_Firefox_or_Thunderbird_with_a_specified_profile>

    --
    Rom
     
    Rom, Jan 13, 2009
    #3
  4. Rom

    Ralph Fox Guest

    On Mon, 12 Jan 2009 07:06:49 -0800 (PST), in message <>,
    yogi22 wrote:

    > I have exactly the opposite problem. I like FF to start immediately in
    > a selected profile. Formerly, I had three shortcuts to different FF
    > profiles. e.g.: "C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > "i6a2fh4y.Mary","C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > "rxcqldgg.Default User", etc. This worked great.
    >
    > I recently reloaded Windows, having saved the old profiles, then
    > transferring them to the profiles folder of the the newly installed
    > Firefox. ("C:\Documents and Settings\Administrator\Application Data
    > \Mozilla\Firefox\Profiles").


    OK, you transferred the folder
    "C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles"
    and its subfolders.

    But did you also transfer the file
    "C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\profiles.ini"
    which is NOT in
    "C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles"


    > Now, no matter which shortcut I click on, Profile Manager appears,
    > even tho' I have checked "[x] Don't ask at startup".


    As I understand it, if you start Firefox with a parameter -p "profile-name"
    Firefox looks up the name in profiles.ini (see above), and finds the
    corresponding path to the folder for that profile.


    > Have I missed something? I have used this method on my Windows laptop
    > and on my Linux eeePC, without the Profile Manager interjecting itself
    > and causing added keystrokes/mouseing.
    > kk



    --
    Cheers,
    Ralph
     
    Ralph Fox, Jan 13, 2009
    #4
  5. Rom

    yogi22 Guest

    On Jan 12, 8:32 pm, Rom <> wrote:
    > On Mon, 12 Jan 2009 07:06:49 -0800 (PST), yogi22 wrote:
    > > I have exactly the opposite problem. I like FF to start immediately in
    > > a selected profile. Formerly, I had three shortcuts to different FF
    > > profiles. e.g.: "C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > > "i6a2fh4y.Mary","C:\Program Files\Mozilla Firefox\firefox.exe" -P
    > > "rxcqldgg.Default User", etc. This worked great.

    >
    > Try changing the profile names to the same names displayed in Profile
    > Manager, as it looks like "i6a2fh4y.Mary" is the folder name of the
    > profile (and also in the Path in profiles.ini), so change
    > "i6a2fh4y.Mary" to just "Mary" in the shortcut's Target if Mary is the
    > name displayed in Profile Manager.
    >
    > Try the above and see how you go. More info here:
    >
    > Command line arguments:
    > <http://kb.mozillazine.org/Command_line_arguments>
    >
    > Shortcut to a specific profile:
    > <http://kb.mozillazine.org/Shortcut_to_a_specific_profile>
    >
    > Starting Firefox or Thunderbird with a specified profile:
    > <http://kb.mozillazine.org/Starting_Firefox_or_Thunderbird_with_a_spec...>
    >
    > --
    > Rom


    Thank you so much Rom. It worked like a charm. I now have three FF
    shortcuts, each with a different icon. One for me, one for my wife,
    and one for visitors. Each one starts automatically, without the
    annoyance of having to select from Profile Manager.
    kk
     
    yogi22, Jan 13, 2009
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. aLTeReGo

    Re: Roaming profiles and WPA using PEAP MS-CHAPv2

    aLTeReGo, Sep 2, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    524
    aLTeReGo
    Sep 2, 2004
  2. Ola Theander
    Replies:
    0
    Views:
    666
    Ola Theander
    Sep 8, 2004
  3. Splibbilla
    Replies:
    0
    Views:
    802
    Splibbilla
    Mar 21, 2005
  4. =?Utf-8?B?TG91?=

    Mail Profiles missing

    =?Utf-8?B?TG91?=, May 8, 2006, in forum: Windows 64bit
    Replies:
    1
    Views:
    432
    Darrell Gorter[MSFT]
    May 9, 2006
  5. Peter Potamus the Purple Hippo

    Re: Profiles Missing

    Peter Potamus the Purple Hippo, Jan 12, 2009, in forum: Firefox
    Replies:
    0
    Views:
    440
    Peter Potamus the Purple Hippo
    Jan 12, 2009
Loading...

Share This Page