Re: LindowsOS skymedia (ihug Ultra) install

Discussion in 'NZ Computing' started by cowboyz, Jul 12, 2003.

  1. cowboyz

    cowboyz Guest

    Richard Malcolm-Smith wrote:
    >> samba setserial skeleton splash_checkfs splash_checkroot
    >> splash_init rdsendsigs single skymedia splash_checkfs_done
    >> splash_checkroot_done sysklogd
    >>
    >> xp2100:/etc/init.d# skymedia start
    >>
    >> bash: skymedia: command not found
    >>
    >> xp2100:/etc/init.d#
    >>
    >>
    >> Any ideas what is going on? Can't locate skymedia file which is just
    >> sitting there. On the other side I have other drivers I could use
    >> but it
    >> wants a "make" file. Where do I get this command file from? Is there a
    >> website source for these command files?

    >
    >
    > Do a ls -l and check that it is executable
    >
    > And run it as ./skymedia start, or type the full path as the
    > instructions say to, that will work.
    >
    >
    >
    >

    yes it does list it when i type ls -1

    Is that what you meant?

    I did the full path and it worked - I think.

    xp2100:~# /etc/init.d/skymedia restart
    Stopping sm200d: monitor interface logging module done.
    Starting sm200d: module Initializing card logging interface done.
    xp2100:~#


    it is not listed under lsmod though and cant open card when i try to
    call it.

    back to the books.

    I really am trying to do this this time like I know nothing. having to
    type out the entire path of a file when you are in it's directory seems
    silly though.
     
    cowboyz, Jul 12, 2003
    #1
    1. Advertising

  2. cowboyz

    ChrisOD Guest

    "cowboyz" <> wrote in message
    news:...
    >
    >
    > Richard Malcolm-Smith wrote:
    > >> samba setserial skeleton splash_checkfs splash_checkroot
    > >> splash_init rdsendsigs single skymedia splash_checkfs_done
    > >> splash_checkroot_done sysklogd
    > >>
    > >> xp2100:/etc/init.d# skymedia start
    > >>
    > >> bash: skymedia: command not found
    > >>
    > >> xp2100:/etc/init.d#
    > >>
    > >>
    > >> Any ideas what is going on? Can't locate skymedia file which is just
    > >> sitting there. On the other side I have other drivers I could use
    > >> but it
    > >> wants a "make" file. Where do I get this command file from? Is there

    a
    > >> website source for these command files?

    > >
    > >
    > > Do a ls -l and check that it is executable
    > >
    > > And run it as ./skymedia start, or type the full path as the
    > > instructions say to, that will work.
    > >
    > >
    > >
    > >

    > yes it does list it when i type ls -1
    >
    > Is that what you meant?
    >
    > I did the full path and it worked - I think.
    >
    > xp2100:~# /etc/init.d/skymedia restart
    > Stopping sm200d: monitor interface logging module done.
    > Starting sm200d: module Initializing card logging interface done.
    > xp2100:~#
    >
    >
    > it is not listed under lsmod though and cant open card when i try to
    > call it.
    >
    > back to the books.
    >
    > I really am trying to do this this time like I know nothing. having to
    > type out the entire path of a file when you are in it's directory seems
    > silly though.
    >
    >
    >


    Yeah I know it does seem wierd, but it is pretty common for multi user
    systems.
    Generally they are set up so a normal user has "." in their $PATH "." is the
    current directory. But root generally doesn't. The reasons for this are
    security. A trivial example follows:
    A normal user complies an evil program calls it ls and put it in his home
    directory. Then he asks the sysadmin for help with some wierd shit going on
    in his home directory. Sysadmin then cds to users home and first thing he
    does is ls. if "." is in path there is a chance that root may execute evil
    prog (tm)
    Outcome system is now toast.

    So there are many wierdnesses that multiuser systems have over normal single
    user systems but there is generally a good reason.

    Chris
     
    ChrisOD, Jul 12, 2003
    #2
    1. Advertising

  3. cowboyz

    cowboyz Guest

    ok. I got this far now.

    xp2100:/usr/local/sm200d-ihug-2.2.14-glibc# /etc/init.d/skymedia start


    Starting sm200d: module Initializing card logging interface done.


    xp2100:/usr/local/sm200d-ihug-2.2.14-glibc# lsmod


    Module Size Used by Tainted: PF

    ppp_deflate 39456 0 (autoclean)
    bsd_comp 4032 0 (autoclean)
    ppp_async 6336 1 (autoclean)
    ppp_generic 16076 3 (autoclean) [ppp_deflate bsd_comp
    ppp_async]
    slhc 4416 1 (autoclean) [ppp_generic]
    lt_serial 18784 3 (autoclean)
    lt_modem 479739 0 (autoclean) [lt_serial]
    ipt_LOG 3168 1 (autoclean)
    ipt_limit 960 4 (autoclean)
    ipt_state 608 1 (autoclean)
    ip_conntrack_ftp 3200 0 (unused)
    ip_conntrack 12908 2 [ipt_state ip_conntrack_ftp]
    iptable_filter 1728 1 (autoclean)
    ip_tables 10400 4 [ipt_LOG ipt_limit ipt_state
    iptable_filter]
    autofs 8868 3 (autoclean)
    lp 6368 0 (autoclean) (unused)
    apm 9276 2 (autoclean)
    pcmcia_core 38208 0
    ehci-hcd 14240 0 (unused)
    nls_iso8859-1 2848 1 (autoclean)
    nls_cp437 4384 1 (autoclean)
    serial 42304 0 (autoclean) (unused)
    isa-pnp 27708 0 (autoclean) [serial]
    md 56672 0 (autoclean) (unused)
    NVdriver 1065536 10
    sr_mod 13656 4
    cdrom 27232 0 [sr_mod]
    ide-scsi 7584 2
    floppy 45888 0
    sd_mod 10012 0 (unused)
    scsi_mod 50092 3 [sr_mod ide-scsi sd_mod]
    snd-via8233 5444 1
    snd-pcm-oss 35460 0
    snd-pcm 51232 0 [snd-via8233 snd-pcm-oss]
    snd-timer 9024 0 [snd-pcm]
    snd-ac97-codec 23792 0 [snd-via8233]
    snd-mixer-oss 8704 1 [snd-pcm-oss]
    af_packet 11688 1 (autoclean)
    usbmouse 1792 0 (unused)
    printer 6752 0
    snd 23400 0 [snd-via8233 snd-pcm-oss snd-pcm
    snd-timer snd-ac97-codec snd-mixer-oss]
    soundcore 3332 3 [snd]
    8139too 13472 0
    mii 1056 0 [8139too]
    usb-uhci 20964 0 (unused)
    parport 21888 0 [lp]
    keybdev 1664 0 (unused)
    mousedev 3872 1
    hid 18144 0 (unused)
    input 3136 0 [usbmouse keybdev mousedev hid]
    usbcore 54272 1 [ehci-hcd usbmouse printer snd
    usb-uhci hid]
    rtc 5916 0 (autoclean)
    reiserfs 158160 1
    ide-disk 9872 2
    ide-probe-mod 8592 0
    ide-mod 147872 2 [ide-scsi ide-disk ide-probe-mod]

    xp2100:/usr/local/sm200d-ihug-2.2.14-glibc#

    /usr/local/sm200d-ihug-2.2.14-glibc/sm200dstats

    SM200D open failed

    Lock QPSK Viterbi Frame FEC AGC Bit Error Rate kbps pps
    ---- ---- ------- ----- --- --- -------------- -----
    -----

    xp2100:/usr/local/sm200d-ihug-2.2.14-glibc#




    The manual simply says:

    If SkyData fails with a
    ?
    ??????? SM200D open failed
    then check that the card is seated and that the module loaded correctly.


    Well I know the card is seated properly cause I can restart to windows
    and it will work fine. I know the module is not loading correctly
    cause it is not listed above as being so, So this is the end of the
    manual. What is the next step????
     
    cowboyz, Jul 12, 2003
    #3
  4. cowboyz

    cowboyz Guest

    I almost think that I am getting this. I still need an IP address for
    the satcard though....

    xp2100:~# /etc/init.d/skymedia restart

    Stopping sm200d: monitor interface logging module done.
    Starting sm200d: module Initializing card logging interface done.

    xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/sm200dstats

    SM200D open failed
    Lock QPSK Viterbi Frame FEC AGC Bit Error Rate kbps pps
    ---- ---- ------- ----- --- --- -------------- -----
    -----

    xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/SkyData

    SkyData V.2.02 started. (C) 1999 Diego Picciani
    E-Mail:
    IPAddress not defined, but MACFilter = 0 in
    /usr/local/sm200d-ihug-2.2.14-glibc/SkyData.ini

    xp2100:~#


    The above is no IP defined.

    Then if I put in 192.168.0.1 then I get this.

    SkyData V.2.02 started. (C) 1999 Diego Picciani
    E-Mail:
    Sky_OpenSystem Error
    xp2100:~#


    The funny thing that I just don't get my head around is how can you set
    an IP address for a device that hasn't been installed yet??

    Is there a device manager equivalent?
     
    cowboyz, Jul 12, 2003
    #4
  5. cowboyz

    RecylerMan Guest

    cowboyz wrote:
    >
    > I almost think that I am getting this. I still need an IP address for
    > the satcard though....
    >
    > xp2100:~# /etc/init.d/skymedia restart
    >
    > Stopping sm200d: monitor interface logging module done.
    > Starting sm200d: module Initializing card logging interface done.
    >
    > xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/sm200dstats
    >
    > SM200D open failed
    > Lock QPSK Viterbi Frame FEC AGC Bit Error Rate kbps pps
    > ---- ---- ------- ----- --- --- -------------- ----- -----
    >
    > xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/SkyData
    >
    > SkyData V.2.02 started. (C) 1999 Diego Picciani
    > E-Mail:
    > IPAddress not defined, but MACFilter = 0 in
    > /usr/local/sm200d-ihug-2.2.14-glibc/SkyData.ini
    >
    > xp2100:~#
    >
    >
    > The above is no IP defined.
    >
    > Then if I put in 192.168.0.1 then I get this.
    >
    > SkyData V.2.02 started. (C) 1999 Diego Picciani
    > E-Mail:
    > Sky_OpenSystem Error
    > xp2100:~#
    >
    >
    > The funny thing that I just don't get my head around is how can you set
    > an IP address for a device that hasn't been installed yet??
    >
    > Is there a device manager equivalent?
    >

    you have to supply an Ip address I think the command is
    #> ifconfig sm200d 192.168.0.xxx (an Ip in youre subnet)
    infact i loaded mine like this

    in the /ect/rc.d/rc.local

    # Ihug Ultra Stff put in by coozerb:)
    /sbin/insmod -f /usr/local/sm200d/sm200d_lnx.o
    /sbin/ifconfig sm200d 192.168.2.2 &
    /usr/local/sm200d/SkyData &

    This way it is always there the real trick is to make the module even
    though I made mine I still had to use the -f swich to force it


    --
    RecylerMan ICQ 22245595


    Mail to :- l i n u x u s r AT i h u g DOT c o DOT n z
     
    RecylerMan, Jul 12, 2003
    #5
  6. cowboyz

    cowboyz Guest

    "RecylerMan" <0.nz> wrote in message
    news:beptv2$351$...
    > cowboyz wrote:
    > >
    > > I almost think that I am getting this. I still need an IP address for
    > > the satcard though....
    > >
    > > xp2100:~# /etc/init.d/skymedia restart
    > >
    > > Stopping sm200d: monitor interface logging module done.
    > > Starting sm200d: module Initializing card logging interface done.
    > >
    > > xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/sm200dstats
    > >
    > > SM200D open failed
    > > Lock QPSK Viterbi Frame FEC AGC Bit Error Rate kbps

    pps
    >
    > ---- ---- ------- ----- --- --- -------------- ----- ----

    -
    > >
    > > xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/SkyData
    > >
    > > SkyData V.2.02 started. (C) 1999 Diego Picciani
    > > E-Mail:
    > > IPAddress not defined, but MACFilter = 0 in
    > > /usr/local/sm200d-ihug-2.2.14-glibc/SkyData.ini
    > >
    > > xp2100:~#
    > >
    > >
    > > The above is no IP defined.
    > >
    > > Then if I put in 192.168.0.1 then I get this.
    > >
    > > SkyData V.2.02 started. (C) 1999 Diego Picciani
    > > E-Mail:
    > > Sky_OpenSystem Error
    > > xp2100:~#
    > >
    > >
    > > The funny thing that I just don't get my head around is how can you set
    > > an IP address for a device that hasn't been installed yet??
    > >
    > > Is there a device manager equivalent?
    > >

    > you have to supply an Ip address I think the command is
    > #> ifconfig sm200d 192.168.0.xxx (an Ip in youre subnet)
    > infact i loaded mine like this
    >
    > in the /ect/rc.d/rc.local
    >
    > # Ihug Ultra Stff put in by coozerb:)
    > /sbin/insmod -f /usr/local/sm200d/sm200d_lnx.o
    > /sbin/ifconfig sm200d 192.168.2.2 &
    > /usr/local/sm200d/SkyData &
    >
    > This way it is always there the real trick is to make the module even
    > though I made mine I still had to use the -f swich to force it
    >
    >



    There is no mention of editing etc/rc.d/rc.local Could that be the same as
    etc/init.d ?


    The following is a catch up post from linux.os. If you would like to shed
    your thoughts on it?




    Richard Adams wrote:
    > On Sat, 12 Jul 2003 18:35:08 +1200, cowboyz wrote:
    >
    >
    >>I really don't even know what my question is.
    >>I think I need to know what the IP address is of the satcard. How can I
    >>find this out?

    >
    >
    > /sbin/ifconfig
    > However you are running before you can walk, just what type of satcard do
    > you have,? DVB ?.
    >


    It is a tellemann DTP200d for use with NZ Ihug Ultra Satelite internet
    service. The problem with running before I can walk is that I have used
    windows systems for as long as I can remember and this is certainly a
    new thing. However I need that satelite running cause without it I
    only have 20k dialup and that is enought to lose my interest in Linux
    all together. After all. without an internet connection a computer is
    a doorstop.

    >
    >>I also need a file called make Where can I get this from? Is there a
    >>website with a heap of command files on it that I can browse through.

    >
    >
    > Install gcc.
    >
    >
    >>I have the satcard thinking it is installed but can't open it. and it is
    >>not logging anything.

    >
    >
    > Things "have" to be configured before they can work (properly).
    >
    > If you choose to reply to this mail, please include;
    >
    > Linux distro,


    LindowsOS3


    > kernel number,


    I have searched and search through the help files and I'm buggered if I
    can find this out. THis was one of my first thoughts that the driver I
    have 2.2.17 is not compatible with the kernel I am using but I would
    have thought it would give me a nice error saying kernel incompatible or
    something like that.


    > make/model and chipset of the card in question.


    Tellemann DTP200D

    >
    > We on this group cannot possably see what you use, its up to you to tell
    > us the whole story to get a decent answer.
    >


    I know exactly where you are coming from. For years I have helped
    people on the phone with windows systems one of the biggest problems is
    getting them to ask the right questions for me to give them the answer
    they are looking for. This is how I feel now but I really can't figure
    out what my question is. I have gone through the readme files that
    came with the drivers methodically step by step but still doesn't work.
    The first set of drivers I downloaded from the tellemann website says
    "error :make: not found" which I why I thought I needed a make command.

    The ones I am working on at the moment is from Ihugs website and they
    are a little easy to work with cause everything seems more laid out but
    still not luck.

    This is where i am at at the moment.

    I have set the values in usr/local/sky/skymedia and copied it to
    /etc/init.d/ and run it with the start command and get this.

    xp2100:/etc/init.d# ./skymedia start
    Starting sm200d: module Initializing card logging interface done.

    From Helpfile:
    12. Run the script to load the card: /etc/init.d/skymedia start
    13. Note that the module 'sm200_lnx' or 'sm200d_lnx' is now visible when
    you do an lsmod


    If I do a lsmod it does not list it.

    xp2100:/usr/local/sky# lsmod
    Module Size Used by Tainted: PF
    ppp_deflate 39456 0 (autoclean)
    bsd_comp 4032 0 (autoclean)
    ppp_async 6336 1 (autoclean)
    ppp_generic 16076 3 (autoclean) [ppp_deflate bsd_comp
    ppp_async]
    slhc 4416 1 (autoclean) [ppp_generic]
    lt_serial 18784 3 (autoclean)
    lt_modem 479739 0 (autoclean) [lt_serial]
    ipt_LOG 3168 1 (autoclean)
    ipt_limit 960 4 (autoclean)
    ipt_state 608 1 (autoclean)
    ip_conntrack_ftp 3200 0 (unused)
    ip_conntrack 12908 2 [ipt_state ip_conntrack_ftp]
    iptable_filter 1728 1 (autoclean)
    ip_tables 10400 4 [ipt_LOG ipt_limit ipt_state
    iptable_filter]
    autofs 8868 3 (autoclean)
    lp 6368 0 (autoclean) (unused)
    apm 9276 2 (autoclean)
    pcmcia_core 38208 0
    ehci-hcd 14240 0 (unused)
    nls_iso8859-1 2848 1 (autoclean)
    nls_cp437 4384 1 (autoclean)
    serial 42304 0 (autoclean) (unused)
    isa-pnp 27708 0 (autoclean) [serial]
    md 56672 0 (autoclean) (unused)
    NVdriver 1065536 10
    sr_mod 13656 4
    cdrom 27232 0 [sr_mod]
    ide-scsi 7584 2
    floppy 45888 0
    sd_mod 10012 0 (unused)
    scsi_mod 50092 3 [sr_mod ide-scsi sd_mod]
    snd-via8233 5444 1
    snd-pcm-oss 35460 0
    usbmouse 1792 0 (unused)
    snd-pcm 51232 0 [snd-via8233 snd-pcm-oss]
    snd-timer 9024 0 [snd-pcm]
    snd-ac97-codec 23792 0 [snd-via8233]
    snd-mixer-oss 8704 1 [snd-pcm-oss]
    printer 6752 0
    snd 23400 0 [snd-via8233 snd-pcm-oss snd-pcm
    snd-timer snd-ac97-codec snd-mixer-oss]
    soundcore 3332 3 [snd]
    8139too 13472 1
    mii 1056 0 [8139too]
    usb-uhci 20964 0 (unused)
    parport 21888 0 [lp]
    keybdev 1664 0 (unused)
    mousedev 3872 1
    hid 18144 0 (unused)
    input 3136 0 [usbmouse keybdev mousedev hid]
    usbcore 54272 1 [ehci-hcd usbmouse printer snd
    usb-uhci hid]
    rtc 5916 0 (autoclean)
    reiserfs 158160 1
    ide-disk 9872 2
    ide-probe-mod 8592 0
    ide-mod 147872 2 [ide-scsi ide-disk ide-probe-mod]
    xp2100:/usr/local/sky#


    I had a look at a file called /usr/local/sky/sm200dload.sh which the
    help file makes no mention of and it says:

    #!/bin/sh
    module="sm200d_lnx.o"

    #enter installed directory
    INSTALL_DIR=/usr/local/sky

    #echo "Bringing up skymedia interface"
    # invoke rmmod with all arguments we got
    #/sbin/rmmod $INSTALL_DIR/$module

    # invoke insmod with all arguments we got
    /sbin/insmod $INSTALL_DIR/$module



    So I thought I would do it manually and typed:

    xp2100:/usr/local/sky# /sbin/insmod /usr/local/sky/sm200d_lnx.o

    Floating point exception

    xp2100:/usr/local/sky#




    Is that enough info. I certainly appreciate any light you can shed on this.

    Oh yeah. and this

    xp2100:/usr/local/sky# /sbin/ifconfig
    eth0 Link encap:Ethernet HWaddr 00:05:1C:0B:CD:4D
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:276 errors:0 dropped:0 overruns:0 frame:0
    TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:44251 (43.2 KiB) TX bytes:10015 (9.7 KiB)
    Interrupt:11 Base address:0x9d00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:22 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:901 (901.0 b) TX bytes:901 (901.0 b)

    ppp0 Link encap:point-to-Point Protocol
    inet addr:203.173.247.30 P-t-P:192.168.251.44
    Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1514 Metric:1
    RX packets:686 errors:0 dropped:0 overruns:0 frame:0
    TX packets:792 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:348634 (340.4 KiB) TX bytes:78441 (76.6 KiB)

    xp2100:/usr/local/sky#


    eth0 would be my home network?

    lo would be local host?

    ppp0 would be my current dialup connection?
     
    cowboyz, Jul 12, 2003
    #6
  7. cowboyz

    cowboyz Guest

    The simplest of things turn bad

    I was advised to install gcc

    so I downloaded it and unpacked it and trying to configure it.

    instructions say


    To configure GCC:

    % mkdir objdir
    % cd objdir
    % srcdir/configure [options] [target]


    Target specification

    GCC has code to correctly determine the correct value for target for
    nearly all native systems. Therefore, we highly recommend you not
    provide a configure target when configuring a native compiler.
    target must be specified as --target=target when configuring a cross
    compiler; examples of valid targets would be i960-rtems, m68k-coff,
    sh-elf, etc.
    Specifying just target instead of --target=target implies that the host
    defaults to target.

    Options specification

    Use options to override several configure time options for GCC. A list
    of supported options follows; configure --help may list other options,
    but those not listed below may not work and should not normally be used.



    I get

    xp2100:~/C:/gcc-3.3# dir
    ChangeLog config copying include libstdc++-v3
    missing
    MAINTAINERS config-ml.in copying.lib install libtool.m4
    mkdep
    Makefile.def config.guess faq install-sh ltcf-c.sh
    mkinstalldirs
    Makefile.in config.if faq.html libf2c ltcf-cxx.sh
    move-if-change
    Makefile.tpl config.sub fastjar libffi ltcf-gcj.sh
    readme
    boehm-gc configure gcc libiberty ltconfig
    symlink-tree
    bugs configure.in gnats libjava ltmain.sh
    ylwrap
    bugs.html contrib gnats.html libobjc maintainer-scripts
    zlib
    xp2100:~/C:/gcc-3.3# mkdir objdir
    xp2100:~/C:/gcc-3.3# cd objdir
    xp2100:~/C:/gcc-3.3/objdir# srcdir/configure
    bash: srcdir/configure: No such file or directory
     
    cowboyz, Jul 12, 2003
    #7
  8. cowboyz

    RecylerMan Guest

    cowboyz wrote:
    > "RecylerMan" <0.nz> wrote in message
    > news:beptv2$351$...
    >
    >>cowboyz wrote:
    >>
    >>>I almost think that I am getting this. I still need an IP address for
    >>>the satcard though....
    >>>
    >>>xp2100:~# /etc/init.d/skymedia restart
    >>>
    >>>Stopping sm200d: monitor interface logging module done.
    >>>Starting sm200d: module Initializing card logging interface done.
    >>>
    >>>xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/sm200dstats
    >>>
    >>>SM200D open failed
    >>>Lock QPSK Viterbi Frame FEC AGC Bit Error Rate kbps

    >
    > pps
    >
    >>---- ---- ------- ----- --- --- -------------- ----- ----

    >
    > -
    >
    >>>xp2100:~# /usr/local/sm200d-ihug-2.2.14-glibc/SkyData
    >>>
    >>>SkyData V.2.02 started. (C) 1999 Diego Picciani
    >>>E-Mail:
    >>>IPAddress not defined, but MACFilter = 0 in
    >>>/usr/local/sm200d-ihug-2.2.14-glibc/SkyData.ini
    >>>
    >>>xp2100:~#
    >>>
    >>>
    >>>The above is no IP defined.
    >>>
    >>>Then if I put in 192.168.0.1 then I get this.
    >>>
    >>>SkyData V.2.02 started. (C) 1999 Diego Picciani
    >>>E-Mail:
    >>>Sky_OpenSystem Error
    >>>xp2100:~#
    >>>
    >>>
    >>>The funny thing that I just don't get my head around is how can you set
    >>>an IP address for a device that hasn't been installed yet??
    >>>
    >>>Is there a device manager equivalent?
    >>>

    >>
    >>you have to supply an Ip address I think the command is
    >>#> ifconfig sm200d 192.168.0.xxx (an Ip in youre subnet)
    >>infact i loaded mine like this
    >>
    >>in the /ect/rc.d/rc.local
    >>
    >># Ihug Ultra Stff put in by coozerb:)
    >>/sbin/insmod -f /usr/local/sm200d/sm200d_lnx.o
    >>/sbin/ifconfig sm200d 192.168.2.2 &
    >>/usr/local/sm200d/SkyData &
    >>
    >>This way it is always there the real trick is to make the module even
    >>though I made mine I still had to use the -f swich to force it
    >>
    >>

    >
    >
    >
    > There is no mention of editing etc/rc.d/rc.local Could that be the same as
    > etc/init.d ?


    Ok I found it the most fool proff way fo geting the interface to work
    Its called Hacking:) the init.d should be a similar thing but would have
    to look at the system to find out what it is.
    >
    >
    > The following is a catch up post from linux.os. If you would like to shed
    > your thoughts on it?
    >
    >
    >
    >
    > Richard Adams wrote:
    >
    >>On Sat, 12 Jul 2003 18:35:08 +1200, cowboyz wrote:
    >>
    >>
    >>
    >>>I really don't even know what my question is.
    >>>I think I need to know what the IP address is of the satcard. How can I
    >>>find this out?

    >>
    >>
    >>/sbin/ifconfig
    >>However you are running before you can walk, just what type of satcard do
    >>you have,? DVB ?.
    >>

    >
    >
    > It is a tellemann DTP200d for use with NZ Ihug Ultra Satelite internet
    > service. The problem with running before I can walk is that I have used
    > windows systems for as long as I can remember and this is certainly a
    > new thing. However I need that satelite running cause without it I
    > only have 20k dialup and that is enought to lose my interest in Linux
    > all together. After all. without an internet connection a computer is
    > a doorstop.
    >
    >
    >>>I also need a file called make Where can I get this from? Is there a
    >>>website with a heap of command files on it that I can browse through.

    >>
    >>
    >>Install gcc.
    >>
    >>
    >>
    >>>I have the satcard thinking it is installed but can't open it. and it is
    >>>not logging anything.

    >>
    >>
    >>Things "have" to be configured before they can work (properly).
    >>
    >>If you choose to reply to this mail, please include;
    >>
    >>Linux distro,

    >
    >
    > LindowsOS3
    >
    >
    >
    >>kernel number,

    >
    >
    > I have searched and search through the help files and I'm buggered if I
    > can find this out. THis was one of my first thoughts that the driver I
    > have 2.2.17 is not compatible with the kernel I am using but I would
    > have thought it would give me a nice error saying kernel incompatible or
    > something like that.
    >
    >

    Sound like this is the cause of your problems I think lindows uses a
    newer Kernal say a 2.4.x
    A $> demesg | less command should let you know what kernal you are using.
    >
    >>make/model and chipset of the card in question.

    >
    >
    > Tellemann DTP200D
    >
    >
    >>We on this group cannot possably see what you use, its up to you to tell
    >>us the whole story to get a decent answer.
    >>

    >
    >
    > I know exactly where you are coming from. For years I have helped
    > people on the phone with windows systems one of the biggest problems is
    > getting them to ask the right questions for me to give them the answer
    > they are looking for. This is how I feel now but I really can't figure
    > out what my question is. I have gone through the readme files that
    > came with the drivers methodically step by step but still doesn't work.
    > The first set of drivers I downloaded from the tellemann website says
    > "error :make: not found" which I why I thought I needed a make command.
    >
    > The ones I am working on at the moment is from Ihugs website and they
    > are a little easy to work with cause everything seems more laid out but
    > still not luck.
    >
    > This is where i am at at the moment.
    >
    > I have set the values in usr/local/sky/skymedia and copied it to
    > /etc/init.d/ and run it with the start command and get this.
    >
    > xp2100:/etc/init.d# ./skymedia start
    > Starting sm200d: module Initializing card logging interface done.
    >
    > From Helpfile:
    > 12. Run the script to load the card: /etc/init.d/skymedia start
    > 13. Note that the module 'sm200_lnx' or 'sm200d_lnx' is now visible when
    > you do an lsmod
    >
    >
    > If I do a lsmod it does not list it.
    >
    > xp2100:/usr/local/sky# lsmod
    > Module Size Used by Tainted: PF
    > ppp_deflate 39456 0 (autoclean)
    > bsd_comp 4032 0 (autoclean)
    > ppp_async 6336 1 (autoclean)
    > ppp_generic 16076 3 (autoclean) [ppp_deflate bsd_comp
    > ppp_async]
    > slhc 4416 1 (autoclean) [ppp_generic]
    > lt_serial 18784 3 (autoclean)
    > lt_modem 479739 0 (autoclean) [lt_serial]
    > ipt_LOG 3168 1 (autoclean)
    > ipt_limit 960 4 (autoclean)
    > ipt_state 608 1 (autoclean)
    > ip_conntrack_ftp 3200 0 (unused)
    > ip_conntrack 12908 2 [ipt_state ip_conntrack_ftp]
    > iptable_filter 1728 1 (autoclean)
    > ip_tables 10400 4 [ipt_LOG ipt_limit ipt_state
    > iptable_filter]
    > autofs 8868 3 (autoclean)
    > lp 6368 0 (autoclean) (unused)
    > apm 9276 2 (autoclean)
    > pcmcia_core 38208 0
    > ehci-hcd 14240 0 (unused)
    > nls_iso8859-1 2848 1 (autoclean)
    > nls_cp437 4384 1 (autoclean)
    > serial 42304 0 (autoclean) (unused)
    > isa-pnp 27708 0 (autoclean) [serial]
    > md 56672 0 (autoclean) (unused)
    > NVdriver 1065536 10
    > sr_mod 13656 4
    > cdrom 27232 0 [sr_mod]
    > ide-scsi 7584 2
    > floppy 45888 0
    > sd_mod 10012 0 (unused)
    > scsi_mod 50092 3 [sr_mod ide-scsi sd_mod]
    > snd-via8233 5444 1
    > snd-pcm-oss 35460 0
    > usbmouse 1792 0 (unused)
    > snd-pcm 51232 0 [snd-via8233 snd-pcm-oss]
    > snd-timer 9024 0 [snd-pcm]
    > snd-ac97-codec 23792 0 [snd-via8233]
    > snd-mixer-oss 8704 1 [snd-pcm-oss]
    > printer 6752 0
    > snd 23400 0 [snd-via8233 snd-pcm-oss snd-pcm
    > snd-timer snd-ac97-codec snd-mixer-oss]
    > soundcore 3332 3 [snd]
    > 8139too 13472 1
    > mii 1056 0 [8139too]
    > usb-uhci 20964 0 (unused)
    > parport 21888 0 [lp]
    > keybdev 1664 0 (unused)
    > mousedev 3872 1
    > hid 18144 0 (unused)
    > input 3136 0 [usbmouse keybdev mousedev hid]
    > usbcore 54272 1 [ehci-hcd usbmouse printer snd
    > usb-uhci hid]
    > rtc 5916 0 (autoclean)
    > reiserfs 158160 1
    > ide-disk 9872 2
    > ide-probe-mod 8592 0
    > ide-mod 147872 2 [ide-scsi ide-disk ide-probe-mod]
    > xp2100:/usr/local/sky#
    >
    >
    > I had a look at a file called /usr/local/sky/sm200dload.sh which the
    > help file makes no mention of and it says:
    >
    > #!/bin/sh
    > module="sm200d_lnx.o"
    >
    > #enter installed directory
    > INSTALL_DIR=/usr/local/sky
    >
    > #echo "Bringing up skymedia interface"
    > # invoke rmmod with all arguments we got
    > #/sbin/rmmod $INSTALL_DIR/$module
    >
    > # invoke insmod with all arguments we got
    > /sbin/insmod $INSTALL_DIR/$module
    >
    >
    >
    > So I thought I would do it manually and typed:
    >
    > xp2100:/usr/local/sky# /sbin/insmod /usr/local/sky/sm200d_lnx.o
    >
    > Floating point exception
    >
    > xp2100:/usr/local/sky#
    >
    >
    >
    >
    > Is that enough info. I certainly appreciate any light you can shed on this.
    >
    > Oh yeah. and this
    >
    > xp2100:/usr/local/sky# /sbin/ifconfig
    > eth0 Link encap:Ethernet HWaddr 00:05:1C:0B:CD:4D
    > inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    > RX packets:276 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:100
    > RX bytes:44251 (43.2 KiB) TX bytes:10015 (9.7 KiB)
    > Interrupt:11 Base address:0x9d00
    >
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > UP LOOPBACK RUNNING MTU:16436 Metric:1
    > RX packets:22 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:0
    > RX bytes:901 (901.0 b) TX bytes:901 (901.0 b)
    >
    > ppp0 Link encap:point-to-Point Protocol
    > inet addr:203.173.247.30 P-t-P:192.168.251.44
    > Mask:255.255.255.255
    > UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1514 Metric:1
    > RX packets:686 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:792 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:3
    > RX bytes:348634 (340.4 KiB) TX bytes:78441 (76.6 KiB)
    >
    > xp2100:/usr/local/sky#
    >
    >
    > eth0 would be my home network?
    >
    > lo would be local host?
    >
    > ppp0 would be my current dialup connection?
    >
    >
    >
    >
    >



    --
    RecylerMan ICQ 22245595


    Mail to :- l i n u x u s r AT i h u g DOT c o DOT n z
     
    RecylerMan, Jul 13, 2003
    #8
  9. cowboyz

    RecylerMan Guest

    cowboyz wrote:
    > 8 1/2 hours into it and I have not installed a single thing or changed
    > anything from the default lindowsOS install.
    >
    > I am thinking my luck might increase with Mandrake. Has anyone in the
    > Hamilton/Te awamutu area got a mandrake cd I can copy. I can't download it
    > cause my 2G cap won't allow it so I would have to download it over a couple
    > of months.
    >
    > anyone can help me out here can you mail me?
    >
    >
    >
    >
    >

    Got mandrake or even red hat

    --
    RecylerMan ICQ 22245595


    Mail to :- l i n u x u s r AT i h u g DOT c o DOT n z
     
    RecylerMan, Jul 13, 2003
    #9
  10. cowboyz

    Nic Guest

    On Sat, 12 Jul 2003 18:12:12 +1200, cowboyz wrote:

    > xp2100:/usr/local/sm200d-ihug-2.2.14-glibc# lsmod

    ^^^^^^

    [snip lsmod output]

    > Well I know the card is seated properly cause I can restart to windows
    > and it will work fine. I know the module is not loading correctly
    > cause it is not listed above as being so, So this is the end of the
    > manual. What is the next step????


    You're trying to load drivers for a 2.2.14 on what is, from the lsmod
    listing you supplied, a recent 2.4.x kernel. This is not going to work -
    ever.

    It's unlikely any of the pre-built drivers have been tested with
    precisely the kernel Lindows is using, but you might get lucky - look
    for a version of the drivers as close as possible to the output you get
    when you run 'uname -r' (which tells you the kernel version you're
    running).

    HTH,
    Nic.

    fxl ng jvooyr qbg arg
     
    Nic, Jul 13, 2003
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Eberhard Funke

    Sandisk Ultra II, "new" Ultra, "original " Ultra

    Eberhard Funke, Jan 13, 2004, in forum: Digital Photography
    Replies:
    0
    Views:
    534
    Eberhard Funke
    Jan 13, 2004
  2. Craig Whitmore

    Re: LindowsOS skymedia (ihug Ultra) install

    Craig Whitmore, Jul 12, 2003, in forum: NZ Computing
    Replies:
    1
    Views:
    671
    cowboyz
    Jul 12, 2003
  3. Oedipus Rex

    WTD: LindowsOS

    Oedipus Rex, Oct 18, 2003, in forum: NZ Computing
    Replies:
    23
    Views:
    722
    Julius Caesar
    Oct 21, 2003
  4. Peter Huebner

    nVidia chipset mobo, Skymedia 200d card and Win98

    Peter Huebner, Dec 13, 2003, in forum: NZ Computing
    Replies:
    7
    Views:
    683
    Steve
    Dec 14, 2003
  5. cowboyz
    Replies:
    14
    Views:
    875
    cowboyz
    Nov 25, 2004
Loading...

Share This Page