Re: html - font problem

Discussion in 'NZ Computing' started by Lawrence D'Oliveiro, Jan 12, 2011.

  1. In message <igjkck$iev$>, Richard wrote:

    > You are sending the page with the wrong encoding


    That <meta...> tag for setting the encoding looks wrong. It should be
    something like “<META HTTP-EQUIV="charset" CONTENT="utf-8">â€.

    Of course, writing the character as “&eacute;†should also solve the
    problem.
    Lawrence D'Oliveiro, Jan 12, 2011
    #1
    1. Advertising

  2. In message <>, Reg wrote:

    > Somehow I have fixed it by copying the original source code from the
    > sitepoint page again and putting it into a new file.


    My guess is, the way you originally copied the text, the UTF-8-encoded e-
    acute somehow got converted into some other encoding (most likely
    Windows-1252, from my impressions of how Windows works—or doesn’t). So if
    you tried serving it up as UTF-8, no wonder it looked wrong.
    Lawrence D'Oliveiro, Jan 12, 2011
    #2
    1. Advertising

  3. Lawrence D'Oliveiro

    Ralph Fox Guest

    On Wed, 12 Jan 2011 21:00:51 +1300, in message <igjn3j$m5h$>
    Lawrence D'Oliveiro wrote:

    > In message <igjkck$iev$>, Richard wrote:
    >
    > > You are sending the page with the wrong encoding

    >
    > That <meta...> tag for setting the encoding looks wrong. It should be
    > something like “<META HTTP-EQUIV="charset" CONTENT="utf-8">”.



    I think you mean

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    Even so, if the web server were also sending a (different) charset in the
    HTTP response headers, then the web server's charset would override this
    meta tag. See http://www.w3.org/TR/REC-html40/charset.html#h-5.2.2


    > Of course, writing the character as “&eacute;” should also solve the
    > problem.



    --
    Regards
    Ralph
    Ralph Fox, Jan 12, 2011
    #3
  4. In message <>, Ralph Fox wrote:

    > I think you mean
    >
    > <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />


    Sorry, yeah. But without the “/†at the end. :)
    Lawrence D'Oliveiro, Jan 12, 2011
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Martin de Groot
    Replies:
    2
    Views:
    6,161
    Harrison
    Nov 19, 2003
  2. skidaddy

    Font Problem

    skidaddy, Feb 27, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    463
    TheDailySpank
    Feb 28, 2004
  3. Lookout

    Windows XP explorer font and font size

    Lookout, Jun 4, 2006, in forum: Computer Support
    Replies:
    0
    Views:
    607
    Lookout
    Jun 4, 2006
  4. andreasbell

    creating font with fixed font size

    andreasbell, Aug 30, 2010, in forum: Software
    Replies:
    1
    Views:
    1,157
    Hotspot
    Aug 30, 2010
  5. Monima
    Replies:
    0
    Views:
    1,743
    Monima
    Dec 14, 2010
Loading...

Share This Page