Re: File Association

Discussion in 'Firefox' started by Tom Linden, Jul 18, 2008.

  1. Tom Linden

    Tom Linden Guest

    On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple Hippo
    <> wrote:

    > Tom Linden wrote:
    >> Firefox/2.0.0.16 on XP
    >> I have file extension .pli associated with Xemacs. When I click
    >> on such a file it opens it directly in the same tab as a text file.
    >> when I click on a file with extension .sdl it pops a window asking
    >> open with and I can select the program.
    >> Why doesn't the PL/I launch Xemacs checking Folder Options under the
    >> control panel it is properly set or launch the Open with window?
    >> Tom

    >
    > within FF, click on Tools, Options, Content, Manage button for File
    > Types, find anything there for .pli and either delete it or try and
    > change the setting. You may have to restart FF for this to work. Did it?
    >

    That file type is not listed there and I didn't see any option to add a
    new file type.

    --
    PL/I for OpenVMS
    www.kednos.com
     
    Tom Linden, Jul 18, 2008
    #1
    1. Advertising

  2. Tom Linden

    Tom Linden Guest

    On Fri, 18 Jul 2008 11:31:42 -0700, Peter Potamus the Purple Hippo
    <> wrote:

    > Tom Linden wrote:
    >> On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple Hippo
    >> <> wrote:
    >>
    >>> Tom Linden wrote:
    >>>> Firefox/2.0.0.16 on XP
    >>>> I have file extension .pli associated with Xemacs. When I click
    >>>> on such a file it opens it directly in the same tab as a text file.
    >>>> when I click on a file with extension .sdl it pops a window asking
    >>>> open with and I can select the program.
    >>>> Why doesn't the PL/I launch Xemacs checking Folder Options under the
    >>>> control panel it is properly set or launch the Open with window?
    >>>> Tom
    >>>
    >>> within FF, click on Tools, Options, Content, Manage button for File
    >>> Types, find anything there for .pli and either delete it or try and
    >>> change the setting. You may have to restart FF for this to work. Did
    >>> it?
    >>>

    >> That file type is not listed there and I didn't see any option to add a
    >> new file type.
    >>

    >
    > thats one of the downsides of FF, you can't add. The only other option
    > I can say is to reinstall xemacs.
    >

    I tried to find the file associations. I haven't checked the registry
    yet, but that must be where they are.


    --
    PL/I for OpenVMS
    www.kednos.com
     
    Tom Linden, Jul 18, 2008
    #2
    1. Advertising

  3. Tom Linden

    Dan Gall Guest

    Tom Linden wrote:
    > On Fri, 18 Jul 2008 11:31:42 -0700, Peter Potamus the Purple Hippo
    > <> wrote:
    >
    >> Tom Linden wrote:
    >>> On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple Hippo
    >>> <> wrote:
    >>>
    >>>> Tom Linden wrote:
    >>>>> Firefox/2.0.0.16 on XP
    >>>>> I have file extension .pli associated with Xemacs. When I click
    >>>>> on such a file it opens it directly in the same tab as a text file.
    >>>>> when I click on a file with extension .sdl it pops a window asking
    >>>>> open with and I can select the program.
    >>>>> Why doesn't the PL/I launch Xemacs checking Folder Options under
    >>>>> the control panel it is properly set or launch the Open with window?
    >>>>> Tom
    >>>>
    >>>> within FF, click on Tools, Options, Content, Manage button for File
    >>>> Types, find anything there for .pli and either delete it or try and
    >>>> change the setting. You may have to restart FF for this to work.
    >>>> Did it?
    >>>>
    >>> That file type is not listed there and I didn't see any option to
    >>> add a new file type.
    >>>

    >>
    >> thats one of the downsides of FF, you can't add. The only other
    >> option I can say is to reinstall xemacs.
    >>

    > I tried to find the file associations. I haven't checked the registry
    > yet, but that must be where they are.
    >
    >


    To Add a file asscociation is simple.

    Find a file of the type you want to add. Download it, tell Firefox what
    to do with it, check the remember box. (do this for other files of this
    type in future)

    That's it, a file association will now be listed for the file type.
     
    Dan Gall, Jul 19, 2008
    #3
  4. Tom Linden

    Tom Linden Guest

    On Fri, 18 Jul 2008 16:54:23 -0700, Dan Gall <> wrote:

    > Tom Linden wrote:
    >> On Fri, 18 Jul 2008 11:31:42 -0700, Peter Potamus the Purple Hippo
    >> <> wrote:
    >>
    >>> Tom Linden wrote:
    >>>> On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple Hippo
    >>>> <> wrote:
    >>>>
    >>>>> Tom Linden wrote:
    >>>>>> Firefox/2.0.0.16 on XP
    >>>>>> I have file extension .pli associated with Xemacs. When I click
    >>>>>> on such a file it opens it directly in the same tab as a text file.
    >>>>>> when I click on a file with extension .sdl it pops a window asking
    >>>>>> open with and I can select the program.
    >>>>>> Why doesn't the PL/I launch Xemacs checking Folder Options under
    >>>>>> the control panel it is properly set or launch the Open with window?
    >>>>>> Tom
    >>>>>
    >>>>> within FF, click on Tools, Options, Content, Manage button for File
    >>>>> Types, find anything there for .pli and either delete it or try and
    >>>>> change the setting. You may have to restart FF for this to work.
    >>>>> Did it?
    >>>>>
    >>>> That file type is not listed there and I didn't see any option to add
    >>>> a new file type.
    >>>>
    >>>
    >>> thats one of the downsides of FF, you can't add. The only other
    >>> option I can say is to reinstall xemacs.
    >>>

    >> I tried to find the file associations. I haven't checked the registry
    >> yet, but that must be where they are.
    >>
    >>

    >
    > To Add a file asscociation is simple.
    >
    > Find a file of the type you want to add. Download it, tell Firefox what
    > to do with it, check the remember box. (do this for other files of this
    > type in future)
    >
    > That's it, a file association will now be listed for the file type.


    Two problems with that,
    1. The remember box is not active so can't check the box
    2. file type extension .pli doesn't pop the window opens directly as text




    --
    PL/I for OpenVMS
    www.kednos.com
     
    Tom Linden, Jul 19, 2008
    #4
  5. Tom Linden

    Dan Gall Guest

    Tom Linden wrote:
    > On Fri, 18 Jul 2008 16:54:23 -0700, Dan Gall <> wrote:
    >
    >> Tom Linden wrote:
    >>> On Fri, 18 Jul 2008 11:31:42 -0700, Peter Potamus the Purple Hippo
    >>> <> wrote:
    >>>
    >>>> Tom Linden wrote:
    >>>>> On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple Hippo
    >>>>> <> wrote:
    >>>>>
    >>>>>> Tom Linden wrote:
    >>>>>>> Firefox/2.0.0.16 on XP
    >>>>>>> I have file extension .pli associated with Xemacs. When I click
    >>>>>>> on such a file it opens it directly in the same tab as a text file.
    >>>>>>> when I click on a file with extension .sdl it pops a window asking
    >>>>>>> open with and I can select the program.
    >>>>>>> Why doesn't the PL/I launch Xemacs checking Folder Options
    >>>>>>> under the control panel it is properly set or launch the Open
    >>>>>>> with window?
    >>>>>>> Tom
    >>>>>>
    >>>>>> within FF, click on Tools, Options, Content, Manage button for
    >>>>>> File Types, find anything there for .pli and either delete it or
    >>>>>> try and change the setting. You may have to restart FF for this
    >>>>>> to work. Did it?
    >>>>>>
    >>>>> That file type is not listed there and I didn't see any option to
    >>>>> add a new file type.
    >>>>>
    >>>>
    >>>> thats one of the downsides of FF, you can't add. The only other
    >>>> option I can say is to reinstall xemacs.
    >>>>
    >>> I tried to find the file associations. I haven't checked the
    >>> registry yet, but that must be where they are.
    >>>
    >>>

    >>
    >> To Add a file asscociation is simple.
    >>
    >> Find a file of the type you want to add. Download it, tell Firefox
    >> what to do with it, check the remember box. (do this for other files
    >> of this type in future)
    >>
    >> That's it, a file association will now be listed for the file type.

    >
    > Two problems with that,
    > 1. The remember box is not active so can't check the box
    > 2. file type extension .pli doesn't pop the window opens directly as
    > text
    >
    >
    >
    >

    pli is a file extension associated with Oracle 7 Data Description
    OR
    pli is a file extension asscociated with PL/1 programming language source


    There is no MIME type for this type of file.
    Firefox uses the MIME type to define a file and 'assign' it to another
    program. Without a MIME type, it is presented as (usually) a
    "application/octet-stream"
    which can be ANYTHING from a text file to a virus to an exe program.
    There is no possibility of assigning a program to handle this mime type
    (because it could be anything).

    Without a valid MIME type, Firefox will not assign the file to a program
    because it has no idea of which programs handle it.

    The only MIME types within the "pl" field are .pl which is text/plain
    or text/x-script.perl

    Simply download the file to your desktop and open it with the applicable
    program from there.
     
    Dan Gall, Jul 21, 2008
    #5
  6. Tom Linden

    Dan Gall Guest

    Dan Gall wrote:
    > Tom Linden wrote:
    >> On Fri, 18 Jul 2008 16:54:23 -0700, Dan Gall <> wrote:
    >>
    >>> Tom Linden wrote:
    >>>> On Fri, 18 Jul 2008 11:31:42 -0700, Peter Potamus the Purple Hippo
    >>>> <> wrote:
    >>>>
    >>>>> Tom Linden wrote:
    >>>>>> On Fri, 18 Jul 2008 10:45:55 -0700, Peter Potamus the Purple
    >>>>>> Hippo <> wrote:
    >>>>>>
    >>>>>>> Tom Linden wrote:
    >>>>>>>> Firefox/2.0.0.16 on XP
    >>>>>>>> I have file extension .pli associated with Xemacs. When I click
    >>>>>>>> on such a file it opens it directly in the same tab as a text
    >>>>>>>> file.
    >>>>>>>> when I click on a file with extension .sdl it pops a window
    >>>>>>>> asking
    >>>>>>>> open with and I can select the program.
    >>>>>>>> Why doesn't the PL/I launch Xemacs checking Folder Options
    >>>>>>>> under the control panel it is properly set or launch the Open
    >>>>>>>> with window?
    >>>>>>>> Tom
    >>>>>>>
    >>>>>>> within FF, click on Tools, Options, Content, Manage button for
    >>>>>>> File Types, find anything there for .pli and either delete it or
    >>>>>>> try and change the setting. You may have to restart FF for this
    >>>>>>> to work. Did it?
    >>>>>>>
    >>>>>> That file type is not listed there and I didn't see any option to
    >>>>>> add a new file type.
    >>>>>>
    >>>>>
    >>>>> thats one of the downsides of FF, you can't add. The only other
    >>>>> option I can say is to reinstall xemacs.
    >>>>>
    >>>> I tried to find the file associations. I haven't checked the
    >>>> registry yet, but that must be where they are.
    >>>>
    >>>>
    >>>
    >>> To Add a file asscociation is simple.
    >>>
    >>> Find a file of the type you want to add. Download it, tell Firefox
    >>> what to do with it, check the remember box. (do this for other files
    >>> of this type in future)
    >>>
    >>> That's it, a file association will now be listed for the file type.

    >>
    >> Two problems with that,
    >> 1. The remember box is not active so can't check the box
    >> 2. file type extension .pli doesn't pop the window opens directly as
    >> text
    >>
    >>
    >>
    >>

    > pli is a file extension associated with Oracle 7 Data Description
    > OR
    > pli is a file extension asscociated with PL/1 programming language source
    >
    > There is no MIME type for this type of file.
    > Firefox uses the MIME type to define a file and 'assign' it to another
    > program. Without a MIME type, it is presented as (usually) a
    > "application/octet-stream"
    > which can be ANYTHING from a text file to a virus to an exe program.
    > There is no possibility of assigning a program to handle this mime
    > type (because it could be anything).
    >
    > Without a valid MIME type, Firefox will not assign the file to a
    > program because it has no idea of which programs handle it.
    >
    > The only MIME types within the "pl" field are .pl which is
    > text/plain or text/x-script.perl
    >
    > Simply download the file to your desktop and open it with the
    > applicable program from there.

    sorry, there is one other in the 'pl' field... .plx
    application/x-pixclscript
     
    Dan Gall, Jul 21, 2008
    #6
  7. Ed Mullen wrote:
    > An alternative is to use SeaMonkey to create the file. SM has a user
    > interface for this whereas FF does not. You could then copy the file
    > into your FF profile.


    thats one of the reason I've stuck with SM.

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email
    help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Jul 21, 2008
    #7
  8. Ed Mullen wrote:
    > Peter Potamus the Purple Hippo wrote:
    >> Ed Mullen wrote:
    >>> An alternative is to use SeaMonkey to create the file. SM has a user
    >>> interface for this whereas FF does not. You could then copy the file
    >>> into your FF profile.

    >>
    >> thats one of the reason I've stuck with SM.
    >>

    >
    > Ditto. They took too much out of FF for my liking.
    >


    and I'm concerned they may have done the same with SM2.

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email
    help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Jul 21, 2008
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Simian Dyson

    Weird file association

    Simian Dyson, Aug 23, 2005, in forum: Firefox
    Replies:
    0
    Views:
    423
    Simian Dyson
    Aug 23, 2005
  2. Hugo
    Replies:
    0
    Views:
    456
  3. k

    Stange mp3 file association issue...

    k, Aug 6, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    528
    ┬░Mike┬░
    Aug 7, 2003
  4. Boomer

    Re: File Association

    Boomer, Aug 11, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    409
    Boomer
    Aug 11, 2003
  5. Boomer

    Re: File Association

    Boomer, Aug 11, 2003, in forum: Computer Support
    Replies:
    3
    Views:
    475
    slumpy
    Aug 11, 2003
Loading...

Share This Page