Re: cisco1811: mac addresses from vlan interfaces problem

Discussion in 'Cisco' started by Merv, Nov 25, 2006.

  1. Merv

    Merv Guest

    What version of IOS is been used ?

    Post output of show version

    Did you try:

    int fa2
    no switchport
    exit
     
    Merv, Nov 25, 2006
    #1
    1. Advertising

  2. > What version of IOS is been used ?
    >
    > Post output of show version
    >
    > Did you try:
    >
    > int fa2
    > no switchport
    > exit


    Cisco IOS Software, C181X Software (C181X-ADVIPSERVICESK9-M), Version
    12.4(6)T3, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Fri 21-Jul-06 15:17 by kellythw

    ROM: System Bootstrap, Version 12.3(8r)YH8, RELEASE SOFTWARE (fc2)

    c1811-turaevo uptime is 4 days, 2 hours, 5 minutes
    System returned to ROM by power-on
    System image file is "flash:c181x-advipservicesk9-mz.124-6.T3.bin"
    ---------------
    I'm not sure how no switchport helps? I try to change MAC on vlan
    interface.
    Well, anyway I tried 'no switchport' but it did not help. Just
    disconnect fa2 from vlan2.

    --
    Sem.
     
    Sergey Matveychuk, Nov 25, 2006
    #2
    1. Advertising

  3. Merv

    Merv Guest

    Perhaps can be acccomplished using HSRP

    interface Vlan99
    ip address 99.99.99.98 255.255.255.0
    standby ip 99.99.99.99
    standby 99 mac-address aaaa.aaaa.aaaa
    end
     
    Merv, Nov 25, 2006
    #3
  4. Merv

    Guest

    Merv wrote:
    > Perhaps can be acccomplished using HSRP
    >
    > interface Vlan99
    > ip address 99.99.99.98 255.255.255.0
    > standby ip 99.99.99.99
    > standby 99 mac-address aaaa.aaaa.aaaa
    > end


    So it does!

    #sh int vlan1 | inc rotocol|bia
    Vlan1 is up, line protocol is up
    Hardware is EtherSVI, address is 0019.2f48.xx60 (bia 0019.2f48.xx60)
    #sh int gi 0/0 | inc rotocol|bia
    GigabitEthernet0/0 is up, line protocol is up
    Hardware is BCM1125 Internal MAC, address is 0019.2f48.xx60 (bia
    0019.2f48.xx60)

    Thing is, this does not usually matter, it is normal
    for example for Sun workstations to use the same mac
    on all interfaces, there are millions out there.

    Since a Cisco router will not normally let you put the same
    IP subnet on more than one interface the two interfaces
    never "see" each other.

    You can also do this:-

    interface FastEthernet1/5
    description
    no switchport
    ip address xxx.xxx.98.65 255.255.255.224

    In this config the ports get their own individual macs.

    FastEthernet1/4 is up, line protocol is up
    Hardware is Fast Ethernet, address is 0018.1926.xxbe (bia
    0018.1926.xxbe)
    FastEthernet1/5 is up, line protocol is up
    Hardware is Fast Ethernet, address is 0018.1926.xxbf (bia
    0018.1926.xxbf)

    This is a NM-16ESW in a 3845.

    Why do you think that this is something to worry about?
     
    , Nov 25, 2006
    #4
  5. > Perhaps can be acccomplished using HSRP
    >
    > interface Vlan99
    > ip address 99.99.99.98 255.255.255.0
    > standby ip 99.99.99.99
    > standby 99 mac-address aaaa.aaaa.aaaa
    > end


    Great! Thanks! It works.

    --
    Sem.
     
    Sergey Matveychuk, Nov 27, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Patrick
    Replies:
    0
    Views:
    890
    Patrick
    Jul 25, 2003
  2. Bill F
    Replies:
    0
    Views:
    597
    Bill F
    Sep 17, 2004
  3. Bill F
    Replies:
    1
    Views:
    1,785
    Walter Roberson
    Sep 17, 2004
  4. Frank L.
    Replies:
    0
    Views:
    942
    Frank L.
    Jun 28, 2006
  5. pfisterfarm
    Replies:
    3
    Views:
    933
    pfisterfarm
    Jan 27, 2010
Loading...

Share This Page