Re: Changing icon for AVI?

Discussion in 'Computer Support' started by Terry Pinnell, Feb 15, 2008.

  1. John <> wrote:

    >Terry Pinnell wrote:
    >> Somehow VLC player took over the file association AVI. I managed to
    >> change that back to VirtualDub, but the VLC icon is still shown
    >> against all AVI files. And the File Types list still refers to VLC as
    >> the default program for this type. Even though d-clicking an AVI does
    >> now open it in VirtualDub.
    >>
    >> I couldn't find any settings in VLC itself to change file types.
    >>
    >> Anyone have any suggestions please?
    >>

    >Hi Terry,
    >
    >Open up Explorer, then click on Tools, then folder options. Click on the
    >file types tab at the top, then scroll down to AVI. files. Highlight it,
    >then click on the change button and choose what program you would like
    >to open this type of file.
    >
    >John.


    Thanks John, but I had tried that without success. I still have the
    VLC icon. Here's a screenshot showing what I see in File Types, and
    the Change dialog.
    http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg

    Obviously, somehow I need to convince XP that VLC is NOT the default
    for AVI! But how? It's no big deal, but it irritates me ;-)

    --
    Terry, East Grinstead, UK
    Terry Pinnell, Feb 15, 2008
    #1
    1. Advertising

  2. Terry Pinnell

    Rôgêr Guest

    Terry Pinnell wrote:
    > John <> wrote:
    >
    >> Terry Pinnell wrote:
    >>> Somehow VLC player took over the file association AVI. I managed to
    >>> change that back to VirtualDub, but the VLC icon is still shown
    >>> against all AVI files. And the File Types list still refers to VLC as
    >>> the default program for this type. Even though d-clicking an AVI does
    >>> now open it in VirtualDub.
    >>>
    >>> I couldn't find any settings in VLC itself to change file types.
    >>>
    >>> Anyone have any suggestions please?
    >>>

    >> Hi Terry,
    >>
    >> Open up Explorer, then click on Tools, then folder options. Click on the
    >> file types tab at the top, then scroll down to AVI. files. Highlight it,
    >> then click on the change button and choose what program you would like
    >> to open this type of file.
    >>
    >> John.

    >
    > Thanks John, but I had tried that without success. I still have the
    > VLC icon. Here's a screenshot showing what I see in File Types, and
    > the Change dialog.
    > http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >
    > Obviously, somehow I need to convince XP that VLC is NOT the default
    > for AVI! But how? It's no big deal, but it irritates me ;-)


    Try clicking the Browse button and surf to whatever program you want to
    use and select that. If there an "always use" box, check that.
    Rôgêr, Feb 15, 2008
    #2
    1. Advertising

  3. Rôgêr <> wrote:

    >Terry Pinnell wrote:
    >> John <> wrote:
    >>
    >>> Terry Pinnell wrote:
    >>>> Somehow VLC player took over the file association AVI. I managed to
    >>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>> against all AVI files. And the File Types list still refers to VLC as
    >>>> the default program for this type. Even though d-clicking an AVI does
    >>>> now open it in VirtualDub.
    >>>>
    >>>> I couldn't find any settings in VLC itself to change file types.
    >>>>
    >>>> Anyone have any suggestions please?
    >>>>
    >>> Hi Terry,
    >>>
    >>> Open up Explorer, then click on Tools, then folder options. Click on the
    >>> file types tab at the top, then scroll down to AVI. files. Highlight it,
    >>> then click on the change button and choose what program you would like
    >>> to open this type of file.
    >>>
    >>> John.

    >>
    >> Thanks John, but I had tried that without success. I still have the
    >> VLC icon. Here's a screenshot showing what I see in File Types, and
    >> the Change dialog.
    >> http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>
    >> Obviously, somehow I need to convince XP that VLC is NOT the default
    >> for AVI! But how? It's no big deal, but it irritates me ;-)

    >
    >Try clicking the Browse button and surf to whatever program you want to
    >use and select that. If there an "always use" box, check that.


    Thanks Roger, but already tried that too. Whether I select VirtualDub
    from the list already present (see screenshot), or after browsing to
    the executable itself, it doesn't stick. Icons in folders are still
    VLC, and on re-opening File Types and clicking Change I still see VLC
    is the default!

    --
    Terry, East Grinstead, UK
    Terry Pinnell, Feb 15, 2008
    #3
  4. Terry Pinnell

    Charles May Guest

    Have you tried checking the options for the associations it places on
    filetypes for each viewer? I would think you could select .avi in virtual
    dubs options and deselect it in VLC.

    I don't have either installed here but I will check when I get to another
    machine.
    "Terry Pinnell" <> wrote in message
    news:...
    > Rôgêr <> wrote:
    >
    >>Terry Pinnell wrote:
    >>> John <> wrote:
    >>>
    >>>> Terry Pinnell wrote:
    >>>>> Somehow VLC player took over the file association AVI. I managed to
    >>>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>>> against all AVI files. And the File Types list still refers to VLC as
    >>>>> the default program for this type. Even though d-clicking an AVI does
    >>>>> now open it in VirtualDub.
    >>>>>
    >>>>> I couldn't find any settings in VLC itself to change file types.
    >>>>>
    >>>>> Anyone have any suggestions please?
    >>>>>
    >>>> Hi Terry,
    >>>>
    >>>> Open up Explorer, then click on Tools, then folder options. Click on
    >>>> the
    >>>> file types tab at the top, then scroll down to AVI. files. Highlight
    >>>> it,
    >>>> then click on the change button and choose what program you would like
    >>>> to open this type of file.
    >>>>
    >>>> John.
    >>>
    >>> Thanks John, but I had tried that without success. I still have the
    >>> VLC icon. Here's a screenshot showing what I see in File Types, and
    >>> the Change dialog.
    >>> http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>>
    >>> Obviously, somehow I need to convince XP that VLC is NOT the default
    >>> for AVI! But how? It's no big deal, but it irritates me ;-)

    >>
    >>Try clicking the Browse button and surf to whatever program you want to
    >>use and select that. If there an "always use" box, check that.

    >
    > Thanks Roger, but already tried that too. Whether I select VirtualDub
    > from the list already present (see screenshot), or after browsing to
    > the executable itself, it doesn't stick. Icons in folders are still
    > VLC, and on re-opening File Types and clicking Change I still see VLC
    > is the default!
    >
    > --
    > Terry, East Grinstead, UK
    Charles May, Feb 15, 2008
    #4
  5. Terry Pinnell

    Charles May Guest

    Try this:
    Go to the avi file type. Click on the restore button to change it back to
    VLC
    The restore button should change to Advanced
    Click Advanced and browse to the VirtualDub and select it that way.

    Charlie
    "Terry Pinnell" <> wrote in message
    news:...
    > Rôgêr <> wrote:
    >
    >>Terry Pinnell wrote:
    >>> John <> wrote:
    >>>
    >>>> Terry Pinnell wrote:
    >>>>> Somehow VLC player took over the file association AVI. I managed to
    >>>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>>> against all AVI files. And the File Types list still refers to VLC as
    >>>>> the default program for this type. Even though d-clicking an AVI does
    >>>>> now open it in VirtualDub.
    >>>>>
    >>>>> I couldn't find any settings in VLC itself to change file types.
    >>>>>
    >>>>> Anyone have any suggestions please?
    >>>>>
    >>>> Hi Terry,
    >>>>
    >>>> Open up Explorer, then click on Tools, then folder options. Click on
    >>>> the
    >>>> file types tab at the top, then scroll down to AVI. files. Highlight
    >>>> it,
    >>>> then click on the change button and choose what program you would like
    >>>> to open this type of file.
    >>>>
    >>>> John.
    >>>
    >>> Thanks John, but I had tried that without success. I still have the
    >>> VLC icon. Here's a screenshot showing what I see in File Types, and
    >>> the Change dialog.
    >>> http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>>
    >>> Obviously, somehow I need to convince XP that VLC is NOT the default
    >>> for AVI! But how? It's no big deal, but it irritates me ;-)

    >>
    >>Try clicking the Browse button and surf to whatever program you want to
    >>use and select that. If there an "always use" box, check that.

    >
    > Thanks Roger, but already tried that too. Whether I select VirtualDub
    > from the list already present (see screenshot), or after browsing to
    > the executable itself, it doesn't stick. Icons in folders are still
    > VLC, and on re-opening File Types and clicking Change I still see VLC
    > is the default!
    >
    > --
    > Terry, East Grinstead, UK
    Charles May, Feb 15, 2008
    #5
  6. Terry Pinnell

    Charles May Guest

    Sorry, left out a few steps.
    Click on Advanced.
    Select Open and then click to edit it
    Then browse to virtualdubs exe file
    "Charles May" <> wrote in message
    news:mhgtj.4372$%x3.3746@trndny06...
    > Try this:
    > Go to the avi file type. Click on the restore button to change it back to
    > VLC
    > The restore button should change to Advanced
    > Click Advanced and browse to the VirtualDub and select it that way.
    >
    > Charlie
    > "Terry Pinnell" <> wrote in message
    > news:...
    >> Rôgêr <> wrote:
    >>
    >>>Terry Pinnell wrote:
    >>>> John <> wrote:
    >>>>
    >>>>> Terry Pinnell wrote:
    >>>>>> Somehow VLC player took over the file association AVI. I managed to
    >>>>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>>>> against all AVI files. And the File Types list still refers to VLC as
    >>>>>> the default program for this type. Even though d-clicking an AVI does
    >>>>>> now open it in VirtualDub.
    >>>>>>
    >>>>>> I couldn't find any settings in VLC itself to change file types.
    >>>>>>
    >>>>>> Anyone have any suggestions please?
    >>>>>>
    >>>>> Hi Terry,
    >>>>>
    >>>>> Open up Explorer, then click on Tools, then folder options. Click on
    >>>>> the
    >>>>> file types tab at the top, then scroll down to AVI. files. Highlight
    >>>>> it,
    >>>>> then click on the change button and choose what program you would like
    >>>>> to open this type of file.
    >>>>>
    >>>>> John.
    >>>>
    >>>> Thanks John, but I had tried that without success. I still have the
    >>>> VLC icon. Here's a screenshot showing what I see in File Types, and
    >>>> the Change dialog.
    >>>> http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>>>
    >>>> Obviously, somehow I need to convince XP that VLC is NOT the default
    >>>> for AVI! But how? It's no big deal, but it irritates me ;-)
    >>>
    >>>Try clicking the Browse button and surf to whatever program you want to
    >>>use and select that. If there an "always use" box, check that.

    >>
    >> Thanks Roger, but already tried that too. Whether I select VirtualDub
    >> from the list already present (see screenshot), or after browsing to
    >> the executable itself, it doesn't stick. Icons in folders are still
    >> VLC, and on re-opening File Types and clicking Change I still see VLC
    >> is the default!
    >>
    >> --
    >> Terry, East Grinstead, UK

    >
    >
    Charles May, Feb 15, 2008
    #6
  7. "Charles May" <> wrote:

    >Sorry, left out a few steps.
    >Click on Advanced.
    >Select Open and then click to edit it
    >Then browse to virtualdubs exe file
    >"Charles May" <> wrote in message
    >news:mhgtj.4372$%x3.3746@trndny06...
    >> Try this:
    >> Go to the avi file type. Click on the restore button to change it back to
    >> VLC
    >> The restore button should change to Advanced
    >> Click Advanced and browse to the VirtualDub and select it that way.
    >>
    >> Charlie
    >> "Terry Pinnell" <> wrote in message
    >> news:...
    >>> Rôgêr <> wrote:
    >>>
    >>>>Terry Pinnell wrote:
    >>>>> John <> wrote:
    >>>>>
    >>>>>> Terry Pinnell wrote:
    >>>>>>> Somehow VLC player took over the file association AVI. I managed to
    >>>>>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>>>>> against all AVI files. And the File Types list still refers to VLC as
    >>>>>>> the default program for this type. Even though d-clicking an AVI does
    >>>>>>> now open it in VirtualDub.
    >>>>>>>
    >>>>>>> I couldn't find any settings in VLC itself to change file types.
    >>>>>>>
    >>>>>>> Anyone have any suggestions please?
    >>>>>>>
    >>>>>> Hi Terry,
    >>>>>>
    >>>>>> Open up Explorer, then click on Tools, then folder options. Click on
    >>>>>> the
    >>>>>> file types tab at the top, then scroll down to AVI. files. Highlight
    >>>>>> it,
    >>>>>> then click on the change button and choose what program you would like
    >>>>>> to open this type of file.
    >>>>>>
    >>>>>> John.
    >>>>>
    >>>>> Thanks John, but I had tried that without success. I still have the
    >>>>> VLC icon. Here's a screenshot showing what I see in File Types, and
    >>>>> the Change dialog.
    >>>>> http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>>>>
    >>>>> Obviously, somehow I need to convince XP that VLC is NOT the default
    >>>>> for AVI! But how? It's no big deal, but it irritates me ;-)
    >>>>
    >>>>Try clicking the Browse button and surf to whatever program you want to
    >>>>use and select that. If there an "always use" box, check that.
    >>>
    >>> Thanks Roger, but already tried that too. Whether I select VirtualDub
    >>> from the list already present (see screenshot), or after browsing to
    >>> the executable itself, it doesn't stick. Icons in folders are still
    >>> VLC, and on re-opening File Types and clicking Change I still see VLC
    >>> is the default!
    >>>
    >>> --
    >>> Terry, East Grinstead, UK

    >>
    >>

    >

    Many thanks, that finally did the job!

    There were a few further difficulties. I had in fact already gone that
    route, but this time I noticed something I missed before: there was
    only a PLAY entry, not an OPEN one. So I used New to add one, and
    assigned VirtualDub to that, and changed the icon. I made OPEN the
    default action.

    But then VirtualDub gave an error when I d-clicked an AVI, saying it
    couldn't find the folder.

    I then went back and noted that the OPEN action was
    "D:\Program Files\VirtualDub-1.7.7\VirtualDub.exe"
    So I checked the PLAY action (aiming to copy it) and was very
    surprised to find that it was
    "D:\Program Files\VideoLAN\VLC\vlc.exe" --started-from-file "%1"

    That just doesn't square with fact that my AVIs *were* opening with
    VirtualDub! Any idea?

    Anyway, putting that puzzle aside, I duly changed that to
    "D:\Program Files\VirtualDub-1.7.7\VirtualDub.exe" "%1"

    .... and it works!

    --
    Terry, East Grinstead, UK
    Terry Pinnell, Feb 15, 2008
    #7
  8. Terry Pinnell

    Lookout Guest

    On Fri, 15 Feb 2008 09:16:25 +0000, Terry Pinnell
    <> wrote:

    >John <> wrote:
    >
    >>Terry Pinnell wrote:
    >>> Somehow VLC player took over the file association AVI. I managed to
    >>> change that back to VirtualDub, but the VLC icon is still shown
    >>> against all AVI files. And the File Types list still refers to VLC as
    >>> the default program for this type. Even though d-clicking an AVI does
    >>> now open it in VirtualDub.
    >>>
    >>> I couldn't find any settings in VLC itself to change file types.
    >>>
    >>> Anyone have any suggestions please?
    >>>

    >>Hi Terry,
    >>
    >>Open up Explorer, then click on Tools, then folder options. Click on the
    >>file types tab at the top, then scroll down to AVI. files. Highlight it,
    >>then click on the change button and choose what program you would like
    >>to open this type of file.
    >>
    >>John.

    >
    >Thanks John, but I had tried that without success. I still have the
    >VLC icon. Here's a screenshot showing what I see in File Types, and
    >the Change dialog.
    >http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >
    >Obviously, somehow I need to convince XP that VLC is NOT the default
    >for AVI! But how? It's no big deal, but it irritates me ;-)


    Open VLC and change the default associations there. Make sure that AVI
    isn't checked.
    It's one reason I won't install it.
    Lookout, Feb 15, 2008
    #8
  9. Terry Pinnell

    Guest

    Lookout <> wrote:

    >>Obviously, somehow I need to convince XP that VLC is NOT the default
    >>for AVI! But how? It's no big deal, but it irritates me ;-)


    >Open VLC and change the default associations there. Make sure that AVI
    >isn't checked.
    >It's one reason I won't install it.


    I just drop my AVI's on VLC to play them, my default AVI association
    is Irfanview.
    --

    Bette Davis Eyes
    http://youtube.com/watch?v=_-RdAzkKlXY
    , Feb 16, 2008
    #9
  10. Lookout <> wrote:

    >On Fri, 15 Feb 2008 09:16:25 +0000, Terry Pinnell
    ><> wrote:
    >
    >>John <> wrote:
    >>
    >>>Terry Pinnell wrote:
    >>>> Somehow VLC player took over the file association AVI. I managed to
    >>>> change that back to VirtualDub, but the VLC icon is still shown
    >>>> against all AVI files. And the File Types list still refers to VLC as
    >>>> the default program for this type. Even though d-clicking an AVI does
    >>>> now open it in VirtualDub.
    >>>>
    >>>> I couldn't find any settings in VLC itself to change file types.
    >>>>
    >>>> Anyone have any suggestions please?
    >>>>
    >>>Hi Terry,
    >>>
    >>>Open up Explorer, then click on Tools, then folder options. Click on the
    >>>file types tab at the top, then scroll down to AVI. files. Highlight it,
    >>>then click on the change button and choose what program you would like
    >>>to open this type of file.
    >>>
    >>>John.

    >>
    >>Thanks John, but I had tried that without success. I still have the
    >>VLC icon. Here's a screenshot showing what I see in File Types, and
    >>the Change dialog.
    >>http://img84.imageshack.us/my.php?image=vlciconissuerw4.jpg
    >>
    >>Obviously, somehow I need to convince XP that VLC is NOT the default
    >>for AVI! But how? It's no big deal, but it irritates me ;-)

    >
    >Open VLC and change the default associations there. Make sure that AVI
    >isn't checked.
    >It's one reason I won't install it.


    I've now sorted the problem as you see from my later reply. But I'm
    curious about your suggestion. As I said in my opening post "I
    couldn't find any settings in VLC itself to change file types."

    Where do you see these VLC default associations please?

    --
    Terry, East Grinstead, UK
    Terry Pinnell, Feb 16, 2008
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hugh Sutherland

    LARGE AVI to smal AVI files

    Hugh Sutherland, Oct 16, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    1,836
  2. Steve

    Ok, rotate AVI, save as AVI (mjpeg)

    Steve, Aug 10, 2003, in forum: Digital Photography
    Replies:
    2
    Views:
    5,899
    eimage
    Jul 17, 2009
  3. SVP
    Replies:
    1
    Views:
    38,413
    PerthMETRO.net
    Jul 13, 2004
  4. J. Manuel

    convert avi to "avi dv2"

    J. Manuel, Jan 28, 2004, in forum: DVD Video
    Replies:
    2
    Views:
    825
    Arminio Grgic
    Jan 29, 2004
  5. Giuen
    Replies:
    0
    Views:
    875
    Giuen
    Sep 12, 2008
Loading...

Share This Page