rate limiting an ethernet subinterface?

Discussion in 'Cisco' started by dexx, Jun 3, 2005.

  1. dexx

    dexx Guest

    My telco is able to handle vlan tagging and dot1q encapsulation. They
    present their services via ethernet fibre or copper. What would be the
    easiest way to configure my router to limit the traffic rate on each
    subinterface?

    Eg, my router has a 10mb copper ethernet connection to the telco and
    two remote sites route through. The actual barer speed is 4mb. What
    would be the easiest way to limit the traffic on both remotes to 2mbs
    each?

    interface fastethernet0/1.2
    encapsulation dot1q 2
    ip address 192.168.101.1 255.255.255.252

    interface fastethernet0/1.3
    encapsulation dot1q 3
    ip address 192.168.101.9 255.255.255.252
     
    dexx, Jun 3, 2005
    #1
    1. Advertising

  2. dexx

    Guest

    Depending on the type of L3 switch / router, I would use the following
    for a 3550:

    !
    mls qos
    !
    class-map match-all allip
    match access-group 100
    !
    policy-map 2mbps
    class allip
    police 2000000 32000 exceed-action drop
    !
    int fa0/1.2
    encapsulation dot1q 2
    ip address 192.168.101.1 255.255.255.252
    service policy input 2mpps
    service policy output 2mbps

    int fa0/1.3
    encapsulation dot1q 2
    ip address 192.168.101.9 255.255.255.252
    service policy input 2mpps
    service policy output 2mbps
    !
    access-list 100 permit ip any any
    !


    Goodluck!

    Paul

    On 2 Jun 2005 22:22:23 -0700, "dexx" <> wrote:

    >My telco is able to handle vlan tagging and dot1q encapsulation. They
    >present their services via ethernet fibre or copper. What would be the
    >easiest way to configure my router to limit the traffic rate on each
    >subinterface?
    >
    >Eg, my router has a 10mb copper ethernet connection to the telco and
    >two remote sites route through. The actual barer speed is 4mb. What
    >would be the easiest way to limit the traffic on both remotes to 2mbs
    >each?
    >
    >interface fastethernet0/1.2
    > encapsulation dot1q 2
    > ip address 192.168.101.1 255.255.255.252
    >
    >interface fastethernet0/1.3
    > encapsulation dot1q 3
    > ip address 192.168.101.9 255.255.255.252
     
    , Jun 3, 2005
    #2
    1. Advertising

  3. dexx

    dexx Guest

    Thanks for that reply. Ive since read that using 'match ip dscp 0' in
    the class map also works well. Can you (or others) offer advice on
    choosing the 'burst bytes' value for the 'police' line? For my 2mb
    ethernet-delivered fibre link you've specified 32000 for the token
    bucket size. What is a good way of determining this?
     
    dexx, Jun 8, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Craig Whitmore

    Rate Limiting on a 3550/2950 combo

    Craig Whitmore, Jul 20, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,824
    Craig Whitmore
    Jul 20, 2003
  2. Rick
    Replies:
    10
    Views:
    12,402
    riteshmahajan1
    Dec 17, 2008
  3. Peter
    Replies:
    2
    Views:
    1,100
  4. WAState
    Replies:
    5
    Views:
    5,206
  5. Patrick Cervicek
    Replies:
    0
    Views:
    894
    Patrick Cervicek
    Aug 7, 2007
Loading...

Share This Page